Lomaketietojen lähettäminen sähköpostiviestissä

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Voit lisätä lomakemalliin toissijaisen lähetystietoyhteyden, joka sallii käyttäjien lähettää lomaketiedot sähköpostiviestissä. Voit määrittää sähköpostiosoitteet, johon lomake lähetetään, sähköpostiviestin aiheen ja lomakkeen nimen käyttämällä ennalta määrättyjä arvoja, lomakkeen tietoihin perustuvia arvoja tai kaavaa. Voit myös määrittää, haluatko lähettää lomakkeen sähköpostiviestin tekstiosassa vai viestin liitteenä.

Jos määrität lomakemallin niin, että lomake lähetetään sähköpostiviestin liitteenä, voit myös liittää lomakemallin sähköpostiviestiin. Sisällyttämällä lomakkeen ja lomakemallin sähköpostiviestiin liitteenä voit varmistaa, että sähköpostiviestin vastaanottajat voivat avata lomakkeen Microsoft Office InfoPathissa, vaikkei heillä olisikaan lomakemallia tietokoneen välimuistissa. Jotta vastaanottajat voivat avata liitteet, heidän tietokoneeseensa on oltava asennettuna InfoPath.

Kun käyttäjät lähettävät lomaketiedot sähköpostiviestissä, InfoPath luo lomaketiedot sisältävän sähköpostiviestin ja lähettää sen tietoyhteyden luonnin yhteydessä määritetyille sähköpostin vastaanottajille. Jos henkilöt, jotka vastaanottavat täytetyt lomakkeet, käyttävät Microsoft Office Outlook 2007 -ohjelmaa, he voivat lisätä Saapuneet-kansioon kaikki vastaanotetut InfoPath-lomakkeet sisältävän kansion ja määrittää kansion näyttämään lomakkeiden tiedot sarakkeissa Outlookissa.

Lähetystietoyhteyden lisäämisen jälkeen voit määrittää lomakemallin sallimaan käyttäjien lähettää lomaketiedot. Kun käyttäjät avaavat lomakkeen, InfoPath lisää tällöin automaattisesti Lähetä-painikkeen vakiotyökaluriville ja Lähetä-komennon Tiedosto-valikkoon. Voit myös mukauttaa lomakemallin lähetysasetuksia seuraavasti:

  • Voit muuttaa vakiotyökalurivin Lähetä-painikkeen ja Tiedosto-valikon Lähetä-komennon tekstiä.

  • Voit muuttaa vakiotyökalurivin Lähetä-painikkeen ja Tiedosto-valikon Lähetä-komennon pikanäppäintä.

  • Voit luoda mukautettuja viestejä, jotka näytetään käyttäjille heidän lähettäessään lomakkeita.

  • Voit määrittää, haluatko säilyttää lomakkeen avoinna, sulkea lomakkeen tai avata toisen tyhjän lomakkeen lomakkeen lähettämisen jälkeen.

Sivun alkuun

Lähetystietoyhteyden lisääminen

  1. Valitse Työkalut-valikosta Lähetyksen asetukset.

  2. Valitse Lähetyksen asetukset -valintaikkunassa Salli tämän lomakkeen lähettäminen -valintaruudun valinta.

  3. Valitse Lähetä lomakkeen tiedot yhteen kohteeseen ja valitse sitten luettelosta Sähköposti.

  4. Valitse Lisää.

  5. Kirjoita ohjatussa tietoyhteyden muodostamisessa vastaanottajien sähköpostiosoitteet, sähköpostiviestin aihe ja haluamasi lisätietokohdan teksti niitä vastaaviin ruutuihin ja valitse sitten Seuraava.

    Vihje: Voit myös luoda arvon jokaiselle ruudulle, lukuun ottamatta Johdanto-ruutua, määrittämällä kentän tai käyttämällä kaavaa.

    Toimintaohjeet:

    1. Valitse Lisää kaava Painikkeen kuva .

    2. Tee Kaavan lisääminen -valintaikkunassa jompikumpi seuraavista:

      • Jos haluat käyttää kaavassa kenttää, valitse Lisää kenttä tai ryhmä, valitse haluamasi kenttä Kentän tai ryhmän valitseminen -valintaikkunassa ja valitse sitten OK.

      • Jos haluat käyttää kaavassa funktiota, valitse Lisää funktio, valitse haluamasi funktio Funktion lisääminen -valintaikkunassa ja valitse OK.

        Vihje: Jos funktio edellyttää parametreja, valitse funktio Funktion lisääminen -valintaikkunassa ja valitse OK. Kaksoisnapsauta sitten Kaavan lisääminen -valintaikkunan Kaava-ruudussa lisäämääsi funktiota ja napsauta kenttää tai ryhmää. Lisätietoja funktioista on Katso myös -osan linkeissä.

      • Jos haluat lisätä kaavaan arvon tai laskutoimituksen, kirjoita arvo tai laskutoimituksen merkki Kaava-ruutuun.

    Laskutoimitus

    Merkki

    Yhteenlasku

    +

    Vähennyslasku

    -

    Kertolasku

    *

    Jakolasku

    /

    • Huomautus: Jos kaava käyttää jakolaskuoperaattoria (/), varmista, että jakolaskuoperaattoria ennen ja sen jälkeen on välilyönti. Jos jakolaskuoperaattoria ennen tai sen jälkeen ei ole välilyöntiä, InfoPath saattaa tulkita merkinnän "/" XPathin sijaintivaiheiden erottimeksi jakolaskuoperaattorin asemesta.

    • Voit tarkistaa kaavan syntaksin oikeellisuuden valitsemalla Lisää kaava -valintaikkunassa Tarkista kaava.

      Lisätietoja kaavoista on Katso myös -osan linkeissä.

  6. Tee ohjatun toiminnon seuraavalla sivulla jompikumpi seuraavista:

    1. Jos haluat näyttää lomakkeen sähköpostiviestin tekstiosassa, valitse Lähetä vain lomakkeen aktiivinen näkymä ilman liitettä.

    2. Jos haluat lähettää lomaketietoja sähköpostiviestin liitteenä, valitse Lähetä lomaketiedot liitteenä, valitse Varmista lomakkeen avautuminen käyttäjillä liittämällä lomakemalli -valintaruutu ja kirjoita sitten lomakkeen nimi Liitteen nimi -ruutuun. Voit myös varmistaa määrittämällä kentän tai käyttämällä kaavaa, että jokainen lomakenimi on yksilöllinen.

      Toimintaohjeet:

      1. Valitse Lisää kaava Painikkeen kuva .

      2. Tee Kaavan lisääminen -valintaikkunassa jompikumpi seuraavista:

        • Jos haluat käyttää kaavassa kenttää, valitse Lisää kenttä tai ryhmä, valitse haluamasi kenttä Kentän tai ryhmän valitseminen -valintaikkunassa ja valitse sitten OK.

        • Jos haluat käyttää kaavassa funktiota, valitse Lisää funktio, valitse haluamasi funktio Funktion lisääminen -valintaikkunassa ja valitse OK.

          Vihje: Jos funktio edellyttää parametreja, valitse funktio Funktion lisääminen -valintaikkunassa ja valitse OK. Kaksoisnapsauta sitten Kaavan lisääminen -valintaikkunan Kaava-ruudussa lisäämääsi funktiota ja napsauta kenttää tai ryhmää. Lisätietoja funktioista on Katso myös -osan linkeissä.

        • Jos haluat lisätä kaavaan arvon tai laskutoimituksen, kirjoita arvo tai laskutoimituksen merkki Kaava-ruutuun.

      Laskutoimitus

      Merkki

      Yhteenlasku

      +

      Vähennyslasku

      -

      Kertolasku

      *

      Jakolasku

      /

      • Huomautus: Jos kaava käyttää jakolaskuoperaattoria (/), varmista, että jakolaskuoperaattoria ennen ja sen jälkeen on välilyönti. Jos jakolaskuoperaattoria ennen tai sen jälkeen ei ole välilyöntiä, InfoPath saattaa tulkita merkinnän "/" XPathin sijaintivaiheiden erottimeksi jakolaskuoperaattorin asemesta.

      • Voit tarkistaa kaavan syntaksin oikeellisuuden valitsemalla Lisää kaava -valintaikkunassa Tarkista kaava.

        Lisätietoja kaavoista on Katso myös -osan linkeissä.

      Huomautus: Henkilöiden, jotka vastaanottavat lomaketiedot sähköpostiviestin liitteenä, tietokoneeseen on oltava asennettuna InfoPath, jotta he voivat avata liitteen.

  7. Valitse Seuraava.

  8. Kirjota ohjatun toiminnon seuraavan sivun Kirjoita tämän tietoyhteyden nimi -ruutuun lähetystietoyhteyden kuvaava nimi.

  9. Varmista, että tiedot ovat oikein Yhteenveto-osassa, ja valitse sitten Valmis.

    1. Voit muuttaa käyttäjän lomaketta täyttäessä Vakio-työkaluriville tulevan Lähetä-painikkeen sekä Tiedosto-valikkoon näkyviin tulevan Lähetä-komennon nimeä kirjoittamalla uuden nimen Lähetyksen asetukset -valintaikkunan Komennon nimi -ruutuun.

      Vihje: Jos haluat määrittää painikkeelle ja komennolle pikanäppäimen, kirjoita pikanäppäimenä käytettävän merkin eteen et-merkki (&). Jos esimerkiksi haluat määrittää Lähetä-painikkeen ja -komennon pikanäppäimeksi ALT+H, kirjoita Lä&hetä.

  10. Jos et halua, että käyttäjät voivat käyttää Lähetä-komentoa tai vakiotyökalurivinLähetä-painiketta täyttäessään lomakettasi, poista Näytä Lähetä-valikkokomento ja työkalurivin Lähetä-painike -valintaruudun valinta.

    1. Oletusarvon mukaan InfoPath jättää lomakeikkunan avoimeksi käyttäjän lähetettyä lomakkeen ja näyttää sanoman, joka ilmaisee, onnistuiko lomakkeen lähettäminen. Voit muuttaa tätä oletusarvon mukaista toimintaa valitsemalla Lisäasetukset ja toimimalla jollakin seuraavista tavoista:

      • Jos haluat, että täytetyn lomakkeen lähettämisen jälkeen lomake suljetaan tai luodaan uusi, tyhjä lomake, valitse haluamasi vaihtoehto Lähettämisen jälkeen -luettelosta.

      • Jos haluat luoda mukautetun sanoman, joka ilmoittaa lähetyksen onnistuneen tai epäonnistuneen, valitse Käytä mukautettuja sanomia -valintaruutu ja kirjoita haluamasi teksti Toiminnon onnistuessa- ja Toiminnon epäonnistuessa -ruutuihin.

        Vihje: Sisällytä Toiminnon epäonnistuessa -ruudun tekstiin ohje, mitä tehdä, jos lomakkeen lähettäminen ei onnistu. Voit esimerkiksi kehottaa käyttäjää tallentamaan lomakkeen ja ottamaan yhteyttä tukipalveluun.

      • Jos et halua, että näyttöön tulee sanoma sen jälkeen, kun käyttäjä on lähettänyt lomakkeen, poista Näytä onnistumis- ja epäonnistumissanomat -valintaruudun valinta.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×