Lomaketietojen lähettäminen Web-palveluun

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Jos haluat käyttäjien lähettävän lomaketiedot Web-palveluun, voit lisätä lomakemalliin lähetystietoyhteyden toissijaisena tietoyhteytenä. Web-palvelun hyväksymien tietotyyppien mukaan voit määrittää lähetystietoyhteyden lähettämään joko määritetyn kentän tiedot, ryhmän kaikkien kenttien tiedot tai lomakkeen kaikki tiedot.

Lähetystietoyhteyden lisäämisen jälkeen voit määrittää lomakemallin sallimaan käyttäjien lähettää lomaketiedot Web-palveluun. Microsoft Office InfoPath lisää tällöin Lähetä-painikkeen vakiotyökaluriville ja Lähetä-komennon Tiedosto-valikkoon lomakkeessa. Voit myös mukauttaa lomakemallin lähetysasetuksia seuraavasti:

  • Voit muuttaa vakiotyökalurivin Lähetä-painikkeen ja Tiedosto-valikon Lähetä-komennon tekstiä.

  • Voit muuttaa vakiotyökalurivin Lähetä-painikkeen ja Tiedosto-valikon Lähetä-komennon pikanäppäintä.

  • Voit luoda mukautettuja viestejä, jotka näytetään käyttäjille heidän lähettäessään lomakkeita.

  • Voit määrittää, haluatko säilyttää lomakkeen avoinna, sulkea lomakkeen tai avata toisen tyhjän lomakkeen lomakkeen lähettämisen jälkeen.

Lähetystietoyhteyden lisääminen

  1. Valitse Työkalut-valikosta Lähetyksen asetukset.

  2. Valitse Lähetyksen asetukset -valintaikkunassa Salli tämän lomakkeen lähettäminen -valintaruudun valinta.

  3. Valitse Lähetä lomakkeen tiedot yhteen kohteeseen ja valitse sitten luettelosta Web-palvelu.

  4. Valitse Lisää.

  5. Kirjoita ohjatussa tietoyhteyden muodostamisessa sen Web-palvelun sijainti, johon käyttäjät lähettävät tiedot, ja valitse sitten Seuraava.

    Vihje: Jos haluat etsiä Web-palvelua UDDI (Universal Description, Discovery, and Integration) -palvelimesta, valitse UDDI-haku ja kirjoita sitten etsittävä UDDI-palvelin. Määritä sitten, haluatko etsiä palveluntarjoajan vai tarjottavien palvelujen mukaan, ja kirjoita haulle avainsana. Valitse sitten Etsi. Haun avainsanaa vastaavat Web-palvelut näkyvät Etsinnän tulokset -luettelossa.

  6. Valitse ohjatun toiminnon seuraavalla sivulla Valitse toiminto -luettelosta Web-palvelun toiminto, jota haluat käyttää lomaketietojen vastaanottamiseen, ja valitse sitten Seuraava.

  7. Jotta voit valita, mitä lomakkeen tietoja voit lähettää kullekin Web-palvelun parametrille, tee ohjatun toiminnon seuraavalla sivulla jokin seuraavista:

    Kentän tai ryhmän tietojen lähettäminen

    1. Valitse Parametrit-luettelosta Web-palvelun parametri, joka vastaanottaa lomaketiedot lomakkeesta.

    2. Valitse Parametrin asetukset -kohdassa Kenttä tai ryhmä.

    3. Valitse Muokkaa Tietolähde-painike .

    4. Valitse Kentän tai ryhmän valitseminen -valintaikkunasta kenttä tai ryhmä, jonka tiedot haluat lähettää, ja valitse OK.

    5. Jos haluat lähettää vain tämän kentän tiedot ja kentän tai ryhmän alielementit, valitse Sisällytä-ruudussa Vain teksti ja alielementit. Jos haluat lähettää kentän nimen, kentän tiedot ja valitun ryhmän tai kentän alielementit, valitse XML-alipuu, mukaan lukien valittu elementti.

    Lomakkeen kaikkien tietojen lähettäminen

    1. Valitse Parametrit-luettelosta Web-palvelun parametri, joka vastaanottaa lomaketiedot lomakkeesta.

    2. Valitse parametrin asetukset-kohdassa koko lomake (XML-asiakirja ja käsittelyohjeet).

    Tietojen lähettäminen merkkijonona

    1. Valitse Parametrit-luettelosta Web-palvelun parametri, joka vastaanottaa lomaketiedot lomakkeesta.

    2. Valitse parametrin asetukset-kohdassa koko lomake (XML-asiakirja ja käsittelyohjeet).

    3. Valitse Lähetä tiedot merkkijonona -valintaruutu.

      Huomautus: Yleensä tämä valintaruutu valitaan, kun halutaan lähettää digitaalisesti allekirjoitettuja tietoja. Useimmissa tapauksissa tämän valintaruudun valinnan voi poistaa.

    Teknisiä tietoja Microsoft ADO.NET DataSet -objekteista

    Jos Web-palvelu edellyttää ADO.NET DataSet -objektia, valitse DataSet-solmu, kun määrität kyseistä tietoyhteyttä. Jos käytät jotakin muuta solmua ADO DataSetiä edellyttävään Web-palveluun liittyvässä tietoyhteydessä, lähetystoiminto epäonnistuu.

  8. Valitse Seuraava.

  9. Kirjota ohjatun toiminnon seuraavalla sivulla Kirjoita tämän tietoyhteyden nimi -ruutuun lähetystietoyhteyden kuvaava nimi.

    1. Voit muuttaa käyttäjän lomaketta täyttäessä Vakio-työkaluriville tulevan Lähetä-painikkeen sekä Tiedosto-valikkoon näkyviin tulevan Lähetä-komennon nimeä kirjoittamalla uuden nimen Lähetyksen asetukset -valintaikkunan Komennon nimi -ruutuun.

      Vihje: Jos haluat määrittää painikkeelle ja komennolle pikanäppäimen, kirjoita pikanäppäimenä käytettävän merkin eteen et-merkki (&). Jos esimerkiksi haluat määrittää Lähetä-painikkeen ja -komennon pikanäppäimeksi ALT+H, kirjoita Lä&hetä.

  10. Varmista, että tiedot ovat oikein Yhteenveto-osassa, ja valitse sitten Valmis.

  11. Jos haluat sallia Lähetä-komennon tai vakiotyökalurivin Lähetä-painikkeen käytön lomaketta täytettäessä, valitse Näytä Lähetä-valikkokomento ja työkalurivin Lähetä-painike -valintaruutu.

    1. Oletusarvon mukaan InfoPath jättää lomakeikkunan avoimeksi käyttäjän lähetettyä lomakkeen ja näyttää sanoman, joka ilmaisee, onnistuiko lomakkeen lähettäminen. Voit muuttaa tätä oletusarvon mukaista toimintaa valitsemalla Lisäasetukset ja toimimalla jollakin seuraavista tavoista:

      1. Jos haluat, että täytetyn lomakkeen lähettämisen jälkeen lomake suljetaan tai luodaan uusi, tyhjä lomake, valitse haluamasi vaihtoehto Lähettämisen jälkeen -luettelosta.

      2. Jos haluat luoda mukautetun sanoman, joka ilmoittaa lähetyksen onnistuneen tai epäonnistuneen, valitse Käytä mukautettuja sanomia -valintaruutu ja kirjoita haluamasi teksti Toiminnon onnistuessa- ja Toiminnon epäonnistuessa -ruutuihin.

        Vihje: Sisällytä Toiminnon epäonnistuessa -ruudun tekstiin ohje, mitä tehdä, jos lomakkeen lähettäminen ei onnistu. Voit esimerkiksi kehottaa käyttäjää tallentamaan lomakkeen ja ottamaan yhteyttä tukipalveluun.

      3. Jos et halua, että näyttöön tulee sanoma sen jälkeen, kun käyttäjä on lähettänyt lomakkeen, poista Näytä onnistumis- ja epäonnistumissanomat -valintaruudun valinta.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×