Lomakemallin päivitetyn version julkaiseminen

Kun julkaiset muokkaamasi lomakemallin, InfoPath voi päivittää sekä lomakemallin (.xsn-tiedoston) että kaikki siihen perustuvat olemassa olevat lomakkeet (.xml-tiedostot) InfoPath korvaa oletusarvoisesti lomakemallin vanhemman version uudemmalla mallilla. Olemassa oleville lomakkeille voit valita haluamasi päivitystavan.

Tässä artikkelissa

Tietojen menetyksen estäminen aiemmin luoduissa käyttäjien lomakkeissa

Päivitetyn lomakemallin julkaiseminen

Lomakemallien päivityspäätöksen antaminen käyttäjille

Tietojen menetyksen estäminen aiemmin luoduissa käyttäjien lomakkeissa

Jos sinun täytyy päivittää olemassa olevaa lomakemallia, voit muuttaa sitä, julkaista sen uudelleen ja jakaa sen käyttäjille. Tietyntyyppiset muutokset saattavat kuitenkin estää sinua käyttämästä tietoja täytetyistä lomakkeista, jotka perustuivat alkuperäiseen lomakemalliin.

Jos teet lomakemalliin muutoksia, jotka saattavat aiheuttaa tietojen menetyksiä tai virheitä aiemmin täytetyissä lomakkeissa, saat tästä ilmoituksen. Saat ilmoituksen usein silloin, kun lisäät uusia pakollisia kenttiä lomakemalliin tai nimeät uudelleen tai poistat kenttiä tai ryhmiä lomakemallissa.

Virhesanoma, joka ilmoittaa lomakkeen luojia mahdollisesta tietojen menettämisen uhkasta

Kun saat tämän ilmoituksen ja jatkat muutettujen tietojen käyttöä valitsemalla Kyllä, et ehkä voi käyttää olemassa olevien lomakkeiden tietoja enää sen jälkeen, kun julkaiset päivitetyn lomakemallin. Joissain tilanteissa tämä voi olla hyväksyttyä. Sinun täytyy päättää, mikä toimintatapa sopii parhaiten omaan tilanteeseesi.

Jos haluat varmistaa, että voit käyttää käyttäjiltä jo aiemmin kerättyjä tietoja, toimi seuraavien ohjeiden mukaisesti, kun teet muutoksia alkuperäiseen lomakemalliin:

  • Älä nimeä uudelleen olemassa olevia kenttiä ja ryhmiä tietolähteessä.

  • Älä siirrä olemassa olevia kenttiä ja ryhmiä tietolähteessä.

  • Älä poista olemassa olevia kenttiä ja ryhmiä tietolähteestä. Voit poistaa lomakemallin ohjausobjekteja ilman ongelmia, kunhan jätät ohjausobjektia vastaavan kentän tai ryhmän ennalleen tietolähteessä.

Sivun alkuun

Päivitetyn lomakemallin julkaiseminen

Oletetaan, että aiot tehdä muutoksia lomakemalliin, joka on jo käytössä koko yrityksessä. Jos muutokset sisältävät lomakemallin pohjana olevan tietolähteen muokkaamista, lomakemallin aiemmin julkaistu versio on päivitettävä tehokkaasti, jotta kaikki käyttäjät varmasti käyttävät päivitettyä versiota. Voit myös määrittää, mitä haluat tapahtuvan aiemmin luoduille lomakkeille, jotka perustuvat alkuperäiseen lomakemalliin.

  1. Avaa päivitettävä lomakemalli.

  2. Tee lomakemalliin tarvittavat muutokset.

  3. Valitse Työkalut-valikosta Lomakkeen asetukset.

  4. Valitse Luokka-luettelosta Versiot.

    Tässä vaiheessa on määritettävä, mitä tulee tapahtua niille aiemmin luoduille lomakkeille (.xml-tiedostoille), jotka on täytetty käyttämällä alkuperäistä lomakemallia.

  5. Tee Kun versio päivitetään -luettelon Lomakemallin versio -kohdassa jokin seuraavista:

    • Jos haluat lomakkeen vanhojen versioiden muuntuvan automaattisesti päivitetyn version mukaisiksi, valitse Päivitä aiemmin luodut lomakkeet automaattisesti. Kun tämä asetus on valittuna, InfoPath ei kehota käyttäjiä päivittämään aiemmin luotuja lomakkeita, vaan lomakkeet päivittyvät automaattisesti, kun käyttäjät seuraavan kerran avaavat aiemmin luodun tai uuden lomakkeen.

    • Jos haluat kirjoittaa mukautettua koodia, joka käsittelee päivittämisen käyttäjien puolesta, valitse Käytä mukautettua tapahtumaa ja valitse sitten Muokkaa. Voit sitten käyttää OnVersionUpgrade-tapahtumaa, joka ilmenee, kun avattavan InfoPath-lomakkeen versionumero on vanhempi kuin sen lomakemallin versionumero, johon lomake perustuu. Lisätietoja OnVersionUpgrade-tapahtumasta on InfoPathin kehittäjän ohjeissa.

    • Jos haluat estää lomakkeiden päivittämisen, valitse Älä tee mitään (aiemmin luodut lomakkeet eivät ehkä toimi oikein). Kun tämä asetus on valittuna, käyttäjät voivat täyttää päivitettyyn lomakemalliin perustuvia lomakkeita, mutta eivät ehkä voi avata aiemmin luotuja lomakkeita. Jos he voivat avata aiemmin luotuja lomakkeita, he eivät voi muokata äskettäin lisättyjä kenttiä.

  6. Valitse Tiedosto-valikosta Julkaise ja noudata sitten ohjatun julkaisutoiminnon ohjeita.

    Kun käyttäjät avaavat lomakemalliisi perustuvan lomakkeen, he saavat automaattisesti käyttöönsä lomakemallin uuden version. Jos he yrittävät avata lomakkeita, jotka on luotu käyttäen lomakemallin aiempaa versiota, vaiheessa 5 määritetyt muutokset tulevat voimaan.

Sivun alkuun

Lomakemallien päivityspäätöksen antaminen käyttäjille

Kun julkaiset lomakemallin päivitetyn version, InfoPath korvaa käyttäjien tietokoneille tallennetun lomakemallin version uusimmalla versiolla. Tämä tapahtuu automaattisesti, kun käyttäjät avaavat päivitettyyn lomakemalliin perustuvan lomakkeen. Useimmiten tämä on paras vaihtoehto. On kuitenkin myös mahdollista tuoda näkyviin valintaikkuna, joka kehottaa käyttäjiä päivittämään lomakemallin, kun uusi versio tulee käytettäväksi.

  1. Valitse Työkalut-valikosta Lomakkeen asetukset.

  2. Valitse Luokka-luettelosta Versiot.

  3. Valitse Lomakemallin versio -kohdasta Lomakkeen käyttävät voivat valita, päivittävätkö lomakemallin uuteen versioon -valintaruutu ja valitse sitten OK.

    Huomautus: Oletusarvon mukaan rekisteriarvon EnableAutoUpdatePrompt tiedot ovat 0 (off). Käyttäjiä kehotetaan päivittämään lomake vain, jos järjestelmänvalvoja on muuttanut EnableAutoUpdatePrompt-arvon tiedot 0:sta (off) 1:een (on).

  4. Valitse Tiedosto-valikosta Julkaise ja noudata sitten ohjatun julkaisutoiminnon ohjeita.

Kun käyttäjä seuraavan kerran avaa lomakemalliin perustuvan lomakkeen, InfoPath tuo näkyviin valintaikkunan, jossa käyttäjää kehotetaan korvaamaan aiemmin luotu lomakemalli uudella versiolla. Käyttäjä voi sitten päättää, haluaako hän tehdä niin. Jos valintaikkuna ei tule näkyviin, EnableAutoUpdatePrompt-arvon tiedot ovat silloin luultavasti 0 (off) 1:n (on) asemesta.

Huomautus: Ennen lomakkeen avaamista käyttäjät voivat itse hakea tietyn lomakemallin (.xsn-tiedoston) uusimman version napsauttamalla Täytä lomake -valintaikkunassa Hae tämän lomakkeen päivitys- tai Hae tämän luokan lomakkeiden päivitykset -linkkiä. Linkit ovat käytettävissä, vaikka käyttäjillä olisi jo tietokoneellaan lomakemallin uusin versio. Jos käyttäjä tällöin napsauttaa päivityslinkkiä, InfoPath vain tallentaa uusimman lomakemallin uudelleen käyttäjän tietokoneelle.

Sivun alkuun

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×