LASKE.JOS/LASKE.JOS.JOUKKO-funktion #ARVO!-virheen korjaaminen

Tässä artikkelissa luetellaan #ARVO!-virheen yleiset syyt LASKE.JOS- ja LASKE.JOS.JOUKKO-funktioissa sekä niiden ratkaiseminen.

Ongelma: Kaava viittaa suljetussa työkirjassa oleviin soluihin

LASKE.JOS/LASKE.JOS.JOUKKO-funktiot, jotka viittaavat suljetussa työkirjassa olevaan soluun tai solualueeseen, aiheuttavat #ARVO!-virheen.

Huomautus: Tämä on tunnettu ongelma useiden muiden Excel-funktioiden, kuten SUMMA.JOS-, SUMMA.JOS.JOUKKO- ja LASKE.TYHJÄT-funktioiden kohdalla. Katso lisätietoja artikkelista SUMMA.JOS-, LASKE.JOS- ja LASKE.TYHJÄT-funktiot palauttavat #ARVO!-virheen.

Ratkaisu: Avaa kaavaan merkitty linkitetty työkirja ja päivitä kaava painamalla F9-näppäintä.

Voit ratkaista ongelman myös käyttämällä SUMMA- ja JOS-funktioita yhdessä matriisikaavassa. Katso lisätietoja artikkelista SUMMA.JOS-, LASKE.JOS- ja LASKE.TYHJÄT-funktiot palauttavat #ARVO!-virheen.

Ongelma: Merkkijono on yli 255 merkkiä.

Ratkaisu: Lyhennä merkkijonoa, jos mahdollista. Jos et voi lyhentää, jaa arvo useaan merkkijonoon käyttämällä KETJUTA-funktiota tai et-merkkioperaattoria (&). Esimerkki:

  • = LASKE.JOS(B2:B12,”pitkä merkkijono”&”toinen pitkä merkkijono”)

Onko sinulla jokin funktioihin liittyvä kysymys?

Lähetä kysymys Excel-yhteisön keskustelupalstalle

Auta meitä parantamaan Exceliä

Onko sinulla ehdotuksia, miten voimme parantaa seuraavaa Excel-versiota? Jos on, lue aiheet Excel User Voice -palvelussa.

Katso myös

#ARVO!-virheen korjaaminen

LASKE.JOS-funktio

LASKE.JOS.JOUKKO-funktio

JOS-funktio – sisäkkäiset kaavat ja ongelmien välttäminen

Katso edistyneitä JOS-funktioita koskeva video

Yleiskuva kaavoista Excelissä

Viallisten kaavojen ratkaiseminen

Kaavoissa esiintyvien virheiden etsiminen

Kaikki Excel-funktiot (aakkosjärjestyksessä)

Kaikki Excel-funktiot (luokittain)

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×