Kaavoissa esiintyvien virheiden etsiminen

Kaavat voivat toisinaan palauttaa virheitä ja aiheuttaa odottamattomia tuloksia. Seuraavilla työkaluilla voit etsiä ja tutkia virheiden syitä sekä määrittää ratkaisuja.

Huomautus: Tässä artikkelissa käsitellään tekniikoita, joilla voit korjata kaavavirheitä. Artikkeli ei sisällä täydellistä luetteloa menetelmistä kaikkien mahdollisten kaavavirheiden korjaamiseen. Jos haluat lisätietoja tietyistä virheistä, voit etsiä oman kysymyksesi kaltaisia kysymyksiä Excel-yhteisön keskustelupalstalta tai julkaista oman kysymyksesi.

Linkki Excelin Community-keskustelupalstalle

Yksinkertaisten kaavojen kirjoittaminen

Kaavat ovat yhtälöitä, joilla suoritetaan laskutoimituksia käyttämällä taulukon arvoja. Kaavan alussa on yhtäläisyysmerkki (=). Esimerkiksi seuraava kaava laskee yhteen luvut 3 ja 1.

=3+1

Kaava voi sisältää myös funktioita, viittauksia, operaattoreita ja vakioita.

Kaavan osat

Kaavan osat

  1. Funktiot: Excelin funktiot ovat suunniteltuja kaavoja, jotka suorittavat määrättyjä laskutoimituksia. Esimerkiksi funktio PII() palauttaa piin arvon: 3,142...

  2. Viittaukset: viittauksia yksittäisiin soluihin tai solualueisiin. A2 palauttaa solun A2 arvon.

  3. Vakiot: suoraan kaavaan kirjoitettuja lukuja tai tekstiarvoja, esimerkiksi luku 2.

  4. Operaattorit: ^-operaattori (sirkumfleksi) korottaa luvun potenssiin, ja *-operaattori (tähti) kertoo luvun. Operaattorien + ja – avulla voit tehdä yhteen- ja vähennyslaskuja ja operaattorilla / jakolaskuja.

    Huomautus: Jotkin funktiot vaativat argumentteja. Argumentit ovat arvoja, joita tietyt funktiot käyttävät laskutoimitusten suorittamiseen. Tarvittaessa argumentit sijoitetaan funktion sulkeisiin (). PII-funktio ei edellytä argumentteja, joiden vuoksi sulut ovat tyhjät. Jotkin funktiot edellyttävät vähintään yhden argumentin, mutta niissä voi olla mahdollisuus käyttää useampiakin argumentteja. Argumentit pitää erottaa toisistaan pilkulla tai puolipisteellä (;) sijainti-asetusten mukaan.

Esimerkiksi SUMMA-funktio vaatii vain yhden argumentin, mutta siinä voidaan käyttää jopa 255 argumenttia.

SUMMA (SUMMA-funktio)

=Summa(A1:A10) on esimerkki yhdestä argumentista.

=Summa(A1:A10, C1:C10) on esimerkki useasta argumentista.

Seuraavassa taulukossa on yhteenveto yleisimmistä virheistä, joita voit tehdä kaavoja kirjoittaessasi, ja ohjeita niiden korjaamiseksi:

Tarkista seuraavat asiat:

Lisätietoja

Jokaisen kaavan alussa on yhtäläisyysmerkki (=)

Jos et käytä yhtäläisyysmerkkiä, kirjoittamasi kaava saattaa tulla näkyviin tekstinä tai päivämääränä. Esimerkiksi jos kirjoitat SUMMA(A1:A10), Excel näyttää tekstimerkkijonon SUMMA(A1:A10) eikä suorita laskutoimitusta. Jos kirjoitat 11/2, Excel näyttää päivämäärän 11.helmi (edellyttäen, että solun muotoiluasetuksena on Yleinen) jakolaskun suorittamisen asemesta.

Alkusulkeita ja loppusulkeita on oltava yhtä paljon

Varmista, että kaikki sulkeet muodostavat parin (alku- ja loppusulkeet). Kun kaavassa käytetään funktiota, jokaisen sulkeen on oltava oikeassa paikassa, jotta funktio toimisi oikein. Esimerkiksi kaava =JOS(B5<0);”Ei kelpaa”;B5*1,05) ei toimi, koska loppusulkeita on kaksi ja alkusulkeita vain yksi, vaikka molempia pitäisi olla vain yksi. Oikea kaava näyttää tältä: =JOS(B5<0;”Ei kelpaa”;B5*1,05).

Alueen ilmaiseminen kaksoispisteellä

Kun viittaat solualueeseen, erota viittaus alueen ensimmäiseen soluun viittauksesta alueen viimeiseen soluun kaksoispisteellä (:). Esimerkiksi: =SUMMA(A1:A5), ei =SUM(A1 A5), joka palauttaisi #TYHJÄ!-virheen.

Kaikki tarvittavat argumentit on kirjoitettu

Joillakin funktioilla on pakollisia argumentteja. Varmista myös, että et ole kirjoittanut liikaa argumentteja.

Kirjoitettu argumenttien tyyppi on oikea

Osa funktioista, kuten SUMMA, edellyttää numeerisia argumentteja, kun taas osa, kuten KORVAA, edellyttää vähintään yhtä argumenttia, jolla on tekstiarvo. Jos käytät väärää argumenttilajia, Excel saattaa palauttaa odottamattomia tuloksia tai näyttää virheen.

Sisäkkäisiä funktioita on enintään 64

Voit käyttää funktiossa sisäkkäisiä funktioita enintään 64 tasolla.

Muiden taulukoiden nimet on kirjoitettu heittomerkkeihin

Jos kaava viittaa muiden laskentataulukoiden tai työkirjojen arvoihin tai soluihin ja työkirjan tai taulukon nimessä on välilyöntejä tai merkki, joka ei ole kirjain, nimi on kirjoitettava puolilainausmerkkeihin ( ’ ), kuten =’Vuosineljänneksen tiedot’!D3, tai =’123’!A1.

Huutomerkki (!) on asetettu laskentataulukon nimen jälkeen, kun siihen viitataan kaavassa

Jos esimerkiksi haluat palauttaa arvon saman työkirjan Neljännesvuoden tiedot -laskentataulukon solusta D3, käytä seuraavaa kaavaa: ='Neljännesvuoden tiedot'!D3.

Ulkoisten työkirjojen nimiin on sisällytetty polku

Varmista, että kukin ulkoinen viite sisältää työkirjan nimen ja työkirjaan johtavan polun.

Työkirjaviittaus sisältää työkirjan nimen, ja sen on oltava hakasulkeissa ([Työkirjannimi.xlsx]). Viittauksessa on myös oltava työkirjan laskentataulukon nimi.

Jos työkirja, johon haluat viitata, ei ole avattuna Excelissä, kaavaan voi silti lisätä työkirjaan osoittavan viittauksen. Tällöin kaavaan kirjoitetaan koko polku, kuten =RIVIT(’C:\Omat tiedostot\[N2-toiminnot.xlsx]Myynti’!A1:A8). Tämä kaava palauttaa rivien määrän toisen työkirjan alueessa A1–A8 (8).

Huomautus: Jos täydellisessä polussa on välilyöntejä, kuten edellisessä esimerkissä, polku on kirjoitettava puolilainausmerkkeihin, jotka sijoitetaan polun alkuun ja laskentataulukon nimen jälkeen ennen huutomerkkiä.

Luvut on kirjoitettu ilman muotoilua

Älä käytä luvuissa erotinmerkkejä, kun kirjoitat niitä kaavoihin. Jos haluat kaavaan esimerkiksi arvon 1 000 €, kirjoita se muodossa 1000. Jos kirjoitat esimerkiksi pilkun (jota käytetään esimerkiksi Yhdysvalloissa lukujen tuhaterottimena) osaksi lukua, Excel tulkitsee pilkun erotinmerkiksi. Jos haluat kaavan tulosten lukujen näkyvän niin, että niissä on tuhaterotin ja rahayksikön tunnus, muotoile solut muotoilemattomia lukuargumentteja käyttävien kaavojen kirjoittamisen jälkeen.

Jos esimerkiksi käytössä on englannin aluekohtaiset asetukset ja kirjoitat soluun A3 arvon 3100 ja määrität kaavan =SUMMA(3,100,A3), Excel laskee yhteen luvut 3 ja 100 ja lisää sitten summan A3-solun arvoon sen sijaan, että se lisäisi luvun 3100 soluun A3, joka tehtäisiin kaavalla SUMMA(3100;A3). Tai jos kirjoitat kaavan =ITSEISARVO(-2,134), Excel näyttää virheen, koska ITSEISARVO-funktio hyväksyy vain yhden argumentin: =ITSEISARVO(-2134).

Voit käyttää kaavojen tarkistuksessa tiettyjä sääntöjä. Säännöt eivät takaa, että työkirjasi on virheetön, mutta niiden avulla löydät yleisimmät virheet. Voit ottaa säännöt käyttöön ja poistaa ne käytöstä yksitellen.

Virheitä voidaan merkitä ja korjata kahdella tavalla: yksi virhe kerrallaan samoin kuin tarkistettaessa oikeinkirjoitusta tai heti niiden ilmetessä lisättäessä tietoja laskentataulukkoon.

Voit ratkaista virheen joko käyttämällä Excelin näyttämiä vaihtoehtoja tai ohittamalla sen Ohita virhe -komennolla. Jos tietyssä solussa oleva virhe ohitetaan, kyseinen virhe ei näy tulevissa virheentarkistuksissa. Aiemmin ohitetut virheet voidaan kuitenkin nollata, minkä jälkeen ne tulevat uudelleen näkyviin.

  1. Valitse Tiedosto > Asetukset > Kaavat.

    Valitse Excel 2007:ssä Microsoft Office -painike Office-painikkeen kuva > Excel-asetukset > Kaavat.

  2. Valitse Virheentarkistus-kohdasta, Salli virheiden tarkistaminen taustalla. Jokainen löytynyt virhe merkitään kolmiolla solun vasempaan yläkulmaan.

    Solu, jossa on virheellinen kaava
  3. Jos haluat muuttaa virheestä ilmoittavan kolmion väriä, valitse Ilmaise virheet tällä värillä -ruudusta uusi väri.

  4. Valitse Excelin tarkistussäännöt -kohdassa seuraavien sääntöjen valintaruudut tai poista niiden valinta:

    • Virhearvon tuottavia kaavoja sisältävät solut: Virhearvo tulee näkyviin, koska kaavassa ei ole käytetty ohjelman odottamaa syntaksia, argumentteja tai tietotyyppejä. Virhearvoja ovat #JAKO/0!, #PUUTTUU, #NIMI?, #TYHJÄ!, #LUKU!, #VIITTAUS! ja #ARVO!. Kullakin virhearvolla on eri syyt, ja virhearvot myös ratkaistaan eri tavoilla.

      Huomautus: Jos kirjoitat virhearvon suoraan soluun, se tallennetaan virhearvona, mutta ohjelma ei merkitse sitä virheeksi. Jos kuitenkin jossakin toisessa solussa oleva kaava viittaa kyseiseen soluun, kaava palauttaa toisessa solussa virheen.

    • Taulukossa on ristiriitainen lasketun sarakkeen kaava: Laskettu sarake voi sisältää kaavoja, jotka ovat erilaisia kuin sarakkeen poikkeuksen aiheuttava pääkaava. Excel luo poikkeuksen laskettuun sarakkeeseen, kun teet jonkin seuraavista:

      • Kirjoitat lasketun sarakkeen soluun muita tietoja kuin kaavan.

      • Kirjoitat kaavan lasketun sarakkeen soluun ja käytät näppäinyhdistelmää Ctrl + Z tai napsautat Kumoa Painikkeen kuva -painiketta pikatyökalurivillä.

      • Kirjoitat uuden kaavan sellaiseen laskettuun sarakkeeseen, joka sisältää jo ainakin yhden poikkeuksen.

      • Kopioit laskettuun sarakkeeseen tietoja, jotka ovat erilaisia kuin lasketun sarakkeen kaava. Jos kopioidut tiedot sisältävät kaavan, tämä kaava korvaa lasketun sarakkeen tiedot.

      • Siirrät tai poistat solun toiselle laskentataulukon alueelle, johon on viittaus lasketun sarakkeen riveillä.

    • Solut, jotka sisältävät kaksinumeroisia vuosilukuja: Solussa on tekstimuotoinen päivämäärä, jonka vuosisata voidaan tulkita väärin, jos päivämäärää käytetään kaavoissa. Esimerkiksi kaavassa =VUOSI(”1.1.31”) vuosi voi olla 1931 tai 2031. Tarkista epäselvät tekstimuotoiset päivämäärät tämän säännön avulla.

    • Luvut on muotoiltu tekstiksi, tai niiden edessä on heittomerkki: Solussa on tekstimuodossa tallennettuja lukuja. Tällaiset luvut ovat yleensä peräisin muista lähteistä tuoduista tiedoista. Tekstimuodossa tallennetut luvut saattavat aiheuttaa odottamattomia lajitteluja, eikä niitä voi laskea, joten niiden solut kannattaa muuntaa lukumuotoon. ’=SUMMA(A1:A10) näkyy tekstinä.

    • Kaavat, jotka ovat yhteensopimattomia alueen muiden kaavojen kanssa: Kaava ei vastaa muiden sen lähellä olevien kaavojen muotoa. Yleensä muihin kaavoihin liittyvät kaavat eroavat vain niissä käytettyjen soluviittausten suhteen. Seuraavassa neljä toisiinsa liittyvää kaavaa sisältävässä esimerkissä Excel näyttää virheen solun D4 kaavan =SUMMA(A10:C10) vieressä, koska muut kaavat käyttävät yhden rivin lisäystä ja kaava =SUMMA(A10:C10) käyttää kahdeksan rivin lisäystä – Excel odottaa tällöin kaavaa =SUMMA(A4:C4).

      Excel näyttää virheen, kun kaava ei vastaa vierekkäisten kaavojen muotoa

      Jos kaavassa käytetyt viittaukset eivät ole johdonmukaisia verrattuna kaavaan liittyviin muihin kaavoihin, Excel näyttää virheen.

    • Kaavat, jotka ohittavat alueen soluja: Kaava ei ehkä automaattisesti sisällä viittauksia tietoihin, jotka lisäät alkuperäisen tietoalueen ja kaavan sisältämän solun väliin. Sääntö vertaa viittausta kaavan sisältämän solun viereiseen solualueeseen. Jos viereiset solut eivät ole tyhjiä vaan sisältävät lisää arvoja, Excel näyttää virheen kaavan vieressä.

      Excel esimerkiksi näyttää virheen kaavan =SUMMA(D2:D4) vieressä, kun tätä sääntöä käytetään, koska solut D5, D6 ja D7 sijaitsevat kaavan viittaamien solujen ja kaavan sisältävän solun (D8) vieressä ja nämä solut sisältävät tietoja, joihin kaavan olisi pitänyt viitata.

      Excel näyttää virheen, kun kaava ohittaa alueen soluja
    • Lukitsemattomat solut, joissa on kaavoja: Kaavaa ei ole suojattu lukitsemalla. Oletusarvoisesti kaikki laskentataulukon solut on lukittu, joten niitä ei voi muuttaa, kun laskentataulukko on suojattu. Näin voit estää vahingossa tehdyt virheet, kuten kaavojen poistamisen tai muuttamisen vahingossa. Tämä virhe tarkoittaa, että solun lukitus on poistettu, mutta laskentataulukkoa ei ole suojattu. Varmista, haluatko solulle lukituksen vai et.

    • Tyhjiin soluihin viittaavat kaavat: Kaava sisältää viittauksen tyhjään soluun. Tulos ei ehkä vastaa odotuksia, kuten seuraavassa esimerkissä.

      Oletetaan, että haluat laskea seuraavan sarakkeen solujen sisältämien lukujen keskiarvon. Jos kolmas solu on tyhjä, sitä ei sisällytetä laskutoimitukseen ja tulos on 22,75. Jos kolmannen solun arvo on 0, tulos on 18,2.

      Excel näyttää virheen, kun kaava viittaa tyhjiin soluihin
    • Taulukkoon kirjoitetut tiedot ovat virheellisiä: Taulukossa on kelpoisuustarkistusvirhe. Tarkista solun kelpoisuuden tarkistusasetus valitsemalla Tiedot-välilehti > Datatyökalut-ryhmä Tietojen kelpoisuuden tarkistaminen.

  1. Valitse laskentataulukko, josta haluat etsiä virheitä.

  2. Jos laskentataulukko on manuaalisesti laskettava taulukko, laske se uudelleen painamalla F9-näppäintä.

    Jos Virheentarkistus-valintaikkuna ei ole näkyvissä, valitse Kaavat-välilehti > Kaavan tarkistaminen > Virheentarkistus-painike.

  3. Jos olet ohittanut virheitä aiemmin, voit tarkistaa kyseiset virheet uudelleen toimimalla seuraavasti: valitse Tiedosto > Asetukset > Kaavat.

    Valitse Virheentarkistus-osasta Nollaa ohitetut virheet > OK.

    Virheentarkistus

    Huomautus: Ohitettujen virheiden nollaaminen nollaa aktiivisen työkirjan kaikkien laskentataulukoiden kaikki virheet.

    Vihje: Virheentarkistus-valintaikkunan siirtäminen aivan kaavarivin alapuolelle voi helpottaa käyttöä.

    Siirrä Virheentarkistus-ruutu kaavarivin alapuolelle
  4. Napsauta jotakin valintaikkunassa oikealla olevista toimintopainikkeista. Käytettävissä olevat vaihtoehdot määräytyvät virhelajin mukaan.

  5. Valitse Seuraava.

Huomautus: Jos valitset Ohita virhe, virhe merkitään ohitettavaksi seuraavissa tarkistuksissa.

  1. Napsauta solun viereen näkyviin tulevaa Virheentarkistus-painiketta Virheentarkistus-kuvake ja valitse sitten haluamasi vaihtoehto. Kullakin virhelajilla on omat komentonsa, ja virheen kuvaus on ensimmäisellä rivillä.

    Jos valitset Ohita virhe, virhe merkitään ohitettavaksi seuraavissa tarkistuksissa.

    Siirrä Virheentarkistus-ruutu kaavarivin alapuolelle

Jos kaava ei voi laskea tulosta oikein, Excel näyttää virhearvon, esimerkiksi #####, #JAKO/0!, #PUUTTUU, #NIMI?, #TYHJÄ!, #LUKU!, #VIITTAUS! tai #ARVO!. Kullakin virhelajilla on omat syynsä ja ratkaisunsa.

Seuraavassa taulukossa on linkkejä näitä virheitä kuvaaviin artikkeleihin ja lyhyt kuvaus, jonka avulla pääset nopeasti alkuun.

Aihe

Kuvaus

####-virheen korjaaminen

Excel näyttää tämän virheen, kun sarake ei ole tarpeeksi leveä näyttääkseen kaikki solun merkit tai solu sisältää negatiivisen päivämäärä- tai aika-arvon.

Esimerkiksi kaavan, joka vähentää tulevan päivämäärän menneisyydessä olevasta päivämäärästä, kuten 15.06.2008-01.07.2008, tuloksena on negatiivinen arvo.

Vihje: Yritä sovittaa automaattisesti soluun kaksoisnapsauttamalla sarakeotsikoiden väliä. Jos ### tulee näkyviin, koska Excel ei voi näyttää kaikkia merkkejä, tämä korjaa asian.

# virhe

#JAKO/0!-virheen korjaaminen

Excel näyttää tämän virheen, kun luku jaetaan joko nollalla (0) tai solulla, joka ei sisällä arvoa.

Vihje: Lisää virheenkäsittelytoiminto, kuten seuraavassa esimerkissä, joka on =JOS(C2,B2/C2,0)

Virheenkäsittelyfunktion kuten JOS-funktion avulla voidaan käsitellä virheitä

#PUUTTUU!-virheen korjaaminen

Excel näyttää tämän virheen, jos funktiolle tai kaavalle ei ole käytettävissä arvoa.

Jos käytät esimerkiksi PHAKU-funktiota, näkyykö etsimällesi arvolle vastine hakualueelta? Useimmiten ei.

Kokeile estää #PUUTTUU!-virhe käyttämällä JOSVIRHE-funktiota. Tällöin voit käyttää seuraavaa kaavaa:

=JOSVIRHE(PHAKU(D2,$D$6:$E$8,2,TOSI),0)

#PUUTTUU-virhe

#NIMI?-virheen korjaaminen

Tämä virhe näytetään, jos Excel ei tunnista kaavan tekstiä. Esimerkiksi alueen nimi tai funktion nimi voi olla kirjoitettu väärin.

Huomautus: Jos käytät funktiota, varmista, että funktion nimi on kirjoitettu oikein. Tässä tapauksessa SUMMA on kirjoitettu väärin. Poista ”e”, niin Excel korjaa sen.

Excel näyttää #NIMI?-virheen, kun funktion nimessä on kirjoitusvirhe

#TYHJÄ! -virheen korjaaminen

Excel näyttää tämän virheen, jos kaavassa on määritetty kahden alueen leikkauspiste, mutta alueet eivät leikkaa. Leikkausoperaattori on välilyönti, joka erottelee kaavan viittauksia.

Huomautus: Varmista, että alueet erotetaan oikein – alueet C2:C3 ja E4:E6 alueet eivät leikkaa, joten kaava =SUMMA(C2:C3 E4:E6) palauttaa #TYHJÄ!-virheen. Virheen voi korjata lisäämällä pilkun C- ja E-alueiden väliin eli =SUMMA(C2:C3,E4:E6).

#TYHJÄARVO!-virhe

#LUKU! -virheen korjaaminen

Excel näyttää tämän virheen, jos kaavassa tai funktiossa on virheellisiä numeerisia arvoja.

Käytätkö iteroivaa funktiota, kuten SISÄINEN.KORKO tai KORKO? Jos käytät, #LUKU!-virhe johtuu todennäköisesti siitä, että funktio ei löydä tulosta. Katso ohjeista ratkaisu ongelmaan.

#VIITTAUS!-virheen korjaaminen

Excel näyttää tämän virheen, jos soluviittaus on virheellinen. Olet esimerkiksi saattanut poistaa soluja, joihin muut kaavat viittasivat, tai olet saattanut liittää soluja sellaisten solujen eteen, joihin muut kaavat viittasivat.

Poistitko vahingossa rivin tai sarakkeen? Poistimme sarakkeen B tästä kaavasta = SUMMA(A2,B2,C2) ja katso, mitä tapahtui.

Kumoa poisto joko Kumoa-komennolla (Ctrl + Z) tai luo kaava uudelleen tai käytä jatkuvaa solualuetta seuraavasti: =SUMMA(A2:C2), jolloin päivitys tapahtuu automaattisesti, kun sarake B poistetaan.

Excel näyttää #VIITE!-virheen, jos soluviittaus on virheellinen

#ARVO!-virheen korjaaminen

Excel näyttää tämän virheen, jos kaavassa on eri tietotyyppejä sisältäviä soluja.

Käytätkö matemaattisia operaattoreita (+, -, *, / tai ^) eri tietotyyppien kanssa? Jos käytät, kokeile funktiota. Tässä tapauksessa =SUMMA(F2:F5) korjaisi ongelman.

#ARVO!-virhe

Kun solut eivät ole näkyvissä laskentataulukossa, voit silti tarkastella noita soluja ja niiden kaavoja Seurantaikkuna-työkalurivillä. Seurantaikkunan avulla on helppo tutkia, tarkistaa tai vahvistaa kaavojen laskutoimitukset ja tulokset suuressa laskentataulukossa. Kun käytät seurantaikkunaa, sinun ei tarvitse jatkuvasti selata laskentataulukkoa ja siirtyä taulukon paikasta toiseen.

Seurantaikkunan avulla voit helposti valvoa laskentataulukossa käytettäviä kaavoja

Tämän työkalurivin voi siirtää tai kiinnittää kuten muutkin työkalurivit. Voit esimerkiksi kiinnittää sen ikkunan alaosaan. Työkalurivin avulla voidaan seurata seuraavia solun ominaisuuksia: 1) Työkirja, 2) Taulukko, 3) Nimi (jos solussa on vastaava nimetty alue), 4) Solun osoite, 5) Arvo ja 6) Kaava.

Huomautus: Yhtä solua kohti käytössä voi olla vain yksi seurantaikkuna.

Solujen lisääminen seurantaikkunaan

  1. Valitse seurattavat solut.

    Kun haluat valita kaikki laskentataulukon solut, joissa on kaava, valitse Aloitus-välilehden Muokkaaminen-ryhmässä Etsi ja valitse (tai käytä näppäinyhdistelmää Ctrl + G tai Control + G Macissa) > Siirry määräten > Kaavat.

    Siirry määräten -valintaikkuna
  2. Valitse Kaavat-välilehden Kaavan tarkistaminen -ryhmässä Seurantaikkuna.

  3. Valitse Lisää seuranta.

    Valitsemalla Lisää seuranta voit lisätä seurannan laskentataulukkoon
  4. Varmista, että olet valinnut kaikki solut, joita haluat seurata, ja valitse sitten Lisää.

    Kirjoita Seurannan lisääminen -kohtaan seurattava solualue
  5. Voit muuttaa Seurantaikkuna-sarakkeen leveyttä vetämällä sarakeotsikon oikeaa reunaa.

  6. Jos haluat tarkastella solua, johon Seurantaikkuna-työkalurivin merkintä viittaa, kaksoisnapsauta merkintää.

    Huomautus: Solut, joissa on ulkoisia viittauksia muihin työkirjoihin, näkyvät Seurantaikkuna-työkalurivillä vain silloin, kun kyseiset työkirjat ovat avoinna.

Solujen poistaminen seurantaikkunasta

  1. Jos Seurantaikkuna-työkalurivi ei ole näkyvissä, valitse Kaavat-välilehden Kaavan tarkistaminen -ryhmässä Seurantaikkuna.

  2. Valitse solut, jotka haluat poistaa.

    Voit valita useita soluja pitämällä CTRL-näppäintä painettuna, kun napsautat soluja.

  3. Valitse Poista seuranta.

    Poista seuranta

Joskus voi olla vaikeaa ymmärtää, kuinka sisäkkäisiä osia sisältävä kaava laskee lopputuloksen, koska se joutuu laskemaan useita välituloksia ja tekemään loogisia testejä. Käyttämällä Kaavan laskeminen -valintaikkunaa voit kuitenkin nähdä, missä järjestyksessä Excel laskee kaavan eri osat. Esimerkiksi kaava =JOS(KESKIARVO(D2:D5)>50,SUMMA(E2:E5),0) on helpompi ymmärtää, kun näet seuraavat välitulokset:

Laske kaava -toiminnon avulla  näet, kuinka sisäkkäisen kaavan eri osia arvioidaan

Kaavan laskeminen -valintaikkunassa

Kuvaus

=JOS(KESKIARVO(D2:D5) > 50,SUMMA(E2:E5),0)

Sisäkkäisiä osia sisältävä kaava näkyy ensimmäiseksi. KESKIARVO-funktio ja SUMMA-funktio ovat JOS-funktion sisällä.

Solualue D2:D5 sisältää arvot 55, 35, 45 ja 25, joten funktion KESKIARVO(D2:D5) tulos on 40.

=JOS(40>50,SUMMA(E2:E5),0)

Solualue D2:D5 sisältää arvot 55, 35, 45 ja 25, joten funktion KESKIARVO(D2:D5) tulos on 40.

=JOS(Epätosi,SUMMA(E2:E5),0)

40 ei ole suurempi kuin 50, joten JOS-funktion ensimmäisen argumentin (totuus_testi-argumentin) arvo on EPÄTOSI.

JOS-funktio palauttaa kolmannen argumentin arvon (arvo_jos_epätosi-argumentti). SUMMA-funktiota ei lasketa, koska se on JOS-funktion toinen argumentti (arvo_jos_tosi-argumentti), ja se palautetaan vain, kun lauseke on tosi.

  1. Valitse laskettava solu. Vain yksi solu voidaan laskea kerrallaan.

  2. Valitse Kaavat-välilehti > Kaavan tarkistaminen > Laske kaava.

  3. Tarkista alleviivatun viittauksen arvo napsauttamalla Laske. Laskennan tulos näkyy kursivoituna.

    Jos kaavan alleviivattu osa on viittaus toiseen kaavaan, valitsemalla Suorita rivi voit näyttää toisen kaavan Laskeminen-ruudussa. Voit palata takaisin edelliseen soluun ja kaavaan valitsemalla Suorita toimintosarja loppuun.

    Suorita rivi -painike ei ole käytettävissä viittausta varten, jos viittaus on kaavassa toiseen kertaan tai jos kaava viittaa jonkin muun työkirjan soluun.

  4. Napsauta Laske, kunnes olet laskenut kaavan jokaisen osan.

  5. Jos haluat nähdä laskennan uudelleen, valitse Aloita alusta.

  6. Lopeta laskenta valitsemalla Sulje.

Huomautukset: 

  • Jos joitakin JOS- ja VALITSE INDEKSI-funktioita käyttävien kaavojen osia ei lasketa, Laskenta-ruudussa näkyy virhearvo #PUUTTUU.

  • Jos viittaus on tyhjä, Laskenta-ruudussa näkyy nolla-arvo (0).

  • Seuraavat funktiot lasketaan uudelleen aina, kun laskentataulukko muuttuu, joten Kaavan laskenta -valintaikkuna saattaa antaa eri tuloksen kuin solussa näkyvä tulos: SATUNNAISLUKU, ALUEET, INDEKSI, SIIRTYMÄ, SOLU, EPÄSUORA, RIVIT, SARAKKEET, NYT, TÄNÄÄN, SATUNNAISLUKU.VÄLILTÄ.

Onko sinulla jokin erityinen kysymys?

Lähetä kysymys Excel-yhteisön keskustelupalstalle

Auta meitä parantamaan Exceliä

Onko sinulla ehdotuksia, miten voimme parantaa seuraavaa Excel-versiota? Jos on, lue aiheet Excel User Voice -palvelussa.

Katso myös

Kaavojen ja solujen välisten yhteyksien näyttäminen

Video: Viallisten kaavojen korjaaminen (Excel 2010)

Viallisten kaavojen välttäminen

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×