Kaavan luominen käyttämällä funktiota

Tärkeää   Kaavojen ja joidenkin Excel-laskentataulukkofunktioiden lasketut tulokset saattavat olla hieman erilaisia tietokoneissa, joissa käytetään x86- tai x86-64-arkkitehtuuria, sekä Windows RT PC:ssä, jossa käytetään ARM-arkkitehtuuria. Lisätietoa eroista.

Voit luoda kaava, jos haluat laskea laskentataulukon arvoja käyttämällä funktio. Esimerkiksi kaavoissa =SUMMA(A1:A2) ja SUMMA(A1;A2) lasketaan solujen A1 ja A2 arvot yhteen SUMMA-funktiolla. Kaavat alkavat aina yhtäläisyysmerkillä (=).

  1. Valitse solu, johon haluat kirjoittaa kaavan.

  2. Voit aloittaa kaavan funktiolla napsauttamalla kaavarivillä Lisää funktio -painiketta Painikkeen kuva.

    Excel lisää kaavaan yhtäläisyysmerkin (=) puolestasi.

  3. Valitse Tai valitse luokka -ruudusta Kaikki.

    Jos tunnet funktioluokat, voit valita myös luokan.

    Jos et ole varma käytettävästä funktiosta, voit kirjoittaa toimintoa vastaavan kysymyksen Etsi funktio -ruutuun (esimerkiksi "laske luvut yhteen" palauttaa SUMMA-funktion ).

    Vihje    Käytettävissä olevista funktioista on luettelo artikkeleissa Excelin funktiot (aakkosjärjestyksessä) ja Excelin funktiot (luokittain).

  4. Valitse haluamasi funktio Valitse funktio -ruutuun ja valitse sitten OK.

  5. Kirjoita haluamasi arvot, tekstimerkkijonot tai soluviittaukset valitsemasi funktion perusteella näytettäviin argumenttiruutuihin.

    Soluviittausten kirjoittamisen sijaan voit myös valita solut, joihin haluat viitata. Pienennä valintaikkuna napsauttamalla Painikkeen kuva -painiketta, valitse solut, joihin haluat viitata, ja laajenna valintaikkuna uudelleen napsauttamalla sitten Painikkeen kuva -painiketta.

    Vihje    Jos haluat lisätietoja funktiosta ja sen argumenteista, valitse Tämän funktion ohje.

  6. Kun olet kirjoittanut kaavan argumentit, valitse OK.

Vihje    Jos käytät funktioita usein, voit lisätä kaavoja suoraan laskentataulukkoon. Kun olet kirjoittanut yhtäläisyysmerkin (=) ja funktion nimen, saat tietoja kaavan syntaksista ja funktion argumenteista painamalla F1-näppäintä.

Esimerkkejä

Käytä tässä esitettyä upotettua työkirjaa, jos haluat käsitellä esimerkkikaavoja, jotka käyttävät funktiota. Voit tarkistaa ja muuttaa kaavoja sekä kirjoittaa omia kaavoja.

Kopioi taulukko Excelin tyhjän laskentataulukon soluun A1, jos haluat käyttää näiden esimerkkien funktioita käyttäviä kaavoja.

Tiedot

5

4

2

6

3

8

7

1

Kaava

Kuvaus

Tulos

'=SUMMA(A:A)

Lisää kaikki numerot sarakkeesta A

=SUMMA(A:A)

'=KESKIARVO(A1:B4)

Laskee solualueella A1:B4 olevien numeroiden keskiarvon

=KESKIARVO(A1:B4)

Jos haluat tutustua tähän työkirjaan tarkemmin, voit ladata sen tietokoneeseesi ja avata sen Excelissä. Lisätietoja on artikkelissa Upotetun työkirjan lataaminen OneDrivesta ja sen avaaminen tietokoneessa.

Sivun alkuun

Käyttö: Excel 2013



Oliko näistä tiedoista hyötyä?

Kyllä Ei

Miten voimme parantaa?

255 merkkiä jäljellä

Yksityisyytesi suojaamiseksi älä sisällytä palautteeseen yhteystietoja. Arvioi tietosuojakäytäntö.

Kiitos palautteesta!

Tukiresurssit

Vaihda kieli