Kaavan kopioiminen täyttökahvaa vetämällä Excel 2016 for Macissa

Voit kopioida kaavoja nopeasti vierekkäisiin soluihin täyttökahvalla.

Täyttökahva

Kun vedät kahvan toisiin soluihin, Excel näyttää eri tulokset kullekin solulle.

Kaavan kopioiminen täyttökahvaa vetämällä

  1. Valitse solu, joka sisältää vierekkäisiin soluihin täytettävän kaavan.

  2. Pidä osoitinta oikeassa alakulmassa, kunnes se muuttuu plusmerkiksi (+) kuvassa osoitetulla tavalla:

    Kohdistin täyttökahvan päällä

  3. Vedä täyttökahvaa alaspäin, ylöspäin tai sivuttain täytettävissä soluissa. Tässä esimerkissä täyttökahvaa vedetään alaspäin:

    Osoitin vetää täyttökahvan alas

  4. Kun vapautat painikkeen, kaava täytetään automaattisesti muihin soluihin:

    Arvot viittaavat täytettyihin soluihin

  5. Voit muuttaa solujen täyttötapaa Automaattisen täytön asetukset -painikkeella Automaattisen täytön asetukset -painike , joka tulee näkyviin, kun lopetat vetämisen. Valitse sitten haluamasi vaihtoehto.

Lisätietoja kaavojen kopioimisesta on artikkelissa Kaavan kopioiminen ja liittäminen toiseen soluun tai laskentataulukkoon.

Vihjeitä: 

  • Voit täyttää kaavaa sarakkeessa alaspäin myös painamalla näppäinyhdistelmää CONTROL + D. Valitse ensin solu, jonka kaavalla haluat täyttää soluja, ja valitse sitten soluja sen alapuolelta ja paina näppäinyhdistelmää CONTROL + D.

  • Voit täyttää kaavaa rivillä oikealle myös painamalla näppäinyhdistelmää CONTROL + R. Valitse ensin solu, jonka kaavalla haluat täyttää soluja, valitse sitten soluja sen oikealta puolelta ja paina CONTROL + R.

Täyttäminen epäonnistuu

Joskus solujen täyttäminen toimii hyvin, mutta toisinaan se ei toimi odotetulla tavalla. Tämän vuoksi on tärkeää tarkistaa ensin soluviittaukset.

Soluviittaukset osoittavat toisiin soluihin. Jos ensimmäisessä solussa on esimerkiksi seuraava kaava:


=SUMMA(A1,B1)


A1 ja B1 ovat suhteellisia viittauksia. Kun täytät kaavaa alaspäin, viittaukset muuttuvat asteittain, esimerkiksi A1, B1 – A2, B2 ja niin edelleen:

=SUMMA(A1,B1)

=SUMMA(A2,B2)

=SUMMA(A3,B3)

Joskus et taas ehkä halua muiden solujen viittausten muuttuvan. Voit esimerkiksi haluta ensimmäisen A1-viittauksen pysyvän ennallaan ja B1-viittauksen muuttuvan kahvaa vedettäessä. Kirjoita tässä tapauksessa dollarin merkit ensimmäiseen viittaukseen seuraavasti: =SUMMA($A$1,B1). Dollarin merkit pakottavat Excelin osoittamaan soluun A1 muita soluja täytettäessä. Kaavat näyttävät seuraavilta:

=SUMMA($A$1,B1)

=SUMMA($A$1,B2)

=SUMMA($A$3,B3)

Dollarin merkit ($) sisältäviä viittauksia kutsutaan suoriksi viittauksiksi. Kun soluja täytetään alaspäin, A1-viittaus pysyy muuttumattomana, mutta Excel muuttaa B1-, B2- ja B3-viittaukset.

Täyttökahva ei näy

Jos täyttökahvaa ei ole näkyvissä, se on voitu piilottaa. Tuo se uudelleen näkyviin seuraavasti:

  1. Valitse Excel-valikossa Asetukset.

  2. Valitse Muokkaa.

  3. Valitse Muokkausasetukset-kohdassa Ota täyttökahva ja solujen vetäminen ja pudottaminen käyttöön -valintaneliö.

Jos automaattista työkirjan laskentaa ei ole otettu käyttöön, ohjelma ei laske kaavoja uudelleen soluja täytettäessä. Voit ottaa tarvittaessa laskennan käyttöön seuraavasti:

  1. Valitse Excel-valikossa Asetukset.

  2. Valitse Laskenta.

  3. Varmista Laskenta-asetukset-kohdassa, että Automaattinen-vaihtoehto on valittuna.

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×