KETJUTA-funktion #ARVO!-virheen korjaaminen

Tärkeää: Excel 2016:ssa, Excel Mobilessa ja Excel Onlinessa KETJUTA-funktio on korvattu YHDISTÄ-funktiolla. Vaikka KETJUTA-funktio on yhä käytettävissä taaksepäisen yhteensopivuuden takia, kannattaa käyttää laadukkaampaa YHDISTÄ-funktiota.

Yksi yleisimmistä skenaariosta, joissa kohtaat #ARVO!-virhearvon KETJUTA-funktion yhteydessä, on tilanne, jossa yrität muodostaa merkkijonoa ja siinä on virheellinen viittaus, kuten #VALUE!.

Seuraavassa esimerkissä haluamme ketjuttaa solut D2, E2 ja F2, ja solussa E2 on #VALUE!-virhearvo.

KETJUTA-funktion #ARVO!-virhe

Solussa E2 oleva virhe aiheuttaa sen, että funktio näyttää arvon #VALUE!. Jotta se toimisi oikein, sinun on korvattava virheen aiheuttava arvo toisella arvolla, joka ei aiheuta virhettä. Voit muodostaa kaavan, joka etsii virhettä soluviittauksesta. Jos virhe löytyy, kaava näyttää merkkijonon, jossa virheen tilalla näkyy arvo 0 (voit myös korvata arvon 0 omalla tekstilläsi, mutta teksti on kirjoitettava lainausmerkkeihin – ”Oma teksti”).

Tällainen kaava on sopiva:

=JOS(ONVIRHE(E2);KETJUTA(D2;” ”;0;” ”;F2))

JOS-ja ONVIRHE-funktioita käytetään vaihtoehtoisena menetelmänä, jolla merkkijono ja #ARVO-virhe yhdistetään

Miten tämä toimii? JOS-funktio määrittää JOSVIRHE-funktion avulla, onko solussa E2 virhe. Jos on, KETJUTA-funktio yhdistää arvot soluissa D2, E2 ja F2 (funktio korvaa virheen arvo 0), ja näyttää tuloksena saatavan tekstimerkkijonon. Huomaa, että kaava käyttää myös välilyöntejä (” ”) arvojen erottamiseen.

#ARVO!-virhearvon korjaaminen KETJUTA-funktion avulla Excel 2003:ssa ja vanhemmissa versioissa

Jos näyttöön tulee #ARVO!-virhe Office Excel 2003:ssa tai aiemmassa versiossa, poista käytöstä Muulla ohjelmistolla luodun kaavan arviointi -asetus Excelissä. Voit ratkaista ongelman noudattamalla artikkelin #ARVO!-virhe ketjutettaessa soluja ohjeita.

Onko sinulla jokin funktioihin liittyvä kysymys?

Lähetä kysymys Excel-yhteisön keskustelupalstalle

Auta meitä parantamaan Exceliä

Onko sinulla ehdotuksia, miten voimme parantaa seuraavaa Excel-versiota? Jos on, lue aiheet Excel User Voice -palvelussa.

Katso myös

#ARVO!-virheen korjaaminen

KETJUTA-funktio

YHDISTÄ-funktio

Yleiskuva kaavoista Excelissä

Viallisten kaavojen ratkaiseminen

Kaavoissa esiintyvien virheiden etsiminen

Kaikki Excel-funktiot (aakkosjärjestyksessä)

Kaikki Excel-funktiot (luokittain)

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×