KESKIARVO- tai SUMMA-funktioiden #ARVO!-virheen korjaaminen

Jos KESKIARVO tai SUMMA viittaa soluihin, jotka sisältävät #ARVO!-virheen, kaavat palauttavat #ARVO!-virheen.

#ARVO!-virhe KESKIARVO-funktiossa

Jotta virhearvot voidaan jättää huomiotta, laaditaan kaava, joka ohittaa viittausalueen virheet laskettaessa keskiarvoa jäljellä olevilla normaaleilla arvoilla.

Tällöin käytetään KESKIARVO-funktiota yhdessä JOS- ja ONVIRHE-funktioiden kanssa sen määrittämiseksi, onko määritetyllä alueella virhe. Tilanne edellyttää matriisikaavaa:

=KESKIARVO(JOS(ONVIRHE(B2:D2),””,B2:D2))

Huomautus: Tämä on matriisikaava, ja se on syötettävä näppäinyhdistelmällä Ctrl + Vaihto + Enter. Excel lisää kaavan ympärille automaattisesti kaarisulkeet {}. Jos yrität kirjoittaa ne itse, Excel näyttää kaavan tekstinä.

Matriisifunktio KESKIARVO-funktiossa #ARVO!-virheen ratkaisemiseksi

Huomautus: Edellä oleva funktio toimii #ARVO!-virheen lisäksi myös muun muassa #PUUTTUU-, #TYHJÄARVO- ja #JAKO/0!-virheiden kanssa.

Voit käyttää SUMMA-funktiota samalla tavalla:

= SUMMA(JOS(ONVIRHE(B2:D2),””,B2:D2))

Onko sinulla jokin funktioihin liittyvä kysymys?

Lähetä kysymys Excel-yhteisön keskustelupalstalle

Auta meitä parantamaan Exceliä

Onko sinulla ehdotuksia, miten voimme parantaa seuraavaa Excel-versiota? Jos on, lue aiheet Excel User Voice -palvelussa.

Katso myös

#ARVO!-virheen korjaaminen

KESKIARVO-funktio

SUMMA-funktio

Yleiskuva kaavoista Excelissä

Viallisten kaavojen ratkaiseminen

Kaavoissa esiintyvien virheiden etsiminen

Kaikki Excel-funktiot (aakkosjärjestyksessä)

Kaikki Excel-funktiot (luokittain)

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×