KESKIARVO-funktio

Tässä artikkelissa kuvataan Microsoft Excelin KESKIARVO-funktion kaavasyntaksi ja käyttö.

Kuvaus

Palauttaa argumenttien aritmeettisen keskiarvon. Jos esimerkiksi alue A1:A20 sisältää lukuja, kaava =KESKIARVO(A1:A20) palauttaa näiden lukujen keskiarvon.

Syntaksi

KESKIARVO(luku1; [luku2]; ...)

KESKIARVO-funktion syntaksilla on seuraavat argumentit:

  • Luku1    Pakollinen. Ensimmäinen luku, soluviittaus tai alue, jonka arvojen keskiarvon haluat laskea.

  • Luku2;...    Valinnainen. Muut luvut, soluviittaukset tai alueet, joiden keskiarvon haluat laskea. Muita lukuja voi olla enintään 255.

Huomautuksia

  • Argumentit voivat olla lukuja tai lukuja sisältäviä nimiä, alueita tai soluviittauksia.

  • Funktio laskee argumenteiksi kirjoittamasi totuusarvot ja tekstimuotoiset luvut mukaan summaan.

  • Funktio ohittaa alue- tai soluviittausargumenttien sisältämän tekstin, totuusarvot ja tyhjät solut. Sen sijaan solut, joiden arvo on nolla, otetaan huomioon.

  • Jos argumentti on virhearvo tai teksti, jota ohjelma ei pysty muuntamaan luvuksi, ohjelma ilmoittaa virheestä.

  • Jos haluat sisällyttää viittaukseen totuusarvoja ja tekstimuotoisia lukuja laskutoimituksen osaksi, käytä KESKIARVOA-funktiota.

  • Jos haluat laskea vain tietyt ehdot täyttävien arvojen keskiarvon, käytä KESKIARVO.JOS-funktiota tai KESKIARVO.JOS.JOUKKO-funktiota.

Huomautus: KESKIARVO-funktio kuvaa keskimääräisyyttä, joka on lukujoukon keskipiste tilastollisessa jakautumassa. Kolme yleisintä keskimääräisyyden kuvaajaa ovat seuraavat:

  • Keskiarvo eli aritmeettinen keskiarvo, joka lasketaan laskemalla yhteen joukko lukuja ja jakamalla tulos lukujen määrällä. Esimerkiksi lukujen 2, 3, 3, 5, 7 ja 10 on keskiarvo on 30 jaettuna 6:lla eli 5.

  • Mediaani eli lukujoukon keskimmäinen luku, jolloin puolet joukon luvuista on pienempiä ja puolet suurempia kuin mediaani. Esimerkiksi lukujen 2, 3, 3, 5, 7 ja 10 mediaani on 4.

  • Moodi, joka on lukujoukossa useimmin esiintyvä luku. Esimerkiksi lukujen 2, 3, 3, 5, 7 ja 10 moodi on 3.

Jos lukujoukon hajonta on symmetrinen, nämä kolme keskimääräisyyden kuvaajaa ovat samanarvoisia. Jos lukujoukon hajautuma on vinoutunut, nämä kuvaajat voivat olla erilaisia.

Vihje: Kun lasket keskiarvoa, muista tyhjien solujen ja nolla-arvon sisältävien solujen välinen ero, erityisesti jos olet poistanut Excel-työpöytäsovelluksen Excelin asetukset -välilehdessä Näytä nolla soluissa, jotka sisältävät nolla-arvon -valintaruudun valinnan. Kun tämä vaihtoehto on valittuna, tyhjiä soluja ei lasketa keskiarvoon, mutta nolla-arvot lasketaan.

Voit etsiä Näytä nolla soluissa, jotka sisältävät nolla-arvon -valintaruudun seuraavasti:

  • Valitse Tiedosto-välilehti, valitse Asetukset ja valitse sitten Lisäasetukset-luokan Tämän laskentataulukon näyttöasetukset.

Esimerkki

Kopioi esimerkkitiedot seuraavaan taulukkoon ja lisää se uuden Excel‑laskentataulukon soluun A1. Kaavat näyttävät tuloksia, kun valitset ne, painat F2-näppäintä ja sitten Enter-näppäintä. Voit säätää sarakkeiden leveyttä, että näet kaikki tiedot.

Tiedot

10

15

32

7

9

27

2

Kaava

Kuvaus

Tulos

=KESKIARVO(A2;A6)

Laskee solujen A2 ja A6 rajaaman solualueen lukujen keskiarvon.

11

=KESKIARVO(A2:A6; 5)

Laskee solujen A2 ja A6 rajaaman solualueen lukujen ja luvun 5 keskiarvon.

10

=KESKIARVO(A2:C2)

Laskee solujen A2 ja C6 rajaaman solualueen lukujen keskiarvon.

19

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×