Julkaistun lomakemallin siirtäminen uuteen SharePoint-kirjastossa

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Sisältö

Yleiskatsaus

Ennen aloittamista

Lomakemallin toimimasta kopioiminen

Vaihe 1: Lomakemallin julkaiseminen uusi asiakirjakirjasto

Vaihe 2: Kopioi ja linkitä lomakkeisiin

Yleiskatsaus

Kun olet julkaissut lomakemallin, jotta käyttäjät voivat täyttää ne, sinun on ehkä siirrettävä kyseinen lomakemalli toiseen asiakirjakirjastoon. Sinun on esimerkiksi ehkä siirrettävä lomakemalli tehokkaampaan palvelimeen, jotta käyttäjät voivat täyttää lomakkeita samanaikaisesti. Jotkut käyttäjät ovat ehkä jo täyttäneet lomakkeita, jotka perustuvat alkuperäiseen asiakirjakirjastoon tallentamaasi lomakemalliin. Kun siirrät lomakemallin uuteen asiakirjakirjastoon, haluat siirtää myös nämä aiemmin luodut lomakkeet. Haluat myös varmistaa, että kyseiset aiemmin luodut lomakkeet toimivat uudessa asiakirjakirjastossa, ennen kuin arkistoit tai poistat vanhan asiakirjakirjaston.

Vihje: Ennen kuin siirrät julkaistut lomakemallit uuteen asiakirjakirjastoon, luo suunnitelma, jonka mukaan ilmoitat myös käyttäjille, että heidän lomakkeensa on siirretty uuteen asiakirjakirjastoon. Haluat käyttäjien käyttävän uutta asiakirjakirjastoa uusien lomakkeiden tallentamiseen tai aiemmin luotujen lomakkeiden muokkaamiseen. Suunnitelman tulee pitää sisällään myös alkuperäisen asiakirjakirjaston arkistointi- tai poistamisprosessi.

Jotta voit siirtää lomakemallin ja sen aiemmin luodut lomakkeet uuteen asiakirjakirjastoon, sinun on ensin julkaistava työkopio lomakemallista uuteen asiakirjakirjastoon. Työkopio on se lomakemallin versio, joka on tallennettu tietokoneeseen tai versionhallintaohjelmaan, kuten Microsoft Visual SourceSafeen.

Vihje: Jos sinulla ei ole työkopiota lomakemallista, voit tallentaa lomakemallin kopion alkuperäisestä asiakirjakirjastosta tietokoneeseen käyttääksesi sitä työkopiona.

Kun olet julkaissut työkopion uuteen asiakirjakirjastoon, sinun on kopioitava kaikki lomakkeet vanhasta asiakirjakirjastosta uuteen asiakirjakirjastoon ja linkitettävä sitten uuden asiakirjakirjaston lomakkeet uudelleen äskettäin julkaistuun lomakemalliin.

Jos sinun on lomakemallin siirtämisestä johtuen tehtävä muutoksia, tee muutokset ennen lomakemallin julkaisemista. Kyseiseen lomakemalliin perustuvien lomakkeiden käyttämien ulkoisten tietolähteiden sijainti saattaa esimerkiksi myös muuttua lomakemallin siirtämisen tuloksena. Tällöin sinun on muutettava tietoyhteys lomakemallissa ulkoisten tietolähteiden uuteen sijaintiin ennen lomakemallin julkaisemista. Lisätietoja tietoyhteyksien muuttamisesta on Katso myös -osan linkeissä.

Huomautus: Lomakemallin julkaiseminen ei tarkoita samaa kuin lomakemallin tallentaminen. Kun julkaiset lomakemallin, ohjattu julkaisutoiminto lisää lomakemallin julkaisusijainnin ja käsittelyohjeet siten, että käyttäjät voivat avata tähän lomakemalliin perustuvat lomakkeet. Kun tallennat lomakemallin, tallennat lomakemallin kopion samalla tavoin kuin jos tallentaisit tiedoston tietokoneeseen. Käytä ohjattua julkaisutoimintoa aina, kun haluat asettaa lomakemallin käyttäjien saataville täytettäväksi.

Sivun alkuun

Toimet ennen aloittamista

Ennen kuin siirrät lomakemallin ja aiemmin luotuja kyseiseen lomakemalliin perustuvia lomakkeita uuteen asiakirjakirjastoon, sinulla on oltava käytössäsi seuraavat asiat:

  • Lomakemallin työkopio    Tämä on kopio lomakemallista, jota muokkaat ja jonka sitten julkaiset uudelleen asiakirjakirjastoon. Työkopio voi olla tallennettu tietokoneeseen tai versionhallintaohjelmaan, kuten Visual SourceSafeen.

  • Uusien ulkoisten tietolähteiden sijainnit    Jos lomakemalliin perustuvat lomakkeet käyttävät muuttuneita ulkoisia tietolähteitä, tarvitset ulkoisten tietolähteiden uudet sijainnit. Varmista järjestelmänvalvojalta, että sinulla ja käyttäjillä on tarvittavat oikeudet käyttää ulkoisia tietolähteitä. Jos lomakemalli muodostaa yhteyden ulkoiseen tietolähteeseen käyttämällä tietoyhteystiedoston asetuksia, varmista, että tietoyhteystiedosto päivitettiin yhdessä ulkoisen tietolähteen uuden sijainnin kanssa.

  • Tarvittavat käyttöoikeudet palvelimessa, jossa on käytössä Windows SharePoint Services 3.0    Sinulla on oltava tarvittavat palvelimen käyttöoikeudet, jotta voit julkaista lomakemallin ja kopioida aiemmin luodut lomakkeet vanhasta asiakirjakirjastosta uuteen asiakirjakirjastoon. Tarkista palvelimen järjestelmänvalvojalta, että sinulla on kyseiset käyttöoikeudet.

Sivun alkuun

Lomakemallin työkopion hankkiminen

Jos haluat muokata asiakirjakirjastoon tai jaettuun verkkosijaintiin julkaistua lomakemallia, eikä sinulla ole työkopiota lomakemallista, voit tallentaa lomakemallin työkopion julkaisusijainnista tietokoneeseen.

Vihje: Harkitse versionhallintaohjelman, kuten Microsoft Visual SourceSafen, käyttämistä lomakemallien työkopioiden hallitsemiseen.

Lomakemallin kopion tallentaminen asiakirjakirjastosta tietokoneeseen

  1. Avaa selain tiedostokirjastoon, jossa lomakemalli on julkaistu.

  2. Valitse asetukset -valikossa asetuksetja valitse sitten Lomakkeen kirjaston asetukset.

  3. Valitse Yleiset asetukset -kohdasta Lisäasetukset.

  4. Valitse Asiakirjamalli-osasta Muokkaa mallia.

    Lomakemallin avautuu Microsoft Office InfoPath.

  5. Valitse Microsoft Office InfoPath -valintaikkunassa Kyllä.

  6. Valitse Tiedosto-valikosta Tallenna nimellä.

  7. Valitse Microsoft Office InfoPath -valintaikkunassa OK.

  8. Etsi Tallenna nimellä -valintaikkunassa sijainti, johon haluat tallentaa kopion lomakemallista, ja valitse sitten Tallenna.

Lomakemallin kopion tallentaminen jaetusta verkkokansiosta tietokoneeseen

  1. Valitse Tiedosto -valikossa lomakemallin suunnitteleminen.

  2. Valitse Avaa lomakemalli -kohdasta Tässä tietokoneessa.

  3. Julkaistun lomakemallin jaettu verkkokansio selaamalla, valitse ensin lomakemalli ja valitse sitten Avaa.

  4. Valitse Tiedosto-valikosta Tallenna nimellä.

  5. Valitse Microsoft Office InfoPath -valintaikkunassa OK.

  6. Valitse Tallenna nimellä -valintaikkunassa sijainti, muita kuin alkuperäisen sijainti, johon toimimasta iPadin lomakemallin julkaiseminen ja valitse sitten Tallenna.

Sivun alkuun

Vaihe 1: lomakemallin julkaiseminen uuteen asiakirjakirjastoon

  1. Avaa lomakemallin työkopio suunnittelutilassa.

  2. Napsauta Tiedosto-valikosta Julkaise.

  3. Napsauta ohjatussa julkaisutoiminnossa SharePoint-palvelimeen (InfoPath Forms Services ei ole pakollinen) ja napsauta sitten Seuraava.

  4. Kirjoita Kirjoita SharePoint- tai InfoPath Forms Services -sivuston sijainti -ruutuun sen SharePoint-sivuston sijainti, joka sisältää uuden asiakirjakirjaston, johon haluat siirtää lomakemallin. Valitse sitten Seuraava.

  5. Valitse ohjatun toiminnon seuraavalla sivulla Asiakirjakirjasto ja valitse sitten Seuraava.

  6. Valitse Luo uusi asiakirjakirjasto ja valitse sitten Seuraava.

  7. Kirjoita ohjatun toiminnon seuraavalle sivulle uuden asiakirjakirjaston nimi ja kuvaus ja valitse sitten Seuraava.

  8. Valitse lomakemallin kentät, joiden haluat näkyvän asiakirjakirjaston oletusnäkymän sarakkeina.

    Toimintaohjeet

    1. Valitse Lisää.

    2. Valitse kenttä, jonka haluat lisätä tiedostokirjaston sarakkeeksi, ja tee sitten jompikumpi seuraavista:

      • Kirjoita sarakkeelle nimi Sarakkeen nimi -ruutuun.

      • Valitse sivustosarake Sivustosarakeryhmä-luettelosta ja valitse sitten nimi Sarakkeen nimi -luettelosta. Valitse lopuksi OK.

        Huomautus: Jos valitset toistuvan kentän tiedostokirjaston tietojen näyttämiseksi, voit määrittää, miten haluat näyttää kentän tiedostokirjastossa napsauttamalla arvoa Funktio-luettelossa. Voit valita, näytetäänkö kentän ensimmäinen arvo vai viimeinen arvo, lasketaanko kentän kaikkien esiintymien määrä yhteen vai yhdistetäänkö kaikki arvot.

    3. Valitse OK.

    Lisätietoja tietojen näyttämisestä asiakirjakirjaston sarakkeissa on Katso myös -osan linkeissä.

  9. Valitse Seuraava.

  10. Vahvista ohjatun toiminnon seuraavalla sivulla, että tiedot ovat oikein, ja valitse sitten Julkaise.

  11. Jos haluat avata asiakirjakirjaston ja testata kyseiseen lomakemalliin perustuvan lomakkeen täyttämistä, valitse Avaa tämä asiakirjakirjasto -valintaruutu ja valitse sitten Sulje.

    Asiakirjakirjasto avataan selaimessa. Kun valitset Uusi luettelopalkista, tähän lomakemalliin perustuva lomake avautuu Microsoft Office InfoPathissa.

Kun olet julkaissut lomakemallin uuteen asiakirjakirjastoon, voit kopioida aiemmin luodut lomakemallin vanhaan versioon perustuvat lomakkeet vanhasta asiakirjakirjastosta uuteen asiakirjakirjastoon. Kun olet kopioinut aiemmin luodut lomakkeet, voit linkittää aiemmin luodut lomakkeet uudelleen lomakemallin uuteen versioon. Jos et linkitä aiemmin luotuja lomakkeita, käyttäjät eivät voi ehkä avata kyseisiä aiemmin luotuja lomakkeita.

Sivun alkuun

Vaihe 2: aiemmin luotujen lomakkeiden kopioiminen ja uudelleenlinkittäminen

Tässä prosessissa oletetaan, että molemmat asiakirjakirjastot ovat palvelimessa, jossa on käytössä Windows SharePoint Services 3.0.

  1. Avaa vanha asiakirjakirjasto Web-selaimessa.

  2. Valitse Näytä-valikosta Resurssienhallintanäkymä.

  3. Pidä CTRL-näppäintä alhaalla ja valitse kaikki lomakkeet, jotka haluat siirtää. Napsauta sitten hiiren kakkospainikkeella yhtä lomakkeista.

  4. Valitse Internet Explorer -valintaikkunasta Kyllä ja valitse sitten pikavalikosta Kopioi.

  5. Avaa uusi asiakirjakirjasto.

  6. Valitse Valitse näkymä -kohdasta Resurssienhallintanäkymä.

  7. Napsauta hiiren kakkospainikkeella kansioikkunan tyhjällä alueella.

  8. Valitse Internet Explorer -valintaikkunasta Kyllä ja valitse sitten pikavalikosta Liitä.

  9. Valitse Näytä-valikosta Linkitä asiakirjat uudelleen.

  10. Valitse Linkitä uudelleen -sarakkeessa jokaisen lomakkeen, jonka haluat linkittää uuteen lomakemalliin, valintaruutu.

  11. Valitse luettelopalkista Linkitä valitut asiakirjat uudelleen.

Kun olet linkittänyt uudelleen aiemmin luodut lomakkeet uuteen lomakemalliin, käyttäjät voivat muuttaa aiemmin luotuja uuteen asiakirjakirjastoon kopioituja lomakkeita tai täyttää äskettäin julkaistuun lomakemalliin perustuvia uusia lomakkeita.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×