JOS- ja JA-funktioiden sekä TAI- ja EI-funktioiden yhteiskäyttö

JOS-funktion avulla voit tehdä loogisen vertailun arvon ja odotetun arvon välillä testaamalla ehtoa ja palauttamalla tuloksen, jos ehto on Tosi tai Epätosi.

  • JOS(jokin on Tosi, tee jotain, muutoin tee jotain muuta)

Entä jos haluat kuitenkin testata useita ehtoja, joista kaikkien on oltava Tosi tai Epätosi (JA) tai joista vain yhden on oltava Tosi tai Epätosi (TAI), tai jos haluat tarkistaa, että ehto EI täytä antamiasi ehtoja? Kaikkia kolmea funktiota voi käyttää erikseen, mutta on yleisempää käyttää niitä yhdessä JOS-funktioiden kanssa.

Käytä JOS-funktiota JA-, TAI- ja EI-funktioiden kanssa, jos haluat tehdä monta vertailua siitä, ovatko ehdot Tosi vai Epätosi.

Syntaksi

  • JOS(JA()) - JOS(JA(looginen1, [looginen2], ...), arvo_jos_tosi, [arvo_jos_epätosi]))

  • JOS(TAI()) - JOS(TAI(looginen1, [looginen2], ...), arvo_jos_tosi, [arvo_jos_epätosi]))

  • JOS(EI()) - JOS(EI(looginen1), arvo_jos_tosi, [arvo_jos_epätosi]))

Argumentin nimi

Kuvaus

looginen_testi (pakollinen)

Testattava ehto.

arvo_jos_tosi (pakollinen)

Palautettava arvo, jos loogisen_testin tulos on TOSI.

arvo_jos_epätosi (valinnainen)

Palautettava arvo, jos loogisen_testin tulos on EPÄTOSI.

Seuraavien ohjeiden avulla voit luoda JA-, TAI- ja EI-funktioita yksitellen. Kun yhdistät jonkin näistä JOS-lausekkeen kanssa, ne tarkoittavat seuraavaa:

  • JA – =JOS(JA(jokin on Tosi, jokin muu on Tosi), arvo jos Tosi, arvo jos Epätosi)

  • TAI – =JOS(TAI(jokin on Tosi, jokin muu on Tosi), arvo jos Tosi, arvo jos Epätosi)

  • EI – =JOS(EI(jokin on Tosi), arvo jos Tosi, arvo jos Epätosi)

Esimerkkejä

Seuraavassa on esimerkkejä joistakin yleisistä sisäkkäisistä JOS(JA()), JOS(TAI()) ja JOS(EI())-lausekkeista. JA- ja TAI-funktioissa voidaan käyttää enintään 255 yksittäistä ehtoa, mutta kannattaa käyttää vain muutamaa, koska monimutkaisten, sisäkkäisten kaavojen muodostaminen, testaaminen ja ylläpitäminen voi olla vaikeaa. EI-funktio hyväksyy vain yhden ehdon.

Esimerkkejä numeeristen arvojen ja tekstin arvioimiseen käyttämällä JOS-funktiota JA-, TAI- ja EI-funktioiden kanssa

Kaavojen selitykset niiden logiikan mukaisesti:

Kaava

Kuvaus

=JOS(JA(A2>0,B2<100),TOSI, EPÄTOSI)

JOS A2 (25) on suurempi kuin 0 JA B2 (75) on pienempi kuin 100, palauta arvo TOSI, muuten palauta arvo EPÄTOSI. Tässä tapauksessa molemmat ehdot täyttyvät, joten funktio palauttaa arvon TOSI.

=JOS(JA(A3=”Punainen”,B3=”Vihreä”),TOSI,EPÄTOSI)

Jos A3 (”Sininen”) = ”Punainen” JA B3 (”Vihreä”) on yhtä kuin ”Vihreä”, palauta arvo TOSI, muussa tapauksessa palauta arvo EPÄTOSI. Tässä tapauksessa vain ensimmäinen ehto on TOSI, joten funktio palauttaa arvon EPÄTOSI.

=JOS(TAI(A4>0,B4<50),TOSI, EPÄTOSI)

JOS A4 (25) on suurempi kuin 0 JA B4 (75) on pienempi kuin 50, palauta arvo TOSI, muuten palauta arvo EPÄTOSI. Tässä tapauksessa vain ensimmäinen ehto on TOSI, mutta koska TAI edellyttää, että vain yhden argumentin arvon on oltava TOSI, kaava palauttaa arvon TOSI.

=JOS(TAI(A5=”Punainen”,B5=”Vihreä”),TOSI,EPÄTOSI)

Jos A5 (”Sininen”) on yhtä kuin ”Punainen” TAI B5 (”Vihreä”) on yhtä kuin ”Vihreä”, palauta arvo TOSI, muussa tapauksessa palauta arvo EPÄTOSI. Tässä tapauksessa vain toinen argumentti on TOSI, joten kaava palauttaa arvon TOSI.

=JOS(EI(A6>50),TOSI,EPÄTOSI)

JOS A6 (25) EI ole suurempi kuin 50, palauta arvo TOSI, muuten palauta arvo EPÄTOSI. Tässä tapauksessa 25 ei ole suurempi kuin 50, joten kaava palauttaa arvon TOSI.

=JOS(EI(A7=”Punainen”),TOSI,EPÄTOSI)

Jos A7 (”Sininen”) EI ole yhtä kuin ”Punainen”, palauta arvo TOSI, muuten palauta arvo EPÄTOSI.

Huomaa, että kaikissa esimerkeissä on sulkevat sulut kohdassa, jossa ehto päättyy. Loput Tosi/Epätosi-argumentit jäävät näin ulompaan JOS-ehtoon. Voit myös korvata esimerkkien palauttamat TOSI- tai EPÄTOSI-arvot tekstillä tai numeerisilla arvoilla.

Seuraavassa on esimerkkejä päivämäärien vertailemiseen JA-, TAI- ja EI-funktioilla.

Esimerkkejä päivämäärien arvioimiseen käyttämällä JOS-funktiota JA-, TAI- ja EI-funktioiden kanssa

Kaavojen selitykset niiden logiikan mukaisesti:

Kaava

Kuvaus

=JOS(A2>B2,TOSI,EPÄTOSI)

JOS A2 on suurempi kuin B2, palauta arvo TOSI, muuten palauta arvo EPÄTOSI. 03/12/14 on suurempi kuin 01/01/14, joten kaava palauttaa arvon TOSI.

=JOS(JA(A3>B2,A3<C2),TOSI,EPÄTOSI)

JOS A3 on suurempi kuin B2 JA A3 on pienempi kuin C2, palauta arvo TOSI, muuten palauta arvo EPÄTOSI. Tässä tapauksessa molempien argumenttien arvo on TOSI, joten kaava palauttaa arvon TOSI.

=JOS(TAI(A4>B2,A4<B2+60),TOSI,EPÄTOSI)

JOS A4 on suurempi kuin B2 TAI A4 on pienempi kuin B2 + 60, palauta arvo TOSI, muuten palauta arvo EPÄTOSI. Tässä tapauksessa ensimmäisen argumentin arvo on TOSI, mutta toisen EPÄTOSI. Koska TAI edellyttää, että vain yhden argumenteista on oltava TOSI, kaava palauttaa arvon TOSI. Jos käytät ohjattua Kaavan laskeminen -toimintoa Kaava-välilehden kautta, näet, miten Excel laskee kaavan.

=JOS(EI(A5>B2),TOSI,EPÄTOSI)

JOS A5 EI ole suurempi kuin B2, palauta arvo TOSI, muuten palauta arvo EPÄTOSI. Tässä tapauksessa A5 on suurempi kuin B2, joten kaava palauttaa arvon EPÄTOSI.

Esimerkki ohjatusta Kaavan laskeminen -toiminnosta

JA-, TAI- ja EI-funktioiden käyttö ehdollisen muotoilun kanssa

Voit myös luoda ehdollisia muotoiluja JA-, TAI- ja EI-funktioiden avulla käyttämällä kaava-asetusta. Tällöin voit jättää JOS-funktion pois ja käyttää JA-, TAI- ja EI-funktioita erikseen.

Valitse Aloitus-välilehdessä Ehdollinen muotoilu > Uusi sääntö. Valitse seuraavaksi ”Määritä kaavan avulla, mitkä solut muotoillaan” -vaihtoehto, kirjoita kaava ja käytä valitsemaasi muotoilua.

Ehdollinen muotoilu > Muokkaa sääntöä -valintaikkuna, jossa näkyy Kaava-menetelmä

Käyttäen aiempaa Päivämäärät-esimerkkiä kaavojen pitäisi näyttää seuraavalta.

Esimerkkejä JA-, TAI- ja EI-funktioita käytöstä ehdollisen muotoilun testeihin


Kaava

Kuvaus

=A2>B2

Jos A2 on suurempi kuin B2, muotoile solua, muussa tapauksessa älä tee mitään.

=JA(A3>B2,A3<C2)

Jos A3 on suurempi kuin B2 JA A3 on pienempi kuin C2, muotoile solua, muussa tapauksessa älä tee mitään.

=TAI(A4>B2,A4<B2+60)

Jos A4 on suurempi kuin B2 TAI A4 on pienempi kuin B2 plus 60 (päivää), muotoile solua, muussa tapauksessa älä tee mitään.

=EI(A5>B2)

Jos A5 EI ole suurempi kuin B2, muotoile solua, muussa tapauksessa älä tee mitään. Tässä tapauksessa A5 on suurempi kuin B2, joten kaava palauttaa arvon EPÄTOSI. Jos muuttaisit kaavaa muotoon =EI(B2>A5), se palauttaisi arvon EPÄTOSI eikä kaavaa muotoiltaisi.

Huomautus: Yleinen virhe on tehdä kaavasta ehdollinen muotoilu ilman yhtäläisyysmerkkiä (=). Jos tee näin, Ehdollinen muotoilu -valintaikkuna lisää yhtäläisyysmerkin ja lisää kaavan ympärille lainausmerkit – =”TAI(A4>B2,A4<B2+60)”, joten sinun on poistettava lainausmerkit, jotta kaava toimii oikein.

Sivun alkuun

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta, saada tukea yhteisön vastauksista tai ehdottaa uutta ominaisuutta tai parannusta Excel User Voice -sivustolla.

Katso myös

Katso video JOS-funktion käyttämisestä

Lue, miten voit käyttää sisäkkäisiä funktioita

JOS-funktio

JA-funktio

TAI-funktio

EI-funktio

Yleiskuva Excelin kaavoista

Viallisten kaavojen ratkaiseminen

Kaavoissa esiintyvien virheiden etsiminen

Excel for Windowsin pikanäppäimet

Excel for Macin pikanäppäimet

Loogiset funktiot (hakemisto)

Excelin funktiot (aakkosjärjestyksessä)

Excelin funktiot (luokittain)

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×