JOS-funktio

JOS-funktio on Excelin käytetyimpiä funktioita, ja sen avulla voit tehdä loogisia vertailuja arvon ja odotettujen arvojen välillä. Yksinkertaisimmillaan JOS-funktio on seuraavanlainen:

  • JOS(jokin on Tosi, tee jotain, muutoin tee jotain muuta)

JOS-lausekkeella voi näin olla kaksi tulosta. Ensimmäinen tulos on se, että vertailu on Tosi, ja toinen, että vertailu on Epätosi.

Jos haluat siirtyä eteenpäin useiden JOS-lausekkeiden käsittelemiseen, katso seuraavaa: Edistyneet JOS-funktiot – Sisäkkäisten kaavojen kanssa työskentely ja ongelmien välttäminen.

JOS-funktiolla, joka on looginen funktio, voit palauttaa yhden arvon, jos ehto on tosi, ja toisen arvon, jos ehto on epätosi.

Syntaksi

JOS(looginen_testi, arvo_jos_tosi, [arvo_jos_epätosi])

Esimerkki:

  • =JOS(A2>B2;"Ylittää budjetin";"OK")

  • =JOS(A2=B2;B4-A4;"")

Argumentin nimi

Kuvaus

looginen_testi    (pakollinen)

Testattava ehto.

arvo_jos_tosi    (pakollinen)

Palautettava arvo, jos loogisen_testin tulos on TOSI.

arvo_jos_epätosi    (valinnainen)

Palautettava arvo, jos loogisen_testin tulos on EPÄTOSI.

Yksinkertaisia JOS-esimerkkejä

Solussa D2 on kaava =JOS(C2="Kyllä";1;2)
  • =JOS(C2="Kyllä";1;2)

Edellisessä esimerkissä solu D2 kertoo seuraavaa: JOS(C2 = Kyllä, anna arvoksi 1, muutoin anna arvoksi 2)

Solussa D2 on kaava =JOS(C2=1;"KYLLÄ";"EI")
  • =JOS(C2=1;"Kyllä";"Ei")

Tässä esimerkissä solussa D2 oleva kaava kertoo seuraavaa: JOS(C2 = 1, anna arvoksi Kyllä, muutoin anna arvoksi Ei)

Kuten näet, JOS-funktion avulla voidaan vertailla sekä tekstiä että arvoja. Sen avulla voidaan myös arvioida virheitä. Voit paitsi tarkistaa, vastaako jokin asia toista ja antaa vain yhden tuloksen, myös käyttää matemaattisia operaattoreita ja suorittaa lisälaskutoimituksia määrittämiesi ehtojen perusteella. Voit myös käyttää useita sisäkkäisiä JOS-funktioita yhdessä ja siten suorittaa useita vertailuja.

Huomautus: Jos aiot käyttää kaavoissa tekstiä, sinun on kirjoitettava teksti lainausmerkkeihin (esimerkiksi "Teksti"). Ainoa poikkeus tähän ovat sanat TOSI tai EPÄTOSI, jotka Excel ymmärtää automaattisesti.

Näin pääset alkuun

Paras tapa aloittaa JOS-lausekkeen kirjoittaminen on miettiä, mitä yrität tehdä. Minkä vertailun haluat tehdä? Monesti JOS-lausekkeen kirjoittaminen voi olla niinkin yksinkertaista kuin vain logiikan ajattelemista: "mitä pitäisi tapahtua, jos tämä ehto täyttyy, ja mitä pitäisi tapahtua, jos ehto ei täyty?". Kannattaa aina varmistaa, että vaiheet etenevät loogisesti, sillä muutoin kaava ei tee sitä, mitä haluaisit sen tekevän. Tämä on erityisen tärkeää, kun luot monimutkaisia (sisäkkäisiä) JOS-lausekkeita.

Lisää JOS-esimerkkejä

Kaava solussa D2 on =JOS(C2>B2;"Ylittää budjetin";"Budjetin puitteissa")
  • =JOS(C2>B2;"Ylittää budjetin";"Budjetin puitteissa")

Edellisessä esimerkissä JOS-funktio solussa D2 kertoo, että JOS(C2 on suurempi kuin B2, anna arvoksi "Ylittää budjetin", muutoin anna arvoksi "Budjetin puitteissa")

Kaava solussa E2 on =JOS(C2>B2;C2-B2;"")
  • =JOS(C2>B2,C2-B2,0)

Yllä olevassa kuvassa oleva funktio antaa arvoksi matemaattisen laskutoimituksen tekstin sijaan. Solussa E2 oleva kaava siis kertoo, että JOS(Todellinen on suurempi kuin Budjetoitu, vähennä Budjetoitu summa Todellisesta summasta, muutoin älä anna arvoksi mitään).

Kaava solussa F7 on JOS(E7="Kyllä";F5*0,0825;0)
  • =JOS(E7="Kyllä"F5*0,0825;0)

Tässä esimerkissä solussa F7 oleva kaava kertoo, että JOS(E7 = "Kyllä", laske kokonaissumma F5 * 8,25 %, muutoin ei arvonlisäveroa, joten anna arvoksi 0)

Parhaat käytännöt – vakiot

Edellisessä esimerkissä näkyy sekä "Kyllä" että arvonlisäveroprosentti (0,0825) kirjoitettuina suoraan kaavaan. Literaalien vakioiden (arvojen, joita on ehkä muutettava aika ajoin) syöttäminen suoraan kaavoihin ei yleensä ole suositeltavaa, koska niitä voi olla vaikea löytää ja muuttaa myöhemmin. On paljon parempi sijoittaa vakiot omiin soluihinsa, jolloin ne ovat helppoja löytää ja muuttaa. Tässä esimerkissä se käy kuitenkin päinsä, koska JOS-funktioita on vain yksi ja arvonlisäveroprosentti muuttuu harvoin. Vaikka näin kävisikin, se on helposti muutettavissa kaavaan.

Laskentaoperaattorit

Jos haluat lisätietoja laskentaoperaattoreista, joita voidaan käyttää kaavoissa (< pienempi kuin, > suurempi kuin, = yhtä suuri kuin, <> ei yhtä suuri kuin jne.), lue seuraava artikkeli: Laskentaoperaattorit ja järjestys.

JOS-funktion käyttäminen sen tarkistamiseen, onko solu tyhjä

Joskus pitää tarkistaa, onko solu tyhjä. Yleensä näin on, jos et halua kaavan näyttävän tulosta ilman syöttöä.

Kaava solussa E2 on =JOS(D2=1;"Kyllä";JOS(D2=2;"Ei";"Ehkä"))

Tässä tapauksessa JOS-funktiota käytetään yhdessä ONTYHJÄ-funktion kanssa:

  • =JOS(ONTYHJÄ(D2),"Tyhjä","Ei tyhjä")

Tämä tarkoittaa JOS(D2 on tyhjä, palauta "Tyhjä", muussa tapauksessa palauta "Ei tyhjä"). Voit yhtä hyvin käyttää omaa kaavaasi "Ei tyhjä" -ehdon sijaan. Seuraavassa esimerkissä käytetään "" ONTYHJÄ-ehdon sijaan. "" tarkoittaa käytännössä "ei mitään".

Tarkistaa, onko solu tyhjä - Solun E2 kaava on =JOS(ONTYHJÄ(D2),"Tyhjä","Ei tyhjä")
  • =JOS(D3="","Tyhjä","Ei tyhjä")

Tämä kaava tarkoittaa JOS(D3 on ei mitään, palauta "Tyhjä", muussa tapauksessa palauta "Ei tyhjä"). Tässä on esimerkki hyvin yleisestä menetelmästä, jossa "" käytetään estämään kaavan laskeminen, jos seuraajasolu on tyhjä:

  • =JOS(D3="","",Kaavasi())

    JOS(D3 on ei mitään, älä palauta mitään, muussa tapauksessa laske kaava).

Esimerkki sisäkkäisistä JOS-funktioista

Siinä missä yksinkertaisella JOS-funktiolla voi olla vain kaksi tulosta (Tosi tai Epätosi), sisäkkäisillä JOS-funktioilla voi olla 3–64 tulosta.

Käytetään "" tyhjän solun tarkistamiseen - Kaava solussa E3 on =JOS(D3="","Tyhjä","Ei tyhjä")
  • =JOS(D2=1;"YES";JOS(D2=2;"Ei";"Ehkä"))

Edellä olevassa kuvassa solussa E2 oleva kaava kertoo: JOS(D2 on yhtä suuri kuin 1, anna arvoksi "Kyllä", muutoin JOS(D2 on yhtä suuri kuin 2, anna arvoksi "Ei", muutoin anna arvoksi "Ehkä"). Huomaa, että kaavan lopussa on kaksi sulkevaa suljetta. Niitä tarvitaan kummankin JOS-funktion viemiseksi päätökseen, ja jos yrität lisätä kaavan ilman molempia sulkevia sulkeita, Excel yrittää korjata asian puolestasi.

Varoituksen sana

Vaikka Excelissä voidaankin asettaa sisäkkäin jopa 64 eri JOS-funktiota, se ei ole lainkaan suositeltavaa. Miksi?

  • Useiden JOS-lausekkeiden muodostaminen oikein edellyttää paljon harkintaa, jotta niiden logiikka voi laskea oikein jokaisen ehdon alusta loppuun. Jos et sijoita JOS-lausekkeita sisäkkäin 100-prosenttisen täsmällisesti, kaava voi toimia oikein 75 % ajasta, mutta antaa odottamattomia arvoja 25 % ajasta. On epätodennäköistä, että tunnistaisit kyseiset 25 %.

  • Usean JOS-lausekkeen ylläpidosta voi tulla erittäin vaikeaa, etenkin, kun myöhemmin yrität selvittää, mitä sinä itse olet tai joku muu on yrittänyt tehdä.

  • Useat JOS-lausekkeet vaativat useita avaavia ja sulkevia sulkeita (:), mikä voi olla hankalaa hallita riippuen siitä, kuinka monimutkainen kaavasta tulee.

Yleisiä ongelmia

Ongelma

Mikä meni vikaan

0 (nolla) solussa

Arvo_jos_tosi - tai arvo_jos_epätosi-argumenteille ei löytynyt argumenttia. Jotta oikea arvo palautetaan, lisää argumenttiteksti kahteen argumenttiin tai lisää argumenttiin TOSI tai EPÄTOSI.

#NIMI? solussa

Tämä tarkoittaa yleensä, että kaavassa on kirjoitusvirhe.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta, saada tukea yhteisön vastauksista tai ehdottaa uutta ominaisuutta tai parannusta Excel User Voice -sivustolla.

Tutustu myös seuraaviin ohjeaiheisiin

Video: Edistyneet JOS-funktiot

JOS.JOUKKO-funktio (Office 365, Excel 2016 ja uudempi versio)

Edistyneet JOS-funktiot – Sisäkkäisten kaavojen kanssa työskentely ja ongelmien välttäminen

Koulutusvideot: Edistyneet JOS-funktiot

LASKE.JOS-funktio laskee arvoja yhden ehdon perusteella

LASKE.JOS.JOUKKO-funktio laskee arvoja usean ehdon perusteella

SUMMA.JOS-funktio laskee arvot yhteen yhden ehdon perusteella

SUMMA.JOS.JOUKKO-funktio laskee arvot yhteen usean ehdon perusteella

JA-funktio

TAI-funktio

PHAKU-funktio

Yleiskuva kaavoista Excelissä

Viallisten kaavojen ratkaiseminen

Kaavoissa esiintyvien virheiden etsiminen

Loogiset funktiot

Excelin funktiot (aakkosjärjestyksessä)

Excelin funktiot (luokittain)

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×