Hyperlinkkien muuttaminen ja korjaaminen

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Voit muuttaa hyperlinkin ulkoasua ja paikkaa, minne se johtaa (sen kohdetta). Ellei hyperlinkki toimi, sinun pitää määrittää ongelma ja korjata sitten linkin kohdeosoite.

Huomautus: Jos haluat muuttaa hyperlinkkien tekstejä tai järjestystä siirtymispalkissa, napsauta siirtymispalkkia ja valitse sitten Siirtymispalkin ominaisuudetMuotoile-valikosta.

Valitse haluamasi toimet

Hyperlinkin ulkoasun muuttaminen

Hyperlinkin kohteen muuttaminen

Hyperlinkin muuttaminen tavalliseksi tekstiksi

Hyperlinkkien testaaminen ennen sivuston julkaisemista

Toimimattomien hyperlinkkien korjaaminen

Hyperlinkin ulkoasun muuttaminen

Hyperlinkin tekstin muuttaminen

  1. Napsauta hyperlinkkitekstiä, jota haluat muotoilla.

  2. Kirjoita uusi teksti ja poista alkuperäiset merkit yksitellen painamalla DELETE- tai ASKELPALAUTIN-näppäintä.

Alleviivauksen poistaminen hyperlinkin tekstistä

  1. Valitse hyperlinkin teksti.

    Jos haluat valita vain alleviivatut merkit, napsauta viimeisen alleviivatun merkin jälkeistä kohtaa ja vedä kohdistin ensimmäisen merkin kohdalle.

  2. Napsauta vakiotyökalurivinAlleviivaus-painiketta Painikkeen kuva .

Hyperlinkkinä käytetyn kuvan muokkaaminen

  1. Valitse linkitetty kuva.

  2. Napsauta kuvaa hiiren kakkospainikkeella, vie kohdistin Muuta kuva -kohtaan, ja valitse sitten haluamasi uuden kuvan sijainti. Valitse esimerkiksi Tiedostosta, jos haluat käyttää tietokoneeseesi tallennettua kuvaa.

  3. Valitse haluamasi uusi kuva.

Sivun alkuun

Hyperlinkin kohteen muuttaminen

  1. Napsauta hiiren kakkospainikkeella hyperlinkkiä, jota haluat muuttaa, ja valitse Muokkaa hyperlinkkiä.

    Huomautus: Jos pikavalikko tarjoaa vain oikeinkirjoituksen komentoja, valitse Ohita kaikki, ja napsauta hiiren kakkospainikkeella hyperlinkkiä uudelleen.

  2. Kirjoita Hyperlinkin muokkaaminen -valintaikkunan Osoite-ruutuun hyperlinkin uusi kohde.

Sivun alkuun

Hyperlinkin muuttaminen tavalliseksi tekstiksi

  • Napsauta hyperlinkkiä hiiren kakkospainikkeella ja valitse sitten Poista hyperlinkki.

Sivun alkuun

Hyperlinkkien testaaminen ennen sivuston julkaisemista

Voit testata hyperlinkin toimivuuden ennen kuin julkaiset sivustosi. Tee jokin näistä:

  • Jos haluat seurata, minne verkkojulkaisusi hyperlinkki johtaa, ennen kuin julkaiset sen sivustolla, pidä CTRL-näppäintä painettuna ja napsauta linkitettyä tekstiä tai kuvaa.

  • Valitse Tiedoston-valikossa Verkkosivun esikatselu, ja napsauta jotakin hyperlinkkiä sivuston esikatselussa, niin pääset hyperlinkin kohteeseen.

    Huomautus: Verkkosivuston esikatselussa et voi testata linkkejä ulkoisiin tiedostoihin.

  • Julkaise sivusto paikallisella palvelimella, jotta voit testata hyperlinkit.

    1. Valitse Tiedosto-valikosta Muunna verkkosivuksi.

    2. Jos näkyviin tulee tietoja sivuston isännöintipalvelusta, valitse OK.

    3. Etsi Muunna verkkosivuksi -valintaikkunasta paikallinen palvelin, jossa haluat testata sivustoasi, ja valitse sitten Tallenna.

Sivun alkuun

Toimimattomien hyperlinkkien korjaaminen

Tässä on muutamia yleisiä tapoja korjata toimimattomat hyperlinkit.

Publisher-sivustosi muille sivuille johtavien hyperlinkkien korjaaminen

  • Kun yksi linkki ei toimi    Kun sivu on siirretty, Microsoft Office Publisher päivittää automaattisesti hyperlinkit, jotta ne johtavat oikeille sivuille. Jos hyperlinkki ei toimi, varmista kuitenkin, ettei se osoita siirrettyyn tai poistettuun kirjanmerkkiin. Voit korjata sen näin:

    1. Napsauta hyperlinkkiä hiiren kakkospainikkeella ja valitse sitten Muokkaa hyperlinkkiä.

    2. Valitse Muokkaa hyperlinkkiä -valintaikkunassa Kohta tässä tiedostossa, ja valitse sitten sivu ja kirjanmerkki, johon haluat linkittää.

      Jos kirjanmerkki on poistettu, valitse Peruuta. Siirry sivulle, johon haluat linkittää, ja lisää kirjanmerkki. Palaa sitten hyperlinkkiin, jonka haluat korjata, ja muokkaa sitä.

  • Kun monta linkkiä ei toimi    Jos moni hyperlinkki ei toimi, joitakin tiedostojasi ei ehkä ole julkaistu. Kun julkaiset sivuston, Publisher lataa oletusarvoisesti alikansion nimeltä index_files määritettyyn tiedostosijaintiin. Tämä kansio sisältää kaikki sivustoosi liittyvät tiedostot paitsi julkaisin ensimmäisen sivun (sivuston etusivun), josta päästään siihen liittyvien sivujen alikansioon. Jos tämä kansio ei ole käytettävissä, hyperlinkit julkaisusi muille sivuille eivät toimi. Jos lataat sivuston käyttäen kolmannen osapuolen ohjelmaa, alikansiota ei ehkä ladata automaattisesti verkkopalvelimeen. Lataa tässä tapauksessa alikansio manuaalisesti.

    Huomautus: Voit muuttaa asetuksia niin, että Publisher ei luo index_files-kansiota ja julkaisee sivuston kaikki tiedostot samaan kansioon, kun julkaiset sivuston seuraavan kerran. Valitse verkkojulkaisussasi Työkalut-valikosta Asetukset, napsauta Verkko-välilehteä, ja poista sitten Järjestä tukitiedostot kansioon -valintaruudun valinta.

Korjaa muihin sivustoihin johtavat hyperlinkit

Jos hyperlinkki toiseen sivustoon ei toimi, siirry kohteeseen, johon haluat linkittää. Jos kohdetiedosto on Internetissä, etsi sitä selaimella. Jos tiedosto on kiintolevyllä tai verkossa, etsi se Microsoft Windows Resurssienhallinnassa. Tarkista sitten Publisher-verkkojulkaisussa nämä:

  • Kohde on ehkä siirretty tai sitä ei enää ole    Napsauta hyperlinkkiä hiiren kakkospainikkeella ja valitse Muokkaa hyperlinkkiä. Vahvista Muokkaa hyperlinkkiä -valintaikkunassa, että polku kohdesivulle on virheetön.

  • Teksti, jonka uskot ei olevat hyperlinkkiä, vain näyttää hyperlinkiltä    Valitse teksti ja valitse Lisää hyperlinkki Painikkeen kuva vakiotyökaluriviltä, jotta tiedät, onko teksti hyperlinkki.

    Vihje: Valitse vain yksittäinen hyperlinkki ennen kuin valitset Lisää hyperlinkki. Kun valitset useita hyperlinkkejä tai siirtymispalkissa olevan hyperlinkin, Lisää hyperlinkki ei ehkä ole käytettävissä.

  • Et ehkä pääse käyttämään kohdetta    Jos kohde on Internetissä, varmista, että sinulla on yhteys Internetiin. Jos kohde on verkossa, varmista verkkosi järjestelmänvalvojalta, että pääset käyttämään kohdetiedostoa.

Korjaa ulkoisia tiedostoja avaavat hyperlinkit

Kun luot hyperlinkin verkkosivulle, joka avaa ulkoisen tiedoston, kuten Microsoft Office Word -asiakirjan, Microsoft Office Excel -laskentataulukon tai PDF-tiedoston, muista seuraavat asiat.

Tiedostonimet

Niiden ulkoisten tiedostojen nimissä, joihin linkität, ei saisi mielellään olla välilyöntejä, ja kirjainten pitäisi olla pieniä kirjaimia.

Jos linkität tiedostoon, jonka nimi sisältää välilyöntejä ja jonka nimeä et voi muuttaa, tarkista, että Publisher on korvannut hyperlinkin välilyönnin %20-merkinnällä. Jos tiedoston nimi on esimerkiksi my file.docx, hyperlinkkiosoitteen pitää olla my%20file.docx.

Testaaminen

Et voi testata ulkoiseen tiedostoon johtavaa linkkiä Web-esikatselussa. Voit kuitenkin testata julkaisusi sisältämän hyperlinkin pitämällä CTRL-näppäintä painettuna ja napsauttamalla linkitettyä tekstiä tai kuvaa. Voit myös julkaista sivuston paikalliselle palvelimelle, jotta voit testata hyperlinkit ulkoisiin tiedostoihin.

Tärkeää: Jos olet testaamassa linkkejä ulkoisiin tiedostoihin paikallisella palvelimella, kopioi ulkoiset tiedostot kyseiselle palvelimelle.

Lataaminen

Kun julkaiset sivuston, sinun pitää ladata ulkoinen tiedosto manuaalisesti. Publisher ei lataa sitä puolestasi. Polku määrittyy sen mukaan, mihin sijoitat ulkoisen tiedoston verkkopalvelimella. Esimerkiksi:

  • Jos linkität kotisivulta tiedostoon, joka on samassa verkkopalvelimen hakemistossa, polku voi olla vain tiedostonimi (esimerkiksi myfile.docx).

  • Jos tiedosto on toisessa kansiossa kuin aloitussivu, polun pitää sisältää kansionimi (esimerkiksi index_files/myfile.docx).

Sinun pitää määrittää tämä polku ja kirjoittaa se Lisää hyperlinkki -valintaikkuna ennen julkaisemista verkkoon. Valitse teksti tai kuva, jota haluat sivusi käyttäjien napsauttavan avatakseen ulkoisen tiedoston. Valitse Lisää-valikosta Hyperlinkki. Kirjoita Lisää hyperlinkki -valintaikkunan Osoite-ruutuun polku ulkoiseen tiedostoon.

Huomautus: Jos lisäät hyperlinkin polun Osoite-ruutuun valitsemalla polun, muuta polkua kirjoittamalla vain tiedostonimi tai kansio ja tiedostonimi, kuten kerrottiin edellä.

Korjaa linkin polku levyllä olevaan tiedostoon

Sivuston tiedostot kannattaa tallentaa levylle, kuten CD- tai DVD-levylle, jotta sivustoa voi katsella toisessa tietokoneessa, ennen kuin julkaiset sen verkossa. Jos kopioit verkkojulkaisun tiedostot levylle, linkit eivät toimi. Julkaise sivusto sen sijaan levylle. Tee näin:

Windows Vista

  1. Valitse Tiedosto-valikosta Muunna verkkosivuksi.

  2. Napsauta osoiterivillä sen levyn asematunnusta, johon haluat julkaista sivustosi (esimerkiksi D:\mywebsite).

    Jos haluat lisätä verkkosivuston uuteen kansioon, valitse työkalupalkista Uusi kansio, anna sille nimi ja paina sitten Enteriä.

  3. Valitse Tiedostonimi-ruudussa aloitussivun oletusnimeksi index ja valitse sitten Tallenna.

    Index.htm on oletusvalinta. Kun valitset aloitussivusi nimeksi index, sen käyttö on helpompaa. Tämä myös estää käyttäjiä näkemästä luetteloa tiedostoista, joista sivustosi koostuu.

Windows XP

  1. Valitse Tiedosto-valikosta Muunna verkkosivuksi.

  2. Napsauta Kohde-luettelossa sen levyn asematunnusta, johon haluat julkaista sivustosi (esimerkiksi D:\mywebsite).

    Jos haluat lisätä verkkosivuston uuteen kansioon, napsauta hiiren kakkospainiketta sijainnissa, johon haluat lisätä uuden kansion, ja luo sitten uusi kansio valitsemalla Uusi > Kansio. Anna uuden kansion nimi Nimi-ruutuun ja valitse sitten Avaa.

  3. Valitse Tiedostonimi-ruudussa aloitussivun oletusnimeksi index ja valitse sitten Tallenna.

    Index.htm on oletusvalinta. Kun valitset aloitussivusi nimeksi index, sen käyttö on helpompaa. Tämä myös estää käyttäjiä näkemästä luetteloa tiedostoista, joista sivustosi koostuu.

Näkymättömän hyperlinkin korjaaminen

Tämä voi johtua jostakin näistä:

  • Hyperlinkki sijaitsee kierretyssä tekstiruudussa tai automaattisessa muodossa    Hyperlinkit eivät toimi oikein, jos ne sijaitsevat kierretyissä tekstiruuduissa tai kohteessa Automaattiset muodot. Ne kuitenkin toimivat verkkojulkaisussa, kun painat CTRL-näppäintä ja napsautat linkkiä, ja ne näkyvät oikein eivätkä toimi Web-esikatselussa eivätkä sen jälkeen, kun julkaisu on julkaistu verkossa. Voit palauttaa verkkojulkaisun hyperlinkit palauttamalla hyperlinkkejä sisältävät kierretyt tekstiruudut tai automaattiset muodot alkuperäiseen paikkaansa.

  • Hyperlinkki sijaitsee tekstiruudussa tai automaattisessa muodossa, jolla on kuvareunus    Verkkojulkaisun hyperlinkit eivät toimi oikein, jos ne ovat tekstiruudussa tai automaattisessa muodossa, jolla on kuvareunus. Voit palauttaa verkkojulkaisun hyperlinkit poistamalla kuvareunukset tekstiruuduista tai automaattisista muodoista, joissa on hyperlinkkejä.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×