Funktion sisällyttäminen funktioon

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Kun luot kaavan funktiolla, Sisäkkäisiä funktioita voidaan sisällä muita toimintoja. Kun käytät sisäkkäisen-funktioiden tuloksiin kuin argumentins– ensimmäinen funktio on toimimisen tietoa. Näet aina, kun funktio on sijoitettu koska se on sulkeiden sisällä.

Esimerkki: JOS-funktio käyttää sisällytettyjä KESKIARVO- ja SUMMA-funktioita argumentteina.

=JOS(KESKIARVO(F2:F5)>50;SUMMA(G2:G5);0)

Kaava luetaan vasemmalta oikealle. JOS solujen F2–F5 keskiarvo on suurempi kuin 50, laske solujen G2–G5 arvojen SUMMA. Palauta muussa tapauksessa 0.

Funktioiden tasoja voi sisällyttää enintään 64. Ne syötetään samaan tapaan kuin muutkin funktiot.

  1. Napsauta solua, johon haluat lisätä kaavan.

  2. Kirjoita kaava kaavariville ja paina ENTER-näppäintä.

Toinen esimerkki: Tässä lasketaan tulostasoon perustuvat vähennykset sisällyttämällä JOS-funktio toiseen JOS-funktioon.

=JOS(A5<31500;A5*15%;JOS(A5<72500;A5*25%;A5*28%))

Myös tämä esimerkki luetaan vasemmalta oikealle. JOS solun A5 arvo on pienempi kuin 31 500, kerro arvo 15 %:lla. JOS se ei ole, tarkista, onko arvo pienempi kuin 72 500. JOS se on, kerro 25 %:lla, muussa tapauksessa 28 %:lla.

Huomaa, että tulotasoissa ei ole pilkkuja. Jos niissä olisi, JOS-funktio yrittäisi käyttää niitä argumentteina ja kaava katkeaisi.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×