Esimerkkejä yleisistä kaavoista

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Seuraavia esimerkkejä voi käyttää luetteloiden ja kirjastojen lasketuissa sarakkeissa. Jos esimerkissä ei ole sarakeviitettä, esimerkin kaavaa voi käyttää sarakkeen oletusarvon määrittämiseen.

Sisältö

Ehdollisia kaavoja

Päivämäärä ja kellonaika-kaavat

Matemaattiset kaavat

Tekstin kaavat

Ehtokaavat

Seuraavien kaavojen avulla voit testata lauseen ehdon ja palauttaa Kyllä- tai Ei-arvon, testata vaihtoehtoisen arvon, joka voi olla esimerkiksi OK tai Ei OK, tai palauttaa null-arvoa merkitsevän tyhjän tai yhdysmerkin.

Tarkista, onko luku suurempi kuin tai pienempi kuin toinen luku

Tämä vertailu tehdään JOS-funktiolla.

Sarake1

Sarake2

Kaava

Kuvaus (mahdolliset tulokset)

15000

9000

=[Sarake1]>[Sarake2]

Onko Sarake1 suurempi kuin Sarake2? (Kyllä)

15000

9000

=JOS([Sarake1]<=[Sarake2], "OK", "Ei OK")

Onko Sarake1 pienempi tai yhtä suuri kuin Sarake2? (Ei OK)

Palauta totuusarvo sarakkeiden sisällön vertailun jälkeen

Kun tulos on totuusarvo (Kyllä tai Ei), käytä JA-, TAI- ja EI-funktioita.

Sarake1

Sarake2

Sarake3

Kaava

Kuvaus (mahdolliset tulokset)

15

9

8

=JA([Sarake1]>[Sarake2], [Sarake1]<[Sarake3])

Onko 15 suurempi kuin 9 ja pienempi kuin 8? (Ei)

15

9

8

=TAI([Sarake1]>[Sarake2], [Sarake1]<[Sarake3])

Onko 15 suurempi kuin 9 tai pienempi kuin 8? (Kyllä)

15

9

8

=EI([Sarake1]+[Sarake2]=24)

Onko 15 plus 9 eri suuri kuin 24? (Ei)

Käytä JOS-, JA- ja TAI-funktioita, jos tulos on toinen laskutoimitus tai jokin muu arvo kuin Kyllä tai Ei.

Sarake1

Sarake2

Sarake3

Kaava

Kuvaus (mahdolliset tulokset)

15

9

8

=JOS([Sarake1]=15, "OK", "Ei OK")

Jos Sarake1-arvo on 15, palauta "OK". (OK)

15

9

8

=JOS(JA([Sarake1]>[Sarake2], [Sarake1]<[Sarake3]), "OK", "Ei OK")

Jos 15 on suurempi kuin 9 ja pienempi kuin 8, palauta arvo "OK". (Ei OK)

15

9

8

=JOS(TAI([Sarake1]>[Sarake2], [Sarake1]<[Sarake3]), "OK", "Ei OK")

Jos 15 on suurempi kuin 9 tai pienempi kuin 8, palauta arvo "OK". (OK)

Nollien näyttäminen tyhjinä tai yhdysmerkkeinä

Jos haluat näkyviin nollan, tee yksinkertainen laskutoimitus. Jos haluat näkyviin tyhjän tai yhdysmerkin, käytä JOS-funktiota.

S arake1

Sarake2

Kaava

Kuvaus (mahdolliset tulokset)

10

10

=[Sarake1]-[Sarake2]

Jälkimmäinen luku vähennetty ensimmäisestä (0)

15

9

=JOS([Sarake1]-[Sarake2],"-",[Sarake1]-[Sarake2])

Palauttaa yhdysmerkin, kun arvo on nolla (-)

Sarakkeiden virhearvojen piilottaminen

Käyttämällä ONVIRHE-funktiota voit tuoda näkyviin yhdysmerkin, #PUUTTUU!-arvon tai PUUTTUU-arvon virhearvon asemesta.

Sarake1

Sarake2

Kaava

Kuvaus (mahdolliset tulokset)

10

0

=[Sarake1]/[Sarake2]

Tuottaa virheen (#JAKO/0!)

10

0

=JOS(ONVIRHE([Sarake1]/[Sarake2]),"PUUTTUU",[Sarake1]/[Sarake2])

Palauttaa arvon PUUTTUU, kun arvo on virhe

10

0

=JOS(ONVIRHE([Sarake1]/[Sarake2]),"-",[Sarake1]/[Sarake2])

Palauttaa yhdysmerkin, kun arvo on virhe

Sivun alkuun

Päivämäärä- ja kellonaikakaavat

Seuraavia kaavoja käytetään päivämääriin ja kellonaikoihin perustuvissa laskutoimituksissa. Tällaisia laskutoimituksia ovat esimerkiksi päivien, kuukausien ja vuosien lisääminen päivämäärään, kahden päivämäärän välin laskeminen ja ajan muuntaminen desimaaliarvoksi.

Päivämäärien lisääminen

Päivämäärään lisätään päiviä yhteenlaskuoperaattorilla (+).

Huomautus: Päivämääriä käsiteltäessä lasketun sarakkeen palautustyypin täytyy olla Päivämäärä ja kellonaika.

Sarake1

Sarake2

Kaava

Kuvaus (tulos)

09.06.2007

3

=[Sarake1]+[Sarake2]

Päivämäärään 9.6.2007 lisätään kolme päivää (12.6.2007)

10.12.2008

54

=[Sarake1]+[Sarake2]

Päivämäärään 10.12.2008 lisätään 54 päivää (2.2.2009)

Päivämäärään lisätään kuukausia PÄIVÄYS-, VUOSI-, KUUKAUSI- ja PÄIVÄ-funktioilla.

Sarake1

Sarake2

Kaava

Kuvaus (tulos)

09.06.2007

3

=PÄIVÄYS(VUOSI([Sarake1]),KUUKAUSI([Sarake1])+[Sarake2],PÄIVÄ([Sarake1]))

Päivämäärään 9.6.2007 lisätään kolme kuukautta (9.9.2007)

10.12.2008

25

=PÄIVÄYS(VUOSI([Sarake1]),KUUKAUSI([Sarake1])+[Sarake2],PÄIVÄ([Sarake1]))

Päivämäärään 10.12.2008 lisätään 25 kuukautta (10.1.2011)

Päivämäärään lisätään vuosia PÄIVÄYS-, VUOSI-, KUUKAUSI- ja PÄIVÄ-funktioilla.

Sarake1

Sarake2

Kaava

Kuvaus (tulos)

09.06.2007

3

=PÄIVÄYS(VUOSI([Sarake1])+[Sarake2],KUUKAUSI([Sarake1]),PÄIVÄ([Sarake1]))

Päivämäärään 9.6.2007 lisätään kolme vuotta (9.6.2010)

10.12.2008

25

=PÄIVÄYS(VUOSI([Sarake1])+[Sarake2],KUUKAUSI([Sarake1]),PÄIVÄ([Sarake1]))

Päivämäärään 10.12.2008 lisätään 25 vuotta (10.12.2033)

Päivämäärään lisätään päivien, kuukausien ja vuosien yhdistelmiä PÄIVÄYS-, VUOSI-, KUUKAUSI- ja PÄIVÄ-funktioilla.

Sarake1

Kaava

Kuvaus (tulos)

9.6.2007

=PÄIVÄYS(VUOSI([Sarake1])+3,KUUKAUSI([Sarake1])+1,PÄIVÄ([Sarake1])+5)

Lisää 3 vuotta, 1 kuukauden ja 5 päivää päivämäärään 9.6.2007 (14.07.10)

10.12.2008

=PÄIVÄYS(VUOSI([Sarake1])+1,KUUKAUSI([Sarake1])+7,PÄIVÄ([Sarake1])+5)

Lisää yhden vuoden, 7 kuukautta ja 5 päivää päivämäärään 10.12.08 (15.7.2010)

Kahden päivämäärän välisen eron laskeminen

Tämä laskutoimitus tehdään PVMERO-funktiolla.

Sarake1

Sarake2

Kaava

Kuvaus (tulos)

1.1.1995

15.6.1999

=PVMERO([Sarake1], [Sarake2],"p")

Palauttaa kahden päivämäärän välisten päivien määrän (1626)

1.1.1995

15.6.1999

=PVMERO([Sarake1], [Sarake2],"vk")

Palauttaa päivämäärien välisten kuukausien määrän vuotta huomioimatta (5)

1.1.1995

15.6.99

=PVMERO([Sarake1], [Sarake2],"vp")

Palauttaa päivämäärien välisten päivien määrän vuotta huomioimatta (165)

Kahden kellonajan välisen eron laskeminen

Jotta tulokset voidaan esittää kellonajan vakiomuotoa käyttäen (tunnit:minuutit:sekunnit), käytä vähennyslaskuoperaattoria (-) ja TEKSTI-funktiota. Tämä menetelmä toimii vain, kun tunteja ei ole yli 24 eikä minuutteja ja sekunteja yli 60.

Sarake1

Sarake2

Kaava

Kuvaus (tulos)

9.6.2007 10:35

9.6.2007 15:30

=TEKSTI([Sarake2]-[Sarake1],"t")

Kellonaikojen välisten tuntien määrä (4)

9.6.2007 10:35

9.6.2007 15:30

=TEKSTI([Sarake2]-[Sarake1],"t:mm")

Kellonaikojen välinen tuntien ja minuuttien määrä (4:55)

9.6.2007 10:35

9.6.2007 15:30

=TEKSTI([Sarake2]-[Sarake1],"t:mm:ss")

Kellonaikojen välinen tuntien, minuuttien ja sekuntien määrä (4:55:00)

Tulos esitetään yhden kokonaisen aikayksikön mukaisena KOKONAISLUKU-funktiolla tai TUNNIT-, MINUUTIT- tai SEKUNNIT-funktiolla.

Sarake1

Sarake2

Kaava

Kuvaus (tulos)

9.6.2007 10.35

10.06.2007 15:30

=KOKONAISLUKU(([Sarake2]-[Sarake1])*24)

Kellonaikojen välinen kokonaisten tuntien määrä (28)

9.6.2007 10:35

10.6//2007 15:30

=KOKONAISLUKU(([Sarake2]-[Sarake1])*1440)

Kellonaikojen välinen kokonaisten minuuttien määrä (1 735)

9.6.2007 10:35

10.6.2007 15:30

=KOKONAISLUKU(([Sarake2]-[Sarake1])*86400)

Kellonaikojen välinen kokonaisten sekuntien määrä (104 100)

9.6.2007 10.35

10.06.2007 15:30

=TUNNIT([Sarake2]-[Sarake1])

Kellonaikojen välinen tuntien määrä, kun väli ei ole yli 24 tuntia (4)

9.6.2007 10:35

10.6.2007 15:30

=MINUUTIT([Sarake2]-[Sarake1])

Kellonaikojen välinen minuuttien määrä, kun väli ei ole yli 60 minuuttia (55)

9.6.2007 10.35

10.6.2007 15:30

=SEKUNNIT([Sarake2]-[Sarake1])

Kellonaikojen välinen sekuntien määrä, kun väli ei ole yli 60 sekuntia (0)

Kellonaikojen muuntaminen

Tunnit muunnetaan kellonajan vakiomuodosta desimaaliluvuksi KOKONAISLUKU-funktiolla.

Sarake1

Kaava

Kuvaus (tulos)

10:35

=([Sarake1]-KOKONAISLUKU([Sarake1]))*24

Tunteja kellonlyömästä 12.00 (10,583333)

12:15

=([Sarake1]-KOKONAISLUKU([Sarake1]))*24

Tunteja kellonlyömästä 12.00 (12,25)

Tunnit muunnetaan desimaaliluvusta kellonajan tavalliseksi esitysmuodoksi (tunnit:minuutit:sekunnit) jakolaskuoperaattorilla ja TEKSTI-funktiolla.

Sarake1

Kaava

Kuvaus (tulos)

23:58

=TEKSTI(Sarake1/24, "tt:mm:ss")

Tunteja minuutteja ja sekunteja kellonlyömästä 12:00 (00:59:55)

2:06

=TEKSTI(Sarake1/24, "t:mm")

Tunteja ja minuutteja kellonlyömästä 12.00 (0:05)

Juliaanisen päivämäärien lisääminen

Juliaanisella päivämäärällä tarkoitetaan päivämäärämuotoa, jossa yhdistyvät meneillään oleva vuosi sekä päivien määrä vuoden alusta laskien. Esimerkiksi 1.1.2007 on 2007001 ja 31.12.2007 puolestaan 2007365. Tämä muoto ei perustu juliaaniseen kalenteriin.

Päivämäärä muunnetaan juliaanisen päivämäärän mukaiseksi TEKSTI- ja PÄIVÄYSARVO-funktioilla.

Sarake1

Kaava

Kuvaus (tulos)

23.06.2007

=TEKSTI([Sarake1],"vv")&TEKSTI(([Sarake1]-PÄIVÄYSARVO("1/1/"& TEKSTI([Sarake1],"vv"))+1),"000")

Päivämäärä juliaanisen muodon mukaisena siten, että vuoden esitysmuodossa on kaksi numeroa (07174)

23.06.2007

=TEKSTI([Sarake1],"vvvv")&TEKSTI(([Sarake1]-PÄIVÄYSARVO("1/1/"&TEKSTI([Sarake1],"vv"))+1),"000")

Päivämäärä juliaanisen muodon mukaisena siten, että vuoden esitysmuodossa on neljä numeroa (2007174)

Päivämäärä muunnetaan tähtitieteessä käytettäväksi juliaaniseksi päivämääräsi vakiolla 2415018,50. Tämä kaava toimii vain päivämäärän 1.3.1901 jälkeisillä päivämäärillä ja vain 1900-päivämääräjärjestelmää käytettäessä.

Sarake1

Kaava

Kuvaus (tulos)

23.6.2007

=[Sarake1]+2415018,50

Päivämäärä tähtitieteen käyttämässä juliaanisessa muodossa (2454274,50)

Päivämäärien näyttäminen viikonpäivinä

Päivämäärät muunnetaan viikonpäivien nimiksi TEKSTI- ja VIIKONPÄIVÄT-funktioilla.

Sarake1

Kaava

Kuvaus (mahdolliset tulokset)

19.2.2007

=TEKSTI(VIIKONPÄIVÄT([Sarake1]), "pppp")

Laskee päivämäärän viikonpäivän ja palauttaa viikonpäivän koko nimen (maanantai)

3.1.2008

=TEKSTI(VIIKONPÄIVÄT([Sarake1]), "ppp")

Laskee päivämäärän viikonpäivän ja palauttaa viikonpäivän lyhenteen (to)

Sivun alkuun

Matemaattiset kaavat

Seuraavien kaavojen avulla voit suorittaa erilaisia matemaattisia laskelmia, kuten yhteen-, vähennys-, kerto- ja jakolaskuja. Voit myös laskea mediaanin keskiarvon, pyöristää lukuja ja laskea arvojen määrän.

Yhteenlasku

Rivin sarakkeiden luvut lasketaan yhteen yhteenlaskuoperaattorilla (+) tai SUMMA-funktiolla.

Sarake1

Sarake2

Sarake3

Kaava

Kuvaus (tulos)

6

5

4

=[Sarake1]+[Sarake2]+[Sarake3]

Kolmen ensimmäisen sarakkeen arvot lasketaan yhteen (15)

6

5

4

=SUMMA([Sarake1],[Sarake2],[Sarake3])

Kolmen ensimmäisen sarakkeen arvot lasketaan yhteen (15)

6

5

4

=SUMMA(JOS([Sarake1]>[Sarake2], [Sarake1]-[Sarake2], 10), [Sarake3])

Jos Sarake1 on suurempi kuin Sarake2, lasketaan niiden erotuksen ja Sarake3-arvon summa. Muutoin lasketaan luvun 10 ja Sarake3-arvon summa (5)

Vähennyslasku

Rivin sarakkeissa olevien lukujen vähennyslaskut lasketaan vähennyslaskuoperaattorilla (-) tai SUMMA-funktiolla negatiivisia arvoja käyttäen.

Sarake1

Sarake2

Sarake3

Kaava

Kuvaus (tulos)

15000

9000

-8000

=[Sarake1]-[Sarake2]

Luku 9 000 vähennetään luvusta 15 000 (6 000)

15000

9000

-8000

=SUMMA([Sarake1],[Sarake2],[Sarake3])

Kolmen ensimmäisen sarakkeen luvut lasketaan yhteen, myös negatiiviset arvot (16 000)

Kahden luvun välisen eron laskeminen prosentteina

Käytä vähennyslaskuoperaattoria (-) ja jakolaskuoperaattoria (/) sekä ITSEISARVO-funktiota.

Sarake1

Sarake2

Kaava

Kuvaus (tulos)

2342

2500

=([Sarake2]-[Sarake1])/ITSEISARVO([Sarake1])

Ero prosentteina (6,75 % tai 0,06746)

Lukujen kertominen

Rivin sarakkeiden luvut kerrotaan kertolaskuoperaattorilla (*) tai TULO-funktiolla.

Sarake1

Sarake2

Kaava

Kuvaus (tulos)

5

2

=[Sarake1]*[Sarake2]

Kahden ensimmäisen sarakkeen arvot kerrotaan (10)

5

2

=TULO([Sarake1], [Sarake2])

Kahden ensimmäisen sarakkeen arvot kerrotaan (10)

5

2

=TULO([Sarake1],[Sarake2],2)

Laskee kahden ensimmäisen sarakkeen luvun ja luvun 2 tulon (20)

Lukujen jakaminen

Rivin sarakkeiden lukujen jakolaskuissa käytetään jakolaskuoperaattoria (/).

Sarake1

Sarake2

Kaava

Kuvaus (tulos)

15000

12

=[Sarake1]/[Sarake2]

Jakaa luvun 15 000 luvulla 12 (1250)

15000

12

=([Sarake1]+10000)/[Sarake2]

Jakaa lukujen 15 000 ja 10 000 summan luvulla 12 (2 083)

Lukujoukon keskiarvon laskeminen

Rivin sarakkeiden lukujen keskiarvo lasketaan KESKIARVO-funktiolla.

Sarake1

Sarake2

Sarake3

Kaava

Kuvaus (tulos)

6

5

4

=KESKIARVO([Sarake1], [Sarake2],[Sarake3])

Kolmen ensimmäisen sarakkeen lukujen keskiarvo (5)

6

5

4

=KESKIARVO(JOS([Sarake1]>[Sarake2], [Sarake1]-[Sarake2], 10), [Sarake3])

Jos Sarake1 on suurempi kuin Sarake2, lasketaan niiden erotuksen ja Sarake3-arvon keskiarvo. Muutoin lasketaan arvon 10 ja Sarake3-arvon keskiarvo (2,5)

Laske lukujen mediaani

Mediaanilla tarkoitetaan järjestetyn lukujoukon keskimmäistä arvoa. Lukujoukon mediaani lasketaan MEDIAANI-funktiolla.

A

B

C

D

E

F

Kaava

Kuvaus (tulos)

10

7

9

27

0

4

=MEDIAANI(A, B, C, D, E, F)

Kuuden ensimmäisen sarakkeen lukujen mediaani (8)

Alueen pienimmän tai suurimman luvun laskeminen

Rivin sarakkeiden lukujen pienin tai suurin luku lasketaan MIN- tai MAKS-funktiolla.

Sarake1

Sarake2

Sarake3

Kaava

Kuvaus (tulos)

10

7

9

=MIN([Sarake1], [Sarake2], [Sarake3])

Pienin luku (7)

10

7

9

=MAKS([Sarake1], [Sarake2], [Sarake3])

Suurin luku (10)

Arvojen laskeminen

Numeroarvojen määrä lasketaan LASKE-funktiolla.

Sarake1

Sarake2

Sarake3

Kaava

Kuvaus (tulos)

Omena

12.12.2007

=LASKE([Sarake1], [Sarake2], [Sarake3])

Laskee numeroarvoja sisältävien sarakkeiden määrän. Päivämääriä, kellonaikoja, tekstejä ja null-arvoja ei lasketa numeroarvoiksi (0)

12 €

#JAKO/0!

1,01

=LASKE([Sarake1], [Sarake2], [Sarake3])

Laskee numeroarvoja sisältävien sarakkeiden määrän, mutta jättää virhe- ja totuusarvot pois (2)

Suurenna tai pienennä lukua prosenttimäärällä

Tämä laskutoimitus suoritetaan prosenttioperaattorilla (%).

Sarake1

Sarake2

Kaava

Kuvaus (tulos)

23

3 %

=[Sarake1]*(1+5%)

Sarake1-arvoa suurennetaan 5 prosenttia (24,15)

23

3 %

=[Sarake1]*(1+[Sarake2])

Sarake1-arvoa suurennetaan Sarake2-prosenttiarvolla, joka on 3 % (23,69)

23

3%

=[Sarake1]*(1-[Sarake2])

Sarake1-arvoa pienennetään Sarake2-prosenttiarvolla, joka on 3 % (22,31)

Korota luku potenssiin

Tämä laskutoimitus tehdään eksponenttioperaattorilla (^) tai POTENSSI-funktiolla.

Sarake1

Sarake2

Kaava

Kuvaus (tulos)

5

2

=[Sarake1]^[Sarake2]

Viisi potenssiin kaksi (25)

5

3

=POTENSSI([Sarake1], [Sarake2])

Viisi potenssiin kolme (125)

Luvun pyöristäminen

Luku pyöristetään ylöspäin PYÖRISTÄ.DES.YLÖS-, PARITON- tai PARILLINEN-funktiolla.

Sarake1

Kaava

Kuvaus (tulos)

20,3

=PYÖRISTÄ.DES.YLÖS([Sarake1],0)

Luku 20,3 pyöristetään ylöspäin lähimpään kokonaislukuun (21)

-5,9

=PYÖRISTÄ.DES.YLÖS([Sarake1],0)

Luku -5,9 pyöristetään ylöspäin lähimpään kokonaislukuun (-5)

12,5493

=PYÖRISTÄ.DES.YLÖS([Sarake1],2)

Luku 12,5493 pyöristetään ylöspäin lähimpään sadasosaan, näkyviin jää kaksi desimaalia (12,55)

20,3

=PARILLINEN([Sarake1])

Luku 20,3 pyöristetään ylös lähimpään parilliseen lukuun (22)

20,3

=PARITON([Sarake1])

Luku 20,3 pyöristetään ylöspäin lähimpään parittomaan lukuun (21)

Luku pyöristetään alaspäin PYÖRISTÄ.DES.ALAS-funktiolla.

Sarake1

Kaava

Kuvaus (tulos)

20,3

=PYÖRISTÄ.DES.ALAS([Sarake1],0)

Luku 20,3 pyöristetään alaspäin lähimpään kokonaislukuun (20)

-5,9

=PYÖRISTÄ.DES.ALAS([Sarake1],0)

Luku -5,9 pyöristetään alaspäin lähimpään kokonaislukuun (-6)

12,5493

=PYÖRISTÄ.DES.ALAS([Sarake1],2)

Luku 12,5493 pyöristetään alaspäin lähimpään sadasosaan, näkyviin jää kaksi desimaalia (12,54)

Luku pyöristetään lähimpään lukuun tai murtolukuun PYÖRISTÄ-funktiolla.

Sarake1

Kaava

Kuvaus (tulos)

20,3

=PYÖRISTÄ([Sarake1],0)

Luku 20,3 pyöristetään alaspäin, koska murtolukuosa on pienempi kuin 0,5 (20)

5,9

=PYÖRISTÄ([Sarake1],0)

Luku 5,9 pyöristetään ylöspäin, koska murtolukuosa on suurempi kuin 0,5 (6)

-5,9

=PYÖRISTÄ([Sarake1],0)

Luku -5,9 pyöristetään alaspäin, koska murtolukuosa on pienempi kuin -0,5 (-6)

1,25

=PYÖRISTÄ([Sarake1], 1)

Luku pyöristetään lähimpään kymmenykseen (desimaaleja yksi). Koska pyöristettävä osa on 0,05 tai suurempi, luku pyöristetään ylöspäin (tulos: 1,3)

30,452

=PYÖRISTÄ([Sarake1], 2)

Luku pyöristetään lähimpään sadasosaan (desimaaleja kaksi). Koska pyöristettävä osa 0,002 on pienempi kuin 0,005, luku pyöristetään alaspäin (tulos: 30,45)

Luku pyöristetään nollaa suurempaan merkitsevään numeroon PYÖRISTÄ-, PYÖRISTÄ.DES.YLÖS-, PYÖRISTÄ.DES.ALAS-, KOKONAISLUKU- ja PITUUS-funktioilla.

Sarake1

Kaava

Kuvaus (tulos)

5492820

=PYÖRISTÄ([Sarake1],3-PITUUS(KOKONAISLUKU([Sarake1])))

Luku pyöristetään kolmeen merkitsevään numeroon (5 490 000)

22230

=PYÖRISTÄ.DES.ALAS([Sarake1],3-PITUUS(KOKONAISLUKU([Sarake1])))

Pienin luku pyöristetään alaspäin kolmeen merkitsevään numeroon (22 200)

5492820

=PYÖRISTÄ.DES.YLÖS([Sarake1], 5-PITUUS(KOKONAISLUKU([Sarake1])))

Suurin luku pyöristetään ylöspäin viiteen merkitsevään numeroon (5 492 900)

Sivun alkuun

Tekstikaavat

Seuraavien kaavojen avulla voit käsitellä tekstiä, esimerkiksi yhdistää tai ketjuttaa useiden sarakkeiden arvot, verrata sarakkeiden sisältöä, poistaa merkkejä tai välilyöntejä ja määrittää merkkejä toistumaan.

Tekstin kirjainkoon muuttaminen

Tekstin kirjainkokoa vaihdetaan ISOT-, PIENET- ja ERISNIMI-funktioilla.

Sarake1

Kaava

Kuvaus (tulos)

tiina Lassila

=ISOT([Sarake1])

Muuttaa tekstin kirjainkoon suureksi (TIINA LASSILA)

tiina Lassila

=PIENET([Sarake1])

Muuttaa tekstin kirjainkoon pieneksi (tiina lassila)

tiina Lassila

=ERISNIMI([Sarake1])

Muuttaa sanojen ensimmäiset kirjaimet isoiksi (Tiina Lassila)

Etu- ja sukunimen yhdistäminen

Etu- ja sukunimi yhdistetään et-operaattorilla (&) tai KETJUTA-funktiolla.

Sarake1

Sarake2

Kaava

Kuvaus (tulos)

Teemu

Sallinen

=[Sarake1]&[Sarake2]

Yhdistää kaksi merkkijonoa (TeemuSallinen)

Teemu

Sallinen

=[Sarake1]&" "&[Sarake2]

Kaksi merkkijonoa yhdistetään ja erotetaan välilyönnillä (Teemu Sallinen)

Teemu

Sallinen

=[Sarake2]&", "&[Sarake1]

Kaksi merkkijonoa yhdistetään ja erotetaan pilkulla sekä välilyönnillä (Sallinen, Teemu)

Teemu

Sallinen

=KETJUTA([Sarake2], ",", [Sarake1])

Kaksi merkkijonoa yhdistetään ja erotetaan pilkulla (Sallinen,Teemu)

Tekstin ja lukujen yhdistäminen eri sarakkeista

Tekstiä ja numeroita yhdistetään KETJUTA-funktiolla, et-operaattorilla (&) tai TEKSTI-funktiolla ja et-operaattorilla.

Sarake1

Sarake2

Kaava

Kuvaus (tulos)

Varvikko

28

=[Sarake1]&" myynyt "&[Sarake2]&" yksikköä."

Yhdistää edellä olevat sisällöt lauseeksi (Varvikko myynyt 28 yksikköä.)

Posti

40 %

=[Sarake1]&" myynyt "&TEKSTI([Sarake2],"0%")&" kokonaismyynnistä."

Yhdistää edellä olevat sisällöt lauseeksi (Posti myynyt 40 % kokonaismyynnistä.)

Huomautus: TEKSTI-funktio liittää Sarake2-arvon lauseeseen muotoiltuna, ei pohjana olevaa arvoa 0,4.

Varvikko

28

=KETJUTA([Sarake1]," myynyt ",[Sarake2]," yksikköä.")

Yhdistää edellä olevat sisällöt lauseeksi (Varvikko myynyt 28 yksikköä.)

Tekstin yhdistäminen päivämäärään tai kellonaikaan

Tekstiä yhdistetään päivämääriin ja kellonaikoihin TEKSTI-funktiolla ja et-operaattorilla (&).

Sarake1

Sarake2

Kaava

Kuvaus (tulos)

Laskutuspäivämäärä

5.6.2007

="Laskun päivämäärä: "&TEKSTI([Sarake2], "p-kkk-vvvv")

Yhdistää tekstin päivämäärään (Laskun päivämäärä: 5.6.2007)

Laskutuspäivämäärä

5.6.2007

=[Sarake1]&" "&TEKSTI([Sarake2], "kkk-pp-vvvv")

Yhdistää eri sarakkeiden tekstin ja päivämäärän yhteen sarakkeeseen (Laskutuspäivämäärä 5.6.2007)

Sarakkeen sisällön vertailu

Saraketta verrataan toiseen sarakkeeseen tai arvoluetteloon VERTAA- ja TAI-funktioilla.

Sarake1

Sarake2

Kaava

Kuvaus (mahdolliset tulokset)

BD122

BD123

=VERTAA([Sarake1],[Sarake2])

Vertaa kahden ensimmäisen sarakkeen sisältöä toisiinsa (Ei)

BD122

BD123

=VERTAA([Sarake1], "BD122")

Vertaa Sarake1-arvon ja merkkijonon "BD122" sisältöä toisiinsa (Kyllä)

Tarkista, vastaako sarakkeen arvo tai sen osa tiettyä tekstiä

JOS-, ETSI-, KÄY.LÄPI- ja ONLUKU-funktioilla voit tarkistaa, vastaako sarakkeen arvo tai sen osa tiettyä tekstiä.

Sarake1

Kaava

Kuvaus (mahdolliset tulokset)

Suominen

=JOS([Sarake1]="Suominen", "OK", "Ei OK")

Tarkistaa, onko Sarake1 Suominen (OK)

Suominen

=JOS(ONLUKU(ETSI("v",[Sarake1])), "OK", "Ei OK")

Tarkistaa, sisältääkö Sarake1 kirjaimen v (OK)

BD123

=ONLUKU(ETSI("BD",[Sarake1]))

Tarkistaa, sisältääkö Sarake1 kirjaimet BD (Kyllä)

Tietoja sisältävien sarakkeiden määrän laskeminen

Tietoja sisältävät sarakkeet lasketaan LASKE.A-funktiolla.

Sarake1

Sarake2

Sarake3

Kaava

Kuvaus (tulos)

Myynti

19

=LASKE.A([Sarake1], [Sarake2])

Laskee tietoja sisältävät sarakkeet (2)

Myynti

19

=LASKE.A([Sarake1], [Sarake2], [Sarake3])

Laskee tietoja sisältävät sarakkeet (2)

Merkkien poistaminen tekstistä

Merkkejä poistetaan tekstistä PITUUS-, VASEN- ja OIKEA-funktioilla.

Sarake1

Kaava

Kuvaus (tulos)

A-vitamiini

=VASEN([Sarake1],PITUUS([Sarake1])-2)

Palauttaa 9 (11-2) merkkiä vasemmalta laskettuna (vitamiini)

B1-vitamiini

=OIKEA([Sarake1], PITUUS([Sarake1])-11)

Palauttaa 2 (12-10) merkkiä oikealta laskettuna (B1)

Poista välilyönnit sarakkeen alusta ja lopusta

Välilyönnit poistetaan sarakkeesta POISTA.VÄLIT-funktiolla.

Sarake1

Kaava

Kuvaus (tulos)

Hei kaikille!

=POISTA.VÄLIT([Sarake1])

Poistaa välilyönnit alusta ja lopusta (Hei kaikille!)

Sarakkeen merkin toistaminen

Sarakkeen merkki määritetään toistumaan TOISTA-funktiolla.

Kaava

Kuvaus (tulos)

=TOISTA(".",3)

Piste toistetaan kolme kertaa (...)

=TOISTA("-",10)

Yhdysmerkki toistetaan 10 kertaa (----------)

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×