Ehdollisten kaavojen luominen

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Testataan, onko ehto tosi vai epätosi ja tehdä loogisia vertailuja lausekkeiden välillä löytyvät samanaikaisia tehtäviä. Voit käyttää Luo ehdollisia kaavoja AND, taiei oletai Jos -funktiot.

Esimerkiksi Jos -funktiossa käytetään seuraavia argumentteja.

JOS-funktion sisältävä kaava

Jos-funktiota käyttävä kaava

Painikkeen kuva looginen_testi: ehto, jonka haluat tarkistaa.

Kuvateksti 2 arvo_jos_tosi: arvo, joka palautetaan, jos ehto on TOSI.

Painikkeen kuva arvo_jos_epätosi: arvo, joka palautetaan, jos ehto on EPÄTOSI.

Lisätietoja kaavojen luomisesta on artikkelissa luominen tai poistaminen kaavan.

Valitse haluamasi toimet

Luo ehdollinen kaava, joka tuottaa totuusarvon (tosi tai EPÄTOSI)

Luo ehdollinen kaava, joka toinen laskutoimitus tai arvot, muu kuin tulos TOSI tai EPÄTOSI

Sellaisen ehdollisen kaavan luominen, jonka palauttama tulos on looginen arvo (TOSI tai EPÄTOSI)

Käytä jataija ei -Funktiot ja operaattoreita, kuten seuraavassa esimerkissä.

Esimerkki

Esimerkkiä on ehkä helpompi tarkastella, jos kopioit sen tyhjään laskentataulukkoon.

Miten esimerkki kopioidaan?

  1. Valitse tämän artikkelin esimerkki.

    Tärkeää: Älä valitse rivi- tai saraketunnuksia.

    esimerkin valitseminen Excel 2013 for Windowsin ohjeesta

    Esimerkin valitseminen ohjeesta

  2. Paina CTRL+C.

  3. Luo tyhjä työkirja tai laskentataulukko Excelissä.

  4. Valitse taulukosta solu A1 ja paina CTRL+V.

Tärkeää: Esimerkki toimii oikein vain, kun liität sen laskentataulukon soluun A1.

  1. Voit vaihdella tulosten tarkastelemisen ja tuloksia palauttavien kaavojen tarkastelemisen välillä painamalla CTRL+’ (heittomerkki) tai napsauttamalla Kaavat-välilehdessä Kaavan tarkistaminen -ryhmän Näytä kaavat -painiketta.

Kun olet kopioinut esimerkin tyhjään laskentataulukkoon voit muokata sitä tarpeisiisi sopivaksi.

1

2

3

4

5

6

7



8



9


10


11



12

A

B

Tiedot

15

9

8

Nippelit

Nappelit

Kaava

Kuvaus (tulos)

=JA(A2>A3; A2<A4)

Määrittää, onko solun A2 arvo suurempi kuin solun A3 arvo ja myös onko solun A2 arvo pienempi kuin solun A4 arvo. (EPÄTOSI)

=TAI(A2>A3; A2<A4)

Määrittää, onko solun A2 arvo suurempi kuin solun A3 arvo tai onko solun A2 arvo pienempi kuin solun A4 arvo. (TOSI)

=EI(A2+A3=24)

Määrittää, onko solujen A2 ja A3 arvojen summa eri suuri kuin 24. (EPÄTOSI)

=EI(A5="Nippelit")

Määrittää, onko solun A5 arvo muu kuin "Nippelit." (EPÄTOSI)

=TAI(A5<>"Nippelit",A6 = "Nappelit")

Määrittää, onko solun A5 arvo muu kuin "Nappelit" tai onko solun A6 arvo "Nippelit". (TOSI)

Lisätietoja näiden funktioiden käyttämisestä on artikkelissa AND-funktio, tai-funktioja ei-funktio.

Sivun alkuun

Sellaisen ehdollisen kaavan luominen, jonka palauttama tulos on toinen laskutoimitus tai arvo, joka ei ole TOSI tai EPÄTOSI

Käytä Jos, ANDja tai -funktioiden ja operaattoreita, kuten seuraavassa esimerkissä.

Esimerkki

Esimerkkiä on ehkä helpompi tarkastella, jos kopioit sen tyhjään laskentataulukkoon.

Miten esimerkki kopioidaan?

  1. Valitse tämän artikkelin esimerkki.

Tärkeää: Älä valitse rivi- tai saraketunnuksia.

esimerkin valitseminen Excel 2013 for Windowsin ohjeesta

Esimerkin valitseminen ohjeesta

  1. Paina CTRL+C.

  2. Luo tyhjä työkirja tai laskentataulukko Excelissä.

  3. Valitse taulukosta solu A1 ja paina CTRL+V.

Tärkeää: Esimerkki toimii oikein vain, kun liität sen laskentataulukon soluun A1.

  1. Voit vaihdella tulosten tarkastelemisen ja tuloksia palauttavien kaavojen tarkastelemisen välillä painamalla CTRL+’ (heittomerkki) tai napsauttamalla Kaavat-välilehdessä Kaavan tarkistaminen -ryhmän Näytä kaavat -painiketta.

Kun olet kopioinut esimerkin tyhjään laskentataulukkoon voit muokata sitä tarpeisiisi sopivaksi.

1

2

3

4

5

6

7


8



9



10



11




12



13



14




15



16

A

B

Tiedot

15

9

8

Nippelit

Nappelit

Kaava

Kuvaus (tulos)

=JOS(A2=15; "OK"; "Ei OK")

Jos solun A2 arvo on 15, palauta "OK". Muussa tapauksessa palauta "Ei OK". (OK)

=JOS(A2<>15, "OK", "Ei OK")

Jos solun A2 arvo ei ole 15, palauta "OK". Muussa tapauksessa palauta "Ei OK". (Ei OK)

=JOS(EI(A2<=15), "OK", "Ei OK")

Jos solun A2 arvo ei ole pienempi tai yhtä suuri kuin 15, palauta "OK". Muussa tapauksessa palauta "Ei OK". (Ei OK)

=JOS(A5<>"NIPPELIT", "OK", "Ei OK")

Jos solun A5 arvo ei ole "NIPPELIT", palauta arvo "OK". Muussa tapauksessa palauta "Ei OK". (Ei OK)

=JOS(JA(A2>A3; A2<A4); "OK"; "Ei OK")

Jos solun A2 arvo on suurempi kuin solun A3 arvo ja solun A2 arvo on myös pienempi kuin solun A4 arvo, palauta "OK". Muussa tapauksessa palauta "Ei OK". (Ei OK)

=JOS(JA(A2<>A3, A2<>A4), "OK", "Ei OK")

Jos solun A2 arvo ei ole yhtä suuri kuin solun A3 arvo eikä solun A2 arvo ole yhtä suuri kuin solun A4 arvo, palauta "OK". Muussa tapauksessa palauta "Ei OK". (OK)

=JOS(TAI(A2>A3; A2<A4); "OK"; "Ei OK")

Jos solun A2 arvo on suurempi kuin solun A3 arvo tai solun A2 arvo on pienempi kuin solun A4 arvo, palauta "OK". Muussa tapauksessa palauta "Ei OK". (OK)

=JOS(TAI(A5<>"Nippelit", A6<>"Nappelit"), "OK", "Ei OK")

Jos solun A5 arvo ei ole "Nippelit" tai solun A6 arvo ei ole "Nappelit", palauta "OK". Muussa tapauksessa palauta "Ei OK". (Ei OK)

=JOS(TAI(A2<>A3, A2<>A4), "OK", "Ei OK")

Jos solun A2 arvo on eri suuri kuin solun A3 arvo tai solun A2 arvo on eri suuri kuin solun A4 arvo, palauta "OK". Muussa tapauksessa palauta "Ei OK". (OK)

Lisätietoja näiden funktioiden käyttämisestä on Jos-funktion, AND-funktioja tai-funktio.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×