EI-funktio

Käytä EI-funktiota, joka on yksi loogisista funktioista, kun haluat varmistaa, että arvo ei ole sama kuin toinen.

Esimerkki

Esimerkkejä EI-funktiosta argumenttien kääntämisessä päinvastaisiksi.  Esim. =EI(1+1=2)

EI-funktio kääntää argumentin arvon vastakkaiseksi.

Yleinen tapa käyttää EI-funktiota on laajentaa muita funktioita, jotka suorittavat loogisia testejä. Esimerkiksi JOS-funktio suorittaa loogisen testin ja palauttaa yhden arvon jos testin tulos on TOSI ja toisen arvon jos testin tulos on EPÄTOSI. Käyttämällä EI-funktiota JOS-funktion totuus_testi-argumenttina voit testata useita eri ehtoja vain yhden sijaan.

Syntaksi

EI(looginen)

EI-funktion syntaksissa on seuraavat argumentit:

  • Totuus:    Pakollinen. Arvo tai lauseke, joka on joko TOSI tai EPÄTOSI.

Huomautuksia

Jos looginen arvo on EPÄTOSI, EI palauttaa arvon TOSI. Jos looginen arvo on TOSI, EI palauttaa arvon EPÄTOSI.

Esimerkkejä

Seuraavassa on yleisiä esimerkkejä EI-funktion käytöstä itsenäisesti ja JOS-, JA- ja TAI-funktioiden kanssa.

Esimerkkejä EI-funktiosta JOS-, JA- ja TAI-funktioiden kanssa

Kaava

Kuvaus

=EI(A2>100)

Solun A2 arvo EI ole suurempi kuin 100

=JOS(JA(EI(A2>1),EI(A2<100)),A2,"Arvo on alueen ulkopuolella")

50 on suurempi kuin 1 (TOSI), JA 50 on pienempi kuin 100 (TOSI), joten EI kääntää kummankin argumentin arvoksi EPÄTOSI. JA edellyttää, että kumpikin argumentti on TOSI, joten se palauttaa tuloksen, jos arvo on EPÄTOSI.

=JOS(TAI(EI(A3<0),EI(A3>50)),A3,"Arvo on alueen ulkopuolella")

100 ei ole pienempi kuin 0 (EPÄTOSI) ja 100 on suurempi kuin 50 (TOSI), joten EI kääntää argumenttien arvoksi TOSI/EPÄTOSI. TAI edellyttää vain, että toinen argumentti on TOSI, joten se palauttaa tuloksen, jos arvo on TOSI.

Myyntiprovision laskenta

Tässä on melko tavallinen esimerkki, jossa EI-funktion sekä JOS- ja JA-funktioiden avulla lasketaan, ovatko henkilöt oikeutettuja bonukseen.

Esimerkki myyntibonuksen laskemisesta JOS-, JA- ja EI-funktioiden kanssa.  Solun E14 kaava on =JOS(JA(EI(B14<$B$7),EI(C14<$B$5)),B14*$B$8,0)
  • =JOS(JA(EI(B14<$B$7),EI(C14<$B$5)),B14*$B$8,0)JOS Kokonaismyynti EI ole pienempi kuin Myyntitavoite, JA Tilit-arvo EI ole pienempi kuin Tavoitetili, Kokonaismyynti kerrotaan Provisioprosentilla, kun muussa tapauksessa tulos on 0.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta, saada tukea yhteisön vastauksista tai ehdottaa uutta ominaisuutta tai parannusta Excel User Voice -sivustolla.

Aiheeseen liittyvät artikkelit

Video: Edistyneet JOS-funktiot
Lue, miten voit käyttää sisäkkäisiä funktioita kaavassa
JOS-funktio
JA-funktio
TAI-funktio
Yleiskuva kaavoista Excelissä
Viallisten kaavojen ratkaiseminen
Käytä virheentarkistusta kaavoissa esiintyvien virheiden etsimiseen
Excel 2016 for Windowsin pikanäppäimet
Excel 2016 for Macin pikanäppäimet
Loogiset funktiot (hakemisto)
Excelin funktiot (aakkosjärjestyksessä)
Excelin funktiot (luokittain)

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×