Automaattinen tallentaminen

Automaattinen tallennus -vaihtoasetus Officessa

Automaattinen tallennus on uusi toiminto, joka on Office 365 -tilaajien käytettävissä Excelissä, Wordissa ja PowerPointissa. Kun työskentelet, se tallentaa tiedoston puolestasi automaattisesti, muutaman sekunnin välein. 

Automaattinen tallennus on käytössä Office 365:ssä oletusarvoisesti, kun tiedosto on tallennettu OneDriveen, OneDrive for Businessiin tai SharePoint Onlineen. 

Tärkeää: Valitsetko Tiedosto > Tallenna nimellä tehtyäsi muutoksia alkuperäiseen asiakirjaan tai malliin? Siinä tapauksessa kannattaa valita Tiedosto > Tallenna kopio ennen muutosten tekemistä. Tällöin automaattinen tallennus ei korvaa alkuperäistä tiedostoa muutoksilla. Jos automaattinen tallennus korvasi tiedoston muutoksilla, lue lisää kohdasta En halunnut tallentaa muutoksia, miten siirryn takaisin?

Windowsissa automaattinen tallennus on Office 365 -tilaajien käytettävissä Excelissä, Wordissa ja PowerPointissa. Seuraavassa on joitakin sitä koskevia usein kysyttyjä kysymyksiä.

Voit palauttaa tiedoston aiemman version käyttämällä versiohistoriaa. 

Tiedostoa napsauttava kohdistin, näytä kaikki versiot

Napsauta tiedoston nimeä ikkunan yläreunassa ja napsauta sitten Versiohistoria. Tarkista päivämäärät ja kellonajat, jotta löydät palautettavan version, ja napsauta sitten Avaa versio. Esiin avautuu toinen ikkuna, jossa näkyy tiedoston kyseinen versio. Voit palata tähän versioon napsauttamalla Palauta-painiketta. Katso lisätietoja versiohistoriasta artikkelista Näytä Office-tiedostojen aiemmat versiot.

Kun avaat tiedoston ja teet ensimmäiset haluamasi muutokset, automaattinen tallennus tallentaa muutokset ja versiohistoriaan lisätään uusi versio tiedostosta. Vaikka automaattinen tallennus tallentaa säännöllisesti tekemäsi muokkaukset, uusia versioita lisätään tämän jälkeen muokkauksen aikana versiohistoriaan vain tietyin väliajoin (noin kymmenen minuutin välein).

Jos olet tiedoston omistaja, voit määrittää tiedoston avautumaan aina vain luku -tilassa. Kun käyttäjät avaavat tiedoston tällä asetuksella, he eivät voi tallentaa muutoksia tiedostoon ilman, että muokkaus olisi otettu käyttöön. Voit ottaa tämän asetuksen käyttöön tiedostolle siirtymällä kohtaan Tiedosto > Tiedot > Suojaa asiakirja > Avaa aina vain luku -muodossa. Voit poistaa sen käytöstä myöhemmin uudelleen toistamalla tämän prosessin.

Suojaa asiakirja -ohjausobjekti valittuna ja näkyvissä vaihtoehto Avaa aina vain luku -muodossa.

Voit suojata tiedostoa muokkaukselta myös muilla tavoilla. Jos tiedosto on OneDrivessä, voit muuttaa tiedoston käyttöoikeuksia. Jos tiedosto on SharePointissa, voit määrittää kirjaston edellyttämään uloskirjausta.

Tiedosto > Tallenna kopio

Tallenna nimellä -toimintoa ei löydy Tiedosto-valikosta, kun avaat tiedoston OneDrivesta, OneDrive for Businessista tai SharePoint Onlinesta. Näissä tapauksissa näet Tiedosto-valikossa sen sijaan Tallenna kopio -toiminnon.

Käytätkö Tallenna nimellä -toimintoa paljon? Monet ihmiset ovat tottuneet siihen, että työstäessään tiedostoa he valitsevat Tiedosto-valikosta Tallenna nimellä -toiminnon tallentaakseen muutokset kopioon, ei alkuperäiseen. Kun automaattinen tallennus on käytössä, muutoksesi tallennetaan kuitenkin aina alkuperäiseen. Siksi suosittelemme, että käytät Tiedosto > Tallenna kopio -toimintoa ennen muutosten tekemistä, jos haluat tallentaa muutoksesi kopioon alkuperäisen sijasta.

Jos olet Office 365 -tilaaja ja sinulla on asennettuna Windowsin uusin Excel-, Word- ja PowerPoint-versio, näet automaattisen tallennuksen otsikkorivillä vasemmassa yläkulmassa. Ota huomioon, että jos sinulla on työpaikan tai oppilaitoksen tili, järjestelmänvalvoja voi määrittää, minkä Office-version voit asentaa, ja se ei välttämättä ole uusin versio. Katso lisätietoja artikkelista Milloin saan uusimmat ominaisuudet käyttööni Office 365:ssa?

Jos et ole tilaaja, älä huoli. Voit silti käyttää automaattista palautusta. Automaattinen palautus suojaa tiedostojasi kaatumisen yhteydessä. Jos avaat tiedoston uudelleen kaatumisen jälkeen, näet viimeisimmät muutoksesi sisältävän tiedoston Tiedostojen palauttaminen -ruudussa. Katso lisätietoja tämän toiminnon käyttöönotosta artikkelista Tiedostojen suojaaminen kaatumisen varalta.

Voit toki aina tallentaa tuttuun tapaan manuaalisesti joko painamalla CTRL+S, napsauttamalla Tallenna-painiketta tai siirtymällä Tiedosto > Tallenna.

Automaattinen tallennus on käytössä, kun työstettävänä on tiedosto, joka on tallennettu OneDriveen, OneDrive for Businessiin tai SharePoint Onlineen. Jos tiedosto on tallennettu jonnekin muualle (tai jos sitä ei ole vielä tallennettu ollenkaan), automaattinen tallennus on pois käytöstä. Näin tapahtuu, jos tiedosto on paikallisessa SharePoint-sivustossa, tiedostopalvelimella, toisessa pilvipalvelussa tai paikallisen, esimerkiksi C:\-alkuisen, polun päässä.

Automaattisen tallennuksen käytöstä poistamiseen voi olla muitakin syitä. Seuraavassa on yleisiä syitä siihen, miksi se on poissa käytöstä:

  • Tiedosto on vanhassa tiedostomuodossa, kuten .xls, .ppt tai .doc.

  • Tiedosto on paikallisessa OneDrive-kansiossa ja OneDrive-synkronointi on pysäytettynä.

  • Vanha OneDrive-synkronointiohjelman versio synkronoi juuri tiedostoa. Lisätietoja OneDriven päivittämisestä on artikkelissa Uuden OneDrive-synkronointiohjelman käytön aloittaminen Windowsissa.

  • Tiedoston on upotettu toisen Office-tiedoston sisälle.

  • Esitys on diaesitystilassa.

Jos käytät Exceliä ja kokeilit yllä olevia ohjeita, tiedostosi saattaa sisältää ominaisuuksia, jotka eivät tue automaattista tallennusta. Voit ottaa sen käyttöön toimimalla seuraavasti:

  • Poista käytöstä Jaettu työkirja -ominaisuus. Tämä ominaisuus on vanha jakamistapa. Siinä on monia rajoituksia, ja se on korvattu yhteismuokkaamisella.

  • Poista salasanasuojaus tiedostosta, jos sitä ei tarvita: Valitse Tiedosto > Tiedot > Suojaa työkirja. Poista sitten salasana ja valitse OK.

  • Poista käyttöoikeuksien rajoitus, jos sitä ei tarvita: Valitse Tiedosto > Tiedot > Suojaa työkirja > Rajoita käyttöoikeuksia ja valitse Rajoittamaton käyttö.

  • Jos avaat työkirjan tilannevedoksen SharePointista, avaa tiedosto tilannevedoksen sijaan.

  • Poista käytöstä Päivitä tiedot tiedostoa avattaessa -asetus kaikissa tiedostossa olevissa taulukoissa ja Pivot-taulukoissa. Valitse taulukko tai pivot-taulukko ja valitse sitten Taulukkotyökalut Rakenne > Päivitä > Yhteyden ominaisuudet. Poista sitten käytöstä asetus Päivitä tiedot tiedostoa avattaessa.

  • Poista aktivointi apuohjelmasta, jonka takia automaattinen tallennus ei ole käytössä. Valitse Tiedosto > Asetukset > Apuohjelmat > Excel-apuohjelmat > Siirry ja poista valintaruudun valinta apuohjelman kohdalta.

Helppo tapa on poistaa automaattinen tallennus käytöstä ennen muutosten tekemistä. Jos muutokset on tarkoitettu tilapäisiksi eikä tallennettaviksi, sulje tiedosto. Valitse sitten Ei, kun sinua pyydetään tallentamaan. Jos haluat tallentaa muutokset, ota vain automaattinen tallennus takaisin käyttöön.

Jos et halua tallentaa jatkuvasti tai et halua näyttää muille tekemiäsi muutoksia, voit poistaa automaattisen tallennuksen käytöstä. Kun olet valmis, valitse Tallenna (tai paina CTRL+S), niin tekemäsi muutokset näkyvät muille tätä tiedostoa käyttäville henkilöille. (Voit myös ottaa Automaattisen tallennuksen taas käyttöön ja tallentaa ja jakaa muutoksesi.)

Automaattinen tarkistus on oletusarvoisesti aina käytössä Microsoft Cloudiin tallennetuilla tiedostoilla. Jos kuitenkin otat automaattisen tallennuksen pois käytöstä tietyllä tiedostolla, ohjelma muistaa tämän ja pitää sen poissa toiminnasta aina, kun avaat tiedoston uudestaan. Jos vaihdat sen takaisin käyttöön kyseiselle tiedostolle, ohjelma muistaa tämän ja pitää sen toiminnassa tällä tiedostolla.

Kun automaattinen tallennus on pois käytöstä, automaattinen palautus pysyy toiminnassa järjestelmän kaatumisen tapauksessa, kun tiedosto on avoinna. Katso lisätietoja kohdasta Tiedostojen suojaaminen kaatumisen varalta.

Jos poistat käytöstä automaattisen tallennuksen tietyssä tiedostossa, ohjelma muistaa sen ja pitää automaattisen tallennuksen poissa käytöstä aina, kun avaat tiedoston uudelleen. Jos vaihdat sen takaisin käyttöön kyseiselle tiedostolle, ohjelma muistaa tämän ja pitää sen toiminnassa tällä tiedostolla.

Jos haluat poistaa automaattisen tallennuksen käytöstä kaikissa tiedostoissa, valitse Tiedosto > Asetukset > Tallenna ja poista kohdan Tallenna automaattisesti OneDriven ja SharePoint Onlinen tiedostot oletusarvoisesti <sovelluksessa> vieressä olevan valintaruudun valinta.

Tiedosto > Asetukset > Tallenna-valintaikkuna, jossa näkyy valintaruutu automaattisen tallennuksen käyttöönottoa tai käytöstä poistoa varten

Käynnistä Word (tai muu käyttämäsi sovellus) uudelleen, niin muutos tulee voimaan.

Huomautukset: 

  • Jos haluat poistaa automaattisen tallennuksen käytöstä oletusarvoisesti kaikissa Office-sovelluksissa, kuten PowerPointissa ja Excelissä, sinun täytyy toistaa nämä vaiheet jokaista haluamaasi ohjelmaa varten.

  • Jos haluat, että yksittäiset tiedostot tallennetaan edelleen automaattisesti, voit avata kyseiset tiedostot ja ottaa automaattisen tallennuksen uudelleen käyttöön manuaalisesti kyseisissä tiedostoissa.

Macissa automaattinen tallennus on Office 365 -tilaajien käytettävissä Excelissä, Wordissa ja PowerPointissa. Seuraavassa on joitakin sitä koskevia usein kysyttyjä kysymyksiä.

Voit palauttaa tiedoston aiemman version. Näin vanhempi versio palautetaan nykyiseksi versioksi. Valitse Tiedosto > Selaa versiohistoriaa. Etsi Versiohistoria-ruudusta päivämäärien ja kellonaikojen perusteella se versio, jonka haluat palauttaa, ja valitse sitten Avaa versio. Näyttöön avautuu toinen ikkuna. Jos haluat palata tähän versioon, napsauta Palauta-painiketta.

Jos tiedosto on OneDrivessa, voit muuttaa tiedoston käyttöoikeuksia. Jos tiedosto on SharePointissa, voit määrittää kirjaston edellyttämään uloskirjausta.

Tallenna nimellä -toimintoa ei löydy Tiedosto-valikosta, kun avaat tiedoston OneDrivesta, OneDrive for Businessista tai SharePoint Onlinesta. Näissä tapauksissa näet Tiedosto-valikossa sen sijaan Tallenna kopio -toiminnon.

Käytätkö Tallenna nimellä -toimintoa paljon? Monet ihmiset ovat tottuneet siihen, että työstäessään tiedostoa he valitsevat Tiedosto-valikosta Tallenna nimellä -toiminnon tallentaakseen muutokset kopioon, ei alkuperäiseen. Kun automaattinen tallennus on käytössä, muutoksesi tallennetaan kuitenkin aina alkuperäiseen. Siksi suosittelemme, että käytät Tiedosto > Tallenna kopio -toimintoa heti, jos haluat tallentaa muutoksesi kopioon alkuperäisen sijasta.

Jos olet Office 365 -tilaaja ja sinulla on asennettuna Macin uusin Excel-, Word- ja PowerPoint -versio, näet automaattisen tallennuksen vasemmassa yläkulmassa. Ota huomioon, että jos sinulla on työpaikan tai oppilaitoksen tili, järjestelmänvalvoja voi määrittää, minkä Office-version voit asentaa, ja se ei välttämättä ole uusin versio. Katso lisätietoja artikkelista Milloin saan uusimmat ominaisuudet käyttööni Office 365:ssa?

Jos et ole tilaaja, älä huoli. Voit silti käyttää automaattista palautusta. Automaattinen palautus suojaa tiedostojasi kaatumisen yhteydessä. Jos avaat tiedoston uudelleen kaatumisen jälkeen, näet viimeisimmät muutoksesi sisältävän tiedoston Asiakirjan palautus -ruudussa. Katso lisätietoja tämän toiminnon käyttöönotosta artikkelista Tiedostojen palauttaminen Office for Macissa.

Automaattinen tallennus on käytössä, kun työstettävänä on tiedosto, joka on tallennettu OneDriveen, OneDrive for Businessiin tai SharePoint Onlineen. Jos tiedosto on tallennettu jonnekin muualle (tai jos sitä ei ole vielä tallennettu ollenkaan), automaattinen tallennus on pois käytöstä. Näin tapahtuu, jos tiedosto on paikallisessa SharePoint-sivustossa, tiedostopalvelimella tai paikallisessa tietokoneen kansiossa.

Sinun on lisäksi avattava tiedosto Wordin, Excelin tai PowerPointin Tiedosto-valikosta, jotta automaattinen tallennus aktivoituu.

Huomautus: Jos Tiedosto > Avaa -valintasi näyttää samalta kuin alla olevassa kuvassa, sinun on napsautettava Verkkosijainnit-painiketta ja valittava OneDrive- tai SharePoint-tiedosto sieltä, jotta automaattinen tallennus toimii. Avaa tiedosto -valikko, jossa on Omassa Mac-tietokoneessa -näkymä.

Automaattisen tallennuksen käytöstä poistamiseen voi olla muitakin syitä. Seuraavassa on yleisiä syitä siihen, miksi se on poissa käytöstä:

  • Tiedosto on vanhassa tiedostomuodossa, kuten .xls, .ppt tai .doc.

  • Tiedosto on paikallisessa OneDrive-kansiossa ja OneDrive-synkronointi on pysäytettynä.

  • Tiedoston on upotettu toisen Office-tiedoston sisälle.

  • Esitys on diaesitystilassa.

Jos käytät Exceliä ja kokeilit yllä olevia ohjeita, tiedostosi saattaa sisältää ominaisuuksia, jotka eivät tue automaattista tallennusta. Voit ottaa sen käyttöön toimimalla seuraavasti:

  • Poista käytöstä Jaettu työkirja -ominaisuus. Tämä ominaisuus on vanha jakamistapa. Siinä on monia rajoituksia, ja se on korvattu yhteismuokkaamisella.

  • Poista salasanasuojaus tiedostosta, jos sitä ei tarvita: Valitse Tarkista-välilehdessä Suojaa työkirja. Poista sitten salasana ja valitse OK.

  • Poista käyttöoikeuksien rajoitus, jos sitä ei tarvita: Valitse Tiedosto > Rajoita käyttöoikeuksia > Ei rajoituksia.

  • Jos avaat työkirjan tilannevedoksen SharePointista, avaa tiedosto tilannevedoksen sijaan.

  • Poista käytöstä Päivitä tiedot tiedostoa avattaessa -asetus kaikissa tiedostossa olevissa taulukoissa ja Pivot-taulukoissa. Valitse taulukko tai pivot-taulukko ja siirry sitten Taulukko-välilehteen. Valitse Päivitä > Yhteyden ominaisuudet, ja poista Päivitä tiedot tiedostoa avattaessa -kohdan valinta.

  • Poista aktivointi apuohjelmasta, jonka takia automaattinen tallennus ei ole käytössä. Valitse Työkalut > Excel-apuohjelmat ja poista valintaruudun valinta apuohjelman kohdalta.

Helppo tapa on poistaa automaattinen tallennus käytöstä ennen muutosten tekemistä. Jos haluat tallentaa muutokset, ota vain automaattinen tallennus takaisin käyttöön. Jos et halua tallentaa muutoksia, sulje tiedosto. Valitse sitten Ei, kun sinua pyydetään tallentamaan.

Jos et halua tallentaa jatkuvasti tai et halua näyttää muille tekemiäsi muutoksia, voit poistaa automaattisen tallennuksen käytöstä. Kun olet valmis, valitse Tallenna, niin tekemäsi muutokset näkyvät muille tätä tiedostoa käyttäville henkilöille. (Voit myös ottaa Automaattisen tallennuksen taas käyttöön ja tallentaa ja jakaa muutoksesi.)

Automaattinen tarkistus on oletusarvoisesti aina käytössä pilveen tallennetuilla tiedostoilla. Jos kuitenkin otat automaattisen tallennuksen pois käytöstä tietyllä tiedostolla, ohjelma muistaa tämän ja pitää sen poissa toiminnasta aina kun avaat tiedoston uudestaan. Jos vaihdat sen takaisin käyttöön kyseiselle tiedostolle, ohjelma muistaa tämän ja pitää sen toiminnassa tällä tiedostolla.

Kun automaattinen tallennus on pois käytöstä, automaattinen palautus pysyy toiminnassa järjestelmän kaatumisen tapauksessa, kun tiedosto on avoinna. Katso lisätietoja kohdasta Tiedostojen automaattinen tallentaminen ja palauttaminen.

Jos poistat käytöstä automaattisen tallennuksen tietyssä tiedostossa, ohjelma muistaa sen ja pitää automaattisen tallennuksen poissa käytöstä aina, kun avaat tiedoston uudelleen. Jos vaihdat sen takaisin käyttöön kyseiselle tiedostolle, ohjelma muistaa tämän ja pitää sen toiminnassa tällä tiedostolla.

Jos haluat poistaa automaattisen tallennuksen käytöstä kaikissa tiedostoissa, valitse Asetukset > Tallentaminen ja poista kohdan Ota automaattinen tallennus oletusarvoisesti käyttöön vieressä olevan valintaruudun valinta.

Ei. Voit kuitenkin poistaa käytöstä automaattisen tallennuksen tietyssä tiedostossa. Ohjelma muistaa tämän ja pitää automaattisen tallennuksen poissa käytöstä aina, kun avaat tiedoston uudelleen. Jos vaihdat sen takaisin käyttöön kyseiselle tiedostolle, ohjelma muistaa tämän ja pitää sen toiminnassa tällä tiedostolla.

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×