Arvon esiintymiskertojen laskeminen Excelissä

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Oletetaan, että haluat tietää, montako kertaa tietty teksti- tai lukuarvo esiintyy solualueella. Esimerkki:

  • Jos esimerkiksi alue A2:D20 sisältää lukuarvot 5, 6, 7 ja 6, esiintyy luku 6 kahdesti.

  • Jos sarake sisältää nimet Larsson, Suominen, Suominen ja Suominen, esiintyy Suominen kolme kertaa.

Se, kuinka monta kertaa arvo esiintyy, voidaan laskea monella tavalla.

Sisältö

Arvon esiintymiskertojen laskeminen funktiolla

Laskeminen useiden ehtojen perusteella LASKE.JOS.JOUKKO-funktiolla

Laskeminen ehtojen perusteella käyttämällä LASKE- ja JOS-funktioita yhdessä

Laske SUMMA- ja JOS-funktioilla yhdessä, kuinka usein useat teksti- tai lukuarvot esiintyvät.

Useiden arvojen esiintymiskertojen laskeminen Pivot-taulukkoraportilla

Arvon esiintymiskertojen laskeminen funktiolla

Käytä LASKE.JOS-funktiota tämän tehtävän suorittamiseen.

Esimerkki

Kopioi esimerkkitiedot seuraavasta taulukosta ja lisää ne uuden Excel‑laskentataulukon soluun A1. Kaavat näyttävät tulokset, kun valitset ne, painat F2-näppäintä ja sitten Enter-näppäintä. Voit säätää sarakkeiden leveyttä, että näet kaikki tiedot.

Myyjä

Lasku

Larsson

15 000

Larsson

9 000

Lidman

8 000

Lidman

20 000

Larsson

5 000

Suominen

22 500

Kaava

Kuvaus

Tulos

'=LASKE.JOS(A2:A7,"Larsson")

Larssonin merkintöjen määrä (3)

=LASKE.JOS(A2:A7,"Larsson")

'=LASKE.JOS(A2:A7,A4)

Lidmanin merkintöjen määrä (2)

=LASKE.JOS(A2:A7,A4)

'=LASKE.JOS(B2:B7,"< 20000")

Laskuarvojen määrä pienempi kuin 20 000 (4)

=LASKE.JOS(B2:B7,"< 20000")

'=LASKE.JOS(B2:B7,">="&B5)

Laskuarvojen määrä suurempi tai yhtä suuri kuin 20 000 (2)

=LASKE.JOS(B2:B7,">="&B5)

Lisätietoja tästä funktiosta on artikkelissa LASKE.JOS-funktio.

Sivun alkuun

Laskeminen useiden ehtojen perusteella LASKE.JOS.JOUKKO-funktiolla

Excel 2007:ssä esitelty LASKE.JOS.JOUKKO-funktio on yhtä tärkeää poikkeusta lukuun ottamatta samanlainen kuin LASKE.JOS-funktio: LASKE.JOS.JOUKKO-funktio sallii ehtojen käyttämisen useiden alueiden soluissa ja laskee, montako kertaa kaikki ehdot täyttyvät. Voit käyttää jopa 127:ää alue/ehto-paria LASKE.JOS.JOUKKO-funktiolla. Funktion syntaksi näyttää tältä:

LASKE.JOS.JOUKKO(ehtoalue1, ehto1, [ehtoalue2, ehto2]…)

Esimerkki

Työntekijätunnus

Aluenumero

Osasto

20552

2

Myynti

21268

2

Talous

23949

1

Hallinto

24522

4

Hallinto

28010

3

IT

29546

4

Myynti

31634

3

IT

32131

1

IT

35106

4

Talous

40499

1

Henkilöstö

42051

1

Myynti

43068

2

Henkilöstö

45382

2

Talous

47971

1

IT

Kuinka monta työntekijää on alueella 2 ja talousosastolla?

'=LASKE.JOS(B2:B15,"2",C2:C15,"Talous")

=LASKE.JOS(B2:B15,"2",C2:C15,"Talous")

Ensimmäinen ehtoalue on alueiden numerot ja toinen ehtoalue on osaston nimi. Ensimmäiseen ehtoalueeseen sovellettava ehto on "2" ja toiseen ehtoalueeseen sovellettava ehto on "Talous". LASKE.JOS-funktio tarkastaa, että molemmat ehdot täyttyvät.

Lisätietoja tämän funktion käyttämisestä useiden alueiden ja ehtojen kanssa on artikkelissa LASKE.JOS.JOUKKO-funktio.

Sivun alkuun

Laskeminen ehtojen perusteella käyttämällä LASKE- ja JOS-funktioita yhdessä

Oletetaan, että sinun on määritettävä, kuinka moni myyjä on myynyt tietyn artikkelin tietyllä alueella, tai että haluat tietää, kuinka monta kertaa tietyn myyjän myynti ylitti tietyn arvon. Voit käyttää JOS- ja LASKE-funktioita yhdessä. Sinun täytyy ensin käyttää JOS-funktiota ehdon testaamiseen, ja vain jos JOS-funktion tulos on Tosi, voit käyttää LASKE-funktiota solujen laskemiseen.

Esimerkkejä

Alue

Myyjä

Tyyppi

Myynti

Etelä

Larsson

Juomat

3571

Länsi

Sallinen

Meijerituotteet

3338

Itä

Lidman

Juomat

5122

Pohjoinen

Lidman

Meijerituotteet

6239

Etelä

Suominen

Jalosteet

8677

Etelä

Sallinen

Liha

450

Etelä

Sallinen

Liha

7673

Itä

Lidman

Jalosteet

664

Pohjoinen

Sallinen

Jalosteet

1 500

Etelä

Suominen

Liha

6596

Kaava

Kuvaus

Tulos

=LASKE(JOS((A2:A11="Etelä")*(C2:C11="Liha"),D2:D11))

Lihan myyntiluvut Etelä-alueella. (3)

=LASKE(JOS((A2:A11="Etelä")*(C2:C11="Liha"),D2:D11))

=LASKE(JOS((B2:B11="Lidman")*(D2:D11>=1000),D2:D11))

Lidmanin myyntiluvut, jotka ylittävät 1 000 dollaria. (2)

=LASKE(JOS((B2:B11="Lidman")*(D2:D11>=1000),D2:D11))

Huomautus: 

  • Esimerkin kaavat on annettava matriisikaavoina. Jos tämä työkirja on auki Excelin työpöytäohjelmassa ja haluat muuttaa kaavaa tai luoda vastaavan kaavan, paina ensin F2-näppäintä ja paina sitten näppäinyhdistelmää Ctrl+Vaihto+Enter, jotta kaava palauttaa odottamasi tulokset.

  • Nämä kaavat toimivat vain, jos JOS-funktion toinen argumentti on luku.

LASKE-funktio laskee numeroita sisältävien solujen määrän ja argumenttiluettelon numerot. JOS-funktio palauttaa yhden arvon, jos määrittämäsi ehto on TOSI, ja toisen arvon, jos ehto on EPÄTOSI.

Lisätietoja näistä funktioista on artikkeleissa LASKE-funktio ja JOS-funktio.

Sivun alkuun

Laske SUMMA- ja JOS-funktioilla yhdessä, kuinka usein useat teksti- tai lukuarvot esiintyvät.

Seuraavissa esimerkeissä käytetään JOS- ja SUMMA-funktioita yhdessä. JOS-funktio testaa ensin joidenkin solujen arvot, ja jos testin tulos on tosi, SUMMA-funktio laskee yhteen testin läpäisseet arvot.

Esimerkkejä

Myyjä

Lasku

Larsson

15000

Larsson

9000

Lidman

8000

Lidman

20000

Larsson

5000

Suominen

22500

Kaava

Kuvaus

Tulos

=SUMMA(JOS((A2:A7="Larsson")+(A2:A7="Suominen"),1,0))

Larssonin tai Suomisen laskujen määrä.

=SUMMA(JOS((A2:A7="Larsson")+(A2:A7="Suominen"),1,0))

=SUMMA(JOS((B2:B7<9000)+(B2:B7>19000),1,0))

Laskujen summa, kun arvo on pienempi kuin 9 000 $ tai suurempi kuin 19 000 $.

=SUMMA(JOS((B2:B7<9000)+(B2:B7>19000),1,0))

=SUMMA(JOS(A2:A7="Larsson",JOS(B2:B7<9000,1,0)))

Larssonin laskujen määrä, kun arvo on pienempi kuin 9 000 $.

=SUMMA(JOS(A2:A7="Larsson",JOS(B2:B7<9000,1,0)))

Huomautus: Esimerkin kaavat on annettava matriisikaavoina. Jos tämä työkirja on auki Excelin työpöytäohjelmassa ja haluat muuttaa kaavaa tai luoda vastaavan kaavan, paina ensin F2-näppäintä ja paina sitten näppäinyhdistelmää Ctrl+Vaihto+Enter, jotta kaava palauttaa odottamasi tulokset.

Sivun alkuun

Useiden arvojen esiintymiskertojen laskeminen Pivot-taulukkoraportilla

Voit näyttää summat ja laskea yksittäisten arvojen esiintymiskerrat Pivot-taulukkoraporttia käyttämällä. Pivot-taulukkoraportilla voi tehdä vuorovaikutteisen yhteenvedon suurista tietomääristä. Voit keskittyä tuloksiisi käyttämällä Pivot-taulukkoa tietotasojen pienentämiseen ja suurentamiseen. Sillä voit myös tarkastella sinua kiinnostavien alueiden tietojen yhteenvetoja. Lisäksi näet eri yhteenvetoja lähdetiedoista siirtämällä rivejä sarakkeisiin tai sarakkeita riveihin.

Esimerkki lähdetiedoista ja Pivot-taulukkoraportista

1   Lähdetiedot, tässä tapauksessa laskentataulukosta

2   Pivot-taulukkoraportin golf-yhteenvedon kolmas vuosineljännes

3   Koko Pivot-taulukkoraportti

4   Lähdetietojen solujen C2 ja C8 lähdearvojen yhteenveto

Pivot-taulukkoraportin luominen

  1. Valitse tiedot sisältävä sarake.
    Varmista, että sarakkeella on sarakeotsikko.

  2. Valitse Lisää-välilehden Taulukot-ryhmässä Pivot-taulukko.
    Näytössä näkyy Luo pivot-taulukko -valintaikkuna.

  3. Valitse Valitse taulukko tai alue.

  4. Sijoita Pivot-taulukkoraportti uuteen laskentataulukkoon alkaen solusta A1 valitsemalla Uusi laskentataulukko.

  5. Valitse OK.
    Tyhjä Pivot-taulukkoraportti lisätään määrittämääsi paikkaan, ja näyttöön tulee Pivot-taulukon kenttäluettelo.

  6. Valitse kentän nimi Pivot-taulukon kenttäluettelon yläreunassa olevasta kenttäosasta, pidä hiiren painiketta painettuna ja vedä kenttä Pivot-taulukon kenttäluettelon alaosassa olevan asetteluosan Riviotsikot-ruutuun.

  7. Valitse saman kentän nimi Pivot-taulukon kenttäluettelon yläreunassa olevasta kenttäosasta, pidä hiiren painiketta painettuna ja vedä kenttä nyt Pivot-taulukon kenttäluettelon alaosassa olevan asetteluosan Arvot-ruutuun.

Huomautus: Jos tiedot sisältävät lukuja, Pivot-taulukkoraportti näyttää lukujen summan sijasta niiden määrän. Jos haluat vaihtaa Summa-yhteenvetofunktion Määrä-yhteenvetofunktioksi, valitse sarakkeen solu ja valitse sitten Analysoi-välilehden Aktiivinen kenttä -ryhmässä Kentän asetukset, napsauta Yhdistä-välilehteä, valitse Laske ja valitse sitten OK.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×