Arvojen hakeminen PHAKU-, INDEKSI- tai VASTINE-funktiolla

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Voit etsiä arvoa suuresta luettelosta hakufunktion avulla. PHAKU-funktiota käytetään yleisesti, mutta voit huoletta käyttää myös VHAKU-funktiota sekä INDEKSI- ja VASTINE-funktioiden yhdistelmää.

Tässä on esimerkki PHAKU-funktiosta ja sen käyttämistä argumenteista:

=PHAKU(<hakuarvo>;<hakualue>;<sarake>;<Lähes tarkka vastine>)

Esimerkiksi =PHAKU(21500;C2:E7;3;EPÄTOSI)

  • Ensimmäinen argumentti eli tieto, jonka funktio tarvitsee toimiakseen, on etsittävä arvo. Se voi olla soluviittaus, kuten B2, tai arvo, kuten "smith" tai 21500.

  • Toinen argumentti on solualue, jonka uskot sisältävän etsittävän arvon.

    Tärkeää: Kun hakua tehdään PHAKU-funktiolla, haettavan arvon tai soluviittauksen sisältävän sarakkeen on oltava alueen vasemmanpuoleisimmassa sarakkeessa.

  • Kolmas argumentti on solualueen sarake, joka sisältää etsittävän arvon.

Neljäs argumentti on valinnainen, mutta useimmat käyttäjät syöttävät epätosi (tai 0). Miksi? Koska tämä pakottaa etsiminen tarkkaa tarkkaa vastinetta haku-funktiota. Voit kirjoittaa ei argumentti tai TOSI, mutta jos tarkkaa vastinetta ei löydy, funktio palauttaa lähinnävastineen— yleensä Useimmat käyttäjät enää halua lähes tarkkaa vastinetta.

Jos haluat näyttää, miten lähes tarkkaa vastinetta voi olla vakava ongelma, sano etsit osa, jonka tunnus 2345768 hinnan, mutta voit vaihtaa kahden ja kirjoitat kaavan tältä: =VLOOKUP(2345678,A1:E7,5). kaava palauttaa hinnan virhe-osan, koska PHAKU löydy luku pienempi tai yhtä suuri kuin määritettyä numeroa (2345678). Onnistunut sinut Laskutus asiakkaan väärin tämän virheen vuoksi.

Jos määrität lähes tarkan vastineen argumentiksi EPÄTOSI tai 0 eikä tarkkaa vastinetta ole, kaava palauttaa soluun vain arvon #N/A väärän arvon sijaan. Tässä tapauksessa #N/A ei tarkoita, että kaava on kirjoitettu väärin (lukuun ottamatta väärin kirjoitettua lukua); se tarkoittaa, että arvoa 2345678 ei löytynyt. Haluttu arvo oli 2345768.

Seuraavassa esimerkissä näytetään, kuinka funktio toimii. Kun kirjoitat arvon soluun B2 (ensimmäinen argumentti, PHAKU hakee arvon soluista C2:E7 (toinen argumentti) ja palauttaa lähimmän lähes tarkan vastineen alueen kolmannesta sarakkeesta, joka on sarake E (kolmas argumentti).

PHAKU-funktion tyypillinen käyttötapa

Tässä esimerkissä neljäs argumentti jätettiin tyhjäksi, joten funktio palauttaa lähes tarkan vastineen.

VHAKU-funktion käyttäminen

Kun olet tutustunut PHAKU-funktioon, VHAKU-funktion käyttäminen on helpompaa. Voit kirjoittaa samat argumentit, mutta VHAKU hakee arvoja riveiltä sarakkeiden sijaan.

INDEKSI- ja VASTINE-funktioiden käyttäminen yhdessä

Jos et halua hakea arvoja vain vasemmanpuoleisimmasta sarakkeesta, voit käyttää INDEKSI- ja VASTINE-funktioiden yhdistelmää. Yhdistelmäfunktiota käyttävä kaava on hiukan monimutkaisempi kuin PHAKU-funktiota käyttävä kaava, mutta se voi olla tehokkaampi. Jotkut käyttävätkin mieluummin INDEKSI- ja VASTINE-funktioiden yhdistelmää kuin PHAKU-funktiota.

Tässä esimerkissä näytetään pieni luettelo, jossa etsittävä arvo Chicago ei ole vasemmanpuoleisimmassa sarakkeessa. PHAKU-funktiota ei siis voi käyttää. Etsitään sen sijaan alueen B1:B11 arvo Chicago VASTINE-funktiolla. Se on rivillä 4. INDEKSI käyttää arvoa hakuargumenttina ja etsii Chicagon väkiluvun 4. sarakkeesta (sarake D). Käytettävä kaava näkyy solussa A14.

Arvon etsiminen INDEKSI- ja VASTINE-funktioilla

Lisätietoa hakufunktioista

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×