Arvojen hakeminen PHAKU-, INDEKSI- tai VASTINE-funktiolla

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Sinulla on esimerkiksi toimistonumeroiden luettelo ja haluat tietää, missä toimistoissa työntekijät ovat. Laskentataulukko on kuitenkin erittäin suuri, joten mitä kannattaa tehdä? Voit käyttää hakufunktiota. PHAKU- ja VHAKU-funktiot ovat hyödyllisimmät, samoin kuin INDEKSI- ja VASTINE-funktiot.

Huomautus:  Ohjattu hakukentän luominen -toiminto ei ole enää käytettävissä Excelissä.

Seuraavassa on lyhyt kertaus PHAKU-funktion käytöstä.

=PHAKU(B2,C2:E7,3,TOSI)

Ensimmäinen argumentti eli tieto, jonka funktio tarvitsee toimiakseen, on etsittävä arvo. Se voi olla soluviittaus tai kova arvo, kuten "smith" tai 21 000. Toinen argumentti on solualue, jonka uskot sisältävän etsittävän arvon. Tässä esimerkissä solualue on C2–C7. Kolmas argumentti on solualueen sarake, joka sisältää etsittävän arvon.

Neljäs argumentti on valinnainen. Se voi olla Tosi tai Epätosi. Jos kirjoitat TOSI tai argumentti jätetään tyhjäksi, funktio palauttaa ensimmäisen argumentin arvon lähes tarkan vastineen. Jos kirjoitat EPÄTOSI, funktio etsii ensimmäisen argumentin arvoa vastaavan arvon. Toisin sanoen neljännen argumentin jättäminen tyhjäksi tai TOSI-arvon käyttäminen tekee hausta joustavamman.

Seuraavassa esimerkissä näytetään, kuinka funktio toimii. Kun kirjoitat arvon soluun B2 (ensimmäinen argumentti, PHAKU hakee arvon soluista C2–E7 (toinen argumentti) ja palauttaa lähimmän lähes tarkan vastineen alueen kolmannesta sarakkeesta, joka on sarake E (kolmas argumentti).

PHAKU-funktion tyypillinen käyttötapa

Neljäs argumentti on tyhjä, joten funktio palauttaa lähes tarkan vastineen. Jos näin ei tapahdu, sinun on kirjoitettava yksi sarakkeen C tai D arvoista tuloksen saamiseksi.

Kun olet tutustunut PHAKU-funktioon, VHAKU-funktion käyttäminen on helpompaa. Voit kirjoittaa samat argumentit, mutta funktio hakee arvoja riveiltä sarakkeiden sijaan.

Kokeile

Ennen kuin ryhdyt käyttämään hakufunktioita omissa laskelmissasi, voit halutessasi harjoitella oheisilla mallitiedoilla. Jotkut haluavat käyttää PHAKU- ja VHAKU-funktioita, toiset taas suosivat INDEKSI- ja VASTINE-funktioita yhdessä. Kokeile jokaista ja valitse suosikkisi.

PHAKU käytössä

Kopioi kaikki tämän taulukon solut ja liitä ne tyhjän Excel-taulukon soluun A1.

Vihje    Määritä sarakkeiden A–C sarakeleveydeksi 250 pikseliä ja valitse Rivitä teksti (Aloitus-välilehti, Tasaus-ryhmä) ennen kuin liität tietoja Exceliin.

Tiheys

Viskositeetti

Lämpötila

0,457

3,55

500

0,525

3,25

400

0,606

2,93

300

0,675

2,75

250

0,746

2,57

200

0,835

2,38

150

0,946

2,17

100

1,09

1,95

50

1,29

1,71

0

Kaava

Kuvaus

Tulos

'=PHAKU(1,A2:C10,2)

Käyttää epätarkan vastineen palauttavaa hakua ja etsii sarakkeesta A arvoa 1. Funktio palauttaa sarakkeen A suurimman arvon (0,946), joka on yhtä suuri tai pienempi kuin 1. Funktio palauttaa lisäksi sarakkeen B saman rivin arvon.

=PHAKU(1,A2:C10,2)

'=PHAKU(1,A2:C10,3,TOSI)

Käyttää epätarkan vastineen palauttavaa hakua ja etsii sarakkeesta A arvoa 1. Funktio palauttaa sarakkeen A suurimman arvon (0,946), joka on yhtä suuri tai pienempi kuin 1. Funktio palauttaa lisäksi sarakkeen C saman rivin arvon.

=PHAKU(1;A2:C10;3;TOSI)

'=PHAKU(0.7;A2:C10;3;EPÄTOSI)

Käyttää tarkan vastineen palauttavaa hakua ja etsii sarakkeesta A arvoa 0,7. Koska sarakkeessa A ei ole tätä arvoa vastaavaa arvoa, funktio palauttaa virhearvon.

=PHAKU(0.7;A2:C10;3;EPÄTOSI)

'=PHAKU(0.1,A2:C10;2;TOSI)

Käyttää epätarkan vastineen palauttavaa hakua ja etsii sarakkeesta A arvoa 0,1. Koska 0,1 on pienempi kuin sarakkeen A pienin arvo, funktio palauttaa virhearvon.

=PHAKU(0,1;A2:C10;2;TOSI)

'=PHAKU(2;A2:C10;2;TOSI)

Käyttää epätarkan vastineen palauttavaa hakua ja etsii sarakkeesta A arvoa 2. Funktio palauttaa sarakkeen A suurimman arvon (1,29), joka on yhtä suuri tai pienempi kuin 2. Lisäksi funktio palauttaa sarakkeen B saman rivin arvon.

=PHAKU(2;A2:C10;2;TOSI)

VHAKU käytössä

Kopioi kaikki tämän taulukon solut ja liitä ne tyhjän Excel-taulukon soluun A1.

Vihje    Määritä sarakkeiden A–C sarakeleveydeksi 250 pikseliä ja valitse Rivitä teksti (Aloitus-välilehti, Tasaus-ryhmä) ennen kuin liität tietoja Exceliin.

Akselit

Laakerit

Pultit

4

4

9

5

7

10

6

8

11

Kaava

Kuvaus

Tulos

'=VHAKU("Akselit"; A1:C4; 2; TOSI)

Etsii arvon "Akselit" riviltä 1 ja palauttaa saman sarakkeen (sarake A) rivin 2 arvon.

=VHAKU("Akselit"; A1:C4; 2; TOSI)

'=VHAKU("Laakerit"; A1:C4; 3; EPÄTOSI)

Etsii arvon "Laakerit" riviltä 1 ja palauttaa saman sarakkeen (sarake B) rivin 3 arvon.

=VHAKU("Laakerit"; A1:C4; 3; EPÄTOSI)

'=VHAKU("B"; A1:C4; 3; TOSI)

Etsii arvon "B" riviltä 1 ja palauttaa saman sarakkeen rivin 3 arvon. Koska arvon "B" tarkkaa vastinetta ei löydy, käytetään riviltä 1 suurinta arvoa, joka on pienempi kuin "B": "Akselit," sarakkeessa A.

=VHAKU("B"; A1:C4; 3; TOSI)

'=VHAKU("Pultit"; A1:C4; 4)

Etsii arvon "Pultit" riviltä 1 ja palauttaa saman sarakkeen (sarake C) rivin 4 arvon.

=VHAKU("Pultit"; A1:C4; 4)

'=VHAKU(3;{1;2;3\"a","b","c"\"d","e","f"};2;TOSI)

Etsii luvun 3 kolmerivisestä matriisivakiosta ja palauttaa rivin 2 arvon samasta sarakkeesta (tässä tapauksessa kolmannesta sarakkeesta). Matriisivakiossa on kolme riviä arvoja; rivit on erotettu toisistaan puolipisteellä (;). Koska "c" esiintyy rivillä 2 ja samassa sarakkeessa kuin 3, "c" palautuu.

=VHAKU(3;{1;2;3\"a","b","c"\"d","e","f"};2;TOSI)

INDEKSI ja VASTINE käytössä

Tässä esimerkissä käytetään INDEKSI- ja VASTINE-funktioita yhdessä vanhimman laskun numeron ja sitä vastaavan päivämäärän palauttamiseen kullekin viidelle kaupungille. Päivämäärä palautetaan lukuna, joten TEKSTI-funktiolla se muotoillaan päivämäärämuotoon. INDEKSI-funktio käyttää argumenttinaan VASTINE-funktion tulosta. INDEKSI- ja VASTINE-funktioiden yhdistelmää käytetään kahdesti jokaisessa kaavassa – ensin laskun numeron palauttamiseen ja sitten päivämäärän palauttamiseen.

Kopioi kaikki tämän taulukon solut ja liitä ne tyhjän Excel-taulukon soluun A1.

Vihje    Määritä sarakkeiden A–D sarakeleveydeksi 250 pikseliä ja valitse Rivitä teksti (Aloitus-välilehti, Tasaus-ryhmä) ennen kuin liität tietoja Exceliin.

Lasku

Kaupunki

Laskun päivämäärä

Vanhin lasku kaupungin perusteella, päivämäärä

3115

Atlanta

7.4.2012

="Atlanta = "&INDEKSI($A$2:$C$33,VASTINE("Atlanta",$B$2:$B$33,0),1)& ", Laskun päivämäärä: " & TEKSTI(INDEKSI($A$2:$C$33,VASTINE("Atlanta",$B$2:$B$33,0),3),"k/p/vv")

3137

Atlanta

9.4.2012

="Austin = "&INDEKSI($A$2:$C$33,VASTINE("Austin",$B$2:$B$33,0),1)& ", Laskun päivämäärä: " & TEKSTI(INDEKSI($A$2:$C$33,VASTINE("Austin",$B$2:$B$33,0),3),"k/p/vv")

3154

Atlanta

11.4.2012

="Dallas = "&INDEKSI($A$2:$C$33,VASTINE("Dallas",$B$2:$B$33,0),1)& ", Laskun päivämäärä: " & TEKSTI(INDEKSI($A$2:$C$33,VASTINE("Dallas",$B$2:$B$33,0),3),"k/p/vv")

3191

Atlanta

21.4.2012

="New Orleans = "&INDEKSI($A$2:$C$33,VASTINE("New Orleans",$B$2:$B$33,0),1)& ", Laskun päivämäärä: " & TEKSTI(INDEKSI($A$2:$C$33,VASTINE("New Orleans",$B$2:$B$33,0),3),"k/p/vv")

3293

Atlanta

25.4.2012

="Tampa = "&INDEKSI($A$2:$C$33,VASTINE("Tampa",$B$2:$B$33,0),1)& ", Laskun päivämäärä: " & TEKSTI(INDEKSI($A$2:$C$33,VASTINE("Tampa",$B$2:$B$33,0),3),"k/p/vv")

3331

Atlanta

27.4.2012

3350

Atlanta

28.4.2012

3390

Atlanta

1.5.2012

3441

Atlanta

2.5.2012

3517

Atlanta

8.5.2012

3124

Austin

9.4.2012

3155

Austin

11.4.2012

3177

Austin

19.4.2012

3357

Austin

28.4.2012

3492

Austin

6.5.2012

3316

Dallas

25.4.2012

3346

Dallas

28.4.2012

3372

Dallas

1.5.2012

3414

Dallas

1.5.2012

3451

Dallas

2.5.2012

3467

Dallas

2.5.2012

3474

Dallas

4.5.2012

3490

Dallas

5.5.2012

3503

Dallas

8.5.2012

3151

New Orleans

9.4.2012

3438

New Orleans

2.5.2012

3471

New Orleans

4.5.2012

3160

Tampa

18.4.2012

3328

Tampa

26.4.2012

3368

Tampa

29.4.2012

3420

Tampa

1.5.2012

3501

Tampa

6.5.2012

Lisätietoa hakufunktioista

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×