Apuohjelmien tarkasteleminen, hallinta ja asentaminen Office-ohjelmissa

Kun otat apuohjelman käyttöön, se lisää Office-ohjelmiin mukautettuja komentoja ja uusia toimintoja, joiden myötä työskentelysi tehostuu. Luvattomat käyttäjät voivat yrittää vahingoittaa tietokonettasi apuohjelmien avulla, joten kannattaa käyttää apuohjelmien suojausasetuksia.

Saat lisätietoja napsauttamalla alla olevia otsikoita.

Valitse Ota sisältö käyttöön viestipalkissa, jos tiedät apuohjelman olevan luotettavasta lähteestä.

Sanomapalkki, jossa on Osa aktiivisesta sisällöstä on poistettu käytöstä -ilmoitus

Voit tarkistaa apuohjelman asetukset ja muuttaa niitä luottamuskeskuksessa. Asetusten kuvaukset ovat seuraavassa osiossa. Jos organisaatiosi on määrittänyt apuohjelmien suojausasetukset, kaikki asetukset eivät välttämättä ole muutettavissa.

  1. Valitse Tiedosto > Asetukset.

  2. Valitse Luottamuskeskus > Luottamuskeskuksen asetukset > Apuohjelmat.

  3. Valitse haluamasi valintaruudut tai poista valinta niiden kohdalta.

Luottamuskeskuksen Apuohjelmat-alue

  • Edellytä, että sovellusapuohjelmat allekirjoittaa luotettu julkaisija     Valitse valintaruutu, kun haluat luottamuskeskuksen tarkistavan, että apuohjelma käyttää luotettua julkaisijan allekirjoitusta. Jos julkaisijan allekirjoitus ei ole luotettu, Office-ohjelma ei lataa apuohjelmaa ja näkyviin tulee sanomapalkki, joka ilmoittaa, että apuohjelma on poistettu käytöstä.

  • Poista käytöstä allekirjoittamattomien apuohjelmien ilmoitukset (koodi pysyy käytöstä poistettuna)     Kun valitset Edellytä, että sovellusapuohjelmat allekirjoittaa luotettu julkaisija -ruudun, tämä asetus on käytettävissä. Luotettavien julkaisijoiden apuohjelmat otetaan käyttöön, mutta allekirjoittamattomat apuohjelmat poistetaan käytöstä.

  • Poista käytöstä kaikki sovellusapuohjelmat (saattaa rajoittaa toimintoja)     Valitse tämä valintaruutu, jos et luota apuohjelmiin. Kaikki apuohjelmat poistetaan käytöstä ilman ilmoitusta, ja muut apuohjelman valintaruudut näkyvät harmaana.

Huomautus: Tämä asetus tulee voimaan vasta, kun Office-ohjelma suljetaan ja käynnistetään uudelleen.

Kun käytät apuohjelmia, saatat tarvita lisätietoja digitaalisista allekirjoituksista ja todistuksista, joilla apuohjelma todennetaan, sekä luotetuista julkaisijoista, apuohjelmia luovista ohjelmistokehittäjistä.

  1. Valitse Tiedosto > Asetukset > Apuohjelmat.

  2. Voit tarkistaa apuohjelman nimen, julkaisijan, yhteensopivuuden, sijainnin tietokoneessasi ja toimintojen kuvauksen korostamalla apuohjelman nimen.

Luottamuskeskuksen Apuohjelmat-alueen tarkasteleminen

Huomautus: Jos tietojen suorittamisen estäminen (DEP) estää apuohjelman käytön, voit lukea lisätietoja artikkelista Miksi apuohjelmani kaatuu?

  • Aktiiviset sovellusapuohjelmat     Tietokoneeseen rekisteröidyt laajennukset, jotka ovat tällä hetkellä käytössä Office-ohjelmassa.

  • Passiiviset sovellusapuohjelmat     Tietokoneessa olevat apuohjelmat, jotka eivät ole ladattuina. Esimerkiksi XML-rakenteet ovat aktiivisia, kun se tiedosto on avattu, jossa niihin viitataan. Toisena esimerkkinä voidaan mainita COM-apuohjelma. Jos COM-apuohjelman valintaruutu on valittuna, kyseinen apuohjelma on aktiivinen. Kun valintaruutu ei ole valittuna, apuohjelma ei ole aktiivinen.

  • Asiakirjaan liittyvät apuohjelmat     Mallitiedostot, joihin viitataan avoinna olevilla asiakirjoilla.

  • Käytöstä poistetut sovellusapuohjelmat    Apuohjelmat, jotka on poistettu automaattisesti käytöstä, koska ne aiheuttavat Office-ohjelmien kaatumisen.

  • Apuohjelma     Apuohjelman nimi.

  • Julkaisija     Apuohjelman luomisesta vastuussa oleva ohjelmistokehittäjä tai organisaatio.

  • Yhteensopivuus     Tarkista mahdolliset yhteensopivuusongelmat.

  • Sijainti     Tämä tiedostopolku näyttää, mihin apuohjelma on tallennettu tietokoneessasi.

  • Kuvaus Kuvaus kertoo apuohjelman toiminnasta.

Huomautus: Microsoft Outlookissa on yksi apuohjelmia koskeva asetus luottamuskeskuksessa: Käytä makrosuojausasetuksia myös asennetuissa apuohjelmissa. InfoPath ei tarjoa suojausasetuksia apuohjelmia varten.

Voit hallita ja asentaa apuohjelmia noudattamalla seuraavia ohjeita.

  1. Valitse Tiedosto > Asetukset > Apuohjelmat.

  2. Valitse apuohjelman tyyppi.

  3. Valitse Siirry.

  4. Valitse lisättävä, poistettava tai ladattava apuohjelma tai etsi asennettava apuohjelma selaamalla sen sijaintiin.

Jos olet tilannut Office-kaupan kautta apuohjelman, jonka käyttöä et halua jatkaa, voit peruuttaa tilauksen.

  1. Avaa Office-sovellus ja valitse valintanauhan Lisää-välilehti.

  2. Valitse Apuohjelmat-ryhmästä Omat apuohjelmat

    Valintanauhan Lisää-välilehdessä on Apuohjelmat-ryhmä Excel-apuohjelmien hallintaan
  3. Valitse Hallitse omia apuohjelmia.

    Officen apuohjelmien valintaikkunassa on asennettujen apuohjelmien luettelo. Hallitse apuohjelmia valitsemalla Hallitse omia apuohjelmia.
  4. Valitse peruutettava sovellus ja valitse Toiminto-kohdassa Hallitse tilausta.

  5. Valitse Maksaminen ja laskutus -osasta Peruuta tilaus.

  6. Valitse OK ja Jatka.

Tämän jälkeen sinun pitäisi nähdä sovellusluettelon kommenttikentässä viesti, jossa lukee ”Olet peruuttanut sovelluksen tilaukseen”.

Jotkin apuohjelmat eivät ole välttämättä yhteensopivia organisaatiosi IT-käytäntöjen kanssa. Jos näin käy hiljattain Office-ohjelmaan asennetun apuohjelman kanssa, tietojen suorittamisen estäminen (DEP) poistaa apuohjelman käytöstä ja ohjelma saattaa kaatua.

Lisätietoja tietojen suorittamisen estämisestä.

Tutustu myös seuraaviin ohjeaiheisiin

Saat lisätietoja napsauttamalla alla olevia otsikoita.

Kun asennat 2007 Microsoft Office Systemin, tietokoneeseen asennetaan useita apuohjelmia ja ne rekisteröidään siihen automaattisesti.

Word, Excel, Access ja PowerPoint

  1. Napsauta Microsoft Office -painiketta Office-painikkeen kuva , napsauta Asetukset-painiketta ja napsauta sitten Apuohjelmat.

  2. Voit tarkastella apuohjelmia ja sovellustunnisteita, jotka on luokiteltu seuraavasti:

    • Aktiiviset sovellusapuohjelmat    Luettelee rekisteröidyt tunnisteet, jotka ovat tällä hetkellä käytössä Office-ohjelmassa.

    • Passiiviset sovellusapuohjelmat    Luettelee apuohjelmat, jotka ovat tietokoneessa, mutta joita ei ole tällä hetkellä ladattu. Esimerkiksi toimintotunnisteet tai XML-rakenteet ovat aktiivisia vain silloin, kun asiakirja, jossa niihin viitataan, on avoinna. Toinen esimerkki on COM-apuohjelmat, jotka on lueteltu COM-apuohjelmat-valintaruudussa. Jos COM-apuohjelman valintaruutu on valittuna, apuohjelma on aktiivinen. Jos COM-apuohjelman valintaruudun valinta on poistettu, apuohjelma on aktiivinen. Katso seuraavasta osiosta Asennettujen apuohjelmien poistaminen käytöstä tai hallinnointi, miten voit avata COM-apuohjelmat-valintaruudun.

    • Liittyvät asiakirjat Apuohjelmat    Luettelee mallitiedostot, joihin viitataan nykyisin avoimissa asiakirjoissa.

    • Käytöstä poistetut sovellusapuohjelmat    Luettelee apuohjelmat, jotka on poistettu automaattisesti käytöstä, koska ne aiheuttavat Office-ohjelmien kaatumisen.

Outlook, InfoPath, Publisher ja Visio

  1. Napsauta Työkalut-valikossa Luottamuskeskus ja napsauta sitten Apuohjelmat.

  2. Voit tarkastella apuohjelmia ja sovellustunnisteita, jotka on luokiteltu seuraavasti:

    • Aktiiviset sovellusapuohjelmat    Luettelee rekisteröidyt tunnisteet, jotka ovat tällä hetkellä käytössä Office-ohjelmassa.

    • Passiiviset sovellusapuohjelmat    Luettelee apuohjelmat, jotka ovat tietokoneessa, mutta joita ei ole tällä hetkellä ladattu. Esimerkiksi toimintotunnisteet tai XML-rakenteet ovat aktiivisia vain silloin, kun asiakirja, jossa niihin viitataan, on avoinna. Toinen esimerkki on COM-apuohjelmat, jotka on lueteltu COM-apuohjelmat-valintaruudussa. Jos COM-apuohjelman valintaruutu on valittuna, apuohjelma on aktiivinen. Jos COM-apuohjelman valintaruudun valinta on poistettu, apuohjelma on aktiivinen. Katso seuraavasta osiosta Asennettujen apuohjelmien poistaminen käytöstä tai hallinta, miten voit avata COM-apuohjelmat-valintaruudun.

    • Asiakirjaan liittyvät apuohjelmat     Luetteloi mallitiedostot, joihin viitataan nykyisin avoimissa asiakirjoissa.

    • Käytöstä poistetut sovellusapuohjelmat    Luettelee apuohjelmat, jotka on poistettu automaattisesti käytöstä, koska ne aiheuttavat Office-ohjelmien kaatumisen.

Apuohjelmien hallintaan voi liittyä apuohjelman käyttöönotto ja käytöstä poistaminen, apuohjelman lisääminen tai poistaminen sekä apuohjelman tekeminen aktiiviseksi tai passiiviseksi.

Word, Excel, Access ja PowerPoint

  1. Napsauta Microsoft Office -painiketta Office-painikkeen kuva , napsauta Wordin asetukset ja napsauta sitten Apuohjelmat.

  2. Määritä Apuohjelmat-ruudussa apuohjelma, jonka haluat ottaa käyttöön tai poistaa käytöstä, ja merkitse muistiin Tyyppi-sarakkeessa sijaitseva apuohjelmatyyppi.

  3. Valitse apuohjelmatyyppi Hallitse-ruudussa ja napsauta sitten Siirry.

  4. Valitse tai poista valintaruudun valinta apuohjelmalle, jonka haluat ottaa käyttöön tai poistaa käytöstä, ja napsauta sitten OK.

Huomautus: Esimerkiksi Asiakirjan tarkastaminen -apuohjelman kaltaiset apuohjelmat otetaan käyttöön erilaisella menetelmällä. Nämä apuohjelmat otetaan automaattisesti käyttöön, kun tarkistat, onko asiakirjassa piilotettuja metatietoja tai henkilökohtaisia tietoja. Jos haluat tarkistaa asiakirjasi, napsauta Microsoft Office -painiketta, napsauta Valmistele ja napsauta sitten Tarkista asiakirja.

Outlook, InfoPath, Publisher ja Visio

  1. Napsauta Työkalut-valikossa Luottamuskeskus ja napsauta sitten Apuohjelmat.

  2. Määritä Apuohjelmat-ruudussa apuohjelma, jonka haluat ottaa käyttöön tai poistaa käytöstä, ja merkitse muistiin Tyyppi-sarakkeessa sijaitseva apuohjelmatyyppi.

  3. Valitse apuohjelmatyyppi Hallitse-ruudussa ja napsauta sitten Siirry.

  4. Valitse tai poista valintaruudun valinta apuohjelmalle, jonka haluat ottaa käyttöön tai poistaa käytöstä, ja napsauta sitten OK.

Apuohjelmat ja asiakirjat voivat lisätä mukautettuja painikkeita ja ohjausobjekteja valintanauhaan, joka on osa Microsoft Officen sujuva käyttöliittymäia. Office Fluent -valintanauhan kaikilla mukautetuilla ohjausobjekteilla on erityinen kohdeohje, joka määrittää ohjausobjektin alkuperän. Tässä esimerkissä ohjausobjekti on peräisin RXDemo.xlsm-tiedostosta, ja se määritetään ohjausobjektin kohdeohjeessa.

Valintanauhan kuva

Tällä tavalla voit selvittää, mistä mukautetut ohjausobjektit ovat peräisin, ja sitten poistaa tai päivittää asiakirjan, yleisen mallin tai COM-apuohjelman, joka esittää ohjausobjektin. Katso edellisestä osiosta, miten voit tarkastella asennettuja COM-apuohjelmia.

Asennettuja ja rekisteröityjä apuohjelmia voidaan oletusarvoisesti käyttää ilman ilmoitusta. Hakkerit voivat aiheuttaa apuohjelmille vahinkoa esimerkiksi levittämällä viruksia. Voit estää tämän käyttämällä apuohjelmien suojausasetuksia. Katso lisätietoja tämän artikkelin jäljempänä olevasta kohdasta Apuohjelman suojausasetusten tarkasteleminen tai muuttaminen.

Jos sinä olet määrittänyt tai järjestelmänvalvojasi on määrittänyt korkeamman suojausasetuksen apuohjelmille ja Luottamuskeskus havaitsee mahdollisesti epäluotettavan apuohjelman, joka ei täytä näitä ehtoja, Luottamuskeskus poistaa käytöstä oletusarvon mukaisen koodin. Näyttöön tulee sanomapalkki, joka ilmoittaa sinulle mahdollisesti vahingollisesta apuohjelmasta tai sovellustunnisteesta.

Sanomapalkki

Jos napsautat Asetukset sanomapalkissa, esiin avautuu suojauksen valintaruutu, jossa apuohjelma voidaan ottaa käyttöön. Katso seuraavasta osiosta, miten voit tehdä turvallisen päätöksen ennen vaihtoehdon napsauttamista.

Huomautus: Suojausilmoitukset näkyvät Microsoft Office Outlook 2007ssa ja Microsoft Office Publisher 2007ssa sanomapalkin sijasta valintaruuduissa. Oletusarvoisesti Office Outlook 2007 sallii kaikkien asennettujen apuohjelmien suorittamisen. Jos haluat muuttaa oletusasetusta, katso tämän artikkelin jäljempänä olevaa kohtaa Apuohjelman suojausasetusten tarkasteleminen tai muuttaminen.

Kun muutat apuohjelman suojausasetusta, se vaikuttaa vain ohjelmaan, jossa muutos tehtiin. Toimi seuraavasti näissä 2007 Microsoft Office System-ohjelmissa:

Word, Excel, Access ja PowerPoint

  1. Napsauta Microsoft Office -painiketta Office-painikkeen kuva ja napsauta sitten Asetukset-painiketta.

  2. Napsauta Luottamuskeskus, napsauta Luottamuskeskuksen asetukset ja napsauta sitten Apuohjelmat.

  3. Napsauta haluamiasi asetuksia. Näitä asetuksia ei valita oletusarvoisesti, paitsi jos työskentelet organisaatiossa ja tietotekniikasta (IT) vastaava järjestelmänvalvojasi on muuttanut oletusasetuksia järjestelmänvalvojan käytännön avulla.

    • Edellyttää, että luotettu julkaisija allekirjoittaa sovellusapuohjelmat Valitse tämä asetus, jos haluat, että Luottamuskeskus tarkistaa digitaalinen allekirjoitusin dynamic-link library (.dll) -tiedostossa, joka sisältää apuohjelman. Jos julkaisijaa ei ole määritetty luotetuksi, Office-ohjelma ei lataa apuohjelmaa ja sanomapalkissa näkyy ilmoitus, että apuohjelma on poistettu käytöstä.

    • Poista käytöstä allekirjoittamattomien apuohjelmien ilmoitus (koodi pysyy käytöstä poistettuna) Tämä valintaruutu on käytettävissä vain, jos valitset Edellyttää, että luotettu julkaisija allekirjoittaa sovelluksen tunnisteet -valintaruudun. Joissakin tilanteissa dynamic-link library (.dll) -tiedostoa, joka sisältää apuohjelman, ei ole allekirjoitettu. Näissä tapauksissa otetaan käyttöön luotetun julkaisijan allekirjoittamat apuohjelmat, mutta allekirjoittamattomat apuohjelmat poistetaan käytöstä automaattisesti.

    • Poista käytöstä kaikki sovellusapuohjelmat (saattaa rajoittaa toimintoja) Valitse tämä valintaruutu, jos et luota apuohjelmiin. Kaikki apuohjelmat poistetaan käytöstä ilman ilmoitusta, ja muut apuohjelman valintaruudut näkyvät harmaana.

      Huomautus: Tämä asetus tulee voimaan vasta, kun Office-ohjelma suljetaan ja käynnistetään uudelleen.

Outlook

Oletusarvoisesti Outlook sallii kaikkien asennettujen apuohjelmien suorittamisen. Voit rajoittaa Outlookia suorittamaan vain digitaalisesti allekirjoitetut apuohjelmat käyttämällä apuohjelmiin Allekirjoitettuja makroja koskevat varoitukset; kaikki allekirjoittamattomat makrot poistetaan käytöstä -asetusta seuraavasti:

  1. Napsauta Työkalut-valikossa Luottamuskeskus.

  2. Napsauta vasemmanpuoleisessa ruudussa Makrosuojaus.

  3. Napsauta Allekirjoitettuja makroja koskevat varoitukset; kaikki allekirjoittamattomat makrot poistetaan käytöstä.

  4. Napsauta vasemmanpuoleisessa ruudussa Apuohjelmat.

  5. Valitse Käytä makrosuojausasetuksia asennettuihin apuohjelmiin -valintaruutu.

InfoPath, Publisher ja Visio

  1. Napsauta Työkalut-valikossa Luottamuskeskus.

  2. Napsauta Apuohjelmat.

  3. Napsauta haluamiasi asetuksia. Näitä asetuksia ei valita oletusarvoisesti, paitsi jos työskentelet organisaatiossa ja tietotekniikasta (IT) vastaava järjestelmänvalvojasi on muuttanut oletusasetuksia järjestelmänvalvojan käytännön avulla.

    • Edellyttää, että luotettu julkaisija allekirjoittaa sovellusapuohjelmat Valitse tämä asetus, jos haluat, että Luottamuskeskus tarkistaa digitaalinen allekirjoitusin dynamic-link library (.dll) -tiedostossa, joka sisältää apuohjelman. Jos julkaisijaa ei ole määritetty luotetuksi, Office-ohjelma ei lataa apuohjelmaa ja sanomapalkissa näkyy ilmoitus, että apuohjelma on poistettu käytöstä.

    • Poista käytöstä allekirjoittamattomien apuohjelmien ilmoitus (koodi pysyy käytöstä poistettuna) Tämä valintaruutu on käytettävissä vain, jos valitset Edellyttää, että luotettu julkaisija allekirjoittaa sovelluksen tunnisteet -valintaruudun. Joissakin tilanteissa dynamic-link library (.dll) -tiedostoa, joka sisältää apuohjelman, ei ole allekirjoitettu. Näissä tapauksissa otetaan käyttöön luotetun julkaisijan allekirjoittamat apuohjelmat, mutta allekirjoittamattomat apuohjelmat poistetaan käytöstä automaattisesti.

    • Poista käytöstä kaikki sovellusapuohjelmat (saattaa rajoittaa toimintoja) Valitse tämä valintaruutu, jos et luota apuohjelmiin. Kaikki apuohjelmat poistetaan käytöstä ilman ilmoitusta, ja muut apuohjelman valintaruudut näkyvät harmaana.

      Huomautus: Tämä asetus tulee voimaan vasta, kun Office-ohjelma suljetaan ja käynnistetään uudelleen.

Jos yrität poistaa apuohjelman käytöstä ja saat viestin ”HKEY_LOCAL_MACHINE-rekisteröityjen Office-apuohjelmien yhdistettyä tilaa ei voi muuttaa”, toimi seuraavasti:

  1. Jos Outlook on avoinna, sulje se.

  2. Varmista, että Outlook-palvelu ei ole käynnissä, toimimalla seuraavasti:

    • Napsauta tehtäväpalkin tyhjää kohtaa hiiren kakkospainikkeella, napsauta Tehtävienhallinta ja napsauta sitten Prosessit.

    • Etsi Microsoft Outlook prosessiluettelosta:

      • Jos Outlook ei ole luettelossa, siirry vaiheeseen 3.

      • Jos Outlook on luettelossa, napsauta sitä ja napsauta sitten Lopeta tehtävä.

  3. Napsauta hiiren kakkospainikkeella Aloitus-valikossa Outlook ja napsauta sitten Suorita järjestelmänvalvojana.

  4. Poista käytöstä apuohjelmat, jotka haluat poistaa käytöstä, aiemmin tässä artikkelissa olevan Asennettujen apuohjelmien poistaminen käytöstä tai hallinta -osion mukaisesti.

  5. Sulje Outlook.

  6. Avaa Outlook tavalliseen tapaan (muussa kuin järjestelmänvalvojan tilassa).

Kun suojausvalintaruutu tulee näkyviin, voit ottaa apuohjelman käyttöön vain nykyistä istuntoa varten napsauttamalla Ota tämä apuohjelma käyttöön vain tälle istunnolle tai voit jättää sen tilaan, jossa se on poistettu käytöstä. Ota apuohjelma käyttöön vain, jos olet varma, että se on peräisin luotettavasta lähteestä.

Microsoft Officen Suojausasetukset-valintaikkuna

Vaihtoehtoisesti voit nimenomaisesti luottaa julkaisijaan napsauttamalla Ota käyttöön tämän julkaisijan julkaisemat kaikki koodit. Tällöin apuohjelmat otetaan käyttöön ja luotat aina tämän julkaisijan kaikkiin ohjelmistoihin.

Kun suojausvalintaruutu tulee näkyviin Office Outlook 2007ssa, voit ottaa apuohjelman käyttöön vain nykyiselle istunnolle napsauttamalla Ota sovelluksen apuohjelma käyttöön tai voit jättää sen tilaan, jossa se on poistettu käytöstä. Ota apuohjelma käyttöön vain, jos olet varma, että se on peräisin luotettavasta lähteestä.

Microsoft Office Outlook -tietoturvailmoitus

Vaihtoehtoisesti voit nimenomaisesti luottaa julkaisijaan napsauttamalla Luota tämän julkaisijan kaikkiin asiakirjoihin. Tällöin apuohjelmat otetaan käyttöön ja luotat aina tämän julkaisijan kaikkiin ohjelmistoihin.

Katso lisätietoja luotetuista julkaisijoista artikkelista Luotetun julkaisijan lisääminen, poistaminen tai tarkasteleminen.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×