Ajan lisääminen tai vähentäminen

Oletetaan, että sinun on lisättävä kaksi eri aika-arvoa yhteen, jotta saat kokonaissumman. Tai sinun on vähennettävä yksi aika-arvo toisesta, jotta saat koko projektin parissa käytetyn ajan.

Kuten alla olevissa kohdissa on näkyvissä, aikaa on helppo lisätä tai vähentää Excelin avulla.

Ajan lisääminen

Oletetaan, että haluat tietää, kuinka monta tuntia ja minuuttia kahden tehtävän suorittamiseen kuluu yhteensä. Arvioit, että ensimmäinen tehtävä vie 6 tuntia ja 45 minuuttia ja toinen 9 tuntia ja 30 minuuttia.

Tässä on yksi tapa määrittää tämä laskenta taulukossa.

  1. Kirjoita soluun B2 6:45ja kirjoitasoluun B3 9:30.

  2. Kirjoita soluun B4 = B2 + B3 ja paina sitten ENTER-näppäintä.

    Kahden tehtävän yhteenlaskettu aika

    Tulos on 16:15 – 16 tuntia ja 15 minuuttia – kahden tehtävän valmistumiseen.

    Vihje: Voit laskea aikoja yhteen myös Summa-toiminnolla, joka laskee lukuja yhteen. Valitse solu B4 ja valitse sitten Aloitus-välilehdessä Summa. Kaava näyttää tältä: =SUMMA(B2:B3). Paina ENTER-näppäintä, jotta saat saman tuloksen, 16 tuntia ja 15 minuuttia.

Jos tunteja on yhteensä enemmän kuin 24, sinun on suoritettava ylimääräinen vaihe. Kaavan tuloksessa on käytettävä erikoismuotoilua.

Voit lisätä enintään 24 tuntia:

  1. Kirjoita soluun B2 12:45 ja soluun B3 15:30.

  2. Kirjoita soluun B4 =B2+B3 ja paina ENTER-näppäintä.

    Yhteenlaskettu aika, joka on yli 24 tuntia, antaa odottamattoman tuloksen 4:15

    Tulos on 4:15, mikä ei ehkä ole odotettavissa. Tämä johtuu siitä, että tehtävän 2 aika on 24 tunnin aikana. 15:30 on sama kuin 3:30.

  3. Jos haluat tuloksen olevan yli 24 tuntia, valitse solu B4.

  4. Valitse Aloitus-välilehden Solut-ryhmästä Muotoile ja valitse sitten Muotoile soluja.

    Aloitus-välilehdessä, Muoto-painikkeessa, Muotoile solut -painike valikossa

  5. Valitse Muotoile solut -ruudun Luokka-luettelossa Oma.

  6. Kirjoita muoto luettelon yläreunassa olevaan laji -ruutuun [h]: mm; @ ja valitse sitten OK.

    Huomioi kaksoispiste [h] -kohdan jälkeen ja puoli piste Milli metrinjälkeen.

Tuloksena on 28 tuntia ja 15 minuuttia. Muoto on Tyyppi-luettelossa seuraavaa käyttökertaa varten.

Ajan vähentäminen

Tässä on toinen esimerkki: Oletetaan, että sinä ja kaverisi tunnette sekä alkamis-että päättymis ajan vapaaehtoisprojektissa ja haluat tietää, kuinka paljon aikaa olet käyttänyt koko ajan.

Saat kulunutta aikaa, joka on kahden ajan välinen ero, noudattamalla seuraavia ohjeita.

  1. Kirjoita soluun B2 alkamis aika ja Sisällytä "a" am-tai "p" for PM-kenttään. Paina sitten Enter-näppäintä.

  2. Kirjoita soluun C2 päättymis aika, mukaan lukien "a" tai "p", ja paina sitten ENTER-näppäintä.

  3. Kirjoita myös ystäviesi Liisin ja Selman töiden alkamis- ja päättymisajat.

  4. Vähennä soluun D2 päättymis aika alkamis ajasta kirjoittamalla kaava = C2-B2ja paina sitten ENTER-näppäintä.

    Yhden ajan vähentäminen toisesta kuluneen ajan laskemiseksi

  5. Valitse Muotoile solut -ruudun Luokka-luettelossa Mukautettu.

  6. Valitse Tyyppi-luettelosta h:mm (tunteja ja minuutteja varten) ja valitse sitten OK.

    Nyt näemme, että Richard työskenteli 3 tuntia ja 45 minuuttia.

    Sarakkeessa D luetellut kuluneet ajat

  7. Saat Liisin ja Selman tulokset kopioimalla kaavan: napsauta solua D2 ja vedä soluun D4.

    Solun D2 muotoilu kopioituu kaavan mukana.

Jos haluat vähentää aikaa, joka on yli 24 tuntia:

On tarpeen luoda kaava, jonka avulla vähennetään kahden ajan välinen erotus, joka on yli 24 tuntia.

Noudata seuraavia ohjeita:

  1. Yllä olevaan esimerkkiin liittyen voit napsauttaa solua B1 ja vetää soluun B2, jotta voit käyttää muotoilua molemmissa soluissa samaan aikaan.

  2. Valitse Muotoile solut -ruudun Luokka-luettelossa Mukautettu.

  3. Kirjoita muotoiluvaihtoehtojen luettelon yläreunassa olevaan Laji-ruutuun k/p/vvvv t:mm AM/PM.

    Huomaa tyhjän tilan vvvv -kohdan lopussa ja Milli metrinlopussa.

    Uusi muotoilu on käytettävissä tarvittaessa Tyyppi-luettelossa.

  4. Kirjoita soluun B1 alkamispäivä, mukaan lukien kuukausi/päivä/vuosi ja aika, jossa on joko "a" (AM) tai "p" (PM).

    Kulunut aika on yli 24 tuntia

  5. Tee solussa B2 sama päättymispäivälle.

  6. Kirjoita soluun B3 kaava =(B2-B1)*24.

Tulos on 31,5 tuntia.

Huomautus: Voit lisätä ja vähentää yli 24 tuntia Excel Online, mutta et voi käyttää mukautettua luku muotoilua.

Ajan lisääminen

Oletetaan, että haluat tietää, kuinka monta tuntia ja minuuttia kahden tehtävän suorittamiseen kuluu yhteensä. Arvioit, että ensimmäinen tehtävä vie 6 tuntia ja 45 minuuttia ja toinen 9 tuntia ja 30 minuuttia.

  1. Kirjoita soluun B2 6:45 ja soluun B3 9:30.

  2. Kirjoita =B2+B3 soluun B4 ja paina Enter-näppäintä.

Kahden tehtävän yhteenlaskettu aika

Kahden tehtävän suorittaminen vie 16 tuntia ja 15 minuuttia.

Vihje: Voit myös laskea aikoja yhteen Summa-toiminnolla. Napsauta solua B4. Valitse sitten Aloitus > Summa. Kaava näyttää tältä: =SUMMA(B2:B3). Saat tuloksen, joka on 16 tuntia ja 15 minuuttia, painamalla Enter-näppäintä.

Ajan vähentäminen

Oletetaan, että sinä ja ystäväsi tiedätte vapaaehtoistyöprojektin alkamis- ja päättymisajat ja haluatte tietää projektiin käyttämänne ajan. Haluatte siis tietää kuluneen ajan tai kahden ajan erotuksen.

  1. Kirjoita soluun B2 alkamis aika, kirjoita väli lyönti ja kirjoita sitten "a" am-tai "p" (PM) ja paina ENTER-näppäintä. Kirjoita soluun C2 päättymisaika sekä "a" tai "p" ja paina ENTER-näppäintä. Kirjoita myös ystäviesi Joyn ja Leslien töiden alkamis- ja päättymisajat.

  2. Vähennä solussa D2 päättymisaika alkamisajasta kirjoittamalla kaava: =C2-B2 ja painamalla sitten ENTER-näppäintä.

Yhden ajan vähentäminen toisesta kuluneen ajan laskemiseksi

Nyt näemme, että Richard työskenteli 3 tuntia ja 45 minuuttia.

  1. Saat Joyn ja Leslien työajat, kun kopioit kaavan napsauttamalla solua D2 ja vetämällä soluun D4. Solun D2 muotoilu kopioituu kaavan mukana.

Sarakkeessa D luetellut kuluneet ajat

Huomautus:  Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kerrotko meille, oliko tiedoista hyötyä? Tästä pääset artikkelin englanninkieliseen versioon.

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×