#VIITTAUS!-virheen korjaaminen

#VIITTAUS!-virheen korjaaminen

Huomautus: Microsoft haluaa tarjota sinulle ajantasaisinta ohjesisältöä mahdollisimman nopeasti omalla kielelläsi. Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kertoisitko sivun alareunassa olevan toiminnon avulla, oliko tiedoista hyötyä? Tästä pääset helposti artikkelin englanninkieliseen versioon.

#VIITTAUS!-virhe näytetään, kun kaava viittaa soluun, joka ei ole kelvollinen. Näin käy yleensä silloin, kun soluja, joihin kaavat viittaavat, poistetaan tai niiden päälle liitetään.

Esimerkki #VIITTAUS!-virheestä, jonka syynä on sarakkeen poistaminen

Seuraavassa esimerkissä käytetään kaavaa =SUMMA(B2,C2,D2) sarakkeessa E.

Kaava, joka käyttää tarkkoja soluviittauksia, kuten =SUMMA(B2,C2,D2), voi aiheuttaa #VIITTAUS!-virheen, jos sarake poistetaan.

Jos poistat sarakkeen B, C tai D, tämä aiheuttaa #VIITTAUS!-virheen. Tässä tapauksessa poistamme sarakkeen C (vuoden 2007 myynti), joten kaava on nyt =SUMMA(B2,#VIITTAUS!,C2). Kun käytät tällaisia tarkkoja soluviittauksia, joissa viittaat jokaiseen soluun erikseen pilkulla eroteltuna, ja poistat viitatun rivin tai sarakkeen, Excel ei voi ratkaista kaavaa, joten se antaa #VIITTAUS!-virheen. Tämä on suurin syy sille, miksi emme suosittele tarkkojen soluviittausten käyttöä.

Tämä on esimerkki #VIITTAUS!-virheestä, jonka syynä on sarakkeen poistaminen.

Ratkaisu

  • Jos poistat rivejä tai sarakkeita vahingossa, voit palauttaa ne heti pikatyökalurivin Kumoa-painikkeella (tai näppäinyhdistelmällä CTRL+Z).

  • Muokkaa kaavaa niin, että se käyttää alueviittausta yksittäisten solujen asemesta: =SUMMA(B2:D2). Nyt voit poistaa minkä tahansa sarakkeen summa-alueelta: Excel muokkaa kaavaa automaattisesti. Voit käyttää rivien summaan myös kaavaa =SUMMA(B2:B5).

Esimerkki PHAKU-kaavasta, jossa on virheellisiä alueviittauksia

Seuraavassa esimerkissä =PHAKU(A8,A2:D5,5,FALSE) palauttaa #VIITTAUS!-virheen, koska se etsii palautettavaa arvoa 5. sarakkeesta, mutta viittausalue on vain neljä saraketta: A:D.

Esimerkki PHAKU-kaavasta, jossa on virheellinen alue.  KAAVA on =PHAKU(A8,A2:D5,5,FALSE).  PHAKU-alueessa ei ole viidettä saraketta, joten 5 aiheuttaa #VIITTAUS!-virheen.

Ratkaisu

Muokkaa aluetta suuremmaksi tai pienennä sarakehaun arvoa viittausalueen kokoiseksi. =PHAKU(A8,A2:E5,5,FALSE) olisi kelvollinen viittausalue, samoin =PHAKU(A8,A2:D5,4,FALSE).

Esimerkki INDEKSI-kaavasta, jossa on virheellinen rivi- tai sarakeviittaus

Tässä esimerkissä kaava =INDEKSI(B2:E5,5,5) palauttaa #VIITTAUS!-virheen, koska INDEKSI-alue on neljä riviä kertaa neljä saraketta, mutta kaava pyytää palauttamaan arvon 5. riviltä ja 5. sarakkeesta.

Esimerkki INDEKSI-kaavasta, jossa on virheellinen alueviittaus.  Kaava on =INDEKSI(B2:E5,5,5), mutta alue on vain neljä riviä kertaa neljä saraketta.

Ratkaisu

Muokkaa rivi- tai sarakeviittauksia siten, että ne ovat INDEKSI-hakualueella. =INDEKSI(B2:E5,4,4) palauttaisi kelvollisen tuloksen.

Esimerkki viittauksesta suljettuun työkirjaan EPÄSUORA-funktiolla

Seuraavassa esimerkissä EPÄSUORA-funktio yrittää viitata työkirjaan, joka on suljettu, mikä aiheuttaa #VIITTAUS!-virheen.

Tämä on esimerkki #VIITTAUS!-virheestä, jonka aiheuttaa epäsuora viittaus suljettuun työkirjaan.

Ratkaisu

Avaa viitatun työkirja. Sama virhe ilmetä, jos viittaat suljetun työkirjan dynaaminen array-funktio.

OLE-ongelmat

Jos käytät Object Linking and Embedding (OLE) -linkkiä, joka palauttaa #VIITTAUS!.virheen, käynnistä ohjelma, jota linkki kutsuu.

Huomautus: OLE on tekniikka, jolla voit jakaa tietoja ohjelmien välillä.

DDE-ongelmat

Jos olet käyttänyt Dynamic Data Exchange (DDE) -aihetta, joka palauttaa #VIITTAUS!-virheen, varmista ensin, että viittaat oikeaan aiheeseen. Jos saat edelleen #VIITTAUS!-virheen, tarkista Luottamuskeskuksen asetuksissa ulkoisen sisällön asetukset, kuten artikkelissa Ulkoisen sisällön estäminen tai salliminen Office-tiedostoissa on esitetty.

Huomautus: Dynamic Data Exchange (DDE)on muodostettu protokolla Microsoft Windows-pohjaisten ohjelmien välillä.

Makro-ongelmat

Jos makro siirtyy taulukon funktioon, joka viittaa funktion yläpuolella olevaan soluun, ja solu, joka sisältää funktion, on rivillä 1, funktio palauttaa #VIITTAUS!-virheen, koska rivin 1 yläpuolella ei ole soluja. Tarkista, viittaako jokin funktion argumentti soluun tai solualueeseen, joka ei ole kelvollinen. Tämä saattaa edellyttää makron muokkaamista Visual Basic Editorilla (VBE) tilanteen huomioimiseksi.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta, saada tukea yhteisön vastauksista tai ehdottaa uutta ominaisuutta tai parannusta Excel User Voice -sivustolla.

Katso myös

Yleiskuva kaavoista Excelissä

Viallisten kaavojen ratkaiseminen

Kaavoissa esiintyvien virheiden etsiminen

Excelin funktiot (aakkosjärjestyksessä)

Excelin funktiot (luokittain)

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×