#ARVO! KETJUTA-funktion virhe

Tärkeää: Excel 2016, Excel Mobile ja Excel Online Yhdistä-funktio on korvannut KETJUTA-funktion. Vaikka KETJUTA-funktio on yhä käytettävissä taaksepäisen yhteensopivuuden takia, kannattaa käyttää laadukkaampaa YHDISTÄ-funktiota.

Yksi yleisimmistä tilanteista, joissa kohtaat #VALUE! KETJUTA-virhe tulee näkyviin, kun yrität muodostaa merkki jonon, joka sisältää virheen sisältävän solu viittauksen, kuten #VALUE!.

Seuraavassa esimerkissä halu amme KETJUTA D2, E2 ja F2, jossa E2 on #VALUE! -virheen.

#ARVO! Virhe KETJUTA-sovelluksessa

Solussa E2 oleva virhe aiheuttaa sen, että funktio näyttää arvon #VALUE!. Jotta se toimisi oikein, sinun on korvattava virheen aiheuttava arvo toisella arvolla, joka ei aiheuta virhettä. Voit muodostaa kaavan, joka etsii virhettä soluviittauksesta. Jos virhe löytyy, kaava näyttää merkkijonon, jossa virheen tilalla näkyy arvo 0 (voit myös korvata arvon 0 omalla tekstilläsi, mutta teksti on kirjoitettava lainausmerkkeihin – ”Oma teksti”).

Tällainen kaava on sopiva:

=JOS(ONVIRHE(E2);KETJUTA(D2;” ”;0;” ”;F2))

Jos-ja onError-funktioita käytetään vaihtoehtoisena ratkaisuna merkki jonon KETJUTA #VALUE! -virheen korjaaminen

Miten se toimii? Jos-funktio käyttää JOSVIRHE-funktiota ja määrittää, onko kyseessä E2-funktio, ja jos on, KETJUTA-funktio yhdistää D2-, E2-ja F2-arvot (funktio korvaa virheen arvolla 0) ja näyttää tulokseksi saadun teksti merkki jonon. Huomautus kaava käyttää myös väli lyöntejä (""), jotka helpottavat arvojen erottamiseen.

Korjaa #VALUE! Virhe KETJUTA Excelissä 2003 ja vanhemmissa versioissa

Jos saat #VALUE! Virhe Office Excel 2003 tai vanhemmissa versioissa, sinun on poistettava siirtymäkaavan arviointi (TFE)-vaihto ehto Excel-kohdasta. Noudata ohjeita, jotka on kuvattu kohdassa #VALUE!-virhe solujen ketjuttaessa ongelman ratkaisemiseksi.

Onko sinulla jokin funktioihin liittyvä kysymys?

Lähetä kysymys Excel-yhteisön keskustelupalstalle

Auta meitä parantamaan Exceliä

Onko sinulla ehdotuksia, miten voimme parantaa seuraavaa Excel-versiota? Jos on, lue aiheet Excel User Voice -palvelussa.

Katso myös

#ARVO! -virheen korjaaminen

KETJUTA-funktio

YHDISTÄ-funktio

Yleiskuva kaavoista Excelissä

Viallisten kaavojen ratkaiseminen

Kaavoissa esiintyvien virheiden etsiminen

Kaikki Excelin funktiot (aakkosjärjestyksessä)

Kaikki Excelin funktiot (luokittain)

Huomautus:  Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kerrotko meille, oliko tiedoista hyötyä? Tästä pääset artikkelin englanninkieliseen versioon.

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×