#PUUTTUU!-virheen korjaaminen

#PUUTTUU!-virheen korjaaminen

#PUUTTUU-virhe tarkoittaa yleensä, ettei kaava löydä sitä, mitä sen on pyydetty etsiä.

Paras ratkaisu

#PUUTTUU-virheen yleisin syy liittyy PHAKU-, VHAKU-, HAKU- tai VASTINE-funktioihin, jos kaava ei löydä viitattua arvoa. Esimerkiksi hakuarvoasi ei ole lähdetiedoissa.

Hakuarvoa ei ole olemassa.  Solun E2 kaava on = PHAKU(D2,$D$6:$E$8,2,EPÄTOSI).  Banaani-arvoa ei löytynyt, joten kaava palauttaa #PUUTTUU-virheen.
Kohdetta ei löydy lähdetiedoista

Tässä tapauksessa hakutaulukossa ei ole lueteltu sanaa ”Banaani”, joten PHAKU palauttaa # PUUTTUU-virheen.

Ratkaisu: Varmista, että hakuarvo on lähdetiedoissa tai käytä kaavassa virheenkäsittelyä, kuten JOSVIRHE. Esimerkiksi = JOSVIRHE(KAAVA(),0), jossa lukee:

  • = JOS(kaava määrittää virheen ja näyttää sitten 0, muuten näyttää kaavan tuloksen)

Voit käyttää ””, jos et halua näyttää mitään, tai korvata oman tekstin: = JOSVIRHE(KAAVA(),”virheviesti tähän”)

Jos et ole varma, mitä voit tehdä tässä vaiheessa tai minkälaista apua tarvitset, voit etsiä samantyyppisiä kysymyksiä Excelin Community-keskustelupalstalta tai lähettää oman kysymyksen.

Linkki Excelin Community-keskustelupalstalle

Jos haluat jatkaa, voit seuraavan tarkistusluettelon vianmääritysvaiheiden avulla selvittää, mikä on ehkä mennyt väärin kaavoissa.

Hakuarvo ja lähdetiedot ovat erilaisia tietotyyppejä. Esimerkiksi: yrität saada PHAKU-funktion viittaamaan numeroon, mutta lähdetiedot on tallennettu tekstinä.

Virheelliset arvotyypit.  Esimerkki PHAKU-kaavasta, joka palauttaa #PUUTTUU-virheen, koska hakukohde on muotoiltu numeroksi ja hakutaulukko tekstiksi.
Erilaisten tietotyyppien aiheuttama #PUUTTUU-virhe

Ratkaisu: Varmista, että tietotyypit ovat samat. Voit tarkistaa solumuodot valitsemalla solun tai solualueen, napsauttamalla sitten hiiren kakkospainikkeella ja valitsemalla Muotoile solut > Numero (tai painamalla Ctrl + 1) ja muuttamalla numeromuotoa tarvittaessa.

Muotoile solut -valintaikkuna näyttää Numero-välilehden ja Teksti-asetuksen valittuna

Vihje: Jos haluat pakottaa muodon muutoksen koko sarakkeeseen, sovella ensin haluamaasi muotoa, ja voit sitten siirtyä kohtaan Tiedot > Tekstin jakaminen sarakkeisiin > Valmis.

Voit poistaa alussa tai lopussa olevat välilyönnit RAJAAMINEN-funktion avulla. Seuraavassa esimerkissä käytetään PHAKU-funktion RAJAAMINEN-funktiota alussa olevien välilyöntien poistamiseksi nimistä solussa A2:A7 ja osaston nimen palauttamiseksi.

PHAKU-funktion käyttö RAJAUS-funktion kanssa matriisikaavassa alussa ja lopussa olevien välilyöntien poistamiseksi.  Solun E3 kaava on {= PHAKU(D2,TRIM(A2:B7),2,EPÄTOSI)}, ja se on syötettävä näppäinyhdistelmällä CTRL + VAIHTO + ENTER.

{= PHAKU(D2, RAJAAMINEN(A2:B7),2,EPÄTOSI)}

Huomautus: Tämä on matriisikaava, ja se on syötettävä näppäinyhdistelmällä Ctrl + Vaihto + Enter. Excel lisää kaavan ympärille automaattisesti kaarisulkeet {} puolestasi. Jos yrität kirjoittaa ne itse, Excel näyttää kaavan tekstinä.

Oletusarvoisesti funktiot, jotka hakevat tietoja taulukoissa, on lajiteltava nousevaan järjestykseen. PHAKU- ja VHAKU-laskentataulukkofunktiot sisältävät kuitenkin alue_haku-argumentin, joka määrää funktion etsimään tarkan vastineen, vaikka taulukkoa ei ole lajiteltu. Jos haluat etsiä tarkan vastineen, määritä alue_haku-argumentin arvoksi EPÄTOSI. Huomaa, että arvo TOSI, joka määrää funktion etsimään epätarkan vastineen, voi palauttaa #PUUTTUU-virheen lisäksi myös virheellisiä tuloksia seuraavan esimerkin mukaisesti.

Esimerkki PHAKU-funktion käytöstä TOSI-alue_haku-argumentin kanssa, mikä voi aiheuttaa virheellisiä tuloksia.
PHAKU epäonnistuu, koska lajittelemattomassa taulukossa on käytetty epätarkkaa vastineargumenttia

Tässä esimerkissä ”Banaani”-sana palauttaa #PUUTTUU-virheen ja ”Päärynä”-sana palauttaa väärän hinnan. Tämä johtuu TOSI-argumentista, joka määrää PHAKU-funktion etsimään epätarkan vastineen sijaan tarkkaa vastinetta. ”Banaani”-sanalle ei ole läheistä vastinetta, ja ”Päärynä”-sana on aakkosjärjestyksessä ”Persikka”-sanan jälkeen. Tässä tapauksessa PHAKU-funktion käyttö EPÄTOSI-argumentin kanssa palauttaisi oikean hinnan ”Päärynä”-sanalle mutta ”Banaani”-sana antaisi edelleen #PUUTTUU-virheen, koska vastaavaa ”Banaani”-sanaa ei ole hakuluettelossa.

Jos käytät VASTINE-funktiota, yritä muuttaa vastine_tyyppi-argumentin arvoa taulukon lajittelujärjestyksen määrittämiseksi. Jotta löydät tarkan vastineen, määritä vastine_tyyppi-argumentin arvoksi 0 (nolla).

Varmista, että alueissa, joihin matriisikaava viittaa, on yhtä paljon rivejä ja sarakkeita kuin soluissa, joihin kirjoitit kaavan. Voit myös kirjoittaa matriisikaavan pienempään tai suurempaan solualueeseen, jotta se vastaa kaavan alueviittausta.

Tässä esimerkissä solu E2 on viitannut ristiriitaisiin alueisiin:

Matriisikaavaesimerkki ristiriitaisista alueviitteistä, jotka aiheuttavat #PUUTTUU-virheen.  Solun E2 kaava on {=SUMMA(JOS(A2:A11=D2,B2:B5))}, ja se on syötettävä näppäinyhdistelmällä CTRL + VAIHTO + ENTER.

{= SUMMA(JOS(A2: A11=D2,B2: B5))}

Jotta kaava lasketaan oikein, sitä on muutettava niin, että molemmat alueet vastaavat rivejä 2–11.

{=SUMMA(JOS(A2:A11=D2,B2:B11))}

Huomautus: Tämä on matriisikaava, ja se on syötettävä näppäinyhdistelmällä Ctrl + Vaihto + Enter. Excel lisää kaavan ympärille automaattisesti kaarisulkeet {} puolestasi. Jos yrität kirjoittaa ne itse, Excel näyttää kaavan tekstinä.

Esimerkki soluihin syötetystä #PUUTTUU-funktiosta, joka estää SUMMA-kaavaa laskemasta oikein.

Tässä tapauksessa ajanjaksolla toukokuu–joulukuu on #PUUTTUU-arvot, joten kokonaissummaa ei voida laskea ja palautetaan sen sijaan #PUUTTUU-virhe.

Tämän korjaamiseksi tarkista käyttämäsi funktion kaavan syntaksi ja kirjoita kaikki vaaditut argumentit kaavaan, joka palauttaa virheen. Tämä saattaa edellyttää siirtymistä Visual Basic Editoriin (VBE) funktion tarkistamiseksi. Voit käyttää VBE:tä Kehitystyökalut-välilehdestä tai näppäinyhdistelmällä ALT + F11.

Varmista, että kyseisen funktion sisältämä työkirja on avoinna ja että funktio toimii oikealla tavalla.

Varmista, että funktion argumentit ovat oikein ja oikeilla paikoilla.

Voit korjata ongelman painamalla Ctrl + Alt + F9, jolloin laskentataulukko lasketaan uudelleen.

Voit käyttää apuna funktion ohjattua toimintoa, jos et ole varma oikeista argumenteista. Valitse kyseisen kaavan sisältävä solu ja siirry sitten valintanauhan Kaava-välilehteen ja paina Lisää funktio.

Lisää funktio-painike.

Excel lataa ohjatun toiminnon automaattisesti puolestasi:

Esimerkki Kaavan ohjattu toiminto -valintaikkunasta.

Kun napsautat kutakin argumenttia, Excel antaa kustakin asianmukaiset tiedot.

#PUUTTUU-funktiosta voi olla hyötyä! #PUUTTUU-funktiota käytetään yleisesti, kun tietoja käytetään seuraavan kaavioesimerkin tavoin, kun #PUUTTUU-arvoja ei ole piirretty kaavioon. Seuraavassa on esimerkkejä siitä, miltä kaavio näyttää, kun arvona on 0 verrattuna #PUUTTUU-funktioon.

Esimerkki viivakaavion piirretyistä 0-arvoista.

Edellisessä esimerkissä näet, että arvot 0 on piirretty ja näytetään tasaisena viivana kaavion alareunassa. Sen jälkeen tuloksena näytetään kokonaissumma. Seuraavassa esimerkissä näet, että arvot 0 on korvattu #PUUTTUU-funktiolla.

Esimerkki viivakaavion piirtämättömistä #PUUTTUU-arvoista.

Lisätietoja tietyssä funktiossa esiintyvästä #PUUTTUU-virheestä saat seuraavista ohjeaiheista:

Sivun alkuun

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta, saada tukea yhteisön vastauksista tai ehdottaa uutta ominaisuutta tai parannusta Excel User Voice -sivustolla.

Katso myös

Tekstinä tallennettujen numeroiden muuntaminen numeroiksi

PHAKU-funktio

VHAKU-funktio

HAKU-funktio

VASTINE-funktio

Kaavojen yleiskatsaus Excelissä

Miten välttää katkenneita kaavoja

Virheiden tarkistus virheiden havaitsemiseksi kaavoissa

Excel for Windowsin pikanäppäimet

Excel for Macin pikanäppäimet

Kaikki Excel-funktiot (aakkosjärjestyksessä)

Kaikki Excel-funktiot (luokan mukaan)

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×