#JAKO/0!-virheen korjaaminen

Microsoft Excel näyttää #JAKO/0! -virheen, kun luku jaetaan nollalla (0). Näin tapahtuu, kun syötät yksinkertaisen kaavan (esimerkiksi =5/0) tai kun kaava viittaa arvon 0 sisältävään tai tyhjään soluun, kuten tässä kuvassa.

Esimerkkejä #JAKO/0!-virheitä aiheuttavista kaavoista.

Korjaa virhe jollakin seuraavista tavoista:

  • Varmista, että funktion tai kaavan jakajana ei ole nolla tai tyhjä solu.

  • Muuta kaavan soluviittaus toiseen soluun, joka ei sisällä nollaa (0) tai tyhjää arvoa.

  • Kirjoita arvo #PUUTTUU soluun, johon viitataan kaavassa jakajana. Näin kaavan tulokseksi tulee #PUUTTUU sen merkiksi, että jakajan arvo ei ole käytettävissä.

#JAKO/0!-virhettä ei voida monesti välttää, koska kaavat odottavat tietojen syöttämistä soluun. Jos et tällöin halua virhesanoman näkyvän lainkaan, voit virheenkäsittelymenetelmien avulla estää virheen näyttämisen, kun odotat tietojen syöttämistä.

Määritä nimittäjä nollan (0) tai tyhjän arvon osalta

Yksinkertaisin tapa estää #JAKO/0!-virhe on käyttää JOS-funktiota nimittäjän olemassaolon määrittämiseen. Jos se on 0 tai tyhjä arvo, näytä 0 tai tyhjä arvo kaavan tuloksena #JAKO/0!-virhearvon sijaan, muussa tapauksessa laske kaava.

Jos virheen tuottava kaava on esimerkiksi =A2/A3, palauta nolla (0) käyttämällä kaavaa =JOS(A3,0,A2/A3,0) tai tyhjä merkkijono käyttämällä kaavaa =JOS(A3,A2/A3,""). Voit myös näyttää seuraavanlaisen mukautetun viestin: = JOS(A3,A2/A3, "Tiedot tarvitaan"). Ensimmäisen esimerkin OSAMÄÄRÄ-funktiolla voit käyttää kaavaa =IF(A3,OSAMÄÄRÄ(A2,A3),0). Tämä kertoo Excelille JOS(A3 olemassa, palauta kaavan tulos, muussa tapauksessa ohita se).

Esimerkkejä #JAKO/0!-virheiden ratkaisemisesta.

Estä #JAKO/0!-virhe käyttämällä JOSVIRHE-funktiota

Voit myös estää tämän virheen laittamalla jakolaskutoimituksen JOSVIRHE-funktion sisään. Käyttämällä tässäkin jakolaskua A2/A3 voit käyttää kaavaa =JOSVIRHE(A2/A3,0). Tällöin Excel palauttaa arvoksi 0, jos kaavan tulos on virhe, muussa tapauksessa Excel palauttaa kaavan tuloksen.

Excel 2007:ää aiemmassa versiossa voit käyttää JOS(ONVIRHE())-menetelmää: =JOS(ONVIRHE(A2/A3),0,A2/A3) (katso lisätietoja ON-funktioista).

Huomautus: Sekä JOSVIRHE että JOS(ONVIRHE()) ovat kattavia virheenkäsittelymenetelmiä, eli ne estävät kaikki virheet, ei ainoastaan #JAKO/0!virhettä. Varmista, että kaava toimii oikein, ennen kuin käytät virheenkäsittelymenetelmiä. Muussa tapauksessa et välttämättä huomaa, että kaava ei toimi odotetusti.

Vihje: Jos Excelissä on käytössä virheentarkistus, voit napsauttaa virheen näyttävän solun vieressä olevaa Painikkeen kuva -painiketta. Valitse Näytä laskennan vaiheet, jos se on käytettävissä, ja valitse tietoihisi parhaiten sopiva ratkaisu.

Onko sinulla jokin funktioihin liittyvä kysymys?

Lähetä kysymys Excel-yhteisön keskustelupalstalle

Auta meitä parantamaan Exceliä

Onko sinulla ehdotuksia, miten voimme parantaa seuraavaa Excel-versiota? Jos on, lue aiheet Excel User Voice -palvelussa.

Katso myös

JOS-funktio

JOSVIRHE-funktio

ON-funktiot

Yleiskuva kaavoista Excelissä

Viallisten kaavojen ratkaiseminen

Kaavoissa esiintyvien virheiden etsiminen

Excelin funktiot (aakkosjärjestyksessä)

Excelin funktiot (luokittain)

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×