Diagrammid

Diagrammi andmete värskendamine

Olemasoleva diagrammi andmete värskendamine

Võib juhtuda, et peate pärast diagrammi loomist töölehel selle lähteandmeid muutma. Nende muudatuste kaasamiseks pakub Microsoft Excel mitut diagrammi värskendamise võimalust. Saate diagrammi kohe muudetud väärtuste kajastamiseks värskendada või selle aluseks olevaid lähteandmeid dünaamiliselt muuta. Samuti saate diagrammi värskendamiseks sinna andmeid lisada, neid muuta või sealt andmeid eemaldada.

Diagrammi aluseks olevate andmete muutmine

Diagrammi aluseks olevate andmete värskendamisel muutuvad ka diagrammi andmed ja ilme. Nende muudatuste ulatus sõltub sellest, kuidas on määratletud diagrammi andmeallikas. Exceli töölehel saate muudetud väärtused diagrammis automaatselt värskendada või kasutada mõnda võimalust diagrammi aluseks oleva andmeallika dünaamiliseks muutmiseks.

Töölehel muudetud väärtuste automaatne värskendamine olemasolevas diagrammis

Diagrammi väärtused on seotud nende tööleheandmetega, mille alusel diagramm on loodud. Kui arvutussuvandites on valitud väärtus „Automaatne” (valige Excelis Fail > Suvandid > Valemid > Arvutussuvandid), kuvatakse tööleheandmetes tehtud muudatused automaatselt diagrammil.

Märkus.: Klõpsake rakenduses Excel 2007 Microsoft Office’i nuppu Office’i nupu pilt , seejärel valige Exceli suvandid > Valemid > Arvutus > Arvutussuvandid.

  1. Avage diagrammil esitatud andmeid sisaldav tööleht.

  2. Tippige muudetavat väärtust sisaldavasse lahtrisse uus väärtus.

  3. Vajutage sisestusklahvi (ENTER).

Olemasoleva diagrammi aluseks oleva andmeallika dünaamiline muutmine

Kui soovite, et diagrammi andmeallikas dünaamiliselt kasvaks, saate selleks kasutada kahte võimalust. Saate diagrammi luua Exceli tabelis olevate andmete või määratletud nime põhjal.

Diagrammi loomine Exceli tabeli põhjal

Kui loote diagrammi lahtrivahemiku põhjal, kajastuvad algses vahemikus olevate andmete muudatused ka diagrammil. Kuid selleks et vahemikku ridasid ja veerge lisades laiendada ning diagrammi andmeid ja ilmet muuta, peate algest andmeallikat diagrammis käsitsi muutma, muutes diagrammi aluseks olevat lahtrivahemikku.

Kui soovite, et diagrammi andmed ja ilme muutuks andmeallika laiendamisel, saate diagrammi aluseks oleva andmeallikana kasutada Exceli tabelit.

  1. Klõpsake diagrammi, mille lähteandmete lahtrivahemikku soovite muuta.

    Kuvatakse menüü Diagrammiriistad koos menüüdega Kujundus, Paigutus ja Vorming.

  2. Klõpsake menüü Kujundus jaotises Andmed nuppu Vali andmed.

    Exceli lindi pilt

  3. Jätke meelde dialoogiboksis Andmeallika valimine kuvatud andmevahemiku asukoht ja klõpsake nuppu OK.

  4. Avage selle andmevahemiku asukoht ja klõpsake andmevahemikus mõnda lahtrit.

  5. Klõpsake menüü Lisa jaotises Tabelid nuppu Tabel.

    Exceli lindi pilt

    Kiirklahv: Ctrl + L või Ctrl + T

Diagrammi loomine määratletud nime põhjal

Teine võimalus diagrammi andmete ja ilme dünaamiliseks muutmiseks andmeallika laiendamisel on kasutada määratletud nime ja funktsiooni OFFSET. Seda võimalust on hea kasutada juhul, kui vajate lahendust, mis toimib ka Exceli varasemates versioonides.

Lisateavet leiate teemast Määratletud nimede kasutamine Exceli diagrammivahemiku automaatseks värskendamiseks (inglise keeles).

Olemasolevasse diagrammi andmete lisamine

Olemasolevasse diagrammi lähteandmete lisamiseks on mitu võimalust. Saate kiiresti lisada veel ühe andmesarja, lohistada vahemike suurusepidemeid, et kaasata samale töölehele manustatud diagrammi andmed, või kopeerida täiendavad tööleheandmed manusdiagrammi või eraldi diagrammilehele.

Andmesarja lisamine diagrammile

  1. Klõpsake diagrammi, millele soovite veel ühe andmesarja lisada.

    Kuvatakse menüü Diagrammiriistad koos menüüdega Kujundus, Paigutus ja Vorming.

  2. Klõpsake menüü Kujundus jaotises Andmed nuppu Vali andmed.

    Exceli lindi pilt

  3. Klõpsake dialoogiboksi Andmeallika valimine jaotises Legendikirjed (sari) olevat nuppu Lisa.

  4. Dialoogiboksis Sarja redigeerimine tehke järgmist.

    • Tippige väljale Sarja nimi sarja jaoks kasutatava nimi või valige nimi töölehelt.

    • Tippige väljale Sarja väärtused lisatava andmesarja andmevahemiku viide või valige see vahemik töölehelt.

      Võite klõpsata välja Sarja nimi või Sarja väärtused paremas servas asuvat nuppu Ahenda dialoogiboks Ahendamisnupp ja seejärel valida tabeli jaoks kasutatava vahemiku töölehelt. Lõpetamisel klõpsake kogu dialoogiboksi kuvamiseks uuesti nuppu Ahenda dialoogiboks.

      Kui kasutate viite tippimisel kursori paigutamiseks nooleklahve, saate klahvi F2 vajutades veenduda, et olete redigeerimisrežiimis. Klahvi F2 uuesti vajutamine aktiveerib taas punktirežiimi. Parajasti valitud režiimi saate kontrollida olekuribalt.

Vahemike suurusepidemete lohistamine andmete lisamiseks manusdiagrammi

Kui lõite manusdiagrammi külgnevate töölehelahtrite alusel, saate andmete lisamiseks lohistada lähteandmevahemike suurusepidemeid. Diagramm peab asuma samal töölehel kui diagrammi loomiseks kasutatud andmed.

  1. Töölehel tippige diagrammile lisatavad andmed ja sildid olemasolevate tööleheandmetega külgnevatesse lahtritesse.

  2. Töölehel olevate lähteandmete ümber suurusepidemete kuvamiseks klõpsake diagrammi.

  3. Tehke töölehel ühte järgmistest.

    • Diagrammile uute kategooriate ja andmesarjade lisamiseks lohistage sinist suurusepidet, et kaasata ristkülikusse uued andmed ja sildid.

    • Ainult uute andmesarjade lisamiseks lohistage rohelist suurusepidet, et kaasata ristkülikusse uued andmed ja sildid.

    • Uute kategooriate ja andmepunktide lisamiseks lohistage lillat suurusepidet, et kaasata ristkülikusse uued kategooriad ja sildid.

Tööleheandmete kopeerimine diagrammile

Kui lõite manusdiagrammi mittekülgnevate valikute alusel või kui diagramm asub eraldi diagrammilehel, saate täiendavad tööleheandmed diagrammile kopeerida.

  1. Valige töölehel lahtrid, mis sisaldavad diagrammile lisatavaid andmeid.

    Kui soovite diagrammil kuvada uute andmete veeru- või reasildi, kaasake valikusse ka silti sisaldav lahter.

  2. Klõpsake menüü Avaleht jaotises Lõikelaud nuppu Kopeeri Nupu pilt .

    Jaotis Lõikelaud menüüs Avaleht

    Kiirklahv: Ctrl + C

  3. Klõpsake diagrammilehte või manusdiagrammi, kuhu soovite kopeeritud andmed kleepida.

  4. Tehke ühte järgmistest.

    • Andmete diagrammile kleepimiseks klõpsake menüü Avaleht jaotise Lõikelaud nuppu Kleebi Nupu pilt .

      Kiirklahv: Ctrl + V

    • Selleks et määrata, kuidas kopeeritud andmed tuleks diagrammil esitada, klõpsake menüü Avaleht jaotises Lõikelaud nupu Kleebi kõrval olevat noolt ja siis klõpsake käsku Kleebi teisiti ning valige soovitud suvandid.

Diagrammi andmete muutmine

Olemasoleva diagrammi muutmiseks saate muuta diagrammi aluseks olevat lahtrivahemikku või redigeerida diagrammil kuvatavaid andmesarju. Saate muuta ka horisontaalteljel (kategooriateljel) olevaid teljesilte.

Diagrammi aluseks oleva lahtrivahemiku muutmine

  1. Klõpsake diagrammi, mille lähteandmete lahtrivahemikku soovite muuta.

    Kuvatakse menüü Diagrammiriistad koos menüüdega Kujundus, Paigutus ja Vorming.

  2. Klõpsake menüü Kujundus jaotises Andmed nuppu Vali andmed.

    Exceli lindi pilt

  3. Veenduge, et dialoogiboksis Andmeallika valimine oleks valitud kogu väljal Diagrammi andmevahemik kuvatav viide.

    Võite klõpsata välja Diagrammi andmevahemik paremas servas asuvat nuppu Ahenda dialoogiboks Ahendamisnupp ja seejärel valida tabeli jaoks kasutatava vahemiku töölehelt. Lõpetamisel klõpsake kogu dialoogiboksi kuvamiseks uuesti nuppu Ahenda dialoogiboks.

  4. Valige töölehel lahtrid, mis sisaldavad diagrammil kuvatavaid andmeid.

    Kui soovite diagrammil kuvada veeru- ja reasildid, kaasake valikusse ka neid sisaldavad lahtrid.

    Kui kasutate viite tippimisel kursori paigutamiseks nooleklahve, võite vajutada klahvi F2, tagamaks, et olete redigeerimisrežiimis. Klahvi F2 uuesti vajutamine aktiveerib taas punktirežiimi. Parajasti valitud režiimi saate kontrollida olekuribalt.

Diagrammis kuvatava andmesarja ümbernimetamine või redigeerimine

Olemasoleva andmesarja nime ja väärtusi saate muuta, ilma et see mõjutaks töölehel olevaid andmeid.

  1. Klõpsake diagrammi, mis sisaldab muudetavat andmesarja.

    Kuvatakse menüü Diagrammiriistad koos menüüdega Kujundus, Paigutus ja Vorming.

  2. Klõpsake menüü Kujundus jaotises Andmed nuppu Vali andmed.

    Exceli lindi pilt

  3. Valige dialoogiboksi Andmeallika valimine jaotisest Legendikirjed (sari) muudetav andmesari ja siis klõpsake nuppu Redigeeri.

  4. Andmesarja ümbernimetamiseks tippige väljale Sarja nimi sarja jaoks kasutatava nimi või valige nimi töölehelt. Teie tipitud nimi kuvatakse diagrammi legendil, kuid seda ei lisata töölehele.

  5. Andmesarja andmevahemiku muutmiseks tippige väljale Sarja väärtused lisatava andmesarja andmevahemiku viide, valige see vahemik töölehelt või sisestage väärtused väljadele. Teie tipitud väärtusi ei lisata töölehele.

    XY-diagrammi (punktdiagrammi) korral kuvatakse väljad X-sarja väärtused ja Y-sarja väärtused, et saaksite muuta nende väärtuste andmevahemikku. Mulldiagrammi korral kuvatakse väljad X-sarja väärtused, Y-sarja väärtused ja Sarja mullisuurus, et saaksite muuta nende väärtuste andmevahemikku.

Võite sarja iga välja puhul klõpsata välja Sarja nimi või Sarja väärtused paremas servas asuvat nuppu Ahenda dialoogiboks Ahendamisnupp ja seejärel valida tabeli jaoks kasutatava vahemiku töölehelt. Lõpetamisel klõpsake kogu dialoogiboksi kuvamiseks uuesti nuppu Ahenda dialoogiboks.

Kui kasutate viite tippimisel kursori paigutamiseks nooleklahve, saate klahvi F2 vajutades veenduda, et olete redigeerimisrežiimis. Klahvi F2 uuesti vajutamine aktiveerib taas punktirežiimi. Parajasti valitud režiimi saate kontrollida olekuribalt.

Andmesarjade järjestuse muutmine

  1. Klõpsake diagrammi, mis sisaldab muudetavat andmesarja.

    Kuvatakse menüü Diagrammiriistad koos menüüdega Kujundus, Paigutus ja Vorming.

  2. Klõpsake menüü Kujundus jaotises Andmed nuppu Vali andmed.

    Exceli lindi pilt

  3. Valige dialoogiboksi Andmeallika valimine jaotisest Legendikirjed (sari) andmesari, mille soovite järjestuses teise kohta nihutada.

  4. Andmesarja teisaldamiseks klõpsake noolenuppu Nihuta üles või Nihuta alla.

  5. Korrake 3. ja 4. toimingut kõigi teisaldatavate andmesarjade puhul.

Horisontaaltelje (kategooriatelje) siltide muutmine

Horisontaaltelje (kategooriatelje) siltide muutmisel muudetakse kõiki horisontaaltelje silte. Horisontaaltelje silte ei saa ükshaaval muuta.

  1. Klõpsake diagrammi, mis sisaldab muudetavaid horisontaaltelje silte.

    Kuvatakse menüü Diagrammiriistad koos menüüdega Kujundus, Paigutus ja Vorming.

  2. Klõpsake menüü Kujundus jaotises Andmed nuppu Vali andmed.

    Exceli lindi pilt

  3. Klõpsake jaotises Horisontaaltelje (X-telje) sildid nuppu Redigeeri.

  4. Tippige väljale Teljesiltide vahemik horisontaaltelje siltidena kasutatava andmesarja andmevahemiku viide või valige see vahemik töölehelt.

    Võite klõpsata välja Sarja nimi või Sarja väärtused paremas servas asuvat nuppu Ahenda dialoogiboks Ahendamisnupp ja seejärel valida tabeli jaoks kasutatava vahemiku töölehelt. Lõpetamisel klõpsake kogu dialoogiboksi kuvamiseks uuesti nuppu Ahenda dialoogiboks.

    Kui kasutate viite tippimisel kursori paigutamiseks nooleklahve, võite vajutada klahvi F2, tagamaks, et olete redigeerimisrežiimis. Klahvi F2 uuesti vajutamine aktiveerib taas punktirežiimi. Parajasti valitud režiimi saate kontrollida olekuribalt.

Andmete eemaldamine diagrammist

Kui arvutussuvandites on valitud väärtus „Automaatne”, eemaldatakse töölehelt kustutatud andmed automaatselt diagrammist. Diagrammist saate andmeid eemaldada ka nii, et see ei mõjuta töölehel olevaid lähteandmeid.

Lähteandmete kustutamine töölehelt

  • Valige töölehel lahter või lahtrivahemik, mis sisaldab diagrammilt eemaldatavaid andmeid, ja seejärel vajutage kustutusklahvi (Delete).

    • Kui eemaldate andmed üksnes valitud lahtritest, esitatakse diagrammil tühjad lahtrid. Tühjade lahtrite esitamise viisi muutmiseks paremklõpsake diagrammi ja tehke valik Peidetud ja tühjad lahtrid.

    • Veeru kustutamisel eemaldatakse diagrammilt terve andmesari. Rea kustutamisel võidakse kuvada tõrketeade. Kui klõpsate nuppu OK, võidakse diagrammil kuvada üks või mitu teie kustutatud andmesarja andmepunkti. Saate neid andmepunkte klõpsata ja seejärel kustutusklahvi (Delete) vajutada.

Andmesarja eemaldamine diagrammilt

  1. Klõpsake diagrammi või eemaldatavat andmesarja või tehke järgmist, et valida diagramm või andmesari diagrammielementide loendist.

    1. Klõpsake diagrammi.

      Kuvatakse menüü Diagrammiriistad koos menüüdega Kujundus, Paigutus ja Vorming.

    2. Klõpsake menüü Vorming jaotises Praegune valik ripploendi Diagrammiala noolenuppu. Seejärel klõpsake diagrammiüksust, mida soovite kasutada.

      Jaotis Praegune valik menüüs Paigutus (Diagrammiriistad)

  2. Tehke ühte järgmistest.

    1. Kui valisite diagrammi, tehke järgmist.

      1. Klõpsake menüü Kujundus jaotises Andmed nuppu Vali andmed.

        Exceli lindi pilt

      2. Valige dialoogiboksi Andmeallika valimine jaotisest Legendikirjed (sari) eemaldatav andmesari ja siis klõpsake nuppu Eemalda.

    2. Kui valisite diagrammil oleva andmesarja, vajutage kustutusklahvi (Delete).

Word

Pärast diagrammi loomist saate andmeid Exceli töölehel redigeerida. Muudatused kajastuvad Wordis diagrammis.

  1. Klõpsake menüü View (Vaade) nuppu Print Layout (Küljendivaade).

  2. Klõpsake diagrammi.

  3. Klõpsake menüü Chart Design (Diagrammikujundus) käsku Edit Data in Excel (Redigeeri andmeid Excelis).

    Avaneb Excel ja kuvatakse diagrammi andmetabel.

    Andmetabel Office’i diagrammi jaoks

  4. Diagrammi lisatavate ridade ja veergude arvu muutmiseks osutage valitud andmete vasakule allnurgale ja lohistage seejärel lisaandmete valimiseks. Järgmises näites on täiendavate kategooriate ja andmesarjade lisamiseks tabelit laiendatud.

    Office’i diagrammi jaoks suurema andmehulga valimine

  5. Andmete lisamiseks või lahtriandmete redigeerimiseks klõpsake lahtrit ja tehke seejärel soovitud muudatus.

  6. Muudatuste tulemuste kuvamiseks avage Word.

Pärast diagrammi loomist soovite ehk muuta tabeliridade ja -veergude diagrammis esitamise viisi.  Näiteks diagrammi esimeses versioonis võidakse tabeli andmeread esitada diagrammi vertikaalteljel (väärtusteljel) ja andmeveerud horisontaalteljel (kategooriateljel). Järgmises näites on diagrammis rõhutatud müük vahendi kaupa.

Diagramm, kus on toodud müük kategooria kaupa

Kui soovite, et diagrammis oleks rõhutatut müük kuu kaupa, saate diagrammi esitusviisi ümber pöörata.

Diagramm, kus on toodud müük kuu kaupa

  1. Klõpsake menüü View (Vaade) nuppu Print Layout (Küljendivaade).

  2. Klõpsake diagrammi.

  3. Klõpsake menüü Chart Design (Diagrammikujundus) käsku Switch Row/Column (Vaheta rida/veerg).

    Käsk Switch Row/Column (Vaheta rida/veerg) on saadaval ainult siis, kui diagrammi Exceli andmetabel on avatud, ja ainult teatud diagrammitüüpide korral. Kui käsk Switch Row/Column (Vaheta rida/veerg), tehke järgmist.

    1. Klõpsake diagrammi.

    2. Klõpsake menüü Chart Design (Diagrammikujundus) käsku Edit Data in Excel (Redigeeri andmeid Excelis).

Andmesarja järjestuse muutmiseks peab diagrammis olema mitu andmesarja.

  1. Klõpsake menüü View (Vaade) nuppu Print Layout (Küljendivaade).

  2. Valige mõni diagrammi andmesari. Klõpsake näiteks tulpdiagrammis veergu ja selle andmesarja kõik veerud valitakse.

  3. Klõpsake menüü Chart Design (Diagrammikujundus) käsku Select Data (Vali andmed).

  4. Saate dialoogiboksi Select Data Source (Andmeallika valimine) jaotises Legend entries (Series) (Legendikirjed (sari)) üles- ja allanoole abil sarja loendis üles ja alla nihutada.

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

    Märkus.: Enamiku diagrammitüüpide korral mõjutab andmesarja järjestuse muutmine nii legendi kui ka diagrammi ennast.

  5. Klõpsake nuppu OK.

  1. Klõpsake menüü View (Vaade) nuppu Print Layout (Küljendivaade).

  2. Valige mõni diagrammi andmesari. Klõpsake näiteks tulpdiagrammis veergu ja selle andmesarja kõik veerud valitakse.

  3. Klõpsake menüü Chart Design (Diagrammikujundus) käsku Select Data (Vali andmed).

  4. Tehke dialoogiboksis Select Data Source (Andmeallika valimine) ühte järgmistest.

    Toiming

    Toiming

    Andmesarja eemaldamine

    Valige jaotisest Legend entries (Series) (Legendikirjed (sari)) eemaldatav andmesari ja siis klõpsake käsku Remove (Eemalda) (-).

    Andmesarja lisamine

    Klõpsake jaotises Legend entries (Series) (Legendikirjed (sari)) käsku Add (Lisa) (+) ja seejärel valige Exceli töölehel kõik andmed, mille soovite diagrammi lisada.

  5. Klõpsake nuppu OK.

  1. Klõpsake menüü View (Vaade) nuppu Print Layout (Küljendivaade).

  2. Valige mõni diagrammi andmesari. Klõpsake näiteks tulpdiagrammis veergu ja selle andmesarja kõik veerud valitakse.

  3. Klõpsake menüüd Format (Vorming).

  4. Klõpsake menüü Chart Element Styles (Diagrammielemendid > Laadid) noolenuppu Fill (Täide) Nupp Täitevärv ja seejärel soovitud värvi.

Exceli töölehe andmepunktide väärtuste kuvamiseks diagrammis saate lisada silte.

  1. Klõpsake menüü View (Vaade) nuppu Print Layout (Küljendivaade).

  2. Klõpsake diagrammi ja seejärel menüüd Chart Design (Diagrammikujundus).

  3. Klõpsake käsku Add Chart Element (Lisa diagrammielement) ja valige seejärel Data Labels (Andmesildid).

  4. Valige asukoht, kus soovite andmesilti kuvada (valige näiteks Outside End (Välisäärel)).

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

  1. Klõpsake menüü View (Vaade) nuppu Print Layout (Küljendivaade).

  2. Klõpsake diagrammi ja seejärel menüüd Chart Design (Diagrammikujundus).

  3. Klõpsake käsku Add Chart Element (Lisa diagrammielement) ja valige seejärel Data Table (Andmetabel).

  4. Valige soovitud suvandid.

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

Kui loote diagrammi kuupäevadest koosnevatest andmetest, mida esitatakse diagrammi horisontaalteljel, muudab Office horisontaaltelje automaatselt kuupäevateljeks (ajaskaalateljeks). Saate horisontaaltelje kuupäevateljeks muuta ka käsitsi. Kuupäevateljel kuvatakse kuupäevad ajalises järjestuses kindlate vahemikega või põhiühikutes (nt päevade, kuude või aastate arv), isegi kui kuupäevad pole Exceli töölehel järjestikku või samades põhiühikutes.

Vaikimisi määratleb Excel kuupäevatelje baasühikud mis tahes kahe kuupäeva väikseima vahe alusel. Kui teil on näiteks tegemist aktsiahindade andmetega, kus väikseim kuupäevade vahe on seitse päeva, määrab Office baasühikuks päevad. Soovi korral saate baasühikuks aga määrata ka kuud või aastad, kui soovite näha teatud aktsia liikumist pikema aja jooksul.

  1. Klõpsake menüü View (Vaade) nuppu Print Layout (Küljendivaade).

  2. Klõpsake diagrammi ja seejärel menüüd Chart Design (Diagrammikujundus).

  3. Klõpsake käsku Add Chart Element (Lisa diagrammielement), valige Axes (Teljed) ja seejärel More Axis Options (Veel teljesuvandeid). Kuvatakse paan Format Axis (Telgede vorming).

  4. Veenduge, et muudetava telje teljesildid kuvatakse.

  5. Valige Axis Type (Telje tüüp) > Date axis (Kuupäevatelg).

  6. Valige ripploendiboksi Base (Alus) jaotises Units (Ühikud) kas Days (Päevad), Months (Kuud) või Years (Aastad).

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

Märkus.: Kui teete selle toimingu ja diagrammis kuupäevi ajaskaalateljel ei kuvata, siis veenduge, et teljesildid oleksid Exceli tabelis kuupäevavormingus (nt 05/01/08 või May-08 (mai-08)). Lisateavet lahtrite vormindamise kohta kuupäevadena leiate teemast Kellaaegade, kuupäevade, valuuta, murdude või protsentide kuvamine (inglise keeles).

PowerPoint

Pärast diagrammi loomist saate andmeid Exceli töölehel redigeerida. Muudatused kajastuvad PowerPointis diagrammis.

  1. Klõpsake diagrammi.

  2. Klõpsake menüü Chart Design (Diagrammikujundus) käsku Edit Data in Excel (Redigeeri andmeid Excelis).

    Avaneb Excel ja kuvatakse diagrammi andmetabel.

    Andmetabel Office’i diagrammi jaoks

  3. Diagrammi lisatavate ridade ja veergude arvu muutmiseks osutage valitud andmete vasakule allnurgale ja lohistage seejärel lisaandmete valimiseks. Järgmises näites on täiendavate kategooriate ja andmesarjade lisamiseks tabelit laiendatud.

    Office’i diagrammi jaoks suurema andmehulga valimine

  4. Andmete lisamiseks või lahtriandmete redigeerimiseks klõpsake lahtrit ja tehke seejärel soovitud muudatus.

  5. Muudatuste kuvamiseks avage PowerPoint.

Pärast diagrammi loomist soovite ehk muuta tabeliridade ja -veergude diagrammis esitamise viisi.  Näiteks diagrammi esimeses versioonis võidakse tabeli andmeread esitada diagrammi vertikaalteljel (väärtusteljel) ja andmeveerud horisontaalteljel (kategooriateljel). Järgmises näites on diagrammis rõhutatud müük vahendi kaupa.

Diagramm, kus on toodud müük kategooria kaupa

Kui soovite, et diagrammis oleks rõhutatut müük kuu kaupa, saate diagrammi esitusviisi ümber pöörata.

Diagramm, kus on toodud müük kuu kaupa

  1. Klõpsake diagrammi.

  2. Valige menüü Chart Design (Diagrammikujundus) käsk Switch Row/Column (Vaheta rida/veerg).

    Käsk Switch Row/Column (Vaheta rida/veerg) on saadaval ainult siis, kui diagrammi Exceli andmetabel on avatud, ja ainult teatud diagrammitüüpide korral. Kui käsk Switch Row/Column (Vaheta rida/veerg), tehke järgmist.

    1. Klõpsake diagrammi.

    2. Klõpsake menüü Chart Design (Diagrammikujundus) käsku Edit Data in Excel (Redigeeri andmeid Excelis).

Andmesarja järjestuse muutmiseks peab diagrammis olema mitu andmesarja.

  1. Valige mõni diagrammi andmesari. Klõpsake näiteks tulpdiagrammis veergu ja selle andmesarja kõik veerud valitakse.

  2. Klõpsake menüü Chart Design (Diagrammikujundus) käsku Select Data (Vali andmed).

  3. Saate dialoogiboksi Andmeallika valimine jaotises Legendikirjed (sari) üles- ja allanoole abil sarja loendis üles ja alla nihutada.

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

    Märkus.: Enamiku diagrammitüüpide korral mõjutab andmesarja järjestuse muutmine nii legendi kui ka diagrammi ennast.

  4. Klõpsake nuppu OK.

  1. Valige mõni diagrammi andmesari. Klõpsake näiteks tulpdiagrammis veergu ja selle andmesarja kõik veerud valitakse.

  2. Klõpsake menüüd Chart Design (Diagrammikujundus) ja seejärel käsku Select Data (Vali andmed).

  3. Tehke dialoogiboksis Select Data Source (Andmeallika valimine) ühte järgmistest.

    Toiming

    Toiming

    Andmesarja eemaldamine

    Valige jaotisest Legend entries (Series) (Legendikirjed (sari)) eemaldatav andmesari ja siis klõpsake käsku Remove (Eemalda) (-).

    Andmesarja lisamine

    Klõpsake jaotises Legend entries (Series) (Legendikirjed (sari)) käsku Add (Lisa) (+) ja seejärel valige Exceli töölehel kõik andmed, mille soovite diagrammi lisada.

  4. Klõpsake nuppu OK.

  1. Valige mõni diagrammi andmesari. Klõpsake näiteks tulpdiagrammis veergu ja selle andmesarja kõik veerud valitakse.

  2. Klõpsake menüüd Format (Vorming).

  3. Klõpsake menüü Chart Element Styles (Diagrammielemendid > Laadid) noolenuppu Fill (Täide) Nupp Täitevärv ja seejärel soovitud värvi.

Exceli töölehe andmepunktide väärtuste kuvamiseks diagrammis saate lisada silte.

  1. Klõpsake diagrammi ja seejärel menüüd Chart Design (Diagrammikujundus).

  2. Klõpsake käsku Add Chart Element (Lisa diagrammielement) ja valige seejärel Data Labels (Andmesildid).

  3. Valige asukoht, kus soovite andmesilti kuvada (valige näiteks Outside End (Välisäärel)).

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

  1. Klõpsake diagrammi ja seejärel menüüd Chart Design (Diagrammikujundus).

  2. Klõpsake käsku Add Chart Element (Lisa diagrammielement) ja valige seejärel Data Table (Andmetabel).

  3. Valige soovitud suvandid.

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

Kui loote diagrammi kuupäevadest koosnevatest andmetest, mida esitatakse diagrammi horisontaalteljel, muudab Office horisontaaltelje automaatselt kuupäevateljeks (ajaskaalateljeks). Saate horisontaaltelje kuupäevateljeks muuta ka käsitsi. Kuupäevateljel kuvatakse kuupäevad ajalises järjestuses kindlate vahemikega või põhiühikutes (nt päevade, kuude või aastate arv), isegi kui kuupäevad pole Exceli töölehel järjestikku või samades põhiühikutes.

Vaikimisi määratleb Excel kuupäevatelje baasühikud mis tahes kahe kuupäeva väikseima vahe alusel. Kui teil on näiteks tegemist aktsiahindade andmetega, kus väikseim kuupäevade vahe on seitse päeva, määrab Office baasühikuks päevad. Soovi korral saate baasühikuks aga määrata ka kuud või aastad, kui soovite näha teatud aktsia liikumist pikema aja jooksul.

  1. Klõpsake diagrammi ja seejärel menüüd Chart Design (Diagrammikujundus).

  2. Klõpsake käsku Add Chart Element (Lisa diagrammielement), valige Axes (Teljed) ja seejärel More Axis Options (Veel teljesuvandeid). Kuvatakse paan Format Axis (Telgede vorming).

  3. Veenduge, et muudetava telje teljesildid kuvatakse.

  4. Valige Axis Type (Telje tüüp) > Date axis (Kuupäevatelg).

  5. Valige ripploendiboksi Base (Alus) jaotises Units (Ühikud) kas Days (Päevad), Months (Kuud) või Years (Aastad).

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

Märkus.: Kui teete selle toimingu ja diagrammis kuupäevi ajaskaalateljel ei kuvata, siis veenduge, et teljesildid oleksid Exceli tabelis kuupäevavormingus (nt 05/01/08 või May-08 (mai-08)). Lisateavet lahtrite vormindamise kohta kuupäevadena leiate teemast Kellaaegade, kuupäevade, valuuta, murdude või protsentide kuvamine (inglise keeles).

Excel

Pärast diagrammi loomist saate andmeid Exceli töölehel redigeerida. Muudatused kajastuvad diagrammis.

  1. Klõpsake diagrammi.

    Excelis tõstetakse diagrammis kasutatav andmetabel esile. Hall täide näitab kategooriatelje jaoks kasutatavat rida või veergu. Punane täide näitab andmesarja silte sisaldavat rida või veergu. Sinine täide näitab diagrammis esitatavaid andmepunkte.

    Exceli andmeväljad

    Viiktekst 1 Andmesarja sildid

    Viiktekst 2 Kategooriatelje väärtused

    Viiktekst 3 Diagrammis esitatavad andmepunktid

  2. Diagrammi lisatavate ridade ja veergude arvu muutmiseks osutage valitud andmete vasakule allnurgale ja lohistage seejärel lisaandmete valimiseks. Järgmises näites on täiendavate kategooriate ja andmesarjade lisamiseks tabelit laiendatud.

    Exceli diagrammi suurema andmehulga valimine

    Näpunäide.: Andmete diagrammis kuvamise vältimiseks saate tabeliridu ja -veerge peita.

  3. Andmete lisamiseks või lahtriandmete redigeerimiseks klõpsake lahtrit ja tehke seejärel soovitud muudatus.

Pärast diagrammi loomist soovite ehk muuta tabeliridade ja -veergude diagrammis esitamise viisi.  Näiteks diagrammi esimeses versioonis võidakse tabeli andmeread esitada diagrammi vertikaalteljel (väärtusteljel) ja andmeveerud horisontaalteljel (kategooriateljel). Järgmises näites on diagrammis rõhutatud müük vahendi kaupa.

Diagramm, kus on toodud müük kategooria kaupa

Kui soovite, et diagrammis oleks rõhutatut müük kuu kaupa, saate diagrammi esitusviisi ümber pöörata.

Diagramm, kus on toodud müük kuu kaupa

  1. Klõpsake diagrammi.

  2. Klõpsake menüü Chart Design (Diagrammikujundus) käsku Switch Row/Column (Vaheta rida/veerg).

Andmesarja järjestuse muutmiseks peab diagrammis olema mitu andmesarja.

  1. Valige mõni diagrammi andmesari. Klõpsake näiteks tulpdiagrammis veergu ja selle andmesarja kõik veerud valitakse.

  2. Klõpsake menüü Chart Design (Diagrammikujundus) käsku Select Data (Vali andmed).

  3. Saate dialoogiboksi Select Data Source (Andmeallika valimine) jaotises Legend entries (Series) (Legendikirjed (sari)) üles- ja allanoole abil sarja loendis üles ja alla nihutada.

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

    Märkus.: Enamiku diagrammitüüpide korral mõjutab andmesarja järjestuse muutmine nii legendi kui ka diagrammi ennast.

  4. Klõpsake nuppu OK.

  1. Valige mõni diagrammi andmesari. Klõpsake näiteks tulpdiagrammis veergu ja selle andmesarja kõik veerud valitakse.

  2. Klõpsake menüüd Chart Design (Diagrammikujundus) ja seejärel käsku Select Data (Vali andmed).

  3. Tehke dialoogiboksis Select Data Source (Andmeallika valimine) ühte järgmistest.

    Toiming

    Toiming

    Andmesarja eemaldamine

    Valige jaotisest Legend entries (Series) (Legendikirjed (sari)) eemaldatav andmesari ja siis klõpsake käsku Remove (Eemalda) (-).

    Andmesarja lisamine

    Klõpsake jaotises Legend entries (Series) (Legendikirjed (sari)) käsku Add (Lisa) (+) ja seejärel valige Exceli töölehel kõik andmed, mille soovite diagrammi lisada.

  4. Klõpsake nuppu OK.

  1. Valige mõni diagrammi andmesari. Klõpsake näiteks tulpdiagrammis veergu ja selle andmesarja kõik veerud valitakse.

  2. Klõpsake menüüd Format (Vorming).

  3. Klõpsake menüü Chart Element Styles (Diagrammielemendid > Laadid) noolenuppu Fill (Täide) Nupp Täitevärv ja seejärel soovitud värvi.

    Näpunäide.: Värvi varieerimiseks andmepunkti järgi ainult ühe andmesarjaga diagrammis klõpsake sarja ja seejärel menüüd Format (Vorming). Valige Fill (Täide) ja märkige seejärel olenevalt diagrammist ruut Vary color by point (Varieeri värvi punkti järgi) või Vary color by slice (Varieeri värvi sektori järgi). Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

Exceli töölehe andmepunktide väärtuste kuvamiseks diagrammis saate lisada silte.

  1. Klõpsake diagrammi ja seejärel menüüd Chart Design (Diagrammikujundus).

  2. Klõpsake käsku Add Chart Element (Lisa diagrammielement) ja valige seejärel Data Labels (Andmesildid).

  3. Valige asukoht, kus soovite andmesilti kuvada (valige näiteks Outside End (Välisäärel)).

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

  1. Klõpsake diagrammi ja seejärel menüüd Chart Design (Diagrammikujundus).

  2. Klõpsake käsku Add Chart Element (Lisa diagrammielement) ja valige seejärel Data Table (Andmetabel).

  3. Valige soovitud suvandid.

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

Kui loote diagrammi kuupäevadest koosnevatest andmetest, mida esitatakse diagrammi horisontaalteljel, muudab Office horisontaaltelje automaatselt kuupäevateljeks (ajaskaalateljeks). Saate horisontaaltelje kuupäevateljeks muuta ka käsitsi. Kuupäevateljel kuvatakse kuupäevad ajalises järjestuses kindlate vahemikega või põhiühikutes (nt päevade, kuude või aastate arv), isegi kui kuupäevad pole Exceli töölehel järjestikku või samades põhiühikutes.

Vaikimisi määratleb Excel kuupäevatelje baasühikud mis tahes kahe kuupäeva väikseima vahe alusel. Kui teil on näiteks tegemist aktsiahindade andmetega, kus väikseim kuupäevade vahe on seitse päeva, määrab Office baasühikuks päevad. Soovi korral saate baasühikuks aga määrata ka kuud või aastad, kui soovite näha teatud aktsia liikumist pikema aja jooksul.

  1. Klõpsake diagrammi ja seejärel menüüd Chart Design (Diagrammikujundus).

  2. Klõpsake käsku Add Chart Element (Lisa diagrammielement), valige Axes (Teljed) ja seejärel More Axis Options (Veel teljesuvandeid). Kuvatakse paan Format Axis (Telgede vorming).

  3. Veenduge, et muudetava telje teljesildid kuvatakse.

  4. Valige Axis Type (Telje tüüp) > Date axis (Kuupäevatelg).

  5. Valige ripploendiboksi Base (Alus) jaotises Units (Ühikud) kas Days (Päevad), Months (Kuud) või Years (Aastad).

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

Märkus.: Kui teete selle toimingu ja diagrammis kuupäevi ajaskaalateljel ei kuvata, siis veenduge, et teljesildid oleksid Exceli tabelis kuupäevavormingus (nt 05/01/08 või May-08 (mai-08)). Lisateavet lahtrite vormindamise kohta kuupäevadena leiate teemast Kellaaegade, kuupäevade, valuuta, murdude või protsentide kuvamine (inglise keeles).

Word

Pärast diagrammi loomist saate andmeid Exceli töölehel redigeerida. Muudatused kajastuvad Wordis diagrammis.

  1. Klõpsake menüü View (Vaade) nuppu Print Layout (Küljendivaade).

  2. Klõpsake diagrammi.

  3. Klõpsake menüü Charts (Diagrammid) jaotises Data (Andmed) noolenuppu Edit (Redigeeri) ja seejärel käsku Edit Data in Excel (Redigeeri andmeid Excelis).

    Menüü Diagrammid, jaotis Andmed

    Avaneb Excel ja kuvatakse diagrammi andmetabel.

    Andmetabel Office’i diagrammi jaoks

  4. Diagrammi lisatavate ridade ja veergude arvu muutmiseks osutage valitud andmete vasakule allnurgale ja lohistage seejärel lisaandmete valimiseks. Järgmises näites on täiendavate kategooriate ja andmesarjade lisamiseks tabelit laiendatud.

    Office’i diagrammi jaoks suurema andmehulga valimine

  5. Andmete lisamiseks või lahtriandmete redigeerimiseks klõpsake lahtrit ja tehke seejärel soovitud muudatus.

  6. Muudatuste tulemuste kuvamiseks avage Word.

Pärast diagrammi loomist soovite ehk muuta tabeliridade ja -veergude diagrammis esitamise viisi.  Näiteks diagrammi esimeses versioonis võidakse tabeli andmeread esitada diagrammi vertikaalteljel (väärtusteljel) ja andmeveerud horisontaalteljel (kategooriateljel). Järgmises näites on diagrammis rõhutatud müük vahendi kaupa.

Diagramm, kus on toodud müük kategooria kaupa

Kui soovite, et diagrammis oleks rõhutatut müük kuu kaupa, saate diagrammi esitusviisi ümber pöörata.

Diagramm, kus on toodud müük kuu kaupa

  1. Klõpsake menüü View (Vaade) nuppu Print Layout (Küljendivaade).

  2. Klõpsake diagrammi.

  3. Klõpsake menüü Charts (Diagrammid) jaotises Data (Andmed) käsku Plot series by row (Esita sari reana)  Esita sari reana või Plot series by column (Esita sari veeruna) Esita sari veeruna .

    Menüü Diagrammid, jaotis Andmed

    Kui esituse vahetus pole saadaval

    Esituse vahetus on saadaval ainult siis, kui diagrammi Exceli andmetabel on avatud, ja ainult teatud diagrammitüüpide korral.

    1. Klõpsake diagrammi.

    2. Klõpsake menüü Charts (Diagrammid) jaotises Data (Andmed) noolenuppu Edit (Redigeeri) ja seejärel käsku Edit Data in Excel (Redigeeri andmeid Excelis). Menüü Diagrammid, jaotis Andmed

Andmesarja järjestuse muutmiseks peab diagrammis olema mitu andmesarja.

  1. Klõpsake menüü View (Vaade) nuppu Print Layout (Küljendivaade).

  2. Klõpsake diagrammi, valige andmesari ja valige seejärel menüü Chart Layout (Diagrammi paigutus).

    Klõpsake näiteks tulpdiagrammis veergu ja selle andmesarja kõik veerud valitakse.

  3. Valige Praegune valik > Vorminda valikut.

    Menüü Diagrammid, jaotis Praegune valik

  4. Valige navigeerimispaanil Order (Järjestus), klõpsake sarja nime ja seejärel käsku Move Up (Nihuta üles) või Move Down (Nihuta alla).

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

    Märkus.: Enamiku diagrammitüüpide korral mõjutab andmesarja järjestuse muutmine nii legendi kui ka diagrammi ennast.

  1. Klõpsake menüü View (Vaade) nuppu Print Layout (Küljendivaade).

  2. Valige mõni diagrammi andmesari ja seejärel klõpsake menüüd Charts (Diagrammid).

    Klõpsake näiteks tulpdiagrammis veergu ja selle andmesarja kõik veerud valitakse.

  3. Klõpsake jaotises Data (Andmed) noolenuppu Edit (Redigeeri) ja seejärel käsku Select Data in Excel (Vali andmed Excelist).

    Menüü Diagrammid, jaotis Andmed

  4. Tehke dialoogiboksis Select Data Source (Andmeallika valimine) ühte järgmistest.

    Toiming

    Toiming

    Andmesarja eemaldamine

    Valige jaotisest Series (Sari) eemaldatav andmesari ja siis klõpsake käsku Remove (Eemalda) (-).

    Andmesarja lisamine

    Klõpsake jaotises Series (Sari) käsku Add (Lisa) ja seejärel valige Exceli töölehel kõik andmed, mille soovite diagrammi lisada.

  1. Klõpsake menüü View (Vaade) nuppu Print Layout (Küljendivaade).

  2. Valige mõni diagrammi andmesari ja seejärel klõpsake menüüd Format (Vorming).

    Klõpsake näiteks tulpdiagrammis veergu ja selle andmesarja kõik veerud valitakse.

  3. Klõpsake menüü Chart Element Styles (Diagrammielemendid > Laadid) noolenuppu Fill (Täide) Nupp Täitevärv ja seejärel soovitud värvi.

    Näpunäide.: Värvi varieerimiseks andmepunkti järgi ainult ühe andmesarjaga diagrammis klõpsake sarja ja seejärel menüüd Chart Layout (Diagrammi paigutus). Valige Current Selection (Praegune valik) > Format Selection (Vorminda valikut). Valige navigeerimispaanil Fill (Täide) ja märkige seejärel olenevalt diagrammist ruut Vary color by point (Varieeri värvi punkti järgi) või Vary color by slice (Varieeri värvi sektori järgi). Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

Exceli töölehe andmepunktide väärtuste kuvamiseks diagrammis saate lisada silte.

  1. Klõpsake menüü Vaade nuppu Küljendivaade.

  2. Klõpsake diagrammi ja valige seejärel menüü Diagrammiriistad > Paigutus.

  3. Klõpsake jaotises Labels (Sildid) nuppu Data Labels (Andmesildid) ja seejärel klõpsake loendi ülaservas soovitud andmesarja tüüpi.

    Menüü Diagrammi paigutus, jaotis Sildid

  4. Klõpsake jaotises Labels (Sildid) nuppu Data Labels (Andmesildid) ja seejärel klõpsake loendi allservas kuvatava andmesarja tüüpi.

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

  1. Klõpsake menüü Vaade nuppu Küljendivaade.

  2. Klõpsake diagrammi ja valige seejärel menüü Diagrammiriistad > Paigutus.

  3. Klõpsake jaotises Labels (Sildid) nuppu Data Table (Andmetabel) ning klõpsake seejärel soovitud suvandit.

    Menüü Diagrammi paigutus, jaotis Sildid

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

Kui loote diagrammi kuupäevadest koosnevatest andmetest, mida esitatakse diagrammi horisontaalteljel, muudab Office horisontaaltelje automaatselt kuupäevateljeks (ajaskaalateljeks). Saate horisontaaltelje kuupäevateljeks muuta ka käsitsi. Kuupäevateljel kuvatakse kuupäevad ajalises järjestuses kindlate vahemikega või põhiühikutes (nt päevade, kuude või aastate arv), isegi kui kuupäevad pole Exceli töölehel järjestikku või samades põhiühikutes.

Vaikimisi määratleb Excel kuupäevatelje baasühikud mis tahes kahe kuupäeva väikseima vahe alusel. Kui teil on näiteks tegemist aktsiahindade andmetega, kus väikseim kuupäevade vahe on seitse päeva, määrab Office baasühikuks päevad. Soovi korral saate baasühikuks aga määrata ka kuud või aastad, kui soovite näha teatud aktsia liikumist pikema aja jooksul.

  1. Klõpsake menüü Vaade nuppu Küljendivaade.

  2. Klõpsake diagrammi ja valige seejärel menüü Diagrammiriistad > Paigutus.

  3. Veenduge, et muudetava telje teljesildid kuvatakse.

  4. Valige Axes (Teljed) > Axes (Teljed) > Horizontal Axis (Horisontaaltelg) ja seejärel Axis Options (Teljesuvandid).

    Menüü Diagrammi paigutus, jaotis Teljed

  5. Valige navigeerimispaanil Scale (Skaala) ja seejärel Horizontal axis type (Horisontaaltelje tüüp) ning siis Date (Kuupäev).

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

Märkus.: Kui teete selle toimingu ja diagrammis kuupäevi ajaskaalateljel ei kuvata, siis veenduge, et teljesildid oleksid Exceli tabelis kuupäevavormingus (nt 05/01/08 või May-08 (mai-08)). Lisateavet lahtrite vormindamise kohta kuupäevadena leiate teemast Kellaaegade, kuupäevade, valuuta, murdude või protsentide kuvamine (inglise keeles).

PowerPoint

Pärast diagrammi loomist saate andmeid Exceli töölehel redigeerida. Muudatused kajastuvad PowerPointis diagrammis.

  1. Klõpsake diagrammi.

  2. Klõpsake menüü Charts (Diagrammid) jaotises Data (Andmed) noolenuppu Edit (Redigeeri) ja seejärel käsku Edit Data in Excel (Redigeeri andmeid Excelis).

    Menüü Diagrammid, jaotis Andmed

    Avaneb Excel ja kuvatakse diagrammi andmetabel.

    Andmetabel Office’i diagrammi jaoks

  3. Diagrammi lisatavate ridade ja veergude arvu muutmiseks osutage valitud andmete vasakule allnurgale ja lohistage seejärel lisaandmete valimiseks. Järgmises näites on täiendavate kategooriate ja andmesarjade lisamiseks tabelit laiendatud.

    Office’i diagrammi jaoks suurema andmehulga valimine

  4. Andmete lisamiseks või lahtriandmete redigeerimiseks klõpsake lahtrit ja tehke seejärel soovitud muudatus.

  5. Muudatuste kuvamiseks avage PowerPoint.

Pärast diagrammi loomist soovite ehk muuta tabeliridade ja -veergude diagrammis esitamise viisi.  Näiteks diagrammi esimeses versioonis võidakse tabeli andmeread esitada diagrammi vertikaalteljel (väärtusteljel) ja andmeveerud horisontaalteljel (kategooriateljel). Järgmises näites on diagrammis rõhutatud müük vahendi kaupa.

Diagramm, kus on toodud müük kategooria kaupa

Kui soovite, et diagrammis oleks rõhutatut müük kuu kaupa, saate diagrammi esitusviisi ümber pöörata.

Diagramm, kus on toodud müük kuu kaupa

  1. Klõpsake diagrammi.

  2. Klõpsake menüü Charts (Diagrammid) jaotises Data (Andmed) käsku Plot series by row (Esita sari reana)  Esita sari reana või Plot series by column (Esita sari veeruna) Esita sari veeruna .

    Menüü Diagrammid, jaotis Andmed

    Kui esituse vahetus pole saadaval

    Esituse vahetus on saadaval ainult siis, kui diagrammi Exceli andmetabel on avatud, ja ainult teatud diagrammitüüpide korral.

    1. Klõpsake diagrammi.

    2. Klõpsake menüü Charts (Diagrammid) jaotises Data (Andmed) noolenuppu Edit (Redigeeri) ja seejärel käsku Edit Data in Excel (Redigeeri andmeid Excelis). Menüü Diagrammid, jaotis Andmed

Andmesarja järjestuse muutmiseks peab diagrammis olema mitu andmesarja.

  1. Klõpsake diagrammi, valige andmesari ja valige seejärel menüü Chart Layout (Diagrammi paigutus).

    Klõpsake näiteks tulpdiagrammis veergu ja selle andmesarja kõik veerud valitakse.

  2. Valige Praegune valik > Vorminda valikut.

    Menüü Diagrammid, jaotis Praegune valik

  3. Valige navigeerimispaanil Order (Järjestus), klõpsake sarja nime ja seejärel käsku Move Up (Nihuta üles) või Move Down (Nihuta alla).

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

    Märkus.: Enamiku diagrammitüüpide korral mõjutab andmesarja järjestuse muutmine nii legendi kui ka diagrammi ennast.

  1. Valige mõni diagrammi andmesari ja seejärel klõpsake menüüd Charts (Diagrammid).

    Klõpsake näiteks tulpdiagrammis veergu ja selle andmesarja kõik veerud valitakse.

  2. Klõpsake jaotises Data (Andmed) noolenuppu Edit (Redigeeri) ja seejärel käsku Select Data in Excel (Vali andmed Excelist).

    Menüü Diagrammid, jaotis Andmed

  3. Tehke dialoogiboksis Select Data Source (Andmeallika valimine) ühte järgmistest.

    Toiming

    Toiming

    Andmesarja eemaldamine

    Valige jaotisest Series (Sari) eemaldatav andmesari ja siis klõpsake käsku Remove (Eemalda) (-).

    Andmesarja lisamine

    Klõpsake jaotises Series (Sari) käsku Add (Lisa) ja seejärel valige Exceli töölehel kõik andmed, mille soovite diagrammi lisada.

  1. Valige mõni diagrammi andmesari ja seejärel klõpsake menüüd Format (Vorming).

    Klõpsake näiteks tulpdiagrammis veergu ja selle andmesarja kõik veerud valitakse.

  2. Klõpsake menüü Chart Element Styles (Diagrammielemendid > Laadid) noolenuppu Fill (Täide) Nupp Täitevärv ja seejärel soovitud värvi.

    Näpunäide.: Värvi varieerimiseks andmepunkti järgi ainult ühe andmesarjaga diagrammis klõpsake sarja ja seejärel menüüd Chart Layout (Diagrammi paigutus). Valige Current Selection (Praegune valik) > Format Selection (Vorminda valikut). Valige navigeerimispaanil Fill (Täide) ja märkige seejärel olenevalt diagrammist ruut Vary color by point (Varieeri värvi punkti järgi) või Vary color by slice (Varieeri värvi sektori järgi). Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

Exceli töölehe andmepunktide väärtuste kuvamiseks diagrammis saate lisada silte.

  1. Klõpsake diagrammi ja valige seejärel menüü Chart Layout (Diagrammiriistad > Paigutus).

  2. Klõpsake jaotises Labels (Sildid) nuppu Data Labels (Andmesildid) ja seejärel klõpsake loendi ülaservas soovitud andmesarja tüüpi.

    Menüü Diagrammi paigutus, jaotis Sildid

  3. Klõpsake jaotises Labels (Sildid) nuppu Data Labels (Andmesildid) ja seejärel klõpsake loendi allservas kuvatava andmesarja tüüpi.

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

  1. Klõpsake diagrammi ja valige seejärel menüü Chart Layout (Diagrammiriistad > Paigutus).

  2. Klõpsake jaotises Labels (Sildid) nuppu Data Table (Andmetabel) ning klõpsake seejärel soovitud suvandit.

    Menüü Diagrammi paigutus, jaotis Sildid

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

Kui loote diagrammi kuupäevadest koosnevatest andmetest, mida esitatakse diagrammi horisontaalteljel, muudab Office horisontaaltelje automaatselt kuupäevateljeks (ajaskaalateljeks). Saate horisontaaltelje kuupäevateljeks muuta ka käsitsi. Kuupäevateljel kuvatakse kuupäevad ajalises järjestuses kindlate vahemikega või põhiühikutes (nt päevade, kuude või aastate arv), isegi kui kuupäevad pole Exceli töölehel järjestikku või samades põhiühikutes.

Vaikimisi määratleb Excel kuupäevatelje baasühikud mis tahes kahe kuupäeva väikseima vahe alusel. Kui teil on näiteks tegemist aktsiahindade andmetega, kus väikseim kuupäevade vahe on seitse päeva, määrab Office baasühikuks päevad. Soovi korral saate baasühikuks aga määrata ka kuud või aastad, kui soovite näha teatud aktsia liikumist pikema aja jooksul.

  1. Klõpsake diagrammi ja valige seejärel menüü Chart Layout (Diagrammiriistad > Paigutus).

  2. Veenduge, et muudetava telje teljesildid kuvatakse.

  3. Valige Axes (Teljed) > Axes (Teljed) > Horizontal Axis (Horisontaaltelg) ja seejärel Axis Options (Teljesuvandid).

    Menüü Diagrammi paigutus, jaotis Teljed

  4. Valige navigeerimispaanil Scale (Skaala) ja seejärel Horizontal axis type (Horisontaaltelje tüüp) ning siis Date (Kuupäev).

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

Märkus.: Kui teete selle toimingu ja diagrammis kuupäevi ajaskaalateljel ei kuvata, siis veenduge, et teljesildid oleksid Exceli tabelis kuupäevavormingus (nt 05/01/08 või May-08 (mai-08)). Lisateavet lahtrite vormindamise kohta kuupäevadena leiate teemast Kellaaegade, kuupäevade, valuuta, murdude või protsentide kuvamine (inglise keeles).

Excel

Pärast diagrammi loomist saate andmeid Exceli töölehel redigeerida. Muudatused kajastuvad diagrammis.

  1. Klõpsake diagrammi.

    Excelis tõstetakse diagrammis kasutatav andmetabel esile. Lilla liigendus näitab kategooriatelje jaoks kasutatavat rida või veergu. Roheline liigendus näitab andmesarja silte sisaldavat rida või veergu. Sinine liigendus näitab diagrammis esitatavaid andmepunkte.

    Exceli andmetabel diagrammi jaoks

    Viiktekst 1 Andmesarja sildid

    Viiktekst 2 Kategooriatelje väärtused

    Viiktekst 3 Diagrammis esitatavad andmepunktid

  2. Diagrammi lisatavate ridade ja veergude arvu muutmiseks osutage valitud andmete vasakule allnurgale ja lohistage seejärel lisaandmete valimiseks. Järgmises näites on täiendavate kategooriate ja andmesarjade lisamiseks tabelit laiendatud.

    Exceli diagrammi suurema andmehulga valimine

    Näpunäide.: Andmete diagrammis kuvamise vältimiseks saate tabeliridu ja -veerge peita.

  3. Andmete lisamiseks või lahtriandmete redigeerimiseks klõpsake lahtrit ja tehke seejärel soovitud muudatus.

Pärast diagrammi loomist soovite ehk muuta tabeliridade ja -veergude diagrammis esitamise viisi.  Näiteks diagrammi esimeses versioonis võidakse tabeli andmeread esitada diagrammi vertikaalteljel (väärtusteljel) ja andmeveerud horisontaalteljel (kategooriateljel). Järgmises näites on diagrammis rõhutatud müük vahendi kaupa.

Diagramm, kus on toodud müük kategooria kaupa

Kui soovite, et diagrammis oleks rõhutatut müük kuu kaupa, saate diagrammi esitusviisi ümber pöörata.

Diagramm, kus on toodud müük kuu kaupa

  1. Klõpsake diagrammi.

  2. Klõpsake menüü Charts (Diagrammid) jaotises Data (Andmed) käsku Plot series by row (Esita sari reana)  Esita sari reana või Plot series by column (Esita sari veeruna) Esita sari veeruna .

    Exceli menüü Diagrammid, jaotis Andmed

Andmesarja järjestuse muutmiseks peab diagrammis olema mitu andmesarja.

  1. Klõpsake diagrammi, valige andmesari ja valige seejärel menüü Chart Layout (Diagrammi paigutus).

    Klõpsake näiteks tulpdiagrammis veergu ja selle andmesarja kõik veerud valitakse.

  2. Valige Praegune valik > Vorminda valikut.

    Menüü Diagrammid, jaotis Praegune valik

  3. Valige navigeerimispaanil Order (Järjestus), klõpsake sarja nime ja seejärel käsku Move Up (Nihuta üles) või Move Down (Nihuta alla).

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

    Märkus.: Enamiku diagrammitüüpide korral mõjutab andmesarja järjestuse muutmine nii legendi kui ka diagrammi ennast.

  1. Valige mõni diagrammi andmesari ja seejärel klõpsake menüüd Charts (Diagrammid).

    Klõpsake näiteks tulpdiagrammis veergu ja selle andmesarja kõik veerud valitakse.

  2. Valige Data (Andmed) > Select (Vali).

    Exceli menüü Diagrammid, jaotis Andmed

  3. Tehke dialoogiboksis Select Data Source (Andmeallika valimine) ühte järgmistest.

    Toiming

    Toiming

    Andmesarja eemaldamine

    Valige jaotisest Series (Sari) eemaldatav andmesari ja siis klõpsake käsku Remove (Eemalda) (-).

    Andmesarja lisamine

    Klõpsake jaotises Series (Sari) käsku Add (Lisa) ja seejärel valige Exceli töölehel kõik andmed, mille soovite diagrammi lisada.

  1. Valige mõni diagrammi andmesari ja seejärel klõpsake menüüd Format (Vorming).

    Klõpsake näiteks tulpdiagrammis veergu ja selle andmesarja kõik veerud valitakse.

  2. Klõpsake menüü Chart Element Styles (Diagrammielemendid > Laadid) noolenuppu Fill (Täide) Nupp Täitevärv ja seejärel soovitud värvi.

    Näpunäide.: Värvi varieerimiseks andmepunkti järgi ainult ühe andmesarjaga diagrammis klõpsake sarja ja seejärel menüüd Chart Layout (Diagrammi paigutus). Valige Current Selection (Praegune valik) > Format Selection (Vorminda valikut). Valige navigeerimispaanil Fill (Täide) ja märkige seejärel olenevalt diagrammist ruut Vary color by point (Varieeri värvi punkti järgi) või Vary color by slice (Varieeri värvi sektori järgi). Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

Exceli töölehe andmepunktide väärtuste kuvamiseks diagrammis saate lisada silte.

  1. Klõpsake diagrammi ja valige seejärel menüü Chart Layout (Diagrammiriistad > Paigutus).

  2. Klõpsake jaotises Labels (Sildid) nuppu Data Labels (Andmesildid) ja seejärel klõpsake loendi ülaservas soovitud andmesarja tüüpi.

    Menüü Diagrammi paigutus, jaotis Sildid

  3. Klõpsake jaotises Labels (Sildid) nuppu Data Labels (Andmesildid) ja seejärel klõpsake loendi allservas kuvatava andmesarja tüüpi.

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

  1. Klõpsake diagrammi ja valige seejärel menüü Chart Layout (Diagrammiriistad > Paigutus).

  2. Klõpsake jaotises Labels (Sildid) nuppu Data Table (Andmetabel) ning klõpsake seejärel soovitud suvandit.

    Menüü Diagrammi paigutus, jaotis Sildid

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

Kui loote diagrammi kuupäevadest koosnevatest andmetest, mida esitatakse diagrammi horisontaalteljel, muudab Office horisontaaltelje automaatselt kuupäevateljeks (ajaskaalateljeks). Saate horisontaaltelje kuupäevateljeks muuta ka käsitsi. Kuupäevateljel kuvatakse kuupäevad ajalises järjestuses kindlate vahemikega või põhiühikutes (nt päevade, kuude või aastate arv), isegi kui kuupäevad pole Exceli töölehel järjestikku või samades põhiühikutes.

Vaikimisi määratleb Excel kuupäevatelje baasühikud mis tahes kahe kuupäeva väikseima vahe alusel. Kui teil on näiteks tegemist aktsiahindade andmetega, kus väikseim kuupäevade vahe on seitse päeva, määrab Office baasühikuks päevad. Soovi korral saate baasühikuks aga määrata ka kuud või aastad, kui soovite näha teatud aktsia liikumist pikema aja jooksul.

  1. Klõpsake diagrammi ja valige seejärel menüü Chart Layout (Diagrammiriistad > Paigutus).

  2. Veenduge, et muudetava telje teljesildid kuvatakse.

  3. Valige Axes (Teljed) > Axes (Teljed) > Horizontal Axis (Horisontaaltelg) ja seejärel Axis Options (Teljesuvandid).

  4. Valige navigeerimispaanil Scale (Skaala) ja seejärel Horizontal axis type (Horisontaaltelje tüüp) ning siis Date (Kuupäev).

    Olenevalt diagrammitüübist ei pruugi mõni suvand saadaval olla.

Märkus.: Kui teete selle toimingu ja diagrammis kuupäevi ajaskaalateljel ei kuvata, siis veenduge, et teljesildid oleksid Exceli tabelis kuupäevavormingus (nt 05/01/08 või May-08 (mai-08)). Lisateavet lahtrite vormindamise kohta kuupäevadena leiate teemast Kellaaegade, kuupäevade, valuuta, murdude või protsentide kuvamine (inglise keeles).

Vt ka

Diagrammi loomine

Täiendage Office'i kasutamise oskusi
Tutvuge koolitusmaterjalidega
Kasutage uusi funktsioone enne teisi
Liituge Office Insideri programmiga

Kas sellest teabest oli abi?

Täname tagasiside eest!

Täname tagasiside eest! Tundub, et võiksime teid kokku viia ühega meie Office'i tugiagentidest, kes aitab teil probleemi lahendada.

×