×
inglise
Palume vabandust. See artikkel pole teie keeles saadaval.
Link projects to create a master project

Link projects to create a master project

Office 365 tellimus, Project Professional 2019, Project Professional 2016, Office 2013, Office 2010

To help keep a large project more organized, you can link several project files together to create a master project/ subproject arrangement (also known as external dependencies). For example, a construction master project might have subproject files for plumbing, electrical, and carpentry work.

Linking Project files

  1. Create separate Project files for each subproject, then open or create the project that you want to be the master project.

  2. In the master project, click View > Gantt Chart.

  3. In the Task Name field, click the row below which you want to insert the subproject. You can insert a subproject anywhere in the task list of the master project.

  4. Click Project > Subproject.

    The Project ribbon tab, showing the Insert subproject command.

  5. In the Insert Project box, select the subproject you want to insert.

    • To insert multiple subprojects, hold down Ctrl and click the subprojects in the order that you want to insert them.

    • In most cases, you’ll want to leave the Link to project box checked, so that changes in the subproject are reflected in the master project, and vice-versa. But if you just want to copy the subproject into the master project without the files being dynamically linked, uncheck the box.

  6. Click Insert, or to insert a project in read-only format, click the arrow on the Insert button, and then click Insert Read-Only. Inserting a project read-only creates a link between the two projects, but prevents you from updating the subproject from within the master project. If you update the subproject file directly, however, its changes are reflected in the master project. The Insert Read-Only option is only available when the Link to project box is checked.

Avoiding duplicate resource names in linked projects

If you link projects that have resources with the same name, you’ll create duplicate resource names, which could be confusing. To avoid this, uncheck the Link to project box in the Insert Project dialog box. Doing this will ensure that the resource information in the master project (such as pay rates, resource calendars) will be honored over the subproject resource information.

Note: When you update an unlinked subproject from within the master project, the original subproject file will not show this change.

Reorganizing subprojects in the master project

If you have inserted a subproject into a master project and want to rearrange the task list, you can move the inserted project up or down the task list.

  1. Choose View > Gantt Chart.

  2. Select the ID number of the summary task that represents the inserted project you want to move.

  3. Right-click and choose Cut  to remove the inserted project.

    Note: By cutting and pasting the task, you change the task's unique ID (different from the task ID located in the far left column of the Entry table) when it is pasted back into the task list in a different location. To move the task without changing the unique ID, you can drag the task to the new position in the task list. To drag the task, place the pointer over the Task ID in the ID field. When it changes into a four-way arrow, drag the task to its new location. The information is only removed from the project plan, not deleted, until you paste it back in.

  4. Select the ID number of the task below where you want the project to appear in the task list.

    Note: If you insert or paste a project below another inserted project that has only the project summary task displayed, the project you are inserting or pasting is added at the same level as the inserted project above it. If, however, you insert or paste below an inserted project that has all of its tasks displayed, then the project you are inserting or pasting becomes a subproject of the inserted project above it.

  5. Click Paste  to paste the project above the selected row.

These instructions are specific to Microsoft Project 2007.

When should I use cross-project links, instead of inter-project dependencies?

If your project has a specific task that depends on a specific task in another project, use cross-project links to tie the task dates to one another. This way, if the task that you are dependent upon slips, the new dates are reflected in your own task. If your project is dependent on some aspect of another project, and the dependency is not necessarily tied to a specific task, use inter-project dependencies to identify exactly what each project brings to the relationship.

  1. Open both projects: the project that contains the task that you want to link to and the project that contains the task that you want to link from.

    On the Window menu of one of the projects, click Arrange All.

  2. Click the task for which you want to create a dependency to an external predecessor.

  3. Click Task Information Button image , and then click the Predecessors tab.

  4. In the ID column, type the project name and task ID number of the external predecessor, separated by a backslash. For example, type Project1\1 for task ID 1 in a file named Project1.

By default, you are notified if the data in an externally linked project has changed. The external predecessors and successors and the impacts to your schedule are displayed when you open a project with external links, and you can choose to accept any or all changes.

  • Both projects must be saved before you can link to an external task.

  • When you link tasks in different projects that are stored in Microsoft Office Project Server, the predecessor's task ID must be formatted correctly. In the Task Information dialog box, on the Predecessors tab, in the ID column, the task ID must be formatted as shown in the following example: <>\project1\42. In this example, project1 is the name of the project that contains the predecessor, and 42 is the task ID of the predecessor task.

  • Externally linked tasks appear dimmed in the task list. Double-clicking a task with an external successor or an external predecessor opens the project that contains the external task, if the project is available.

I linked tasks between projects, but the data doesn't match.

When you use the Paste Link option in the Paste Special dialog box (Edit menu) to connect tasks, Project uses Object Linking and Embedding (OLE) to make the connection. Only the fields that you have selected are linked. However, a task may have many more fields of information associated with it that affect how the task is scheduled, and these fields may be hidden if you have a split-screen view.

If you need to create a dependency between tasks in different projects, create external dependencies (instead of pasting a link) to maintain an accurate schedule.

When you use the Paste Link option, select individual fields instead of entire rows, and link only as much information as is needed to avoid conflicting schedule information.

Learn more

Plans within plans: master projects and subprojects

Täiendage Office'i kasutamise oskusi
Tutvuge koolitusmaterjalidega
Kasutage uusi funktsioone enne teisi
Liituge Office Insideri programmiga

Kas sellest teabest oli abi?

Täname tagasiside eest!

Täname tagasiside eest! Tundub, et võiksime teid kokku viia ühega meie Office'i tugiagentidest, kes aitab teil probleemi lahendada.

×