Exceli lisandmoodulite lisamine või eemaldamine

Lisandmoodulid sisaldavad Microsoft Exceli lisakäske ja -funktsioone. Vaikimisi pole lisandmoodulid Excelis kohe saadaval. Seega peate lisandmoodulite kasutamiseks need esmalt installima ja (mõnel juhul) aktiveerima.

Kas otsite teavet HTML-il, CSS-il ja JS-il põhinevate Office’i lisandmoodulite kohta? Kui nii, lugege teemat Office’i lisandmooduli hankimine Exceli jaoks.

Mõned lisandmoodulid on Exceli integreeritud (nt lisandmoodulid Solver ja Analüüsi tööriistapakett), teised on seevastu saadaval allalaadimiskeskuses, kust need tuleb esmalt alla laadida ja seejärel installida. Lisaks on veel muude tootjate (nt teie ettevõtte programmeerija või tarkvaralahenduste pakkuja) loodud lisandmoodulid. Need võivad olla VBA-, DLL- ja Component Object Model (COM) -lisandmoodulid. Ka nende lisandmoodulite kasutamiseks tuleb need esmalt installida.

Enamik lisandmooduleid saab liigitada kolme erineva tüübi järgi:

  • Exceli lisandmoodulid.    Need sisaldavad tavaliselt xlam- (Exceli lisandmoodul), xla- (Excel 97-2003 lisandmoodul) või xll- (DLL-lisandmoodul) vormingus faile või on automatiseerimise lisandmoodulid. Mõned Exceli lisandmoodulid (nt lisandmoodulid Solver ja Analüüsi tööriistapakett) võivad olla saadaval juba pärast Exceli või Microsoft Office'i installimist. Tavaliselt peate nende lisandmoodulite kasutamiseks need ainult aktiveerima.

  • Allalaaditavad lisandmoodulid.    Exceli jaoks saab lisandmooduleid alla laadida ja installida veebisaidi Office.com lehel Allalaaditavad failid.

  • Kohandatud lisandmoodulid.    Arendajad ja lahenduste pakkujad loovad tavaliselt kohandatud automatiseerimise, VBA-, XLL- ja Component Object Model (COM) -lisandmooduleid. Enne kasutamist peate need installima.

Pärast lisandmooduli installimist või aktiveerimist on see ja selle käsud saadaval ühes järgmistest kohtadest.

  • Menüü Andmed. Pärast lisandmoodulite Analüüsi tööriistakomplekt ja Solver installimist ja aktiveerimist kuvatakse jaotises Analüüs käsud Andmete analüüs ja Solver.

    Andmeanalüüs ja Solver

  • Menüü Valemid. Pärast lisandmooduli Eurovääringu tööriistad installimist ja aktiveerimist kuvatakse jaotises Solutions käsud Euro Conversion ja Euro Formatting.

    Euroteisendus ja euro vorming

  • Menüü Lisandmoodulid. Muud lisandmoodulid võidakse lisada menüüsse Lisandmoodulid. See menüü lisatakse lindile, kui olete installinud ja aktiveerinud esimese menüüs Lisandmoodulid kuvatava lisandmooduli. Kui menüü Lisandmoodulid pole nähtaval, väljuge Excelist ja taaskäivitage see.

Mõni lisandmoodul, nagu näiteks menüü Alustamine, on saadaval Exceli muudes kohtades (nt lindi menüüs, makrode kaudu või kohandatud menüüdes).

NB!: Kui te olete tarkvaraarendaja ja pole veel automatiseerimise lisandmooduli jaoks spetsiaalseid installi- ja eemaldusprogramme välja töötanud, saate selle protseduuri kaudu selle installida või eemaldada.

Exceli lisandmooduli aktiveerimine    

  1. Klõpsake menüüs Fail nuppu Suvandid ja seejärel kategooriat Lisandmoodulid.

  2. Klõpsake väljal Haldamine väärtust Exceli lisandmoodulid ja seejärel nuppu Mine.

    Kuvatakse dialoogiboks Lisandmoodulid.

  3. Märkige loendis Saadaolevad lisandmoodulid ruut selle lisandmooduli kõrval, mille soovite aktiveerida. Seejärel klõpsake nuppu OK.

Kui te ei leia loendist Saadaolevad lisandmoodulid lisandmoodulit, mida aktiveerida soovite, siis tuleb see installida.

Exceli lisandmooduli installimine    

  • Selleks, et installida lisandmooduleid, mis on tavaliselt koos Exceliga juba varem installitud (nt lisandmoodul Solver või Analüüsi tööriistapakett), käivitage Exceli või Microsoft Office'i installiprogramm ja klõpsake lisandmooduli installimiseks nuppu Muuda. Pärast Exceli taaskäivitamist peaks lisandmoodul kuvatama loendis Saadaolevad lisandmoodulid.

  • Mõned Exceli lisandmoodulid asuvad teie arvutis ja need saab installida või aktiveerida, kui klõpsate nuppu Sirvi (dialoogiboksis Lisandmoodulid), valite lisandmooduli asukoha ja klõpsate seejärel nuppu OK.

  • Mõni Exceli lisandmoodul nõuab installipaketi käivitamist. Võimalik, et peate installipaketi (installipakett on tavaliselt fail, mille faililaiend on .msi) oma arvutisse alla laadima või kopeerima ja alles seejärel käivitama.

  • Need lisandmoodulid, mis pole teie arvutis saadaval, saate alla laadida veebibrauseri kaudu menüüst Allalaaditavad failid, mõnelt muult Interneti-saidilt või oma töökoha serverist. Allalaadimisel järgige installijuhiseid.

Exceli lisandmooduli desaktiveerimine    

  1. Klõpsake menüüs Fail nuppu Suvandid ja seejärel kategooriat Lisandmoodulid.

  2. Klõpsake boksis Halda väärtust Exceli lisandmoodulid ja seejärel nuppu OK.

  3. Tühjendage loendis Saadaolevad lisandmoodulid ruut selle lisandmooduli kõrval, mille soovite desaktiveerida. Seejärel klõpsake nuppu OK.

    Enamasti eemaldatakse desaktiveeritud lisandmoodul lindi jaotisest. Kui ei eemaldata, siis on võimalik, et peate lisandmooduli lindilt eemaldamiseks Exceli taaskäivitama.

    Märkus.    Lisandmooduli desaktiveerimine ei eemalda seda arvutist. Arvutist eemaldamiseks tuleb see desinstallida.

Exceli lisandmooduli eemaldamine    

NB!: Võimalik, et kui Exceli lisandmoodul on algselt installitud võrgu failiserverist või ühiskasutusega kaustast, tuleb see ka samast asukohast eemaldada. Kui Exceli lisandmoodul on installitud CD-plaadilt ja CD-draiv on pärast lisandmooduli installimist mõne teise draivitähega vastendatud, tuleb lisandmoodul CD-plaadilt uuesti installida. Kui Exceli lisandmoodulid käivitatakse CD-plaadilt, tuleb Exceli lisandmoodulid desinstallida ja seejärel CD-plaadilt uuesti installida.

  1. Klõpsake menüüd Fail ja seejärel käsku Uus.

  2. Klõpsake juhtpaneelil linki Programmid ja funktsioonid (Windows 7 ja Windows Vista) või Programmide lisamine ja eemaldamine (Windows XP).

  3. Valige üks järgmistest:

    • Kui installisite Exceli Microsoft Office'i osana, klõpsake installitud programmide loendis valikut Microsoft Office ning seejärel nuppu Muuda (Change).

    • Kui installisite Exceli eraldi, klõpsake installitud programmide loendis vastava programmi nime ning seejärel nuppu Muuda (Change).

    • Kui installisite lisandmooduli allalaadimiskeskuse kaudu, klõpsake installitud programmide loendis vastava programmi nime ning seejärel nuppu Eemalda (Uninstall).

  4. Järgige installiprogrammis kuvatavaid juhiseid.

NB!: Kui te olete tarkvaraarendaja ja pole veel automatiseerimise lisandmooduli jaoks spetsiaalseid installi- ja eemaldusprogramme välja töötanud, saate selle protseduuri kaudu selle installida või eemaldada. Kui te pole arendaja, ei tohiks te seda protseduuri kasutada. Installi- ja eemaldusjuhiste saamiseks pöörduge lisandmoodulit pakkuva süsteemiadministraatori poole.

COM-lisandmooduli lisamine

  1. Klõpsake menüüs Fail nuppu Suvandid ja seejärel kategooriat Lisandmoodulid.

  2. Klõpsake väljal Halda väärtust COM-i lisandmoodulid ja klõpsake siis nuppu Mine.

    Kuvatakse dialoogiboks COM-i lisandmoodulid.

  3. Märkige loendis Saadaolevad lisandmoodulid ruut selle lisandmooduli kõrval, mida soovite installida. Seejärel klõpsake nuppu OK.

    Näpunäide.    Kui soovitud lisandmoodulit pole boksi Saadaolevad lisandmoodulid loendis, klõpsake nuppu Lisa ja leidke soovitud lisandmooduli asukoht.

COM-lisandmooduli eemaldamine

  1. Klõpsake menüüs Fail nuppu Suvandid ja seejärel kategooriat Lisandmoodulid.

  2. Klõpsake väljal Halda väärtust COM-i lisandmoodulid ja klõpsake siis nuppu Mine.

    Kuvatakse dialoogiboks COM-i lisandmoodulid.

  3. Tühjendage loendis Saadaolevad lisandmoodulid ruut selle lisandmooduli kõrval, mille soovite desaktiveerida. Seejärel klõpsake nuppu OK.

    Märkus.    See toiming eemaldab lisamooduli mälust, kuid jätab selle nime saadaolevate lisandmoodulite nimekirja. Lisandmoodulit ei kustutata teie arvutist.

  4. COM-lisandmooduli eemaldamine mälust ei eemalda seda teie arvutist. COM-lisandmooduli eemaldamiseks loendist ja arvutist klõpsake selle nime loendis Saadaolevad lisandmoodulid ning seejärel klõpsake nuppu Eemalda.

Märkus.: Kui te olete tarkvaraarendaja ja pole veel automatiseerimise lisandmooduli jaoks spetsiaalseid installi- ja eemaldusprogramme välja töötanud, saate selle protseduuri kaudu selle installida või eemaldada. Kui te pole arendaja, ei tohiks te seda protseduuri kasutada. Installi- ja eemaldusjuhiste saamiseks pöörduge lisandmoodulit pakkuva süsteemiadministraatori poole.

  1. Klõpsake menüüs Fail nuppu Suvandid ja seejärel kategooriat Lisandmoodulid.

  2. Klõpsake väljal Haldamine väärtust Exceli lisandmoodulid ja seejärel nuppu Mine.

    Kuvatakse dialoogiboks Lisandmoodulid.

  3. Automatiseerimise lisandmooduli installimiseks klõpsake boksis Saadaolevad automatiseerimisserverid nuppu Automatiseeri ja seejärel klõpsake soovitud lisandmoodulit.

    Näpunäide.    Kui loendis soovitud lisandmoodulit pole, klõpsake nuppu Sirvi, leidke lisandmooduli asukoht ja seejärel klõpsake nuppu OK.

  4. Automatiseerimise lisandmooduli eemaldamiseks tuleb see registrist eemaldada. Üksikasju küsige oma süsteemiadministraatorilt.

Mõned lisandmoodulid on Exceli integreeritud (nt lisandmoodulid Solver ja Analüüsi tööriistapakett), teised on seevastu saadaval allalaadimiskeskuses, kust need tuleb esmalt alla laadida ja seejärel installida. Lisaks on veel muude tootjate (nt teie ettevõtte programmeerija või tarkvaralahenduste pakkuja) loodud lisandmoodulid. Need võivad olla VBA-, DLL- ja Component Object Model (COM) -lisandmoodulid. Ka nende lisandmoodulite kasutamiseks tuleb need esmalt installida.

Enamik lisandmooduleid saab liigitada kolme erineva tüübi järgi:

  • Exceli lisandmoodulid.    Need sisaldavad tavaliselt xlam- (Exceli lisandmoodul), xla- (Excel 97-2003 lisandmoodul) või xll- (DLL-lisandmoodul) vormingus faile või on automatiseerimise lisandmoodulid. Mõned Exceli lisandmoodulid (nt lisandmoodulid Solver ja Analüüsi tööriistapakett) võivad olla saadaval juba pärast Exceli või Microsoft Office'i installimist. Tavaliselt peate nende lisandmoodulite kasutamiseks need ainult aktiveerima.

  • Allalaaditavad lisandmoodulid.    Exceli jaoks saab lisandmooduleid alla laadida ja installida veebisaidi Office.com lehel Allalaaditavad failid.

  • Kohandatud lisandmoodulid.    Arendajad ja lahenduste pakkujad loovad tavaliselt kohandatud automatiseerimise, VBA-, XLL- ja Component Object Model (COM) -lisandmooduleid. Enne kasutamist peate need installima.

Pärast lisandmooduli installimist või aktiveerimist on see ja selle käsud saadaval ühes järgmistest kohtadest.

  • Menüü Data (Andmed). Pärast lisandmoodulite Analysis ToolPak (Analüüsi tööriistakomplekt) ja Solver installimist ja aktiveerimist kuvatakse lindimenüüs Data (Andmed) käsud Data Analysis (Andmete analüüs) ja Solver.

  • Menüü Home (Avaleht). Menüüsse Home (Avaleht) saab lisada ka muid lisandmooduleid.

Mõni lisandmoodul, nagu näiteks menüü Alustamine, on saadaval Exceli muudes kohtades (nt lindi menüüs, makrode kaudu või kohandatud menüüdes).

NB!: Kui te olete tarkvaraarendaja ja pole veel automatiseerimise lisandmooduli jaoks spetsiaalseid installi- ja eemaldusprogramme välja töötanud, saate selle protseduuri kaudu selle installida või eemaldada.

Eelinstallitud Exceli lisandmooduli aktiveerimine    

  1. Klõpsake menüü Tools (Tööriistad) käsku Add-ins (Lisandmoodulid).

  2. Märkige loendis Add-Ins available (Saadaolevad lisandmoodulid) ruut selle lisandmooduli kõrval, mille soovite aktiveerida. Seejärel klõpsake nuppu OK.

Exceli lisandmooduli installimine    

  • Mõned Exceli lisandmoodulid asuvad teie arvutis ja need saab installida või aktiveerida, kui klõpsate ülalkuvatavas dialoogiboksis Add-Ins (Lisandmoodulid) nuppu Browse (Sirvi), otsite üles lisandmooduli asukoha ja klõpsate seejärel nuppu OK.

  • Mõni Exceli lisandmoodul nõuab installipaketi käivitamist. Võimalik, et peate installipaketi (installipakett on tavaliselt fail, mille faililaiend on .msi) oma arvutisse alla laadima või kopeerima ja alles seejärel käivitama.

  • Need lisandmoodulid, mis pole teie arvutis saadaval, saate alla laadida veebibrauseri kaudu menüüst Downloads (Allalaaditavad failid), mõnelt muult Interneti-saidilt, oma töökoha serverist või Exceli sisseehitatud poefunktsiooni Store (Pood) kasutades. Vajaduse korral järgige allalaaditava faili kohta käivaid häälestusjuhiseid.

    Lisandmoodulite installimine Store’ist

    1. Klõpsake lindimenüüd Insert (Lisa).

    2. Klõpsake nuppu Store (Pood).

    3. Lisandmoodulite otsimiseks kasutage loendit Categories (Kategooriad) või välja Search (Otsing).

    4. Lisandmooduli installimiseks klõpsake nuppu Add (Lisa).

      Märkus.: Mõni lisandmoodul on tasuline.

Exceli lisandmooduli eemaldamine    

  1. Klõpsake menüüd Insert (Lisa) ja seejärel klõpsake nuppu My Add-ins (Minu lisandmoodulid).

  2. Klõpsake jaotises Office Add-ins (Office’i lisandmoodulid) eemaldatava lisandmooduli ülaservas kolme punktiga menüüd.

  3. Klõpsake käsku Remove (Eemalda).

  4. Kuvatakse muude seadmete kohta käiv teatis. Lugege see läbi ja klõpsake nuppu Remove (Eemalda).

Täiendage oma oskusi
Tutvuge koolitusmaterjalidega
Kasutage uusi funktsioone enne teisi
Liituge Office Insideri programmiga

Kas sellest teabest oli abi?

Täname tagasiside eest!

Täname tagasiside eest! Tundub, et võiksime teid kokku viia ühega meie Office'i tugiagentidest, kes aitab teil probleemi lahendada.

×