×
inglise
Palume vabandust. See artikkel pole teie keeles saadaval.

Copy reports, calendars, and views in Project

The Organizer is a tool you can use to copy reports, calendars, and other elements to other projects, or to the Global template (Global.MPT). Copying an element to the Global template makes it available to all your projects.

However, you may not need to use the Organizer to accomplish what you want. In fact, Project’s default behavior is to automatically copy all new views and related elements you create to the Global template. This also applies to existing elements you save with a new name. To change this behavior, choose File > Options > Advanced. The setting is in the Display section:

The "Automatically add new views, tables, filters, and groups to the global" option

Use the Organizer

If you have unchecked the setting described above and want to copy selected elements to the Global template, or if you want to copy an element from one project to another, you’ll need to use the Organizer.

The Organizer can also copy custom text styles to other projects or to the Global template. For more information, see Change the text font in a view.

Notes: 

  • You can’t copy task information using the Organizer. If you want specific tasks to be part of each project, save the project file as a regular template.

  • Values in custom value lists (i.e. lookup values) can’t be stored in the Global template. Use a regular template for this situation as well.

Copy elements to the Global template

Suppose you customize the default Gantt chart with cost columns, and now you want to use the new chart in your future projects. Follow these steps to copy the view to the Global template:

  1. Choose File > Organizer.

    (In Project 2007, choose Tools > Organizer.)

  2. In the Organizer dialog box, select the Views tab.

    The Project organizer dialog box.

    Note: To copy other project elements, choose a different tab, such as Calendars.

    The list on the left shows elements in the Global template, while the list on the right shows the elements in the current project. Your job is to move the custom element from the right side to the left side.

    Note:  To see Project elements from other projects, you’ll need to open those projects first.

  3. Select the custom view on the right side, and then choose Copy.
    The Project organizing showing the list of elements in the currently open project.

    The custom view is copied to the Global template and displayed on the left side.

  4. If your customized view contains columns you’ve added, then you’ll need to copy over the associated table. Select the Tables tab, and then copy the table to the Global template. The associated table may have the same name as the view, but if you don’t see a likely match, copy the Entry table.

    All your projects will have the custom view available to them with the correct underlying table.

Copy elements directly to another project

If you want to copy Project elements from one project to another (but not to the Global template):

  1. Open both projects (the “source” project containing the customized elements, and the “destination” project to which you want to copy them).

  2. In the source project, choose File > Organizer.

    (In Project 2007, choose Tools > Organizer.)

  3. In the availability list, select the destination project.

    Selecting a destination project file in the Project organizer.

    Note: To copy other project elements, choose a different tab, such as Calendars.

  4. Select the custom elements on the right side, and then choose Copy to copy them to the destination project.

If an existing calendar has many of the same holidays and other calendar items that you want to use in a new calendar, you can base a new calendar on an existing calendar. Copy the existing calendar in Microsoft Project Web App, and then modify the copy in the desktop version of Project. For example, if the standard calendar in your organization captures all of the organization's unique holidays and events, but you need a separate calendar to reflect an all day, every day working schedule, you can copy the standard calendar and then modify it for the all day, every day schedule.

To create a new calendar as a copy of an existing calendar:

  1. On the Quick Launch, in the Settings section, choose Server Settings.

  2. On the Server Settings page, in the Enterprise Data section, choose Enterprise Calendars.

  3. Select the row that contains the calendar that you want to copy, and then choose Copy Calendar.

  4. On the Copy Calendar dialog box, type the name that you want to use for the new calendar in the Name box, and then choose OK.

    The calendar is added to the list on the Enterprise Calendars page.

  5. Select the row that contains the new, copied calendar, and then choose Edit Calendar.

    If the Windows Security dialog box appears, log on to Microsoft Project Server 2010.

    Project Professional opens and displays the Change Working Time dialog box.

  6. Use the calendar with the Exceptions and Work Weeks tabs to modify the working and nonworking times for your organization. For more information, see Modify working and nonworking times.

  7. Choose OK on the Change Working Time dialog box to save the new calendar to Project Server.

  8. Close Project.

Täiendage Office'i kasutamise oskusi
Tutvuge koolitusmaterjalidega
Kasutage uusi funktsioone enne teisi
Liituge Office Insideri programmiga

Kas sellest teabest oli abi?

Täname tagasiside eest!

Täname tagasiside eest! Tundub, et võiksime teid kokku viia ühega meie Office'i tugiagentidest, kes aitab teil probleemi lahendada.

×