Introducción a la seguridad de Access 2010

En este artículo se ofrece una descripción general de las características de seguridad ofrecidas por Access 2010 y explica cómo usar las herramientas que proporciona Access para ayudar a proteger una base de datos. Este artículo también contiene vínculos a contenido más detallado sobre varias características de seguridad.

En este artículo no se describen las características de seguridad de SharePoint que están disponibles al publicar su base de datos en la web mediante Access Services. Para más información, vea la Ayuda de Microsoft SharePoint Server 2010.

En este artículo

Novedades de seguridad de Access

Usar una base de datos de Access en una ubicación de confianza

Empaquetar, iniciar sesión y distribuir una base de datos de Access 2010

Habilitar y deshabilitar contenido al abrir una base de datos

Usar una contraseña de base de datos para cifrar una base de datos de Access

Cómo funciona la seguridad con bases de datos de versiones anteriores de Access abiertas en Access 2010

Ejecutar expresiones no seguras (deshabilitar el modo de espacio aislado)

Novedades de seguridad de Access

Access ofrece un modelo de seguridad mejorado que ayuda a simplificar los procesos de aplicar seguridad a una base de datos y de abrir una base de datos que tenga habilitada la seguridad.

Nota   Aunque el modelo y las técnicas descritos en este artículo mejoran seguridad, la forma más segura de ayudar a proteger los datos de Access es guardar las tablas en un servidor, como un equipo que ejecute Windows SharePoint Services 3.0 o Microsoft Office SharePoint Server 2010.

He aquí las novedades de seguridad de Access:

Novedades en 2010

  • Nueva tecnología de cifrado     Office 2010 ofrece nueva tecnología de cifrado más segura que la tecnología ofrecida en Office 2007.

  • Soporte técnico para productos de cifrado de terceros     Access 2010 le permite usar una tecnología de cifrado terceros, si así lo prefiere. En este artículo no se describe el uso de productos de terceros.

Novedades en 2007

  • La capacidad de ver datos incluso cuando no se quiere habilitar contenido de la base de datos     En Microsoft Office Access 2003, si se establecía el nivel de seguridad en Alto, tenía que codificar y confiar en una base de datos antes de poder ver los datos. Ahora puede ver los datos sin tener que decidir si confía en una base de datos.

  • Mayor facilidad de uso     Si coloca los archivos de base de datos (ya sea en el nuevo formato de archivo de Access o en formatos de archivo anteriores) en una ubicación de confianza, como una carpeta de archivos o un recurso compartido de red que designa como seguro, estos archivos se abrirán y se ejecutarán sin mostrar mensajes de advertencia ni preguntarle si quiere habilitar el contenido deshabilitado. Además, si abre bases de datos de versiones anteriores de Access, como archivos .mdb o .mde, en Access 2010 y dichas bases de datos se han firmado digitalmente y ha elegido confiar en el editor, estos archivos se ejecutarán sin necesidad de tomar decisiones de confianza. Sin embargo, recuerde que el código VBA de una base de datos firmada no se ejecutará hasta que confíe en el editor y no se ejecutará si la firma digital deja de ser válida. Una firma dejará de ser válida cuando otra persona, distinta de quien que lo ha firmado, modifica el contenido de una base de datos.

    Si no está seguro de si debe confiar en un certificado, en el artículo Cómo saber si una firma digital es de confianza se proporciona información general sobre la comprobación de fechas y otros elementos de un certificado para asegurarse de que es válido.

  • Centro de confianza     El Centro de confianza es un cuadro de diálogo que proporciona una ubicación única para establecer y cambiar la configuración de seguridad de Access. Use el Centro de confianza para crear o cambiar ubicaciones de confianza y establecer opciones de seguridad para Access. Estos valores afectan al comportamiento de las bases de datos nuevas y existentes cuando se abren en esa instancia de Access. El Centro de confianza también contiene la lógica para evaluar los componentes de una base de datos y para determinar si es seguro abrir la base de datos o si el Centro de confianza debe deshabilitar la base de datos y permitirle decidir si quiere habilitarla.

    Para obtener información general sobre el uso del Centro de confianza, consulte el artículo Ver mi configuración de seguridad y privacidad en el Centro de confianza.

  • Menos mensajes de advertencia     Las versiones anteriores de Access le obligaban a tratar con diversos de mensajes de alerta, seguridad de macros y modo de espacio aislado, por citar solo dos. De forma predeterminada, si abre un archivo .accdb en el que aún no ha confiado, verá una sola herramienta denominada Barra de mensajes.

    Barra de mensajes

    Si quiere confiar en la base de datos, puede usar la Barra de mensajes para habilitar el contenido deshabilitado de la base de datos: consultas de acción (consultas que agregan, eliminan o cambian datos), macros, controles ActiveX, expresiones (funciones que se evalúan como un valor único) y código VBA, al abrir una base de datos que contenga uno o varios de esos componentes.

  • Nuevas formas para firmar y distribuir archivos de base de datos     En versiones de Access anteriores a 2007, se usaba el Editor de Visual Basic para aplicar un certificado de seguridad a cada componente de la base de datos. Ahora, se empaqueta la base de datos y después se firma y distribuye el paquete.

    Si se extrae una base de datos de un paquete firmado a una ubicación de confianza, la base de datos se abre sin que se muestre la Barra de mensajes. Si se extrae una base de datos de un paquete firmado a una ubicación que no es de confianza, pero tiene confianza en el paquete certificado y la firma es válida, la base se abre sin que se muestre la Barra de mensajes.

    Nota   Cuando una base de datos se empaqueta y se firma como que no es de confianza o contiene una firma digital no válida, tiene que usar la Barra de mensajes para confiar en la base de datos cada vez que la abra, a menos que la coloque en una ubicación de confianza.

  • Un algoritmo más seguro para cifrar bases de datos en el formato de archivo .accdb que usa la característica de contraseña de base de datos     El cifrado de la base codifica los datos de las tablas y ayuda a evitar que usuarios no deseados los lean.

    Nota   Cuando la base de datos se cifra con una contraseña, la base de datos cifrada usará el bloqueo a nivel de página, independientemente de la configuración de la aplicación. Esto puede afectar a la disponibilidad de datos en un entorno compartido.

  • Una nueva subclase de acciones de macros que se ejecutan cuando una base de datos está deshabilitada     Estas macros más seguras también tienen capacidades de control de errores. También puede insertar macros (incluso las que contienen acciones que Access deshabilita) directamente en cualquier formulario, informe o propiedad de control que trabajaría de forma lógica con un módulo de código VBA o una macro de una versión anterior de Access.

Por último, recuerde estas reglas durante el proceso:

  • Si abre una base de datos en una ubicación de confianza, todos los componentes se ejecutan sin necesidad de tomar decisiones de confianza.

  • Si empaqueta, firma e implementa una base de datos con un formato de archivo anterior (archivo .mdb o .mde), todos los componentes se ejecuta sin necesidad de tomar decisiones de confianza si la base de datos contiene una firma digital válida de un editor de confianza y confía en el certificado.

  • Si firma e implementa una base de datos que no es de confianza en una ubicación que tampoco es de confianza, el Centro de confianza deshabilita la base de datos de forma predeterminada, y tiene que habilitar la base de datos cada vez que la abra.

Access y seguridad a nivel de usuario

Access no admite seguridad a nivel de usuario para bases de datos creadas en el nuevo formato de archivo (archivos .accdb y .accde). Sin embargo, si abre una base de datos de una versión anterior de Access en Access 2010 y esa base de datos tiene aplicada seguridad a nivel de usuario, esas configuraciones seguirán funcionando.

Importante   Los permisos creados por medio de la característica de seguridad a nivel de usuario no protegen su base de datos de usuarios con malas intenciones y no están pensados como una barrera de seguridad. Es adecuado usar esta característica para mejorar la facilidad de uso de una base de datos de usuarios de confianza. Para ayudar a mantener sus datos seguros, solo permita que los usuarios de confianza tengan acceso a su archivo de base de datos o a archivos de seguridad a nivel de usuario asociados con los permisos del sistema de archivos de Windows.

Si convierte una base de datos de una versión anterior de Access con seguridad a nivel de usuario al nuevo formato de archivo, Access puede quitar toda la configuración de seguridad automáticamente y se aplicarán las reglas para asegurar un archivo .accdb o .accde.

Por último, recuerde que todos los usuarios pueden ver todos los objetos de la base de datos en todo momento al abrir las bases de datos que tengan el nuevo formato de archivo.

Arquitectura de seguridad de Access

Para comprender la arquitectura de seguridad de Access, tiene que recordar que una base de datos de Access no es un archivo en el mismo sentido que un libro de Excel o un documento de Word. En su lugar, una base de datos de Access es un conjunto de objetos: formularios, tablas, consultas, macros, informes, etc., que a menudo dependen entre sí para funcionar. Por ejemplo, si crea un formulario de entrada de datos, no puede escribir o almacenar datos en ese formulario a menos que enlace (vincule) los controles del formulario a una tabla.

Varios componentes de Access pueden implicar riesgos de seguridad y, por lo tanto, se deshabilitan en una base de datos que no es de confianza:

  • Consultas de acción (consultas que insertan, eliminan o cambian datos)

  • Macros

  • Algunas expresiones (funciones que devuelven un valor único)

  • Código VBA

Para ayudar a asegurar sus datos, Access y el Centro de confianza ejecutan un conjunto de comprobaciones de seguridad cada vez que se abre una base de datos. El proceso funciona de la siguiente forma:

  • Al abrir un archivo .accdb o .accde, Access envía la ubicación de la base de datos al Centro de confianza. Si el Centro de confianza determina que la ubicación es de confianza, la base de datos se ejecuta con funcionalidad completa. Si abre una base de datos en un formato de archivo anterior, Access envía la ubicación del archivo y los detalles sobre su firma digital (si los hay) al Centro de confianza.

    El Centro de confianza comprueba esa "evidencia" para evaluar la confianza de la base de datos y después informa a Access cómo abrir la base de datos. Access deshabilitará la base de datos o la abrirá con funcionalidad completa.

    Nota   Recuerde que la configuración que usted o el administrador del sistema elijan en el Centro de confianza controlará las decisiones de confianza que se producirán cuando Access abra una base de datos.

    Para más información, consulte la sección Vea también.

  • Si el Centro de confianza deshabilita contenido de la base de datos, al abrir la base de datos aparece la Barra de mensajes.

    Barra de mensajes

    Para habilitar el contenido de la base de datos, haga clic en Opciones y después elija las opciones adecuadas en el cuadro de diálogo que aparece. Access habilitará el contenido deshabilitado y la base de datos se volverá a abrir con funcionalidad completa. En caso contrario, los componentes deshabilitados no funcionarán.

  • Si abre una base de datos creada en el formato de archivo anterior (archivos .mdb o .mde) y esa base de datos no está firmada y ni es de confianza, de forma predeterminada Access deshabilita cualquier contenido ejecutable.

Modo Deshabilitado

Cuando el Centro de confianza evalúa una base de datos como que no es de confianza, Access abre dicha base de datos en modo deshabilitado, es decir, desactiva todo el contenido ejecutable, independientemente del formato de archivo de la base de datos.

En el modo Deshabilitado, Access deshabilita los siguientes componentes:

  • Código VBA y cualquier referencia en el código VBA, además de cualquier expresión no segura.

  • Acciones no seguras en todas las macros. Las acciones "no seguras" son acciones que podrían permitir a un usuario modificar la base de datos u obtener acceso a recursos fuera de la base de datos. Sin embargo, las acciones que Access a veces deshabilita pueden considerarse "seguras". Por ejemplo, si confía en la persona que ha creado la base de datos, puede confiar en cualquier acción de macro no segura.

  • Varios tipos de consultas:

    • Consultas de acción     Son las que agregan, actualizan y eliminan datos.

    • Consultas de lenguaje de definición de datos (DDL)     Se usan para crear o modificar objetos de una base de datos, como tablas y procedimientos.

    • Consultas SQL de paso a través    Son las que envían comandos directamente a un servidor de bases de datos compatible con la conectividad abierta de base de datos (ODBC) estándar. Las consultas de paso a través trabajan con las tablas en el servidor sin la participación del motor de base de datos de Access.

  • Controles ActiveX

Cuando se abra una base de datos, es posible que Access intente cargar complementos, programas que amplían la funcionalidad de Access o la base de datos abierta. Es posible que también quiera ejecutar asistentes que crean los objetos en la base de datos abierta. Cuando se carga un complemento o se inicia un asistente, Access pasa evidencia al Centro de confianza, que toma decisiones de confianza adicionales y habilita o deshabilita el objeto o la acción. Siempre que el Centro de confianza deshabilita una base de datos y usted está de acuerdo con esa decisión, casi siempre puede usar la Barra de mensajes para habilitar el contenido. Los complementos proporcionan la excepción a esa regla. Si, en el Centro de confianza (en el panel Complementos), selecciona la casilla Requerir que los complementos de la aplicación estén firmados por un editor de confianza, Access le pide que habilite el complemento, pero ese proceso no afecta a la Barra de mensajes.

Volver al principio

Usar una base de datos de Access en una ubicación de confianza

Cuando se coloca una base de datos de Access en una ubicación de confianza, todo el código VBA, las macros y las expresiones seguras se ejecutan al abrir la base de datos. No tiene que tomar decisiones de confianza mientras se abre la base de datos.

El proceso de usar una base de datos de Access en una ubicación de confianza sigue estos pasos generales:

  1. Usar el Centro de confianza para encontrar o crear una ubicación de confianza.

  2. Guardar, mover o copiar una base de datos de Access a la ubicación de confianza.

  3. Abrir y usar la base de datos.

Los siguientes conjuntos de pasos explican cómo encontrar o crear una ubicación de confianza y después agregar una base de datos a esa ubicación.

Abrir el Centro de confianza

  1. En la pestaña Archivo, haga clic en Opciones.

    Aparece el cuadro de diálogo Opciones de Access.

  2. Haga clic en Centro de confianza y en Centro de confianza de Microsoft Office Access, haga clic en Configuración del Centro de confianza.

  3. Haga clic en Ubicaciones de confianza y después ejecute una de estas acciones:

    • Anote la ruta de acceso de una o varias ubicaciones de confianza.

    • Cree una nueva ubicación de confianza. Para ello, haga clic en Agregar nueva ubicación y después complete las opciones del cuadro de diálogo Ubicación de confianza de Microsoft Office.

Colocar una base de datos en una ubicación de confianza

  • Use su técnica favorita para mover o copiar un archivo de base de datos a una ubicación de confianza. Por ejemplo, puede usar el Explorador de Windows para copiar o mover el archivo, o bien, puede abrir el archivo en Access y guardarlo en la ubicación de confianza.

Abrir una base de datos en una ubicación de confianza

  • Use su técnica favorita para abrir un archivo. Por ejemplo, puede hacer doble clic en el archivo de base de datos en el Explorador de Windows, o bien, si Access se está ejecutando, puede hacer clic en Abrir en la pestaña Archivo para localizar y abrir el archivo.

Volver al principio

Empaquetar, firmar y distribuir una base de datos de Access 2010

Access hace más fácil y rápida la firma y la distribución de una base de datos. Al crear un archivo .accdb o .accde, puede empaquetar el archivo, aplicarle una firma digital al paquete y después distribuir el paquete firmado a otros usuarios. La herramienta de Empaquetar y firmar coloca la base de datos en un archivo implementación de Access (.accdc), firma el archivo y después coloca el paquete firmado en la ubicación que determine. Otros usuarios pueden extraer la base de datos del paquete y trabajar directamente en ella (no en el archivo de paquete).

Durante el proceso, recuerde los siguientes puntos:

  • Empaquetar una base de datos y firmar el paquete es una forma de transmitir confianza. Al empaquetar y firmar una base de datos, la firma digital confirma que la base de datos no se ha modificado después de crear el paquete.

  • Después de extraer la base de datos del paquete, ya no hay ninguna conexión entre el paquete firmado y la base de datos extraída.

  • Puede usar la herramienta de Empaquetar y firmar solo con bases de datos guardadas en formatos de archivo .accdb, .accdc o .accde. Access también proporciona herramientas para firmar y distribuir bases de datos creadas en un formato de archivo anterior. Debe usar la herramienta de firma digital apropiada para el formato de archivo de base de datos que está utilizando.

  • Solo puede agregar una base de datos a un paquete.

  • El proceso firma digitalmente un paquete que contiene toda la base de datos, no solo macros o módulos.

  • El proceso comprime el archivo de paquete para ayudar a reducir los tiempos de descarga.

  • Puede extraer bases de datos de archivos de paquete ubicados en servidores Windows SharePoint Services 3.0.

Los pasos descritos en las siguientes secciones explican cómo crear un archivo de paquete firmado y cómo extraer y usar la base de datos de un archivo de paquete firmado.

Crear un paquete firmado

  1. Abra la base de datos que quiere empaquetar y firmar.

  2. En la pestaña Archivo, haga clic en Guardar y publicar y después en Avanzadas, haga clic en Empaquetar y firmar.

    Aparece el cuadro de diálogo Seleccionar certificado.

  3. Seleccione un certificado y después haga clic en Aceptar.

    Aparece el cuadro de diálogo Crear paquete firmado de Microsoft Office Access.

  4. En la lista Guardar en, seleccione una ubicación para el paquete firmado de base de datos.

  5. Escriba un nombre para el paquete firmado en el cuadro Nombre de archivo y después haga clic en Guardar.

    Access crea el archivo .accdc y lo coloca en la ubicación que ha elegido.

Extraer y usar un paquete firmado

  1. En la pestaña Archivo, haga clic en Abrir.

    Aparece el cuadro de diálogo Abrir.

  2. Seleccione Paquetes firmados de Microsoft Office Access (* .accdc) como el tipo de archivo.

  3. Use la lista Buscar en para buscar la carpeta que contiene su archivo .accdc, seleccione el archivo y después haga clic en Abrir.

  4. Siga uno de los siguientes procedimientos:

    • Si decide confiar en el certificado de seguridad usado para firmar el paquete de implementación, aparece el cuadro de diálogo Extraer base de datos a. Vaya al paso siguiente.

    • Si ha elegido no confiar en el certificado de seguridad, aparece el siguiente mensaje.

      Mensaje de recomendación

      Si confía en la base de datos, haga clic en Abrir. Si confía en cualquier certificado del proveedor, haga clic en Confiar en todo contenido del editor. Aparece el cuadro de diálogo Extraer base de datos a.

      Nota   Si usa un certificado autofirmado para firmar un paquete de base y después hace clic en Confiar en todo contenido del editor al abrir ese paquete, siempre serán de confianza los paquetes firmados usados con sus certificados autofirmados.

  5. Opcionalmente, en la lista Guardar en, seleccione una ubicación para la base de datos extraída y después, en el cuadro Nombre de archivo, escriba otro nombre para la base de datos extraída.

    Sugerencia   Si extrae la base de datos a una ubicación de confianza, su contenido se habilitará automáticamente cada vez que la abra. Si elige una ubicación que no es de confianza, algún contenido de la base puede estar deshabilitado de forma predeterminada.

  6. Haga clic en Aceptar.

Si no está seguro de si debe confiar en un certificado, el artículo Cómo saber si una firma digital es de confianza proporciona información general sobre la comprobación de fechas y otros elementos de un certificado para ayudar a garantizar que es válido.

Volver al principio

Habilitar y deshabilitar contenido al abrir una base de datos

De forma predeterminada, Access deshabilita todo el contenido ejecutable de una base de datos a menos que confíe en la base de datos o la coloque en una ubicación de confianza. Al abrir una base de datos, Access deshabilita el contenido y muestra la Barra de mensajes.

Barra de mensajes

Además, de forma predeterminada, Access ya no muestra un conjunto de cuadros de diálogo modales (cuadros de diálogo que requieren que tome una decisión antes de poder hacer nada más) al abrir una base de datos, como sucedía en Access 2003. Si prefiere ese comportamiento, puede agregar una clave del Registro y mostrar un cuadro de diálogo modal anterior.

Confiar en una base de datos

Independientemente del modo de comportamiento de Access al abrir una base de datos, si dicha base de datos proviene de un editor de confianza, puede elegir habilitar los componentes ejecutables del archivo, para confiar en la base de datos.

  • En la Barra de mensajes, haga clic en Habilitar contenido.

Importante   Al hacer clic en Habilitar contenido, Access habilita todo el contenido deshabilitado, incluidos posible código malintencionado. Si el código malintencionado perjudica sus datos o su equipo, Access no puede deshacer ese daño.

Ocultar la barra de mensajes

  • Haga clic en el botón Cerrar (X) de la esquina superior de la Barra de mensajes.

    La Barra de mensajes se cierra. Volverá a aparecer la próxima vez que abra la base de datos, a menos que mueva la base de datos a una ubicación de confianza.

Agregar la clave del Registro para mostrar cuadros de diálogo modales

Precaución      Una edición incorrecta del Registro podría causar graves daños en el sistema operativo e, incluso, forzar su reinstalación. Microsoft no puede garantizar que puedan resolverse los problemas resultantes de una edición incorrecta del Registro. Antes de editar el Registro, realice una copia de seguridad de todos los datos de valor. Para obtener la información más reciente sobre el uso y la protección del Registro de su equipo, vea la Ayuda de Microsoft Windows.

  1. En Microsoft Windows, haga clic en el botón Inicio y, a continuación, en Ejecutar.

  2. En el cuadro Abrir, escriba regedit y, a continuación, presione ENTRAR.

    Se inicia el Editor del Registro.

  3. Expanda la carpeta HKEY_CURRENT_USER y desplácese a la clave del Registro siguiente:

    Software\Microsoft\Office\14.0\Access\Security

  4. En el panel derecho del Editor del Registro, haga clic con el botón secundario en el área en blanco, seleccione Nuevo y haga clic en Valor DWORD. Aparece un nuevo valor DWORD en blanco.

  5. Escriba el siguiente nombre para el valor: ModalTrustDecisionOnly.

  6. Haga doble clic en el nuevo valor.

    Aparece el cuadro de diálogo Editar valor DWORD.

  7. En el campo Información del valor, cambie el valor de 0 a 1 y después haga clic en Aceptar.

  8. Cierre el Editor del Registro.

Ahora, al abrir una base de datos con contenido no seguro, verá una serie de cuadros de diálogo en lugar de la Barra de mensajes. Para volver al comportamiento original, repita estos pasos y cambie el valor de 1 a 0.

Volver al principio

Usar una contraseña de base de datos para cifrar una base de datos de Access

La herramienta de cifrado de Access combina y mejora dos herramientas anteriores: codificación y contraseñas de base de datos. Al usar una contraseña de base de datos para cifrar una base de datos, hace que todos los datos sean ilegibles por otras herramientas y obliga a los usuarios a escribir una contraseña para usar la base de datos. El cifrado aplicado en Access 2010 usa un algoritmo más seguro que el que utilizaban versiones anteriores de Access.

Nota   Si usa una contraseña de base de datos de Access 2007 para cifrar una base de datos, es posible que quiera cambiar a la nueva tecnología de cifrado, lo que ayuda a proporcionar una mayor seguridad.

Cambiar una base de datos de Access 2007 cifrada a la nueva tecnología de cifrado

Para cambiar a la nueva tecnología de cifrado, quite la contraseña actual de la base de datos y después vuelva a agregarla.

Cifrar con una contraseña de base de datos

  1. Abra la base de datos que quiere cifrar en modo exclusivo.

    Abrir la base de datos en modo exclusivo.

    1. En la pestaña Archivo, haga clic en Abrir.

    2. En el cuadro de diálogo Abrir, busque y seleccione el archivo que desee abrir.

    3. Haga clic en la flecha que aparece junto al botón Abrir y después haga clic en Abrir en modo exclusivo.

      Abrir un archivo en modo exclusivo

  2. En la pestaña Archivo, haga clic en Información y después en Cifrar con contraseña.

    Aparece el cuadro de diálogo Establecer contraseña para la base de datos.

  3. Escriba la contraseña en el cuadro Contraseña y vuelva a escribirla en el campo Comprobar.

    Notas  Use contraseñas seguras en las que se combinen mayúsculas, minúsculas, números y símbolos. En las contraseñas no seguras estos elementos no se combinan. Contraseña segura: Y6dh!et5. Contraseña no segura: Casa27. Las contraseñas deben tener una longitud mínima de 8 caracteres. Una frase de contraseña en la que se usan 14 o más caracteres es todavía mejor. Para obtener más información, vea el tema sobre cómo proteger la información personal con contraseñas seguras.

    Es fundamental que recuerde la contraseña. Si la olvida, Microsoft no podrá recuperarla. Guarde las contraseñas que anote en un lugar seguro, lejos de la información que ayudan a proteger.

  4. Haga clic en Aceptar.

Descifrar y abrir una base de datos

  1. Abra la base de datos cifrada del mismo modo que cualquier otra base de datos.

    Aparece el cuadro de diálogo Solicitud de contraseña.

  2. Escriba la contraseña en el cuadro Escriba la contraseña de la base de datos y, a continuación, haga clic en Aceptar.

Quitar una contraseña

  1. En la pestaña Archivo, haga clic en Información y después en Descifrar base de datos.

    Aparece el cuadro de diálogo Anular la contraseña establecida para la base de datos.

  2. Escriba la contraseña en el cuadro Contraseña y, a continuación, haga clic en Aceptar.

Volver al principio

Cómo funciona la seguridad con bases de datos de versiones anteriores de Access abiertas en Access 2010

Al abrir una base de datos creada en una versión anterior de Microsoft Access, las características de seguridad aplicadas a esa base de datos siguen funcionando. Por ejemplo, si ha aplicado seguridad a nivel de usuario a una base de datos, la característica funciona en Access 2010.

De forma predeterminada, Access abre las bases de datos anteriores que no son de confianza en modo Deshabilitado y las mantiene en dicho estado. Cada vez que abra la base de datos anterior puede elegir habilitar cualquier contenido deshabilitado, o bien, puede aplicar una firma digital con un certificado de un editor de confianza o puede colocar la base de datos en una ubicación de confianza.

Importante   Los pasos descritos en esta sección no se aplican a bases de datos que usan uno de los nuevos formatos de archivo (* .accd?).

Para bases de datos en un formato de archivo anterior, puede aplicar una firma digital a los componentes de la base de datos. Una firma digital confirma que las macros, los módulos de código y otros componentes ejecutables de la base de datos se han originado con el firmante y que nadie los ha modificado desde se firmó la base de datos.

Para aplicar una firma a su base de datos, primero necesita un certificado digital. Si crea bases de datos para distribución comercial, debe obtener un certificado de una entidad emisora de certificados comercial (CA). Las entidades emisoras de certificados realizan comprobaciones exhaustivas para verificar que las personas que crean contenido (como bases de datos) son programadores acreditados.

Para más información sobre entidades emisoras de certificados que ofrecen servicios para los productos de Microsoft, consulte la sección Vea también.

Si quiere usar una base de datos para escenarios personales o grupos de trabajo limitados, Microsoft Office Professional 2007 proporciona una herramienta para crear un certificado autofirmado. Los pasos descritos en las siguientes secciones explican cómo instalar y usar una herramienta denominada SelfCert.exe para crear un certificado autofirmado.

Crear un certificado autofirmado

  1. Vaya a la carpeta que contiene sus archivos de programa de Office 2010. La carpeta predeterminada es unidad:\Archivos de programa\Microsoft Office\Office14. En esa carpeta, busque y haga doble clic en SelfCert.exe.

    Aparece el cuadro de diálogo Crear certificado digital.

  2. En el cuadro Nombre del certificado, escriba un nombre para el nuevo certificado.

  3. Haga clic en Aceptar dos veces.

Nota   Si no ve el comando Certificado digital para proyectos de VBA o no puede encontrar SelfCert.exe, es posible que tenga que instalar SelfCert.

Código para firmar una base de datos

Nota   Recuerde que estos pasos solo se aplican cuando utiliza bases de datos que usan un formato de archivo de base de datos anterior, como un archivo .mdb.

  1. Abra la base de datos que quiere firmar.

  2. En la pestaña Herramientas de base de datos, en el grupo Macro, haga clic en Visual Basic para iniciar el Editor de Visual Basic.

    Método abreviado de teclado  Presione ALT+F11.

  3. En la ventana Explorador de proyectos, seleccione la base de datos o el proyecto de Visual Basic para Aplicaciones (VBA) que quiere firmar.

  4. En el menú Herramientas, haga clic en Firma digital.

    Aparece el cuadro de diálogo Firma digital.

  5. Haga clic en Elegir para seleccionar el certificado de prueba.

    Aparece el cuadro de diálogo Seleccionar certificado.

  6. Seleccione el certificado que quiere aplicar.

    Si ha seguido los pasos de la sección anterior, seleccione el certificado que ha creado con SelfCert.

  7. Haga clic en Aceptar para cerrar el cuadro de diálogo Certificado autofirmado y haga clic en Aceptar de nuevo para cerrar el cuadro de diálogo Firma digital.

Sugerencias para firmar bases de datos de versiones anteriores

  • Si quiere evitar que los usuarios de su solución de modifique accidentalmente su proyecto VBA e invalidar su firma, bloquee el proyecto VBA antes de firmarlo.

    Nota   El bloqueo del proyecto VBA no evita que otro usuario reemplace la firma digital con otra firma. Los administradores corporativos pueden volver a firmar las plantillas y los complementos para que puedan controlar exactamente lo que los usuarios pueden ejecutar en sus equipos.

  • Al firmar digitalmente un proyecto VBA, piense en obtener una marca de tiempo para que otros usuarios puedan comprobar su firma incluso después de que el certificado usado para la firma haya caducado. Consulte Microsoft Office Online para más información sobre seguridad VBA y marcas de tiempo.

Nota   Recuerde que estos pasos solo se aplican al usar las bases de datos con un formato de archivo anterior en Access 2010.

Instalar SelfCert.exe

  1. Inicie el CD del programa de instalación de Office 2010 u otro medio de instalación.

  2. En el programa de instalación, haga clic en Agregar o quitar funciones y después en Continuar.

    Nota   Si trabaja en un entorno en el que Microsoft Office está instalado en equipos individuales por los administradores de TI en lugar de mediante un CD, siga estos pasos:

    1. En Microsoft Windows, abra el Panel de control.

    2. Haga doble clic en Programas y características.

    3. Seleccione Microsoft Office 2010y después haga clic en Cambiar.

      El programa de instalación se inicia.

    4. Haga clic en Agregar o quitar funciones y después en Continuar.

    5. Continúe con los pasos siguientes.

  3. Expanda los nodos Microsoft Office y Funciones compartidas de Office haciendo clic en los signos más (+) junto a ellos.

  4. Haga clic en Certificado digital para proyectos de VBA.

  5. Haga clic en Ejecutar desde mi PC.

  6. Haga clic en Continuar para instalar el componente.

  7. Haga clic en Cerrar una vez finalizada la instalación y después vuelva al primer conjunto de pasos de esta sección.

Volver al principio

Ejecutar expresiones no seguras (deshabilitar el modo de espacio aislado)

Al agregar una expresión en una base de datos y después confiar en la base de datos o colocarla en una ubicación de confianza, Access ejecute esa expresión en un entorno operativo denominado modo de espacio aislado. Access hace esto para las bases de datos creadas en cualquier Access o en formatos de archivo anteriores de Access. Access habilita el modo de espacio aislado de forma predeterminada y dicho modo siempre deshabilita expresiones no seguras, incluso después de haber confiado en una base de datos. Para más información sobre las expresiones que el deshabilita el modo de espacio aislado, consulte el artículo de Microsoft Office.comAcerca del modo de espacio aislado del Servicio de expresiones de Microsoft Jet.

Si confía en una base de datos y quiere ejecutar una expresión deshabilitada por el modo de espacio aislado, puede ejecutar esa expresión cambiando una clave del Registro y deshabilitando el modo de espacio aislado. Recuerde que, para seguir estos pasos, primero debe confiar en una base de datos.

La siguiente ilustración muestra el proceso de decisión que sigue para ejecutar expresiones no seguras.

Proceso de decisión para el modo de recinto de seguridad

Precaución      Una edición incorrecta del Registro podría causar graves daños en el sistema operativo e, incluso, forzar su reinstalación. Microsoft no puede garantizar que puedan resolverse los problemas resultantes de una edición incorrecta del Registro. Antes de editar el Registro, realice una copia de seguridad de todos los datos de valor. Para obtener la información más reciente sobre el uso y la protección del Registro de su equipo, vea la Ayuda de Microsoft Windows.

Si no está familiarizado con el Registro o no está cómodo con el cambio de claves del Registro, póngase en contacto con alguien que sí lo esté, o piense en convertir una base de datos de una versión anterior de Access a un formato de archivo más reciente. Además, debe tener permisos de administrador en el equipo para cambiar valores del Registro.

Cambiar la clave del Registro

Importante   La realización de estos pasos permite la ejecución de expresiones no seguras en todas las versiones de Access para todos los usuarios de un equipo.

  1. En Microsoft Windows, haga clic en el botón Inicio y, a continuación, en Ejecutar.

  2. En el cuadro Abrir, escriba regedit y, a continuación, presione ENTRAR.

    Se inicia el Editor del Registro.

  3. Expanda la carpeta HKEY_LOCAL_MACHINE y desplácese a la clave del Registro siguiente:

    \Software\Microsoft\Office\14.0\Access Connectivity Engine\Engines

  4. En el panel derecho del Editor del Registro, haga doble clic en el valor SandboxMode.

    Aparece el cuadro de diálogo Editar valor DWORD.

  5. En el campo Información del valor, cambie el valor de 3 a 2 y, a continuación, haga clic en Aceptar.

  6. Cierre el Editor del Registro.

Importante    Recuerde que si no confía primero en la base de datos, Access deshabilita las expresiones no seguras con independencia de que cambie este valor del Registro.

Volver al principio

Se aplica a: Access 2010



¿Le ha sido útil esta información?

No

¿Cómo podemos mejorarlo?

255 caracteres restantes

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!

Recursos de soporte técnico

Cambiar idioma