Función SI

Devuelve un valor si la condición especificada es VERDADERO y otro valor si dicho argumento es FALSO.

Utilice SI para realizar pruebas condicionales en valores y fórmulas.

Sintaxis

SI(prueba_lógica;valor_si_verdadero;valor_si_falso)

Prueba_lógica     es cualquier valor o expresión que pueda evaluarse como VERDADERO o FALSO. Por ejemplo, A10=100 es una expresión lógica; si el valor de la celda A10 es igual a 100, la expresión se evalúa como VERDADERO. De lo contrario, se evaluará como FALSO. Este argumento puede utilizar cualquier operador de comparación.

Valor_si_verdadero      es el valor que se devuelve si el argumento prueba_lógica es VERDADERO. Por ejemplo, si este argumento es la cadena de texto "Dentro de presupuesto" y el argumento prueba_lógica se evalúa como VERDADERO, la función SI muestra el texto "Dentro de presupuesto". Si el argumento prueba_lógica es VERDADERO y el argumento valor_si_verdadero está en blanco, este argumento devuelve 0 (cero). Para mostrar la palabra VERDADERO, utilice el valor lógico VERDADERO para este argumento. Valor_si_verdadero puede ser otra fórmula.

Valor_si_falso      es el valor que se devuelve si el argumento prueba_lógica es FALSO. Por ejemplo, si este argumento es la cadena de texto "Presupuesto excedido" y el argumento prueba_lógica se evalúa como FALSO, la función SI muestra el texto "Presupuesto excedido". Si el argumento prueba_lógica es FALSO y se omite valor_si_falso, (es decir, después de valor_si_verdadero no hay ninguna coma), se devuelve el valor lógico FALSO. Si prueba_lógica es FALSO y valor_si_falso está en blanco (es decir, después de valor_si_verdadero hay una coma seguida por el paréntesis de cierre), se devuelve el valor 0 (cero). Valor_si_falso puede ser otra fórmula.

Observaciones

  • Es posible anidar hasta 64 funciones SI como argumentos valor_si_verdadero y valor_si_falso para crear pruebas más complicadas. (Vea el ejemplo 3 para ver una muestra de funciones SI anidadas). Como alternativa, para comprobar muchas condiciones, plantéese usar las funciones BUSCAR, BUSCARV o BUSCARH. (Vea el ejemplo 4 para obtener una muestra de la función BUSCARH.)

  • Cuando los argumentos valor_si_verdadero y valor_si_falso se evalúan, la función SI devuelve el valor devuelto por la ejecución de las instrucciones.

  • Si uno de los argumentos de la función SI es una matriz, cada elemento de la matriz se evaluará cuando se ejecute la instrucción SI.

  • Microsoft Excel proporciona funciones adicionales que se pueden utilizar para analizar los datos en función de una condición. Por ejemplo, para contar el número de veces que una cadena de texto o un número aparecen dentro de un rango de celdas, utilice las funciones de hoja de cálculo CONTAR.SI y CONTAR.SI.CONJUNTO. Para calcular una suma basándose en una cadena de texto o un número de un rango, utilice las funciones SUMAR.SI y SUMAR.SI.CONJUNTO.

Ejemplo 1

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

Cómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.

  2. Seleccione el ejemplo en el tema de Ayuda.

    Nota   No seleccione los encabezados de fila ni de columna.

    Seleccionar un ejemplo de la Ayuda

    Seleccionar un ejemplo de la Ayuda

  3. Presione CTRL+C.

  4. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

  5. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en el grupo Auditoría de fórmulas de la ficha Fórmulas, haga clic en el botón Mostrar fórmulas.

1

2

A

Datos

50

Fórmula

Descripción (resultado)

=SI(A2<=100;"Dentro de presupuesto";"Presupuesto excedido")

Si el número anterior es igual o menor que 100, la fórmula muestra "Dentro de presupuesto". De lo contrario, la función mostrará "Presupuesto excedido" (Dentro de presupuesto)

=SI(A2=100;SUMA(B5:B15);"")

Si el número anterior es 100, se calcula el rango B5:B15. En caso contrario, se devuelve texto vacío ("") ()

Ejemplo 2

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

Cómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.

  2. Seleccione el ejemplo en el tema de Ayuda.

    Nota   No seleccione los encabezados de fila ni de columna.

    Seleccionar un ejemplo de la Ayuda

    Seleccionar un ejemplo de la Ayuda

  3. Presione CTRL+C.

  4. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

  5. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en el grupo Auditoría de fórmulas de la ficha Fórmulas, haga clic en el botón Mostrar fórmulas.

1

2

3

4

A

B

Gastos reales

Gastos previstos

1500

900

500

900

500

925

Fórmula

Descripción (resultado)

=SI(A2>B2;"Presupuesto excedido";"Aceptar")

Comprueba si la primera fila sobrepasa el presupuesto (Presupuesto excedido)

=SI(A3>B3;"Presupuesto excedido";"Aceptar")

Comprueba si la segunda fila sobrepasa el presupuesto (Aceptar)

Ejemplo 3

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

Cómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.

  2. Seleccione el ejemplo en el tema de Ayuda.

    Nota   No seleccione los encabezados de fila ni de columna.

    Seleccionar un ejemplo de la Ayuda

    Seleccionar un ejemplo de la Ayuda

  3. Presione CTRL+C.

  4. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

  5. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en el grupo Auditoría de fórmulas de la ficha Fórmulas, haga clic en el botón Mostrar fórmulas.

1

2

3

4

A

Puntuación

45

90

78

Fórmula

Descripción (resultado)

=SI(A2>89,"A",SI(A2>79;"B";SI(A2>69;"C";SI(A2>59;"D";"F"))))

Asigna una puntuación de una letra al primer resultado (F)

=SI(A3>89;"A";SI(A3>79;"B";SI(A3>69;"C";SI(A3>59;"D";"F"))))

Asigna una puntuación de una letra al segundo resultado (A)

=SI(A4>89;"A";SI(A4>79;"B";SI(A4>69;"C";SI(A4>59;"D";"F"))))

Asigna una puntuación de una letra al tercer resultado (C)

En el ejemplo anterior, la segunda instrucción SI representa también el argumento valor_si_falso de la primera instrucción SI. De manera similar, la tercera instrucción SI es el argumento valor_si_falso de la segunda instrucción SI. Por ejemplo, si el primer argumento prueba_lógica (Promedio>89) es VERDADERO, se devuelve el valor "A". Si el primer argumento prueba_lógica es FALSO, se evalúa la segunda instrucción SI y así sucesivamente.

Las letras de puntuación se asignan a números utilizando la siguiente clave.

Si la puntuación es

La función devuelve

Mayor que 89

A

De 80 a 89

B

De 70 a 79

C

De 60 a 69

D

Menor que 60

F

Ejemplo 4

En este ejemplo se utiliza la función BUSCAR en lugar de SI, ya que hay que comprobar trece condiciones y puede resultar más fácil de leer y mantener.

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

Cómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.

  2. Seleccione el ejemplo en el tema de Ayuda.

    Nota   No seleccione los encabezados de fila ni de columna.

    Seleccionar un ejemplo de la Ayuda

    Seleccionar un ejemplo de la Ayuda

  3. Presione CTRL+C.

  4. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

  5. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en el grupo Auditoría de fórmulas de la ficha Fórmulas, haga clic en el botón Mostrar fórmulas.

1

2

3

4

A

Puntuación

45

90

78

Fórmula

Descripción (resultado)

=BUSCAR(A2;{0;60;63;67;70;73;77;80;83;87;90;93;97},{"F";"D-";"D";"D+";"C-";"C";"C+";"B-";"B";"B+";"A-";"A";"A+"})

Asigna una puntuación de una letra al primer resultado (F)

=BUSCAR(A3;{0;60;63;67;70;73;77;80;83;87;90;93;97},{"F";"D-";"D";"D+";"C-";"C";"C+";"B-";"B";"B+";"A-";"A";"A+"})

Asigna una puntuación de una letra al segundo resultado (A-)

=BUSCAR(A4;{0;60;63;67;70;73;77;80;83;87;90;93;97},{"F";"D-";"D";"D+";"C-";"C";"C+";"B-";"B";"B+";"A-";"A";"A+"})

Asigna una puntuación de una letra al tercer resultado (C+)

Se aplica a: Excel 2007



¿Le ha sido útil esta información?

No

¿Cómo podemos mejorarlo?

255 caracteres restantes

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!

Recursos de soporte técnico

Cambiar idioma