CONTAR.SI (función CONTAR.SI)

Use CONTAR.SI, una de las funciones estadísticas, para contar el número de celdas que cumplen un criterio; por ejemplo, para contar el número de veces que una ciudad determinada aparece en una lista de clientes.

Sintaxis

CONTAR.SI(rango;criterios)

Por ejemplo:

  • =CONTAR.SI(A2:A5;"manzanas")

  • =CONTAR.SI(A2:A5;A4)

Nombre del argumento

Descripción

Rango    (obligatorio)

El grupo de celdas que desea contar. Rango puede contener números, matrices o referencias que contengan números. Se omiten los valores en blanco o de texto.

Obtenga información sobre cómo seleccionar rangos en una hoja.

Criterios    (obligatorio)

Número, expresión, referencia de celda o cadena de texto que determina las celdas que se van a contar.

Por ejemplo, puede usar un número como 32, una comparación como ">32", una celda como B4 o una palabra como "manzanas".

CONTAR.SI usa solo un criterio. Use CONTAR.SI.CONJUNTO si desea usar varios criterios.

Ejemplos

Para utilizar estos ejemplos en Excel, copie los datos de la tabla de abajo y péguela en la celda A1 de una nueva hoja de cálculo.

Datos

Datos

manzanas

32

naranjas

54

melocotones

75

manzanas

86

Fórmula

Descripción

=CONTAR.SI(A2:A5;"manzanas")

Cuenta el número de celdas con manzanas entre las celdas A2 y A5. El resultado es 2.

=CONTAR.SI(A2:A5;A4)

Cuenta el número de celdas con melocotones (con el criterio de A4) entre las celdas A2 y A5. El resultado es 1.

=CONTAR.SI(A2:A5;A3)+CONTAR.SI(A2:A5;A2)

Cuenta el número de celdas con naranjas (con el criterio de A3) y manzanas (con el criterio de A2) entre las celdas A2 y A5. El resultado es 3.

=CONTAR.SI(B2:B5;">55")

Cuenta el número de celdas con un valor superior a 55 entre las celdas B2 y B5. El resultado es 2.

=CONTAR.SI(B2:B5;"<>"&B4)

Cuenta el número de celdas con un valor distinto de 75 entre las celdas B2 y B5. El símbolo de la "y" (&) combina el operador de comparación "<>" (no es igual a) y el valor de B4 para leer =CONTAR.SI(B2:B5,"<>75"). El resultado es 3.

=CONTAR.SI(B2:B5;">=32")-CONTAR.SI(B2:B5;">85")

Cuenta el número de celdas con un valor superior o igual a 32 e inferior o igual a 85 entre las celdas B2 y A5. El resultado es 3.

=CONTAR.SI(A2:A5,"*")

Cuenta el número de celdas que contienen texto entre las celdas A2 y A5. El carácter comodín * se usa para reemplazar cualquier carácter. El resultado es 4.

=CONTAR.SI(A2:A5,"?????es")

Cuenta el número de celdas que tienen exactamente 7 caracteres que terminan con las letras es entre las celdas A2 y A5. El carácter comodín ? se usa para reemplazar caracteres individuales. El resultado es 2.

Problemas comunes

Problema

Qué ha fallado

Se devolvió un valor incorrecto para cadenas largas.

La función CONTAR.SI devuelve resultados incorrectos cuando se usa para comparar cadenas de más de 255 caracteres.

Para comparar cadenas de más de 255 caracteres, use la función CONCATENAR o el operador concatenar &. Por ejemplo, =CONTAR.SI(A2:A5,"cadena larga"&"otra cadena larga").

No se devolvió ningún valor cuando se esperaba uno.

Asegúrese de encerrar el argumento de criterios entre comillas.

Prácticas recomendadas

Realice este procedimiento

¿Por qué?

Tenga en cuenta que CONTAR.SI pasa por alto mayúsculas y minúsculas en las cadenas de texto.

Los criterios no distinguen entre mayúsculas y minúsculas. En otras palabras, la cadena "manzanas" y la cadena "MANZANAS" darán como resultado la misma cantidad de celdas.

Use caracteres comodín.

Los caracteres comodín, que son el signo de interrogación (?) y el asterisco (*), pueden usarse en los criterios. El signo de interrogación corresponde a un solo carácter cualquiera, y el asterisco equivale a cualquier secuencia de caracteres. Si desea buscar un signo de interrogación o un asterisco reales, escriba una tilde (~) detrás del carácter.

Por ejemplo, =CONTAR.SI(A2:A5,"manzana?") contará todas las instancias de "manzana" con una última letra que podrá variar.

Asegúrese de que los datos no contienen caracteres incorrectos.

Al contar valores de texto, asegúrese de que los datos no contienen espacios al principio ni al final, de que no haya un uso incoherente de las comillas rectas (' o ") ni tipográficas (‘ o “) y de que no haya caracteres no imprimibles. En estos casos, CONTAR.SI puede devolver un valor inesperado o incorrecto.

Es posible que necesite eliminar los espacios finales en una celda, después de los valores de tabla, para obtener resultados precisos. Pruebe a usar la función LIMPIAR o la función SUPRESP.

Relacionado

Se aplica a: Excel 2010, Excel Starter, Excel 2016 Preview, Excel 2007, Excel for Mac 2011, Excel 2013, Excel 2016 for Mac, Excel Online



¿Le ha sido útil esta información?

No

¿Cómo podemos mejorarlo?

255 caracteres restantes

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!

Recursos de soporte técnico

Cambiar idioma