Mostrar u ocultar valores cero

Es posible que tenga una preferencia personal para mostrar los valores cero en una celda, o es posible que esté utilizando una hoja de cálculo que se adhiera a un conjunto de estándares de formato que requieran que se oculten los valores cero. Hay varias maneras para mostrar u ocultar los valores cero.

¿Qué acción desea realizar?

Mostrar u ocultar todos los valores cero en una hoja de cálculo

Usar un formato de número para ocultar los valores cero en las celdas seleccionadas

Usar un formato condicional para ocultar los valores cero devueltos por una fórmula

Usar una fórmula para mostrar ceros como espacios o guiones

Ocultar los valores cero en un informe de tabla dinámica

Mostrar u ocultar todos los valores cero en una hoja de cálculo

  1. Haga clic en el botón de Microsoft Office Imagen del botón de Microsoft Office, haga clic en Opciones de Excel y, luego, haga clic en la categoría Opciones avanzadas.

  2. En Mostrar opciones para esta hoja, seleccione una hoja de cálculo y, a continuación, siga uno de los procedimientos siguientes:

    • Para mostrar valores cero (0) en celdas, active la casilla Mostrar un cero en celdas que tienen un valor cero.

    • Para mostrar valores cero como celdas en blanco, desactive la casilla Mostrar un cero en celdas que tienen un valor cero.

Parte superior de la página

Usar un formato de número para ocultar los valores cero en las celdas seleccionadas

Siga estos pasos para ocultar valores cero en celdas seleccionadas. Si el valor de una de estas celdas cambia a un valor distinto de cero, el formato del valor será similar al formato de número general.

  1. Seleccione las celdas que contengan los valores cero (0) que se desee ocultar.

  2. En la pestaña Inicio, en el grupo Celdas, haga clic en Formato y luego en Formato de celdas.

  3. En la lista Categoría, haga clic en Personalizar.

  4. En el cuadro Tipo, escriba 0;-0;;@.

Nota  

  • Los valores ocultos solo aparecen en la barra de fórmulas barra de fórmulas —o en la celda si edita dentro de la celda— y no se imprimen.

  • En la pestaña Inicio, en el grupo Celdas, haga clic en Formato y luego en Formato de celdas.

  • Para mostrar los valores ocultos nuevamente, seleccione las celdas y, luego, en la pestaña Inicio, en el grupo Celdas, seleccione Formato y haga clic en Formato de celdas. En la lista Categoría, haga clic en General para aplicar el formato de número predeterminado. Para volver a mostrar una fecha o una hora, seleccione el formato de fecha u hora correspondiente en la pestaña Número.

Parte superior de la página

Usar un formato condicional para ocultar los valores cero devueltos por una fórmula

  1. Seleccione la celda que contenga el valor cero (0).

  2. En la pestaña Inicio, en el grupo Estilos, haga clic en la flecha situada junto a Formato condicional, seleccione Resaltar reglas de celdas y, luego, haga clic en Igual que.

  3. En el cuadro de la izquierda, escriba 0.

  4. En el cuadro de la derecha, seleccione Formato personalizado.

  5. En el cuadro de diálogo Formato de celdas, haga clic en la pestaña Fuente.

  6. En el cuadro Color, seleccione blanco.

Parte superior de la página

Usar una fórmula para mostrar ceros como espacios o guiones

Para realizar esta tarea, use la función SI.

Ejemplo

El ejemplo será más fácil de entender si lo copia a una hoja de cálculo en blanco.

¿Cómo se copia un ejemplo?

  1. Seleccione el ejemplo de este artículo.

Importante  No seleccione los encabezados de columna o de fila.

seleccionar un ejemplo de la ayuda de Excel 2013 para Windows

Seleccionar un ejemplo de la Ayuda

  1. Presione CTRL+C.

  2. En Excel, cree un libro o una hoja de cálculo en blanco.

  3. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

Importante  Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

  1. Para cambiar entre la visualización de resultados y la de las fórmulas que devuelven los resultados, pulse ALT+º (ordinal masculino) o, en la pestaña Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.

1

2

3

4

5


6

7

A

B

Datos

10

10

Fórmula

Descripción (resultado)

=A2-A3

Se resta el segundo número del primero (0).

=SI(A2-A3=0,"",A2-A3)

Devuelve una celda en blanco cuando el valor es cero (celda en blanco).

=SI(A2-A3=0,"-",A2-A3

Devuelve un guión cuando el valor es cero (-).

Para más información sobre cómo usar esta función, vea Función SI.

Parte superior de la página

Ocultar los valores cero en un informe de tabla dinámica

  1. Haga clic en el informe de tabla dinámica.

  2. En la pestaña Opciones, en el grupo Opciones de tabla dinámica, haga clic en la flecha junto a Opciones y, a continuación, en Opciones.

  3. Haga clic en la pestaña Diseño y formato y siga uno o varios de los procedimientos siguientes:

    Cambiar el modo en que se muestran los errores    Active la casilla Para valores erróneos, mostrar debajo de Formato. En el cuadro, escriba el valor que desee mostrar en lugar de los errores. Para mostrar errores como celdas en blanco, elimine todos los caracteres del cuadro.

    Cambiar el modo en que se muestran las celdas vacías    Active la casilla Para celdas vacías, mostrar. En el cuadro, escriba el valor que desea mostrar en las celdas vacías. Para mostrar celdas en blanco, elimine todos los caracteres del cuadro. Para mostrar ceros, desactive la casilla.

Parte superior de la página

Se aplica a: Excel 2007



¿Le ha sido útil esta información?

No

¿Cómo podemos mejorarlo?

255 caracteres restantes

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!

Recursos de soporte técnico

Cambiar idioma