Office
Iniciar sesión

Utilizar valores de una base de datos de SQL Server para rellenar un cuadro de lista, cuadro de lista desplegable o cuadro combinado

Nota:  Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Puede rellenar un cuadro de lista, cuadro de lista desplegable o cuadro combinado con datos de una conexión de datos de consulta a una base de datos de Microsoft SQL Server.

En este artículo

Información general

Antes de empezar

Paso 1: Agregue una conexión de datos de consulta

Paso 2: Configure el control

Información general

Un cuadro de lista, cuadro de lista desplegable o cuadro combinado muestra los elementos que puede seleccionar el usuario al rellenar un formulario que se basa en la plantilla de formulario. Puede configurar estos tipos de controles para mostrar los datos de una conexión de datos secundaria a una base de datos de Microsoft SQL Server. Una conexión de datos secundaria es cualquier conexión de datos a un origen de datos externo que agrega a una plantilla de formulario para que los usuarios que rellenen formularios basados en esta plantilla de formulario pueden obtener los datos o enviar datos a un origen de datos externos, como un servicio Web.

Cuando se agrega una conexión de datos secundaria que consulta datos a la plantilla de formulario, Microsoft Office InfoPath crea un secundario origen de datos con grupos y campos de datos que corresponde a la forma en que los datos se almacena en la base de datos. La conexión de datos de consulta obtiene los datos del servicio Web y almacena los datos en el origen de datos secundarios del formulario. De forma predeterminada, los datos de origen de datos secundario están disponibles sólo mientras los usuarios están conectados a una red. Puede configurar la conexión de datos secundaria para guardar los resultados de la consulta en los equipos de los usuarios para que tengan acceso a los datos cuando su formulario no está conectado a una red.

Nota de seguridad: Si está utilizando una conexión de datos secundaria para recuperar datos confidenciales desde un origen de datos externos, desea deshabilitar esta característica para ayudar a proteger los datos de uso no autorizado en caso de que se robe o se pierda el equipo. Si deshabilita esta característica, los datos estará disponibles únicamente si el usuario está conectado a la red.

Dado que la estructura de datos en el origen de datos secundario debe coincidir con la forma en que los datos se almacenan en la base de datos, no puede modificar los campos existentes o grupos en el origen de datos secundario. En la sección Vea también encontrará vínculos a más información sobre las conexiones de datos y orígenes de datos.

Volver al principio

Antes de empezar

Antes de que puede usar valores de una base de datos de SQL Server para rellenar un control en la plantilla de formulario, necesita la siguiente información al administrador de la base de datos:

  • El nombre del servidor con la base de datos que va a utilizar con esta plantilla de formulario.

  • El nombre de la base de datos que va a utilizar con esta plantilla de formulario.

  • La autenticación requerida por la base de datos. La base de datos puede usar autenticación de Windows de Microsoft o la autenticación de SQL Server para determinar cómo los usuarios pueden acceder a la base de datos.

  • El nombre de la tabla que contiene los datos que desea enviar el formulario. Esta es la tabla principal. Si planea usar más de una tabla en la base de datos, necesita los nombres de las otras, las tablas secundarias. También debe los nombres de los campos de las tablas secundarias que tienen relaciones con los campos de la tabla principal.

  • Si puede almacenar con seguridad los resultados de la consulta en los equipos de los usuarios para su uso sin conexión.

Volver al principio

Paso 1: Agregue una conexión de datos de consulta

Si no tiene una conexión de datos de consulta existente que puede usar en la plantilla de formulario, siga estos pasos para agregar una conexión de datos secundaria a la plantilla de formulario que consulta datos. Si la plantilla de formulario ya tiene una conexión de datos secundaria que puede usar, puede omitir esta sección y vaya a paso 2: Configure el control.

  1. En el menú Herramientas, haga clic en Conexiones de datos.

  2. En el cuadro de diálogo Conexiones de datos, haga clic en Agregar.

  3. En el Asistente para la conexión de datos, haga clic en crear una nueva conexión para, haga clic en recibir datos y, a continuación, haga clic en siguiente.

  4. En la siguiente página del asistente, haga clic en base de datos (Microsoft SQL Server o Microsoft Office Access) y, a continuación, haga clic en siguiente.

  5. En la siguiente página del asistente, haga clic en Seleccionar base de datos.

  6. En el cuadro de diálogo Seleccionar origen de datos, haga clic en Nuevo origen.

  7. En la siguiente página del asistente, en la lista ¿qué tipo de origen de datos desea conectarse a, haga clic en Microsoft SQL Server y, a continuación, haga clic en siguiente.

  8. En el cuadro nombre del servidor, escriba el nombre del servidor que contiene la base de datos de SQL Server.

  9. En las credenciales de inicio de sesión, siga uno de estos procedimientos:

    • Si la base de datos determina quién tiene acceso basado en las credenciales utilizadas en una red de Microsoft Windows, haga clic en Usar autenticación de Windows.

    • Si la base de datos determina quién tiene acceso basado en un nombre de usuario y contraseña que recibe desde el Administrador de la base de datos, haga clic en usar el siguiente nombre de usuario y contraseña y, a continuación, escriba su nombre de usuario y contraseña en el Nombre de usuario y Contraseña cuadros.

  10. Haga clic en Siguiente.

  11. En la lista Seleccione la base de datos que contiene los datos que desea, haga clic en el nombre de la base de datos que desea usar, haga clic en Conectar con una tabla específica, haga clic en el nombre de la tabla principal y, a continuación, haga clic en siguiente.

  12. En la siguiente página del asistente, en el cuadro Nombre de archivo, escriba un nombre para el archivo que almacena la información de conexión de datos y, a continuación, haga clic en Finalizar para guardar la configuración.

    Si piensa usar otras tablas en la conexión de datos de la consulta, puede agregar las otras tablas en esta página del asistente.

    Agregar otras tablas

    1. Haga clic en Agregar tabla.

    2. En el cuadro de diálogo Agregar tabla o consulta, haga clic en el nombre de la tabla secundaria y, a continuación, haga clic en siguiente. InfoPath intenta establecer las relaciones haciendo coincidir los nombres de campo en ambas tablas. Si no desea usar la relación sugerida, seleccione la relación y, a continuación, haga clic en Quitar relación. Para agregar una relación, haga clic en Agregar relación. En el cuadro de diálogo Agregar relación, haga clic en el nombre de cada campo relacionado en la columna correspondiente y, a continuación, haga clic en Aceptar.

    3. Haga clic en Finalizar.

    4. Para agregar tablas secundarias adicionales, repita estos pasos.

  13. Haga clic en Siguiente.

  14. Para almacenar los resultados de la consulta con la plantilla de formulario, active la casilla de verificación almacenar una copia de los datos de la plantilla de formulario. Si activa esta casilla, los resultados de la consulta almacena en la plantilla de formulario. Como los datos se almacenan en la plantilla de formulario. los datos están disponibles en los formularios que los usuarios rellenan, incluso si su equipo no está conectado a una red.

    Nota de seguridad: Si activa esta casilla, los resultados de la consulta almacena en la plantilla de formulario. Dado que los datos se almacenan en la plantilla de formulario, está disponible en los formularios que los usuarios rellenan, incluso si su equipo no está conectado a una red. Si está obteniendo datos confidenciales de esta conexión de datos, desea deshabilitar esta característica para ayudar a proteger los datos en caso de que se robe o se pierda el equipo.

  15. Haga clic en Siguiente.

  16. En la siguiente página del asistente, escriba un nombre descriptivo para esta conexión de datos secundaria. Si desea que el formulario reciba datos automáticamente cuando se abre el formulario, active la casilla de verificación recuperar datos automáticamente cuando se abre un formulario.

Volver al principio

Paso 2: Configure el control

  1. Si la plantilla de formulario tiene varias vistas, haga clic en nombre de la vista en el menú Ver para ir a la vista con el control que desea mostrar los datos de origen de datos secundario.

  2. Haga doble clic en el cuadro de lista, cuadro de lista desplegable o control de cuadro combinado que desee rellenar.

  3. Haga clic en la pestaña Datos.

  4. En entradas del cuadro de lista, haga clic en Buscar valores desde un origen de datos externos.

  5. En la lista de Origen de datos, haga clic en el origen de datos que desea usar.

  6. Haga clic en Seleccionar XPath Imagen del botón junto al cuadro entradas.

  7. En el cuadro de diálogo Seleccionar un campo o grupo, especifique qué datos se muestran al usuario y qué datos se enviarán al origen de datos externo siguiendo uno de estos procedimientos.

    Especificar que los datos que verá el usuario son los mismos datos que enviará

    • Haga clic en un campo y, a continuación, haga clic en Aceptar.

    Especificar que los datos que el usuario verá están diferentes de los datos que se enviará el usuario

    Nota: En este escenario, los datos que el usuario verá están uno de los campos en el grupo y los datos que se enviará el usuario están en otro campo en el mismo grupo.

    1. Haga clic en un grupo y, a continuación, haga clic en Aceptar.

    2. En el cuadro de diálogo Propiedades del Control, haga clic en Seleccionar XPath Imagen del botón junto al cuadro valor.

    3. En el cuadro de diálogo Seleccionar un campo o grupo, haga clic en un campo que contiene los datos que el usuario enviar al origen de datos externos y, a continuación, haga clic en Aceptar.

    4. En el cuadro de diálogo Propiedades del Control, haga clic en Seleccionar XPath Imagen del botón junto al cuadro nombre para mostrar.

    5. En el cuadro de diálogo Seleccionar un campo o grupo, haga clic en un campo que contiene los datos que aparecen en el control y a continuación, haga clic en Aceptar.

  8. Si el campo en el cuadro nombre para mostrar tiene valores con nombres para mostrar similares y desea mostrar sólo nombres únicos, active la casilla de verificación Mostrar solamente las entradas con nombres de presentación únicos.

Volver al principio

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×