Usar funciones y funciones anidadas en fórmulas de Excel

Las funciones son fórmulas predefinidas que ejecutan cálculos con valores específicos, denominados argumentos, en un determinado orden o estructura. Las funciones pueden usarse para ejecutar cálculos simples o complejos. Encontrará todas las funciones de Excel en la pestaña Fórmulas de la cinta:

La pestaña Fórmulas de Excel en la cinta
  • Sintaxis de función de Excel

    El siguiente ejemplo de la función REDONDEAR, que redondea un número de la celda A10, ilustra la sintaxis de una función.

    Estructura de una función

    1. Estructura. La estructura de una función comienza por el signo igual (=), seguido por el nombre de la función, un paréntesis de apertura, los argumentos de la función separados por punto y coma y un paréntesis de cierre.

    2. Nombre de función. Para obtener una lista de las funciones disponibles, haga clic en una celda y presione MAYÚ+F3, lo que abrirá el cuadro de diálogo Insertar función.

    Fórmulas de Excel - cuadro de diálogo Insertar función

    3. Argumentos. Los argumentos pueden ser números, texto, valores lógicos como VERDADERO o FALSO, matrices, valores de error como #N/A o referencias de celda. El argumento que se designe deberá generar un valor válido para el mismo. Los argumentos también pueden ser constantes, fórmulas u otras funciones.

    4. Información sobre herramientas de argumentos. Cuando se escribe la función, aparece la información sobre herramientas con su sintaxis y sus argumentos. Por ejemplo, escriba =REDONDEAR( y aparecerá la información sobre herramientas. Esta información solo aparece para las funciones integradas.

    Nota: No hay que escribir las funciones en mayúsculas, como =REDONDEAR, ya que Excel pondrá automáticamente en mayúsculas el nombre de la función después de presionar Entrar. Si se equivoca al escribir un nombre de función, como =SUME(A1:A10) en lugar de =SUMA(A1:A10), ¿devolverá Excel un error #¿NOMBRE?.

  • Escribir funciones de Excel

    Cuando cree una fórmula que contenga una función, puede usar el cuadro de diálogo Insertar función como ayuda para especificar las funciones de la hoja de cálculo. Al seleccionar una función en el cuadro de diálogo Insertar función, Excel iniciará un asistente para funciones, que muestra el nombre de la función, cada uno de sus argumentos, una descripción de la función y de cada argumento, el resultado actual de la función y el resultado actual de toda la fórmula.

    Asistente de funciones de Excel

    Para facilitar la creación y edición de fórmulas, y minimizar los errores de escritura y sintaxis, use Autocompletar fórmula. Después de escribir un = (signo igual) y las letras iniciales de una función, Excel muestra una lista desplegable dinámica de funciones, argumentos y nombres válidos que coinciden con las letras. Puede seleccionar un elemento de la lista desplegable y Excel lo insertará automáticamente.

    Fórmula de Excel Autocompletar

  • Anidar funciones de Excel

    En algunos casos, puede que deba usar una función como uno de los argumentos de otra función. Por ejemplo, la siguiente fórmula usa una función anidada PROMEDIO y compara el resultado con el valor 50.

    Funciones anidadas

    1. La función PROMEDIO y la función SUMA están anidadas dentro de la función SI.

    Resultados válidos    Cuando se usa una función anidada como argumento, deberá devolver el mismo tipo de valor que el que use el argumento. Por ejemplo, si el argumento devuelve un valor VERDADERO o FALSO, la función anidada deberá devolver VERDADERO o FALSO. Si este no es el caso, Excel mostrará el valor de error #¡VALOR!.

    Límites del nivel de anidamiento    Una fórmula puede contener hasta siete niveles de funciones anidadas. Si una función (a la que llamaremos Función B) se usa como argumento de otra función (a la que llamaremos Función A), la Función B actúa como función de segundo nivel. Por ejemplo, la función PROMEDIO y la función SUMA son ambas funciones de segundo nivel si se usan como argumentos de la función SI. Una función anidada dentro de la función anidada PROMEDIO será entonces una función de tercer nivel, y así sucesivamente.

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×