TEXTO (función TEXTO)

Nota: Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

La función TEXTO le permite cambiar la apariencia de un número aplicándole formato con códigos de formato. Es útil para mostrar números en un formato más legible o para combinarlos con texto o símbolos.

Nota: La función TEXTO convertirá los números en texto, lo que puede dificultar la referencia en futuros cálculos. Es mejor mantener el valor original en una celda y usar la función TEXTO en otra celda. Después, si es necesario crear otras fórmulas, haga referencia siempre al valor original y no al resultado de la función de TEXTO.

Sintaxis

TEXTO(valor,formato)

La sintaxis de la función TEXTO tiene los siguientes argumentos:

Nombre del argumento

Descripción

valor

Valor numérico que se quiere convertir en texto.

format_text

Cadena de texto que define el formato que se quiere aplicar al valor especificado

Información general

En su forma más sencilla, la función TEXTO dice:

  • =TEXTO(Valor al que quiere dar formato, “Código de formato que quiere aplicar")

Estos son algunos ejemplos populares que puede copiar directamente en Excel para experimentar con ellos. Observe los códigos de formato entre comillas.

Fórmula

Descripción

=TEXTO(1234.567,"$#,##0.00")

Moneda con separador de millares y 2 decimales, como 1.234,57 $. Tenga en cuenta que Excel redondea el valor a 2 posiciones decimales.

=TEXTO(HOY(),"DD/MM/AA")

Fecha de hoy en formato DD/MM/AA, por ejemplo, 14/03/12

= TEXTO(HOY(),"DDDD")

Día de la semana de hoy, por ejemplo, lunes

=TEXTO(AHORA(),"H:MM AM/PM")

Hora actual, por ejemplo, 13:29

=TEXTO(0.285,"0.0%")

Porcentaje, por ejemplo, 28,5 %

= TEXT(4.34,"# ?/?")

Fracción, por ejemplo, 4 1/3

=ESPACIOS (TEXTO(0.34,"#? /?"))

Fracción, por ejemplo, 1/3. Tenga en cuenta que esto usa la función ESPACIOS para quitar los espacios iniciales de un valor decimal.

=TEXTO(12200000,"0.00E+00")

Notación científica, por ejemplo, 1.22E+07

=TEXTO(1234567898,"[<=9999999]###-####;(###) ###-####")

Especiales (números de teléfono), por ejemplo, (123) 456-7898

=TEXTO(1234,"0000000")

Agrega ceros a la izquierda (0), por ejemplo, 0001234

=TEXTO(123456,"##0° 00' 00''")

Personalizada: latitud y longitud

Nota: Aunque puede utilizar la función texto para cambiar el formato, no es la única manera. Puede cambiar el formato sin una fórmula presionando CTRL + 1 (o Imagen del icono del botón de comando de Mac + 1 en el Mac) y luego elija el formato que desee en el Formato de celdas > cuadro de diálogo de número.

Descargar nuestros ejemplos

Puede descargar un libro de ejemplo con todos los ejemplos de la función de texto que encontrará en este artículo, además de algunos adicionales. Puede seguir a lo largo o crear su propia función texto códigos de formato.

Ejemplos de la función de descargar el texto de Excel

Otros códigos de formato que están disponibles

Puede usar el cuadro de diálogo Formato de celdas para buscar el resto de los códigos de formato disponibles:

  1. Presione Ctrl+1 ( Imagen del icono del botón de comando de Mac +1 en un Mac) para que aparezca el cuadro de diálogo Formato de celdas.

  2. Seleccione el formato que desee en la pestaña Número.

  3. Seleccione la opción Personalizado,

  4. Ahora se muestra el código de formato que desee en el cuadro Tipo. En este caso, seleccione todo del cuadro Tipo excepto el punto y coma (;) y el símbolo @. En el siguiente ejemplo, se seleccionará y se copiará simplemente dd/mm/aa.

  5. Presione CTRL+C para copiar el código de formato, después presione Cancelar para descartar el cuadro de diálogo Formato de celdas.

  6. Ahora, todo lo que debe hacer es presionar CTRL+V para pegar el código de formato en la fórmula TEXTO, por ejemplo: =TEXTO (B2,"dd/mm/aa"). Asegúrese de pegar el código de formato entre comillas ("código de formato"), de lo contrario, Excel mostrará un mensaje de error.

Ejemplo de uso del cuadro de diálogo que se abre con Formato > Celdas > Número > Personalizar para que Excel cree cadenas de formato automáticamente.

Códigos de formato por categoría

A continuación encontrará algunos ejemplos de cómo puede aplicar diferentes formatos de número a los valores utilizando el cuadro de diálogo Formato de celdas, después utilice la opción Personalizado para copiar los códigos de formato a la función TEXTO.

¿Por qué Excel elimina los ceros a la izquierda?

Excel está capacitado para buscar los números que se especifican en las celdas, no los números que aparecen como texto, como números de elemento o SKU. Para mantener los ceros los la izquierda, dar formato el rango de entrada como texto antes de pegar o especifique valores. Seleccione la columna o rango donde deberá poner los valores, use CTRL + 1 para que aparezca la Formato > celdas cuadro de diálogo y, en la pestaña de número, seleccione texto. Ahora Excel mantendrá el interlineado de 0.

Si ya ha escrito datos y Excel ha quitado los ceros a la izquierda, puede usar la función TEXTO para volver a agregarlos. Puede hacer referencia a la celda superior con los valores y usar =TEXTO(valor,"00000"), donde el número de ceros de la fórmula representa el número total de caracteres que quiere usar y, después, copiar y pegar la fórmula en el resto del rango.

Ejemplos de uso de TEXTO para dar formato con ceros a la izquierda. =TEXTO(A2,"00000")

Si, por algún motivo, debe convertir valores de texto de nuevo en números puede multiplicar por 1, por ejemplo, =D4*1, o usar el operador unario doble (--), por ejemplo, =--D4.

Si el formato contiene un punto (.) entre signos de número (#) o ceros, Excel separa los miles con puntos. Por ejemplo, si la cadena de formato es "#,###", Excel muestra el número 12200000 como 12.200.000.

Una coma que sigue a un marcador de posición de dígito escala el número por 1.000. Por ejemplo, si la cadena de formato es "#,###.0,", Excel muestra el número 12200000 como 12.200,0.

Ejemplos de la función TEXTO usando el separador de millar

Notas: 

  • El separador de millares depende de la configuración regional. En los Estados Unidos es una coma, pero en otras configuraciones regionales podría ser un punto (.).

  • El separador de millares está disponible para los formatos de número, moneda y contabilidad.

A continuación encontrará ejemplos de formatos de número estándar (que solo tienen separador de millares y de decimales), moneda y contabilidad. El formato de moneda permite insertar el símbolo de moneda de su elección y lo alinea junto a su valor, mientras que el formato de contabilidad alineará el símbolo de moneda a la izquierda de la celda y el valor a la derecha. Tenga en cuenta la diferencia entre los formatos de moneda y de contabilidad que encontrará a continuación, donde contabilidad usa un asterisco (*) para crear la separación entre el símbolo y el valor.

Ejemplos de la función TEXTO con los formatos de número, moneda y contabilidad

Para buscar el código de formato para un símbolo de moneda, presione Ctrl+1 (o Imagen del icono del botón de comando de Mac +1 en un Mac), seleccione el formato que desee y después elija un símbolo de la lista desplegable Símbolo:

Selección del símbolo de moneda desde el cuadro de diálogo Formato de celdas

Después haga clic en Personalizado a la izquierda de la sección Categoría y copie el código de formato, incluyendo el símbolo de moneda.

Función TEXTO: moneda personalizada con símbolo

Nota: La función TEXTO no admite formato de color, de modo que si copia un código de formato de número del cuadro de diálogo Formato de celdas que contenga un color, como este: $#,##0.00_);[Red]($#,##0.00), la función TEXTO aceptará el código de formato, pero no mostrará el color.

Puede alterar la forma en la que se muestra una fecha mediante una combinación de "M" para los meses, "D" para los días e "Y" para los años.

Códigos de formato de día, mes y año

Los códigos de formato en la función TEXTO no distinguen entre mayúsculas y minúsculas, por lo que puede utilizar "M" o "m", "D" o "d" e "Y" o "y".

Mynda Treacy, MVP de Excel

Mynda recomienda...

Si comparte archivos de Excel e informes con los usuarios de diferentes países, que podría desea darle un informe en su idioma. MVP de Excel, Mynda Treacy tiene una gran solución en este artículo Muestran las fechas de Excel en idiomas diferentes . También incluye un libro de ejemplo que se puede descargar.

Puede alterar la forma en la que se muestran las horas mediante una combinación de "H" para las horas, "M" para los minutos o "S" para los segundos, y "AM/PM" para un reloj de 12 horas.

Formatos de hora para horas, minutos y segundos

Si no incluye "AM/PM" o "A/P" se mostrará la hora basándose en un reloj de 24 horas.

Los códigos de formato en la función TEXTO no distinguen entre mayúsculas y minúsculas, por lo que puede utilizar "H" o "h", "M" o "m" y "S" o "s".

Puede alterar la forma en la que se muestran los valores decimales con formatos de porcentaje (%).

Códigos de formato para porcentajes

Puede alterar la forma en la que se muestran los valores decimales con formatos de fracción (?/?).

Códigos de formato para fracciones

La notación científica es una forma de mostrar números en términos de un número decimal entre 1 y 10, multiplicado por una potencia de 10. Se utiliza a menudo para acortar la manera en que se muestran los números grandes.

Códigos de formato para notación científica

Excel proporciona 4 formatos especiales:

  • Código postal: "00000"

  • Código postal + 4: "00000-0000"

  • Número de teléfono: "[<=9999999]###-####;(###) ###-####"

  • Número de la seguridad social: "000-00-0000"

Formatos especiales de la función TEXTO

Los formatos especiales serán diferentes dependiendo de la configuración regional, pero si no hay formatos especiales para la configuración regional, o si éstos no satisfacen sus necesidades, puede crear uno propio a través del cuadro de diálogo Formato de celdas > Personalizado.

Escenario común

La función texto casi nunca se usa por sí mismo y se usa con mayor frecuencia en combinación con otra cosa. Supongamos que desea combinar el texto y un valor de número, como "informe impreso en: 14/03/12", o "ingresos semanal: 66,348.72 $". También puede escribir en Excel manualmente, pero que derrota la finalidad de tener Excel lo haga por usted. Desgraciadamente, al combinar texto y números con formato, como fechas, horas, moneda, etc., Excel no sabe cómo desea mostrarlos, quita el formato de número. Esto es donde la función texto es sumamente útil, ya que permite obligar a Excel, dar formato a los valores de la que desee mediante un código de formato, como "MM/DD/AA" para el formato de fecha.

En el ejemplo siguiente, verá lo que sucede si intenta combinar texto y un número sin utilizar la función texto . En este caso, usaremos la y comercial (&) para concatenar una cadena de texto, un espacio ("") y un valor = A2 & "" & B2.

Ejemplo de unión de texto sin la función TEXTO

Como puede ver, Excel ha quitado el formato de la fecha en la celda B2. En el siguiente ejemplo, verá cómo la función TEXTO le permite aplicar el formato que desee.

Ejemplo de unión de texto con la función TEXTO

Nuestra fórmula actualizada es:

  • Celda C2:=A2&" "&TEXTO(B2;"dd/mm/aa"), formato de fecha

Preguntas más frecuentes

Desgraciadamente, no puede hacer que la función texto , necesita usar Visual Basic para aplicaciones (VBA). El siguiente vínculo tiene un método: cómo convertir un valor numérico en palabras en inglés en Excel

Sí, puede usar las funciones MAYUSC, MINUSC y NOMPROPIO. Por ejemplo, =MAYUSC("hola") devolverá "HOLA".

Sí, pero se necesitan unos cuantos pasos. En primer lugar, seleccione la celda o celdas donde desea que esto suceda y utilizar Ctrl + 1 para que aparezca la Formato > celdas cuadro de diálogo, a continuación, Alineación > control de texto > Active la opción Ajustar texto. A continuación, ajuste la función texto completada para incluir la función ASCII Car (10) donde desee el salto de línea. Debe ajustar el ancho de columna dependiendo de cómo se alinea el resultado final.

Ejemplo del uso de TEXTO con CHAR(10) para insertar un salto de línea. ="Hoy es: "&CHAR(10))&TEXTO(HOY(),"MM/DD/AA")

En este caso, hemos usado: ="Hoy es: "&CHAR(10)&TEXTO(HOY(),"dd/mm/aa")

Esto se denomina notación científica, y Excel convertirá automáticamente los números de más de 12 dígitos si se aplica el formato General a una de las celdas, y de 15 dígitos si se aplica el formato Número a una de las celdas. Si necesita especificar cadenas numéricas largas, pero no desea convertirlas, aplique el formato Texto a las celdas en cuestión antes de introducir o pegar los valores en Excel.

Mynda Treacy, MVP de Excel

Mynda recomienda...

Si comparte archivos de Excel e informes con los usuarios de diferentes países, que podría desea darle un informe en su idioma. MVP de Excel, Mynda Treacy tiene una gran solución en este artículo Muestran las fechas de Excel en idiomas diferentes . También incluye un libro de ejemplo que se puede descargar.

Vea también

Crear o eliminar un formato de número personalizado

Convertir en número los números guardados como texto

Funciones de Excel (por categoría)

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×