Fórmulas y funciones

Función SUMA

SUMA (función SUMA)

La función SUMA, una de las funciones matemáticas y trigonométricas, suma valores. Puede sumar valores individuales, referencias o rangos de celda o una combinación de las tres.

Por ejemplo:

  • =SUMA(A2:A10)

  • =SUMA(A2:A10, C2:C10)

Su explorador no admite vídeo. Instale Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

SUMA(número1,[número2],...)

Nombre del argumento

Descripción

número1    (obligatorio)

El primer número que desea sumar. El número puede darse como 4, como una referencia de celda como B6, o como un intervalo de celdas como B2:B8.

número2-255    (Opcional)

Este es el segundo número que quiere sumar. Puede especificar hasta 255 números de esta forma.

Esta sección trata algunos procedimientos recomendados para trabajar con la función SUMA. La mayoría de este contenido puede aplicarse para trabajar también con otras funciones.

El método =1+2 o =A+B: aunque puede escribir =1+2+3 o =A1+B1+C2 y obtener resultados totalmente precisos, estos métodos son propensos a errores por varias razones:

  1. Errores de escritura. Imagine que intenta escribir más valores o valores más grandes como estos:

    • =14598,93+65437,90+78496,23

    Después, intente validar que sus entradas son correctas. Es mucho más sencillo poner estos valores en celdas individuales y usar una fórmula SUMA. Además, puede aplicar formato en los valores cuando están en celdas, haciendo que sean más legibles cuando están en una fórmula.

    Use la función SUMA en lugar de los valores codificados de forma rígida en las fórmulas.  La fórmula de la celda D5 es =SUMA(D2:D4)
  2. Errores #¡VALOR! al hacer referencia al texto en lugar de a los números

    Si usa una fórmula como:

    • =A1+B1+C1 o =A1+A2+A3

    Ejemplo de una construcción de fórmula defectuosa.  La fórmula en la celda D2 es =A2+B2+C2

    Su fórmula puede romperse si no existen valores no numéricos (texto) en las celdas a las que se hace referencia, lo que devolverá el error #¡VALOR!. SUMA ignorará los valores de texto y le proporcionará solo la suma de los valores numéricos.

    Construcción correcta de la fórmula.  En lugar de =A2+B2+C2, la fórmula de la celda D2 es =SUMA(A2:C2)
  3. Error #¡REF! al eliminar filas o columnas

    Error #¡REF! provocado al eliminar una columna.  La fórmula ha cambiado a =A2+#¡REF!+B2

    Si elimina una fila o una columna, la fórmula no se actualizará para excluir la fila eliminada y devolverá un error #¡REF!, donde la función SUMA la actualizará automáticamente.

    La función SUMA se ajustará automáticamente para las filas y columnas que se han insertado o eliminado
  4. Las fórmulas no actualizarán las referencias al insertar filas o columnas

    Las fórmulas =A+B+C no se actualizarán si agrega filas

    Si inserta una fila o una columna, la fórmula no se actualizará para incluir la fila agregada, donde una función SUMA la actualizará automáticamente (siempre y cuando no se encuentre fuera del rango al que se hace referencia en la fórmula). Esto es especialmente importante si espera que su fórmula se actualice y no lo hace, ya que le proporcionará resultados incompletos que quizás no detecte.

    El ejemplo representa una fórmula SUMA que se expande automáticamente de =SUMA(A2:C2) a =SUMA(A2:D2) cuando se inserta una columna
  5. SUMA con referencias de celda individuales frente a rangos

    Usar una fórmula como:

    • =SUMA(A1,A2,A3,B1,B2,B3)

    Es igualmente propensa a errores al insertar o eliminar filas dentro del rango al que se hace referencia por las mismas razones. Es mucho mejor usar rangos individuales, como:

    • =SUMA(A1:A3,B1:B3)

    Que se actualizarán cuando se agreguen o eliminen filas.

Problema

Qué ha fallado

Mi función SUMA muestra #####, no el resultado.

Compruebe el ancho de las columnas. Por lo general, ##### significa que la columna es demasiado estrecha para mostrar el resultado de la fórmula.

Mi función SUMA muestra la fórmula como texto, no el resultado.

Compruebe que la celda no tiene formato de texto. Seleccione la celda o el rango en cuestión y use Ctrl+1 para que aparezca el cuadro de diálogo Formato de celdas; luego haga clic en la pestaña Número y seleccione el formato que quiera. Si la celda tenía formato de texto y no cambia después de modificar el formato, es posible que deba usar F2 > ENTRAR para forzar el cambio.

Mi función SUMA no se actualiza.

Asegúrese de que la opción Cálculo esté establecida en Automático. En la ficha Fórmula, vaya a Opciones de cálculo. También puede usar F9 para forzar el cálculo en la hoja.

Asegúrese de que el cálculo esté establecido en Automático.  Desde la pestaña Fórmula, vaya a Opciones de cálculo.

Algunos valores no se suman.

Solo se pueden sumar los valores de la referencia o del rango de la función que son numéricos. Las celdas vacías, los valores lógicos (como VERDADERO) o el texto se ignoran.

Aparece el valor de error #¿Nombre? en lugar del resultado esperado.

Normalmente, esto significa que la fórmula es incorrecta, como =sume(A1:A10) en lugar de =SUMA(A1:A10).

Mi función SUMA muestra un número entero, pero debería tener decimales

Compruebe el formato de la celda para asegurarse de que puede mostrar decimales. Seleccione la celda o el rango en cuestión y use Ctrl+1 para que se muestre el cuadro de diálogo Formato de celdas; luego haga clic en la pestaña Número y seleccione el formato que quiera. Asegúrese de que indica el número de posiciones decimales deseado.

  1. Solo quiero sumar/restar/multiplicar/dividir números. Vea esta serie de vídeos sobre matemáticas básicas en Excel o bien consulte Usar Excel como calculadora.

  2. ¿Cómo puedo mostrar más o menos posiciones decimales? Puede cambiar el formato de número. Seleccione la celda o el rango en cuestión y use Ctrl+1 para que se muestre el cuadro de diálogo Formato de celdas; luego haga clic en la ficha Número y seleccione el formato que quiera. Asegúrese de que indica el número de posiciones decimales deseado.

  3. ¿Cómo puedo sumar o restar horas? Puede agregar y restar horas de varias maneras distintas. Por ejemplo, para obtener la diferencia entre 8:00 AM y 12:00 PM con el fin de pagar las nóminas, puede usar: =("12:00 PM"-"8:00 AM")*24, que resta la hora de inicio a la de finalización. Tenga en cuenta que Excel calcula las horas como fracciones de un día, por lo que hay que multiplicar por 24 para obtener el total de horas. En el primer ejemplo se usa =((B2-A2)+(D2-C2))*24 para obtener la suma de horas desde el inicio hasta la finalización restando el tiempo de la comida (un total de 8,50 horas).

    Si simplemente quiere agregar horas y minutos y mostrar la información de esa manera, puede sumar y no multiplicar por 24. Por ejemplo, en el segundo ejemplo se usa =SUMA(A6:C6) porque solo es necesario calcular el número total de horas y minutos dedicados a las tareas asignadas (5:36 o 5 horas y 36 minutos).

    Cálculo de horas

    Para más información, vea: Sumar o restar tiempo

  4. ¿Cómo obtener la diferencia entre fechas? Al igual que con las horas, las fechas se pueden sumar y restar. El siguiente es un ejemplo muy común de contar el número de días entre dos fechas. Es tan sencillo como =B2-A2. La clave para trabajar con fechas y horas a la vez es empezar con la fecha y hora de finalización y restar la fecha y hora de inicio.

    Cálculo de diferencias entre fechas

    Para otras formas de trabajar con fechas, vea: Calcular la diferencia entre dos fechas.

  5. ¿Cómo puedo sumar solo las celdas visibles? A veces, al ocultar filas manualmente o usar el Filtro automático para mostrar solo cierta información, es posible que solo quiera sumar las celdas visibles. Puede usar la función SUBTOTALES. Si usa una fila de totales en una tabla de Excel, cualquier función que seleccione de la lista desplegable Total se introduce automáticamente como un subtotal. Obtenga más información sobre cómo Obtener el total de los datos en una tabla de Excel.

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Vea también

Más información sobre SUMA

La función SUMAR.SI solo suma los valores que coinciden con un criterio único

La función SUMAR.SI.CONJUNTO solo suma los valores que coinciden con varios criterios

La función CONTAR.SI solo cuenta los valores que coinciden con un criterio único

La función CONTAR.SI.CONJUNTO solo cuenta los valores que coincide con varios criterios

Información general sobre fórmulas en Excel

Cómo evitar la ruptura de las fórmulas

Buscar y corregir errores en fórmulas

Métodos abreviados de teclado de Excel para Windows

Métodos abreviados de teclado de Excel para Mac

Funciones matemáticas y trigonométricas

Funciones de Excel (por orden alfabético)

Funciones de Excel (por categoría)

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×