Fórmulas y funciones

Función SI

SI (función SI)

La función SI es una de las funciones más populares de Excel y le permite realizar comparaciones lógicas entre un valor y un resultado que espera.

Por esto, una instrucción SI puede tener dos resultados. El primer resultado es si la comparación es Verdadera y el segundo si la comparación es Falsa.

Por ejemplo, =SI(C2="Sí",1,2) dice: SI(C2 = Sí, entonces devolver un 1, en caso contrario devolver un 2)

Su explorador no admite vídeo. Instale Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Use la función SI, una de las funciones lógicas, para devolver un valor si una condición es verdadera y otro si es falsa.

SI(prueba_lógica; valor_si_verdadero; [valor_si_falso])

Por ejemplo:

  • =SI(A2>B2,"Presupuesto excedido";"Correcto")

  • =SI(A2=B2,B4-A4,"")

Nombre del argumento

Descripción

prueba_lógica    (requerido)

El valor que quiere probar.

valor_si_verdadero    (requerido)

El valor que desea devuelto si el resultado de prueba_lógica es VERDADERO.

valor_si_falso    (opcional)

El valor que desea devuelto si el resultado de prueba_lógica es FALSO.

Ejemplos sencillos de SI

La celda D2 contiene la fórmula =SI(C2="SÍ",1,2)
  • =SI(C2="Sí",1,2)

En el ejemplo anterior, la celda D2 dice: SI(C2 = Sí, entonces devolver un 1, en caso contrario devolver un 2)

La celda D2 contiene la fórmula =SI(C2=1,"SÍ","NO")
  • =SI(C2=1,"Sí","No")

En este ejemplo, la fórmula de la celda D2 dice: SI(C2 = 1, entonces devolver Sí, en caso contrario devolver No) Como puede ver, la función SI se puede usar para evaluar texto o valores. También se puede usar para evaluar errores. No está limitado exclusivamente a comprobar si un elemento es igual a otro y devolver un único resultado, también puede usar operadores matemáticos y realizar cálculos adicionales según sus criterios. También se pueden anidar varias funciones SI para realizar varias comparaciones.

La fórmula de la celda D2 es =SI(C2 > B2,"Presupuesto excedido","Dentro de presupuesto")
  • =SI(C2>B2,"Presupuesto excedido","Dentro de presupuesto")

En el ejemplo anterior, la función en D2 dice SI(C2 es mayor que B2, devolver "Presupuesto excedido"; de lo contrario, devolver "Dentro de presupuesto")

La fórmula de la celda E2 es =SI(C2>B2,C2-B2,"")
  • =SI(C2>B2;C2-B2;0)

En la ilustración anterior, en lugar de devolver un resultado de texto, vamos a devolver un cálculo matemático. La fórmula en E2 dice lo siguiente: SI(la cantidad real es mayor que la presupuestada, resta la cantidad presupuestada de la cantidad real; en caso contrario, no se devuelve nada).

La fórmula de la celda F7 es SI(E7="Sí";F5*0,0825,0)
  • =SI(E7="Sí";F5*0,0825;0)

En este ejemplo, la fórmula en F7 dice lo siguiente: SI(E7 = "Sí", calcula la cantidad total con F5 * 8,25 %; en caso contrario, no hay ningún impuesto sobre las ventas, por lo que se devuelve 0)

Nota: Si va a usar texto en fórmulas, tendrá que escribir el texto entre comillas (por ejemplo, "Texto"). La única excepción es el uso de VERDADERO o FALSO, que Excel entiende de forma automática.

Problemas comunes

Problema

Qué ha fallado

0 (cero) en la celda

No había argumento para valor_si_verdadero ni para valor_si_falso. Para que se devuelva un valor correcto, agregue texto de argumento a los dos argumentos, o agregue VERDADERO o FALSO al argumento.

#¿NOMBRE? en la celda

Normalmente, esto significa que la fórmula se ha escrito mal.

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Vea también

Operadores de cálculo y prioridad en Excel

Usar funciones anidadas en una fórmula

Usar SI para comprobar si una celda está en blanco

Usar SI para comprobar si una celda está en blanco

Vídeo: Funciones SI avanzadas

Función SI.CONJUNTO (Office 365, Excel 2016 y posterior)

Funciones SI avanzadas: Trabajar con fórmulas anidadas para evitar errores.

Vídeos de aprendizaje: Funciones SI avanzadas

La función CONTAR.SI contará los valores según un solo criterio

La función CONTAR.SI.CONJUNTO contará los valores según varios criterios

La función SUMAR.SI sumará los valores según un solo criterio

La función SUMAR.SI.CONJUNTO sumará los valores según varios criterios

Función Y

Función O

Función BUSCARV

Información general sobre fórmulas en Excel

Cómo evitar la ruptura de las fórmulas

Detectar errores en fórmulas

Funciones lógicas

Funciones de Excel (por orden alfabético)

Funciones de Excel (por categoría)

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×