SI.ERROR (función SI.ERROR)

Puede usar la función si. error para interceptar y controlar errores en una fórmula. Si. error devuelve un valor que se especifica si una fórmula lo evalúa como un error; en caso contrario, devuelve el resultado de la fórmula.

Sintaxis

SIERROR(valor; valor_si_error)

La sintaxis de la función SI.ERROR tiene los siguientes argumentos:

  • value    Obligatorio. Es el argumento donde busca un error.

  • value_if_error    Obligatorio. El valor que se devuelve si la fórmula se evalúa como un error. Se evalúan los siguientes tipos de error: #N/A, #¡VALOR!, #¡REF!, #¡DIV/0!, #¡NUM!, #¿NOMBRE? o #¡NULO!.

Observaciones

  • Si el valor o value_if_error es una celda vacía, si. error la trata como un valor de cadena vacía ("").

  • Si valor es una fórmula de matriz, si. error devuelve una matriz de resultados para cada celda del rango especificado en valor. Vea el segundo ejemplo a continuación.

Ejemplos

Copie los datos de ejemplo en la tabla siguiente y péguelos en la celda A1 de una hoja de cálculo nueva de Excel. Para que las fórmulas muestren los resultados, selecciónelas, presione F2 y luego Entrar.

Cuota

Unidades vendidas

210

35

55

0

,23

Fórmula

Descripción

Resultado

=SI.ERROR(A2/B2; "Error en el cálculo")

Comprueba si hay un error en la fórmula en el primer argumento (divide 210 entre 35), no encuentra ningún error y devuelve los resultados de la fórmula

6

=SI.ERROR(A3/B3; "Error en el cálculo")

Comprueba si hay un error en la fórmula en el primer argumento (divide 55 entre 0), encuentra un error de división entre 0 y devuelve valor_si_error

Error en el cálculo

=SI.ERROR(A4/B4; "Error en el cálculo")

Comprueba si hay un error en la fórmula en el primer argumento (divide "" entre 23), no encuentra ningún error y devuelve los resultados de la fórmula

0

Ejemplo 2

Cuota

Unidades vendidas

Relación

210

35

6

55

0

Error en el cálculo

,23

0

Fórmula

Descripción

Resultado

=C2

Comprueba si hay un error en la fórmula en el primer argumento del primer elemento de la matriz (A2/B2 o divide 210 entre 35), no encuentra ningún error y devuelve los resultados de la fórmula

6

=C3

Comprueba si hay un error en la fórmula en el primer argumento del segundo elemento de la matriz (A3/B3 o divide 55 entre 0), encuentra un error de división por 0 y devuelve valor_si_error

Error en el cálculo

=C4

Comprueba si hay un error en la fórmula en el primer argumento del tercer elemento de la matriz (A4/B4 o divide "" entre 23), no encuentra ningún error y devuelve los resultados de la fórmula

0

Nota: Si tiene una versión actual de Office 365, puede escribir la fórmula en la celda superior izquierda del rango de salida y, a continuación, presionar entrar para confirmar la fórmula como una fórmula de matriz dinámica. En caso contrario, la fórmula debe introducirse como una fórmula de matriz heredada si primero selecciona el rango de salida, introduce la fórmula en la celda superior izquierda del rango de salida y, a continuación, pulsa CTRL + MAYÚS + ENTRAR para confirmarlo. Excel insertará llaves al principio y al final de la fórmula. Para obtener más información sobre las fórmulas de matriz, vea Directrices y ejemplos de fórmulas de matriz.

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Nota:  Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido le resulte útil. ¿Podría decirnos si la información le resultó útil? Aquí puede consultar el artículo en inglés.

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×