Publicar un libro en una biblioteca de SharePoint en Excel para Windows

Nota: Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Puede publicar un libro en una biblioteca de Microsoft SharePoint de modo que los usuarios puedan verlo o editarlo en un explorador web sin tener Excel instalado en sus equipos. Publicar es básicamente lo mismo que guardar, pero con algunas opciones integradas que permiten controlar lo que los usuarios pueden ver cuando abren el libro en un explorador.

Adoptar en toda la organización la práctica de guardar o publicar un libro en un sitio de SharePoint central, le ayuda a garantizar que no empiecen a surgir versiones ligeramente diferentes del mismo libro por toda la organización cuando se envía por correo electrónico.

Estableciendo algunas opciones de publicación, se puede poner el énfasis en partes específicas del libro, como los gráficos, o bien excluir otras partes para que no se visualicen en el explorador. Por ejemplo, puede mostrar un gráfico pero no mostrar los datos subyacentes. O bien, puede mostrar solo determinadas hojas de cálculo a aquellas personas que necesitan verlas y ocultar el resto de hojas de cálculo.

Este artículo le muestra cómo publicar un libro de Excel para Windows y no trata sobre la conexión de un libro o los datos del libro a un elemento Web de Excel Web Access en una página de SharePoint.

Al publicar un libro en un sitio de SharePoint, todo el libro se guarda en SharePoint. Un usuario con los permisos de SharePoint necesarios puede visualizar y trabajar con todo el libro en el explorador o en el programa de escritorio Excel.

Si se implementa Office Online en SharePoint, ver y trabajar con los datos en el explorador puede ser muy similar a trabajar con los datos en el programa de escritorio de Excel. De hecho, a diferencia del programa de escritorio Excel, varios usuarios pueden editar simultáneamente un libro en la cuadrícula del explorador. Al mostrar un libro en el explorador, si el botón Editar en Excel Online está visible, significa que Office Online se encuentra disponible.

Editar en Excel Online en el menú Editar libro

Preparar el libro

Antes de publicar el libro, puede seleccionar solo las hojas de cálculo o elementos que desea que estén visibles en el explorador. Simplemente recuerde que aunque puede limitar qué estará visible en este modo, igualmente se guarda todo el contenido del libro en el servidor de SharePoint.

Si desea incluir todas las hojas de cálculo como un elemento además de otros elementos, como gráficos o tablas dinámicas, defina toda la hoja de cálculo como un rango con nombre. Seleccione toda la hoja de cálculo y, a continuación, defina un rango con nombre. De este modo, el rango con nombre aparecerá como un elemento disponible en el cuadro de diálogo Opciones de publicación cuando esté listo para la publicación.

Para permitir que los usuarios escriban un valor en una celda para trabajar con una fórmula en otra celda, establezca esa celda como un nombre definido en Excel antes de publicar el libro. Después puede agregar ese nombre definido como un parámetro en la pestaña Parámetros, en el cuadro de diálogo Opciones de vista de explorador.

Por ejemplo, a continuación se muestra una celda D2 que tiene el nombre definido "Tasa". En el explorador, un usuario escribe un valor, 5,625, en el cuadro Tasa del panel Parámetros y luego hace clic en Aplicar. El valor aparece entonces en la celda D2 y la fórmula de A2 usa el valor de D2. El resultado de la fórmula se recalcula y se muestra en A2: 1151,31 $.

Al escribir un parámetro en el panel se usa en la celda D2

Nota: Si crea segmentaciones para una tabla de Excel y define un nombre para el intervalo de celdas que contienen la tabla y las segmentaciones, no podrá usar las segmentaciones para filtrar la tabla en el explorador si publica el intervalo definido. Si publica la tabla o toda la hoja de cálculo o su libro, las segmentaciones funcionarán según lo previsto en el explorador.

Publicar el libro

  1. Haga clic en la pestaña Archivo, elija Guardar como y luego haga clic en SharePoint.

  2. Si ve la carpeta de SharePoint en Actuales, Recientes o Antiguas, haga clic en la carpeta que desee.

    Aparecerá el cuadro de diálogo Guardar como.


    En caso contrario, haga clic en Examinar, escriba la dirección web del sitio de SharePoint y, a continuación, vaya a la carpeta donde desea publicar el libro.

    Haga clic en una carpeta de SharePoint o en Examinar
  3. Para seleccionar hojas de cálculo o elementos individuales para publicarlos en el libro, haga clic en Opciones de vista de explorador.

    En el cuadro de diálogo Guardar como, haga clic en Opciones de vista de explorador

    Verá las pestañas Mostrar y Parámetros.

  4. Si solo quiere publicar todo el libro, haga clic en Guardar. De lo contrario, realice uno de los pasos siguientes:

    • Para mostrar el libro entero en el explorador, seleccione Todo el libro en el cuadro de lista de la pestaña Mostrar.

    • Para mostrar solo hojas de cálculo específicas en el explorador, seleccione Hojas en la pestaña Mostrar y desmarque las casillas de verificación de aquellas que no quiera ocultar en el explorador.

      De forma predeterminada, todas las hojas están seleccionadas. Para hacer que todas las hojas vuelvan a estar visibles rápidamente después de desmarcar algunas de las casillas de verificación, marque la casilla de verificación Todas las hojas.

    • Para mostrar únicamente elementos específicos en el explorador (como intervalos con nombre, gráficos, tablas o tablas dinámicas), en la pestaña Mostrar, elija Elementos en el libro en el cuadro de lista y, después, marque las casillas de los elementos que quiere mostrar.

    • En la pestaña Parámetros, agregue todos los nombres definidos que quiera usar para especificar celdas que son editables cuando los usuarios ven el libro en el explorador. A continuación, haga clic en Aceptar.

  5. Guarde el libro.

Notas: 

  • Si selecciona elementos que tienen el mismo nombre (como un gráfico y su tabla de datos subyacente), únicamente uno de esos elementos estará disponible en el explorador. Para mostrar todos los elementos, debe asegurarse de que cada elemento del libro tenga un nombre exclusivo.

  • Puede cambiar el nombre de las tablas en la pestaña Diseño del grupo Propiedades, el nombre de las tablas dinámicas en la pestaña Opciones del grupo Tabla dinámica, y el nombre de los gráficos o gráficos dinámicos en la pestaña Diseño del grupo Propiedades. Puede cambiar el nombre de otros elementos duplicados, como rangos de nombres, en la pestaña Fórmulas del grupo Nombres definidos.

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×