Publicar un libro en un sitio de SharePoint

Nota:  Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

En Microsoft Excel 2010, puede publicar un libro en un sitio de Microsoft SharePoint Services 2010 de modo que otros usuarios puedan ver los datos en un explorador web sin tener Excel instalado en sus equipos. Además, al establecer algunas opciones de publicación, puede resaltar partes específicas del libro en el explorador. Una excelente forma de usar esta característica es mediante la presentación de un gráfico de Excel en una página de SharePoint para ayudar a su organización a tomar ágiles decisiones empresariales.

En este artículo se muestra cómo publicar un libro desde el programa de escritorio de Excel 2010 y no abarca temas sobre la conexión a un libro o a datos de un libro en un elemento web de Excel Web Access en una página de SharePoint.

Para obtener más información sobre los elementos web de Excel Web Access, vea el artículo Mostrar un libro en un elemento web Excel Web Access.

Al publicar un libro en un servidor de SharePoint, todo el contenido del libro se guarda en el servidor y se puede ver y trabajar con él al abrir el libro en el programa de escritorio de Excel. Si se implementa Office Web Apps en el servidor de SharePoint, ver y trabajar con los datos en el explorador web puede ser muy similar a trabajar con los datos en el programa de escritorio de Excel. De hecho, cuando se implementa Office Web Apps, se puede editar simultáneamente un libro en la cuadrícula del explorador. Al mostrar un libro en el explorador, si el botón Editar en el explorador está visible, significa que Office Web Apps se encuentra disponible.

Botón Editar en el explorador

Para obtener más información, vea el artículo Diferencias entre utilizar un libro en Excel y Excel Services .

¿Qué desea hacer?

Preparar el libro

Publicar el libro

Preparar el libro

Antes de publicar el libro, tendrá la oportunidad (en el cuadro de diálogo Opciones de publicación ) para seleccionar las hojas de cálculo o elementos que desee visible en el explorador al editar no está habilitado, haga clic en el botón Editar en el explorador. Recuerde que aunque puede seleccionar lo que está visible en este modo, todo el contenido del libro aún se guarda en el servidor de SharePoint.

Si desea incluir todas las hojas de cálculo como un elemento además de otros elementos, como gráficos o tablas dinámicas, defina toda la hoja de cálculo como un rango con nombre. Seleccione toda la hoja de cálculo y, a continuación, defina un rango con nombre. De este modo, el rango con nombre aparecerá como un elemento disponible en el cuadro de diálogo Opciones de publicación cuando esté listo para la publicación.

Si desea permitir a los usuarios proporcionar un parámetro a una fórmula al ver una hoja de cálculo en un explorador, establezca una celda como un nombre definido. A continuación, puede agregar ese nombre definido como un parámetro en la ficha parámetros en el cuadro de diálogo Opciones de publicación.

Por ejemplo, en el siguiente gráfico que muestra una hoja de cálculo en el explorador, la celda D2 tiene la tasa de nombre definido. En el explorador, un usuario tiene especificado un valor, 5.625, en el cuadro en el panel parámetros y, a continuación, hacer clic en Aplicar. Ese valor aparece en la celda D2 y la fórmula en A2 usa el valor de D2. El resultado de la fórmula se actualiza y se muestra en A2: 1,151.31 $.

Usar un parámetro en el explorador

Para obtener información acerca de cómo definir rangos, vea la Ayuda de Excel.

Volver al principio

Publicar el libro

  1. Haga clic en la pestaña Archivo y, a continuación, haga clic en Guardar y enviar.

  2. Haga clic en Guardar en SharePoint.
    Nota    si el comando Guardar en SharePoint no está disponible, puede aún guardar el libro en un sitio de SharePoint mediante el comando Guardar como. El cuadro de diálogo Opciones de publicación no estarán disponible. También directamente, puede cargar el libro desde una biblioteca de SharePoint. Los usuarios pueden ver y editar el contenido del libro en el explorador, vaya directamente al sitio donde está guardado el libro.

    Comando Guardar como

  3. Si desea seleccionar hojas de cálculo o elementos individuales para publicarlos en el libro, haga clic en el botón Opciones de publicación. De lo contrario, si desea publicar todo el libro, vaya directamente al paso 4.
    En la ficha Mostrar, realice lo siguiente:

    • Para mostrar todo el libro en el explorador, seleccione Todo el libro en el cuadro de lista.

    • Para mostrar solo las hojas de cálculo específicas en el explorador, seleccione hojas en el cuadro de lista y, a continuación, desactive las casillas de verificación de las hojas que no desea que esté visible.
      Nota    de forma predeterminada, se seleccionan todas las hojas. Para hacer que todas las hojas de nuevo visibles rápidamente después de desactivar algunas de las casillas de verificación, puede seleccionar la casilla de verificación de Todas las hojas.

    • Para mostrar únicamente elementos específicos en el explorador (por ejemplo, rangos con nombre, gráficos, tablas o tablas dinámicas), seleccione los elementos en el libro en el cuadro de lista y, a continuación, seleccione las casillas de verificación de los elementos que desea mostrar.
      Nota si selecciona elementos que tengan el mismo nombre (por ejemplo, un gráfico y su tabla de base de datos), solo uno de estos elementos estará disponible en el explorador. Para mostrar todos los elementos, debe asegurarse de que cada elemento en el libro tiene un nombre único. Puede cambiar el nombre de tablas en la ficha Diseño, en el grupo Propiedades, cambiar el nombre de las tablas dinámicas en la pestaña Opciones, en el grupo tabla dinámica y cambiar el nombre de gráficos o gráficos dinámicos en la pestaña Diseño en el grupo Propiedades. Pueden cambiar el nombre de elementos duplicados, como los rangos con nombre, en la ficha fórmulas en el grupo Nombres definidos.
      Seleccionar hojas de cálculo o elementos

    • En la pestaña parámetros, agregue los nombres definidos que desee usar para especificar las celdas que se pueden editables cuando los usuarios ver el libro en el explorador. A continuación, haga clic en Aceptar para cerrar el cuadro de diálogo.
      Establecer parámetros

  4. Elija una ubicación en la cual desee publicar el libro.
    Es posible que ya existan ubicaciones de servidor guardadas en Ubicación actual, Ubicaciones recientes o Ubicaciones entre las que puede elegir. Si no existen estas ubicaciones o desea guardar una nueva ubicación, en Ubicaciones, haga doble clic en Buscar una ubicación.

  5. En el cuadro de diálogo Guardar como, escriba la dirección web del sitio de SharePoint y, a continuación, vaya al sitio o biblioteca en la que desea guardar el libro.

  6. Si todavía no lo ha seleccionado ya distintas hojas de cálculo o elementos o establecer parámetros, haga clic en el botón Opciones de publicación.

  7. En el cuadro nombre de archivo, acepte el nombre sugerido para el libro o escriba un nuevo nombre si lo desea.

  8. Para mostrar el contenido del libro en una ventana del explorador inmediatamente después de que se complete la operación de publicación, asegúrese de que está seleccionada la casilla de verificación Abrir con Excel en el explorador.

  9. Haga clic en Guardar.

Volver al principio

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×