No se puede guardar la base de datos replicada en formato de Access 2007

Nota: Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Síntomas

En Microsoft Office Access 2007, las bases de datos replicadas que se crearon en versiones anteriores de Access (. MDB) no se pueden guardar en el nuevo. ACCDB (formato de archivo). La opción aparece atenuada (no disponible) al intentar usar el comando Guardar base de datos como (haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y, a continuación, haga clic en la flecha situada junto a Guardar como).

Causa

La. El formato de archivo ACCDB no admite la replicación.

Resolución

Usar la base de datos replicada en el. Formato de archivo MDB

Puede seguir usando la base de datos replicada en el. Formato de archivo MDB. La funcionalidad de replicación se sigue admitiendo para. Formato de archivo MDB.

Volver a crear manualmente la base de datos en formato de archivo de Office Access 2007

Si decide que el nuevo formato de archivo ofrece ventajas que compensan las ventajas que obtiene de la replicación, puede crear una nueva base de datos en formato de Office Access 2007 y volver a crear manualmente la base de datos replicada.

Nota: Este método funcionará en cualquier base de datos replicada, pero, a menos que esté trabajando con una réplica completa que se haya sincronizado con todas las demás réplicas del conjunto de réplicas, los datos y proyectos que aún no estén en la réplica no estarán en la nueva base de datos.

Antes de empezar a volver a crear la base de datos, debe asegurarse de que todos los objetos ocultos y de sistema de la réplica estén visibles. De esta forma, se garantiza que se puede acceder a los campos específicos de la réplica al volver a crearlo.

  1. Abra la réplica que desea convertir. Debe abrir la réplica con la misma versión de Access que se usó originalmente para crear la réplica, para mostrar los campos ocultos y de sistema.

  2. En el menú Herramientas, haga clic en Opciones. Se abrirá el cuadro de diálogo Opciones.

  3. En la pestaña Ver , en la sección Mostrar , seleccione objetos ocultos y objetos del sistema. Haga clic en Aceptar para aplicar la nueva configuración y cerrar el cuadro de diálogo Opciones.

Volver a crear manualmente la base de datos

  1. Cree una base de datos en blanco y ábrala.

    Nota: Access crea una nueva tabla vacía con el nombre Table1. Debe eliminar esta tabla, ya que puede hacerlo si la cierra inmediatamente antes de realizar cambios. Haga clic con el botón secundario en la pestaña de objeto y haga clic en cerrar en el menú contextual.

  2. En la pestaña Datos externos, en el grupo Importar, haga clic en Access.

    Aparecerá el cuadro de diálogo obtener datos externos: base de datos de Access .

  3. Haga clic en examinar para buscar la base de datos replicada.

  4. Haga clic en la base de datos replicada que contiene los objetos de base de datos que desea volver a crear en la nueva base de datos y, a continuación, haga clic en abrir.

  5. En el cuadro de diálogo obtener datos externos: base de datos de Access , haga clic en importar tablas, consultas, formularios, informes, macros y módulos en la base de datos actualy, a continuación, haga clic en Aceptar.

  6. Haga clic en los objetos de base de datos que desea importar a la nueva base de datos. Si desea importar todos los objetos, haga clic en seleccionar todo en cada pestaña.

    Importante    No seleccione tablas en este momento. Volverá a crear las tablas en un paso posterior.

  7. Cuando haya terminado de seleccionar objetos, haga clic en Aceptar para importarlos.

    En la última página del asistente, tiene la opción de guardar los pasos de la importación para usarlos en el futuro. Para ello, active la casilla guardar los pasos de la importación, escriba la información adecuada y, a continuación, haga clic en Guardar importación.

  8. Abra la base de datos replicada en Office Access 2007. Para cada tabla de la base de datos replicada, cree una consulta de creación de tabla que use todos los datos de la tabla anterior y cree una tabla en la nueva base de datos con los mismos datos.

    Nota: Si s_GUID es una clave principal (y las claves externas de otras tablas hacen referencia a ella), debe incluir el campo s_GUID en la nueva tabla. Si el campo s_GUID no se usa como clave principal, no hay razón para conservarlo en la nueva tabla. No copie los campos s_Lineage y s_Generation a la nueva tabla.

    De manera predeterminada, los campos s_GUID, s_Lineage y s_Generation están ocultos. Para mostrar estos campos, use el siguiente procedimiento:

    1. En la base de datos replicada, asegúrese de que todas las tablas están cerradas.

    2. Haga clic con el botón secundario en la parte superior del panel de navegación y luego haga clic en Opciones de navegación. Se abre el cuadro de diálogo Opciones de navegación.

    3. En la sección Opciones de presentación , seleccione Mostrar objetos del sistemay, a continuación, haga clic en Aceptar.

      ¿Cómo?

      1. Cree una consulta, seleccionando las tablas que contienen los registros que desea incluir en la nueva tabla.

        ¿Cómo?

        1. En la ficha Crear, en el grupo Otros, haga clic en Diseño de la consulta.

        2. En el cuadro de diálogo Mostrar tabla , haga clic en la pestaña que muestra las tablas con cuyos datos desea trabajar.

        3. Haga doble clic en el nombre de cada objeto que desee agregar a la consulta y, a continuación, haga clic en cerrar.

        4. Agregue campos a la fila campo en el cuadrícula de diseño.

        5. Para ver los resultados de la consulta, haga clic en el menú Ver y, a continuación, en vista Hoja de información.

      2. En consulta vista Diseño, en la pestaña diseño , en el grupo tipo de consulta , haga clic en crear tabla. Aparecerá el cuadro de diálogo Crear tabla.

      3. En el cuadro Nombre de la tabla , escriba el nombre de la tabla que desea crear o reemplazar.

      4. Haga clic en otra base de datosy, a continuación, escriba la ruta de acceso de la base de datos en la que desea colocar la nueva tabla o haga clic en examinar para buscar la base de datos.

      5. Haga clic en Aceptar.

      6. En la pestaña Diseño, en el grupo Resultados, haga clic en Ejecutar. Esto hará que se cree la nueva tabla.

        Nota: La nueva tabla que cree no hereda las propiedades de campo o la configuración clave principal de la tabla original.

  9. Para cada tabla de la nueva base de datos, cree el mismo índice y la misma clave principal que se usa en la tabla de la réplica.

    ¿Cómo?

    1. Abra una tabla en la vista Diseño.

    2. En la parte superior de la ventana, haga clic en el campo para el que desea crear un índice.

    3. En la parte inferior de la ventana, haga clic en el cuadro de la propiedad indexado y, a continuación, haga clic en sí (con duplicados) o sí (sin duplicados).

    4. Seleccione el campo o los campos que componen la clave principal.

    5. En el grupo Herramientas de la pestaña Diseño, haga clic en Clave principal.

  10. Para cada tabla de la nueva base de datos, cree las relaciones que existían para la tabla de la réplica.

    ¿Cómo?

    Cuando se crea una relación entre tablas, no es necesario que los campos relacionados tengan los mismos nombres. Sin embargo, los campos relacionados deben tener el mismo tipo de datos a menos que el campo de clave principal sea un campo autonumeración. Puede hacer coincidir un campo autoNumeración con un campo numérico solo si la propiedad TamañoDelCampo de los dos campos coincidentes es la misma. Por ejemplo, puede hacer coincidir un campo autoNumeración y un campo numérico si la propiedad TamañoDelCampo (FieldSize ) de ambos campos es entero largo. Incluso cuando los dos campos coinciden son campos numéricos, deben tener el mismo valor para la propiedad tamaño del campo .

    Definir una relación uno a varios o uno a uno

    1. Cierre todas las tablas que tenga abiertas. No puede crear o modificar relaciones entre tablas abiertas.

    2. En el grupo Mostrar u ocultar de la pestaña Herramientas de base de datos, haga clic en Relaciones.

    3. Si aún no ha definido ninguna relación en la base de datos, el cuadro de diálogo Mostrar tabla se muestra automáticamente.

      Si necesita agregar las tablas que desea relacionar y no aparece el cuadro de diálogo Mostrar tabla , invoque: en la pestaña diseño , en el grupo Mostrar u ocultar , haga clic en el botón Mostrar tabla .

    4. Haga doble clic en los nombres de las tablas que desea relacionar y, a continuación, cierre el cuadro de diálogo Mostrar tabla . Para crear una relación entre una tabla y él mismo, agregue dos veces esa tabla.

    5. Arrastre el campo que desee relacionar de una tabla al campo relacionado de la otra tabla.

      Para arrastrar varios campos, presione la tecla CTRL, haga clic en cada uno de los campos y, a continuación, arrástrelos.

      En la mayoría de los casos, se arrastra el campo de clave principal (que se muestra en texto en negrita) de una tabla a un campo similar (a menudo con el mismo nombre) denominado clave externa en la otra tabla.

    6. Se muestra el cuadro de diálogo modificar relaciones . Compruebe los nombres de campo que se muestran en las dos columnas para asegurarse de que son correctos. Puede cambiarlos si es necesario.

      Si es necesario, establezca las opciones de la relación.

    7. Haga clic en el botón crear para crear la relación.

    8. Repita los pasos del 4 al 7 para cada par de tablas que desee relacionar.

      Cuando cierra el ventana Relaciones, Microsoft Access pregunta si desea guardar el diseño. Independientemente de si guarda el diseño o no, las relaciones que cree se guardarán en la base de datos.

    Definir una relación de varios a varios

    1. Cree las dos tablas que tendrán un relación de varios a varios.

    2. Cree una tercera tabla, denominada tabla de Unión, y agregue a la tabla de Unión nuevos campos con las mismas definiciones que los campos de clave principal de cada una de las otras dos tablas. En la tabla de Unión, los campos de clave principal funcionan como claves externas. Puede agregar otros campos a la tabla de Unión, al igual que lo haría con cualquier otra tabla.

    3. En la tabla de Unión, establezca la clave principal para incluir los campos de clave principal de las otras dos tablas. Por ejemplo, en una tabla de Unión detalles de pedidos, la clave principal estaría formada por los campos IdPedido e IdProducto.

      ¿Cómo?

      1. Abra la tabla en la vista Diseño.

      2. Seleccione el campo o los campos que desee definir como clave principal.

        Para seleccionar un campo, haga clic en el selector de fila del campo deseado.

        Para seleccionar varios campos, mantenga presionada la tecla CTRL y, a continuación, haga clic en el selector de filas de cada campo.

      3. En el grupo Herramientas de la pestaña Diseño, haga clic en Clave principal.

        Nota: Si desea que el orden de los campos de una clave principal de varios campos sea diferente del orden de esos campos en la tabla, haga clic en el botón índices en el grupo Mostrar u ocultar para mostrar el ventana Índices y, a continuación, cambie el orden de los nombres de campo de la índice denominado PrimaryKey.

    4. Defina una relación de uno a varios entre cada una de las dos tablas principales y la tabla de Unión.

  11. Guarde la nueva base de datos.

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×