INDICE (función INDICE)

La función INDICE devuelve un valor o la referencia a un valor desde una tabla o rango.

Su explorador no admite vídeo. Instale Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Hay dos formas de utilizar la función INDICE:

  • Si desea devolver el valor de una celda especificada o de una matriz de celdas, consulte Forma de matriz.

  • Si desea devolver una referencia a las celdas especificadas, consulte Forma de referencia.

Forma de matriz

Descripción

Devuelve el valor de un elemento de una tabla o matriz, seleccionado por los índices de número de fila y de columna.

Use la forma matricial si el primer argumento de INDICE es una constante matricial.

Sintaxis

INDICE(matriz; núm_fila; [núm_columna])

La forma de matriz de la función INDICE tiene los siguientes argumentos:

  • variedad    Obligatorio. Es un rango de celdas o una constante de matriz.

    • Si matriz contiene solo una fila o columna, el argumento Núm_fila o núm_columna correspondiente es opcional.

    • Si el argumento matriz tiene más de una fila y más de una columna, y solo se usa Núm_fila o núm_columna, INDICE devuelve una matriz de toda la fila o columna en la matriz.

  • fila    Obligatorio. Selecciona la fila de la matriz desde la cual devolverá un valor. Si se omite Núm_fila, se requiere núm_columna.

  • núm_columna    Opcional. Selecciona la columna de la matriz desde la cual devolverá un valor. Si se omite núm_columna, se necesita Núm_fila.

Observaciones

  • Si se usan los argumentos núm_fila y núm_columna, INDICE devuelve el valor de la celda en la intersección de los argumentos núm_fila y núm_columna.

  • los argumentos núm_fila y núm_columna deben indicar una celda dentro de array; en caso contrario, INDICE devuelve un #REF! .

  • Si define Núm_fila o núm_columna como 0 (cero), INDICE devuelve la matriz de valores de toda la columna o fila, respectivamente. Para usar los valores devueltos como una matriz, escriba la función INDICE como una fórmula de matriz.

    Nota: Si tiene una versión actual de Office 365, puede escribir la fórmula en la celda superior izquierda del rango de salida y, a continuación, presionar entrar para confirmar la fórmula como una fórmula de matriz dinámica. En caso contrario, la fórmula debe introducirse como una fórmula de matriz heredada si primero selecciona el rango de salida, introduce la fórmula en la celda superior izquierda del rango de salida y, a continuación, pulsa Ctrl + Mayús + entrar para confirmarlo. Excel insertará llaves al principio y al final de la fórmula. Para obtener más información sobre las fórmulas de matriz, vea Directrices y ejemplos de fórmulas de matriz.

Ejemplos

Ejemplo 1

Estos ejemplos usan la función INDICE para buscar el valor de la celda de intersección de una fila y una columna.

Copie los datos de ejemplo en la tabla siguiente y péguelos en la celda A1 de una hoja de cálculo nueva de Excel. Para que las fórmulas muestren los resultados, selecciónelas, presione F2 y luego Entrar.

Datos

Datos

Manzanas

Limones

Plátanos

Peras

Fórmula

Descripción

Resultado

=INDICE(A2:B3,2,2)

Valor en la intersección de la segunda fila y la segunda columna del rango A2:B3.

Peras

=INDICE(A2:B3,2,1)

Valor en la intersección de la segunda fila y la primera columna del rango A2:B3.

Plátanos

Ejemplo 2

Este ejemplo usa la función INDICE en una fórmula de matriz para buscar los valores de dos celdas especificadas en una matriz de 2x2.  

Nota: Si tiene una versión actual de Office 365, puede escribir la fórmula en la celda superior izquierda del rango de salida y, a continuación, presionar entrar para confirmar la fórmula como una fórmula de matriz dinámica. En caso contrario, la fórmula debe especificarse como una fórmula de matriz heredada, seleccionando primero dos celdas en blanco, especificando la fórmula en la celda superior izquierda del rango de salida y, a continuación, presionando Ctrl + Mayús + entrar para confirmarla. Excel insertará llaves al principio y al final de la fórmula. Para obtener más información sobre las fórmulas de matriz, vea Directrices y ejemplos de fórmulas de matriz.

Fórmula

Descripción

Resultado

=INDICE({1,2;3,4},0,2)

Valor encontrado en la primera fila, segunda columna de la matriz. La matriz contiene 1 y 2 en la primera fila y 3 y 4 en la segunda fila.

2

Valor encontrado en la segunda fila, segunda columna de la matriz (misma matriz que arriba).

4

Volver al principio


Formulario de referencia

Descripción

Devuelve la referencia de la celda ubicada en la intersección de una fila y de una columna determinadas. Si la referencia está constituida por selecciones no adyacentes, puede elegir la selección en la que buscar.

Sintaxis

INDEX(ref, núm_fila, [núm_columna], [núm_área])

La forma de referencia de la función INDICE tiene los siguientes argumentos:

  • Reference    Obligatorio. Es una referencia a uno o varios rangos de celdas.

    • Si especifica un rango no adyacente para la referencia, escríbalo entre paréntesis.

    • Si cada área de referencia contiene solo una fila o columna, el argumento Núm_fila o núm_columna, respectivamente, es opcional. Por ejemplo, use INDICE(ref,,núm_columna) para un argumento ref con una sola fila.

  • Núm_fila    Obligatorio. Es el número de la fila en el argumento ref desde la que se devolverá una referencia.

  • núm_columna    Opcional. Es el número de la columna en el argumento ref desde la que se devolverá una referencia.

  • núm_área    Opcional. Selecciona un rango en referencia desde el que se devolverá la intersección de núm_fila y núm_columna. La primera área seleccionada o especificada se numera con 1, la segunda con 2 y así sucesivamente. Si se omite núm_área, Indice usa área 1.  Las áreas que se muestran aquí deben estar en una hoja.  Si especifica áreas que no están en la misma hoja, provocará un #VALUE! error.  Si necesita usar intervalos que se encuentran en hojas diferentes entre sí, se recomienda usar la forma de matriz de la función INDICE y usar otra función para calcular el rango que compone la matriz.  Por ejemplo, podría usar la función ELEGIR para calcular el intervalo que se va a usar.

Por ejemplo, si Referencia describe las celdas (a1: B4, D1: E4, G1: H4), núm_área 1 es el rango a1: B4, núm_área 2 es el rango D1: E4 y núm_área 3 es el rango G1: H4.

Observaciones

  • Después de que referencia y núm_área hayan seleccionado un rango determinado, núm_fila y núm_columna seleccionan una celda en particular: Núm_fila 1 es la primera fila del rango, núm_columna 1 es la primera columna, y así sucesivamente. La referencia devuelta por INDEX es la intersección de núm_fila y núm_columna.

  • Si define Núm_fila o núm_columna como 0 (cero), Indice devolverá la referencia de toda la columna o fila, respectivamente.

  • los argumentos núm_fila, núm_columna y núm_área deben señalar a una celda dentro de la referencia. en caso contrario, INDICE devuelve un #REF! . Si los argumentos núm_fila y núm_columna se omiten, INDICE devuelve el área en la referencia especificada por núm_área.

  • El resultado de la función INDICE es una referencia y será interpretado como tal por otras fórmulas. El valor devuelto por la función INDICE se puede usar como una referencia o como un valor, dependiendo de la fórmula. Por ejemplo, la fórmula CELDA("ancho";INDICE(A1:B2,1,2)) es igual a CELDA("ancho",B1). La función CELDA usa el valor devuelto por INDICE como referencia a una celda. Por otra parte, una fórmula como 2*INDICE(A1:B2,1,2) traduce el valor devuelto por INDICE al número de la celda B1.

Ejemplos

Copie los datos de ejemplo en la tabla siguiente y péguelos en la celda A1 de una hoja de cálculo nueva de Excel. Para que las fórmulas muestren los resultados, selecciónelas, presione F2 y luego ENTRAR.

Fruta

Precio

Recuento

Manzanas

0,69 $

40

Plátanos

0,34 $

38

Limones

0,55 $

15

Naranjas

0,25 $

veinticinco

Peras

0,59 $

40

Almendras

2,80 $

10

Anacardos

3,55 $

apartado

Cacahuetes

1,25 $

20

Nueces

1,75 $

1,2

Fórmula

Descripción

Resultado

=INDICE(A2:C6; 2; 3)

Intersección de la segunda fila y la tercera columna en el intervalo A2:C6, que es el contenido de la celda C3.

38

=INDICE((A1:C6; A8:C11); 2; 2; 2)

Intersección de la segunda fila y la segunda columna en la segunda área de A8:C11, que es el contenido de la celda B9.

1,25

=SUMA(INDICE(A1:C11; 0; 3; 1))

La suma de la tercera columna en la primera área del rango A1:C11, que es la suma de C1:C11.

216

=SUMA(B2:INDICE(A2:C6; 5; 2))

Suma del rango que comienza en B2 y termina en la intersección de la quinta fila y la segunda columna del rango A2:A6, que es la suma de B2:B6.

2,42

Principio de página

Vea también

Función BUSCARV

Función COINCIDIR

Función INDIRECTO

Directrices y ejemplos de fórmulas de matriz

Funciones de búsqueda y referencia (referencia)

Nota:  Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido le resulte útil. ¿Podría decirnos si la información le resultó útil? Aquí puede consultar el artículo en inglés.

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×