Importar datos XML

Si ha creado previamente una asignación XML, puede usarla para importar datos XML a las celdas que están asignadas, pero también existen varios métodos y comandos para importar datos XML sin una asignación XML.

Si tiene una asignación XML, haga esto para importar datos XML a celdas asignadas:

  1. En la asignación XML, seleccione una de las celdas asignadas.

  2. Haga clic en programador > importar.

    Si no se muestra la pestaña Programador, vea Mostrar la pestaña Programador.

  3. En el cuadro de diálogo importar XML , busque y seleccione el archivo de datos XML (. xml) que desea importar y haga clic en importar.

Otras maneras de importar datos XML

Para obtener más información sobre los problemas, consulte problemas comunes al importar datos XML al final de este artículo.

Importar un archivo de datos XML como una tabla XML

  1. Haga clic en programador > importar.

    Si no se muestra la pestaña Programador, vea Mostrar la pestaña Programador.

  2. En el cuadro de diálogo importar XML , busque y seleccione el archivo de datos XML (. xml) que desea importar y haga clic en importar.

    Si el archivo de datos XML no hace referencia a un esquema, Excel deduce el esquema a partir del archivo de datos XML.

  3. En el cuadro de diálogo importar datos , siga uno de estos procedimientos:

    1. Seleccionar tabla XML en una hoja de cálculo existente para importar el contenido del archivo de datos XML a una tabla XML de la hoja de cálculo en la ubicación de celda especificada.

    2. Seleccionar tabla XML en nueva hoja de cálculo para importar el contenido del archivo en una tabla XML en una hoja de cálculo nueva, empezando por la celda a1. El esquema del archivo de datos XML se muestra en el panel de tareas origen XML .

  4. Si el archivo de datos XML no hace referencia a un esquema, Excel deduce el esquema a partir del archivo de datos XML.

  5. Para controlar el comportamiento de datos XML (como el enlace de datos, el formato y el diseño), haga clic en propiedades, que muestra el cuadro de diálogo propiedades de asignación XML . Por ejemplo, los datos existentes en un rango asignado se sobrescribirán al importar datos de forma predeterminada, pero puede cambiarlos.

Importar varios archivos de datos XML

  1. Seleccione una celda asignada para importar varios archivos XML en un único conjunto de celdas asignadas.

    Si desea importar varios archivos XML en varios conjuntos de celdas asignadas, haga clic en una celda en cualquier lugar de la hoja de cálculo que no esté asignada.

  2. Haga clic en programador > importar.

    Si no se muestra la pestaña Programador, vea Mostrar la pestaña Programador.

  3. En el cuadro de diálogo importar XML , busque y seleccione el archivo de datos XML (. xml) que desea importar.

    • Si los archivos son contiguos, presione la tecla Mayús y haga clic en el primer archivo y el último de la lista. Todos los datos de los archivos XML se importarán y se anexarán a las celdas asignadas.

    • Si los archivos no son contiguos, mantenga presionada la tecla Ctrl y haga clic en cada uno de los archivos que desee importar de la lista.

  4. Haga clic en Importar.

    Si ha seleccionado archivos que no son contiguos, aparece el cuadro de diálogo importar <nombre de archivo>. XML . Seleccione la asignación XML que corresponde al archivo de datos XML que está importando para cada archivo.

    Para usar una única asignación para todos los archivos seleccionados que aún no se han importado, seleccione usar esta asignación XML para todos los archivos seleccionados de este esquema.

Importar varios archivos de datos XML como datos externos

Para importar varios archivos XML que usan el mismo espacio de nombres pero distintos esquemas XML, puede usar el comando desde la importación de datos XML . Excel crea una asignación XML única para cada archivo de datos XML que se importa.

Nota: Si va a importar varios archivos XML que no definen un espacio de nombres, estos archivos XML se tratan como si usaran el mismo espacio de nombres.

  1. Si está usando Excel con una suscripción de Office 365, haga clic en datos > obtener datos > de > de archivo de XML.

    Si usa Excel 2016 o una versión anterior, haga clic en datos > de otros orígenes > desde la importación de datos XML.

  2. Vaya a la unidad, carpeta o ubicación de Internet que tiene el archivo de datos XML (. xml) que desea importar.

  3. Seleccione el archivo y haga clic en Abrir.

  4. En el cuadro de diálogo importar datos , siga uno de estos procedimientos:

    • Tabla XML en una hoja de cálculo existente    El contenido del archivo se importa a una nueva tabla XML en una hoja de cálculo nueva. Si el archivo de datos XML no hace referencia a un esquema, Excel deduce el esquema a partir del archivo de datos XML.

    • Hoja de cálculo existente    Los datos XML se importan en una tabla bidimensional con filas y columnas que muestran etiquetas XML como encabezados de columna y datos en filas debajo de los encabezados de columna. El primer elemento (el nodo raíz) se usa como un título y se muestra en la ubicación de celda especificada. El resto de las etiquetas se ordenan alfabéticamente en la segunda fila. En este caso, Excel no infiere un esquema y no puede usar una asignación XML.

    • Nueva hoja de cálculo    Excel agregará una nueva hoja de cálculo al libro y colocará automáticamente los datos XML en la esquina superior izquierda de la nueva hoja de cálculo. Si el archivo de datos XML no hace referencia a un esquema, Excel deduce el esquema a partir del archivo de datos XML.

  5. Para controlar el comportamiento de datos XML, como el enlace de datos, el formato y el diseño, haga clic en propiedades, que muestra el cuadro de diálogo propiedades de asignación XML . Por ejemplo, los datos existentes en un rango asignado se sobrescriben al importar datos de forma predeterminada, pero puede cambiarlos.

Abrir un archivo de datos XML para importar sus datos

  1. Haga clic en Archivo > Abrir.

    Si está usando Excel 2007, haga clic en el botón Microsoft Office Imagen del botón de Office > abrir.

  2. En el cuadro de diálogo abrir , haga clic en la unidad, carpeta o ubicación de Internet que tiene el archivo que desea abrir.  

  3. Seleccione el archivo y haga clic en Abrir.

  4. Si aparece el cuadro de diálogo importar XML , el archivo que ha abierto hace referencia a una o más hojas de estilo XSLT (Extensible Stylesheet Language Transformation), para que pueda hacer clic en una de las siguientes opciones:

    • Abrir el archivo sin aplicar una hoja de estilos    Los datos XML se importan en una tabla bidimensional con filas y columnas que muestran etiquetas XML como encabezados de columna y datos en filas debajo de los encabezados de columna. El primer elemento (el nodo raíz) se usa como un título y se muestra en la ubicación de celda especificada. El resto de las etiquetas se ordenan alfabéticamente en la segunda fila. En este caso, Excel no infiere un esquema y no puede usar una asignación XML.

    • Abra el archivo con la siguiente hoja de estilos aplicada (seleccione una)    Seleccione la hoja de estilos que desea aplicar y, a continuación, haga clic en Aceptar. El formato de los datos XML se ajusta a la hoja de estilos seleccionada.

      Nota: Los datos XML se abren como solo lectura en Excel para no guardar por error el archivo de origen original en el formato de archivo de libro de Excel habilitado para macros (. xlsm). En este caso, Excel no infiere un esquema y no puede usar una asignación XML.

  5. Si aparece el cuadro de diálogo abrir XML , el archivo XML no tiene ninguna referencia de hoja de estilos XSLT. Para abrir el archivo, haga clic en una de las siguientes opciones:

    • Haga clic en como tabla XML para crear una tabla XML en un libro nuevo.

      El contenido del archivo se importa a la tabla XML. Si el archivo de datos XML no hace referencia a un esquema, Excel deduce el esquema a partir del archivo de datos XML.

    • Hacer Como un libro de solo lectura.

      Los datos XML se importan en una tabla bidimensional con filas y columnas que muestran etiquetas XML como encabezados de columna y datos en filas debajo de los encabezados de columna. El primer elemento (el nodo raíz) se usa como un título y se muestra en la ubicación de celda especificada. El resto de las etiquetas se ordenan alfabéticamente en la segunda fila. En este caso, Excel no infiere un esquema y no puede usar una asignación XML.

      Los datos XML se abren como solo lectura en Excel para no guardar por error el archivo de origen original en el formato de archivo de libro de Excel habilitado para macros (. xlsm). En este caso, Excel no infiere un esquema y no puede usar una asignación XML.

    • Haga clic en usar el panel de tareas origen XML.

      El esquema del archivo de datos XML se muestra en el panel de tareas origen XML . A continuación, puede arrastrar los elementos del esquema a la hoja de cálculo para asignar esos elementos a la hoja de cálculo.

      Si el archivo de datos XML no hace referencia a un esquema, Excel deduce el esquema a partir del archivo de datos XML.

Problemas comunes con la importación de datos XML

Excel muestra el cuadro de diálogo error al importar XML cuando no puede validar datos según la asignación XML. En este cuadro de diálogo, haga clic en detalles para obtener información adicional sobre cada error. En la tabla siguiente se enumeran algunos errores comunes de importación:

Error

Qué ha pasado

Error al validar el esquema

Cuando se hace clic en validar datos con el esquema para importar y exportar en el cuadro de diálogo propiedades de asignación XML , los datos se importaron, pero los datos no se validaron en la asignación XML especificada.

Algunos datos se importaron como texto

Algunos o todos los datos importados se han convertido de su tipo de datos declarado a texto. Para usar estos datos en un cálculo, tendrá que convertir los datos de texto a números o fechas. Por ejemplo, un valor de fecha convertido en texto no funcionará según lo previsto en la función año hasta que lo convierta al tipo de datos fecha. Excel convierte los datos en texto cuando:

  • Los datos están en un formato que Excel no admite.

  • Los datos son incompatibles con la representación interna de Excel del tipo de datos XSD. Para solucionar este problema, compruebe cada declaración de tipo de datos para asegurarse de que los datos XML son válidos de acuerdo con el esquema XML.

Error de análisis XML

El analizador XML no puede abrir el archivo XML especificado. Asegúrese de que el archivo XML no tiene errores de sintaxis y de que el código XML tiene el formato correcto.

No se puede encontrar una asignación XML que corresponda a los datos

Este problema puede ocurrir cuando selecciona más de un archivo de datos XML para importarlo y Excel no encuentra una asignación XML coincidente para uno de los archivos. En el archivo que se menciona en la barra de título del cuadro de diálogo, importe primero un esquema adecuado y, a continuación, intente importar el archivo de nuevo.

No se puede cambiar el tamaño de una tabla XML para dar cabida a datos

Está intentando agregar filas importando o anexando datos a la tabla XML, pero no hay espacio para que la tabla se expanda. Una tabla XML solo puede expandirse de abajo hacia abajo. Por ejemplo, puede haber un objeto, como una imagen u otra tabla, justo debajo de la tabla XML que evita que se expanda la tabla XML. O bien, para que la tabla XML se expanda, superará el límite de filas de Excel de 1.048.576. Para corregir este problema, reorganice las tablas y los objetos de la hoja de cálculo para permitir que la tabla XML se expanda desde la parte inferior hacia abajo.

El archivo XML especificado no hace referencia a un esquema

El archivo XML que está intentando abrir no hace referencia a un esquema XML. Para trabajar con los datos XML del archivo, Excel necesita un esquema basado en el contenido del archivo XML. Si el esquema es incorrecto o insuficiente, quítelo del libro. Después, cree un archivo de esquema XML y edite el archivo de datos XML para que el archivo de datos XML se refiera al esquema. Para obtener más información, vea asignar elementos XML a celdas en una asignación XML.

Nota: No se puede exportar el esquema de Excel inferido como un archivo de datos de esquema XML (. xsd) independiente. Aunque existen editores de esquemas XML y otros métodos para crear un archivo de esquema XML, es posible que no disponga de acceso a estos editores o no sepa cómo utilizarlos.

Siga estos pasos para quitar el esquema que Excel ha creado a partir de su libro:

  1. Click Developer > Source.

    Comandos XML en la pestaña Desarrollador

    Si no se muestra la pestaña Programador, vea Mostrar la pestaña Programador.

  2. En el panel de tareas origen XML , haga clic en asignaciones XML.

  3. En el cuadro de diálogo asignaciones XML , haga clic en la asignación XML de Excel creada y haga clic en eliminar.

Importar varios archivos XML que usan el mismo espacio de nombres pero distintos esquemas no funcionan como se esperaba

Cuando se trabaja con varios esquemas XML y archivos de datos XML, normalmente se crea una asignación XML para cada esquema, se asignan los elementos que se deseen y, a continuación, se importa cada archivo de datos XML a la asignación XML correspondiente. Usar el comando importar para abrir varios archivos XML con el mismo espacio de nombres, solo puede usar un esquema XML. Al usar este comando para abrir varios archivos XML que usan el mismo espacio de nombres pero distintos esquemas, puede obtener resultados inesperados. Por ejemplo, es posible que los datos se sobrescriban o que los archivos no se abran.

Para importar varios archivos XML que usan el mismo espacio de nombres pero distintos esquemas XML, pruebe a usar el comando de importación de datos de XML (haga clic en datos > de otros orígenes). Este comando permite que varios archivos XML con el mismo espacio de nombres usen varios esquemas XML. Excel crea una asignación XML única para cada archivo de datos XML que desee importar.

Nota: Si va a importar varios archivos XML que no definen un espacio de nombres, estos archivos XML se tratan como si usaran el mismo espacio de nombres.

Mostrar la pestaña Programador

Si no aparece la pestaña Programador, realice las siguientes acciones para mostrarla:

  • En Excel 2013 y Excel 2010:

    1. Haga clic en Archivo > Opciones.

    2. Haga clic en la categoría Personalizar cinta de opciones.

    3. Under Main Tabs, check the Developer box, and click OK.

  • En Excel 2007:

    1. Click the Microsoft Office Button Imagen del botón de Office > Excel Options.

    2. Click the Popular category.

    3. Under Top options for working with Excel, check the Show Developer tab in the Ribbon box, and click OK.

Vea también

de la vista de XML en Excel

asignar elementos XML a las celdas de una asignación XML

exportar datos XML

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×