Importar datos de Excel, SQL Server, sitios de SharePoint y otros orígenes externos

Nota: Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Puede importar rápidamente y mostrar datos directamente en las formas usando Microsoft Office Visio Professional 2007. El primer paso es conectarse al origen de datos e importar datos en el dibujo. El segundo paso es vincular los datos importados a formas.

En este artí­culo:

Paso 1: Importar los datos

Paso 2: Vincular filas de datos con las formas del dibujo

Paso 1: Importar los datos

En este primer paso, utilice el Asistente para selector de datos para importar datos a la ventana Datos externos.

Los datos que aparecen en la ventana Datos externos están una instantánea del origen de datos en el momento de la importación. Puede actualizar los datos del dibujo para que coincidan con los cambios en el origen de datos. Sin embargo, no puede actualizar el origen de datos al cambiar los datos del dibujo. Consulte Actualizar datos importados.

  1. En el menú Datos, haga clic en Vincular datos a las formas.

  2. En la primera página del Asistente para selector de datos, elija el tipo de datos que desee usar entre los siguientes tipos de datos:

    • Libro de Microsoft Office Excel

    • Base de datos de Microsoft Office Access

    • Lista de Microsoft Windows SharePoint Services

    • Base de datos de Microsoft SQL Server

    • Otro origen de datos OLEDB u ODBC

    • Conexión creada anteriormente

  3. Concluya los pasos restantes del asistente.

    Nota: Si elige una opción distinta de un libro de Excel, una base de datos de Access o una lista de SharePoint en la primera página del asistente, puede que se desvíe temporalmente al Asistente para conexión de datos mientras concluye los pasos del Asistente para selector de datos.

    En la mayoría de las páginas del asistente hay disponible ayuda específica. Para obtener acceso a la Ayuda, presione F1 o haga clic en el botón Ayuda.

Tras hacer clic en Finalizar en la última página del Asistente para la conexión de datos, aparecerá la ventana Datos externos con los datos importados mostrándose en la cuadrícula.

Inicio de la página

Paso 2: Vincular filas de datos con las formas del dibujo

Existen tres maneras de vincular filas de datos con las formas del dibujo: puede vincular las filas con las formas existentes de una en una, puede vincular las filas con las formas automáticamente o puede crear formas a partir de los datos.

Vincular las filas con las formas existentes de una en una

Este enfoque es el mejor para dibujos existentes con relativamente pocas formas.

  • Arrastre una fila desde la ventana Datos externos hasta una forma del dibujo.

    Los datos aparecen en la forma y se muestra un icono de vínculo a la izquierda de la fila en la ventana Datos externos.

    Arrastrar una fila hasta una forma

    Notas: 

    • Puede vincular una sola fila con varias formas, pero no puede vincular varias filas con una sola forma.

    • Para cambiar o mejorar el aspecto de las formas y de los datos, consulte Mejorar sus datos con gráficos.

    • Para mostrar la ventana Datos externos, en el menú Ver, haga clic en Ventana Datos Externos.

Vincular las filas con las formas existentes automáticamente

Este enfoque es mejor para dibujos existentes con un gran número de formas. Esto funciona solamente si las formas contienen datos ya que puede hacer coincidir a los datos de origen de datos.

  1. En el menú Datos, haga clic en Vincular automáticamente.

  2. Siga los pasos del Asistente para vínculos automáticos.

    Los datos aparecerán en las formas. Para cambiar o mejorar el aspecto de las formas y los datos, vea mejorar los datos con gráficos de datos.

En la mayoría de las páginas del asistente hay disponible ayuda específica. Para obtener acceso a la Ayuda, presione F1 o haga clic en el icono Ayuda.

Crear las formas a partir de los datos

Esta es la mejor opción si el dibujo no tiene formas todavía y no necesita utilizar formas específicas.

  1. Haga clic en una forma en la ventana Formas.

  2. Arrastre una fila o un conjunto de filas desde la ventana Datos externos hasta un espacio en blanco del dibujo.

    Una instancia de la forma en la que hace clic aparece por cada fila que arrastra hasta el dibujo.

Inicio de la página

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×