Función VALORCAMPO

Nota: Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Puede usar la función VALORCAMPO para recuperar los datos del campo de tipos de datos vinculados como los tipos de datos Cotizaciones o Geografía. Hay métodos más fáciles para escribir fórmulas que hacen referencia a los tipos de datos, por lo que la función VALORCAMPO debe usarse principalmente para crear cálculos condicionales basados en los tipos de datos vinculados.

Nota: 12 de junio de 2018: Esta función actualmente es una característica de beta y solo está disponible para una parte del Personal de Office en este momento. Seguimos optimizar esta característica durante los próximos meses. Cuando esté listo, deberá liberarla para todos los expertos de Office y los suscriptores de Office 365.

Detalles técnicos

Sintaxis

=VALORCAMPO(value, field_name)

La sintaxis de la función VALORCAMPO tiene los siguientes argumentos:

  • value: la dirección de la celda, columna de tabla o rango con nombre que contiene un tipo de datos vinculado. 

  • field_name: los nombres de los campos de los que desea extraer el tipo de datos vinculado

Descripción

Ejemplos

En el siguiente ejemplo básico, la fórmula =VALORCAMPO(A2,"Precio") extrae el campo Precio del tipo de datos de cotizaciones para JM Smucker Co.

Recuperar un precio de cotizaciones de empresa con =VALORCAMPO(A2,"Precio")

El siguiente es un ejemplo más habitual de la función VALORCAMPO. Se usa la función SI.ERRROR para comprobar si hay errores. Si no hay un nombre de compañía en la celda A2, la fórmula VALORCAMPO devuelve un error y en ese caso queremos que no se muestre nada (""). Sin embargo, si hay un nombre de compañía, queremos recuperar el precio del tipo de datos en A2 con =SI.ERROR(VALORCAMPO($A2,B$1),"").

Recuperar un precio de cotizaciones de empresa y omitir errores con =SI.ERROR(VALORCAMPO($A2,B$1),"")

Tenga en cuenta que la función VALORCAMPO le permite hacer referencia a celdas de la hoja de cálculo para el argumento field_name, por lo que la fórmula anterior hace referencia a la celda B1 para Precio en lugar de escribir manualmente "Precio" en la fórmula. 

Observaciones

Si intenta recuperar datos de un campo de tipo de datos inexistente, la función VALORCAMPO devolverá el error #CAMPO!. Por ejemplo, podría haber escrito "Precios", cuando el campo de tipo de datos se denomina "Precio". Compruebe la fórmula para asegurarse de que está usando un nombre de campo válido. Si desea mostrar una lista de nombres de campo de un registro, seleccione la celda del registro y presione Ctrl+Mayús+F2.

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Vea también

Tipos de datos Geografía y Cotizaciones

Cómo escribir fórmulas que hagan referencia a tipos de datos

Error #CAMPO!

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×