Fórmulas y funciones

Función SI

Función SI

Nota: Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

La función si es una de las funciones más populares de Excel y le permite realizar comparaciones lógicas entre un valor y lo esperado.

Por esto, una instrucción SI puede tener dos resultados. El primer resultado es si la comparación es Verdadera y el segundo si la comparación es Falsa.

Por ejemplo, =SI(C2="Sí",1,2) dice: SI(C2 = Sí, entonces devolver un 1, en caso contrario devolver un 2)

Cómo usar si:

  1. Seleccione una celda. Tipo = si y un paréntesis de apertura (.

  2. Agregue una condición que desee probar y escriba una coma.

  3. Agregue el valor para devolver si la condición es verdadera y escriba una coma.

  4. Agregue el valor para devolver si la condición es falsa y escriba el paréntesis de cierre ).

  5. Presione Entrar.

  6. Arrastre el controlador para aplicar la función si para otras filas si es necesario.

Ejemplos sencillos de SI

La celda D2 contiene la fórmula =SI(C2="SÍ";1;2)
  • =SI(C2="Sí",1,2)

En el ejemplo anterior, la celda D2 dice: SI(C2 = Sí, entonces devolver un 1, en caso contrario devolver un 2)

La celda D2 contiene la fórmula =SI(C2=1,"SÍ","NO")
  • =SI(C2=1,"Sí","No")

En este ejemplo, la fórmula en la celda D2 dice: IF(C2 = 1, then return Yes, otherwise return No)a medida que ve, la función si puede usarse para evaluar valores y el texto. También puede utilizarse para evaluar errores. No están limitados a sólo comprobar si un elemento es igual a otra y devolver un resultado único, también puede usar operadores matemáticos y realizar cálculos adicionales en función de los criterios. También puede anidar varias funciones si juntos para realizar comparaciones múltiples.

La fórmula de la celda D2 es =SI(C2 > B2,"Presupuesto excedido","Dentro de presupuesto")
  • =SI(C2>B2,"Presupuesto excedido","Dentro de presupuesto")

En el ejemplo anterior, la función en D2 dice SI(C2 es mayor que B2, devolver "Presupuesto excedido"; de lo contrario, devolver "Dentro de presupuesto")

La fórmula de la celda E2 es =SI(C2>B2;C2-B2;"")
  • =SI(C2>B2;C2-B2;0)

En la ilustración anterior, en lugar de devolver un resultado de texto, vamos a devolver un cálculo matemático. La fórmula en E2 dice lo siguiente: SI(la cantidad real es mayor que la presupuestada, resta la cantidad presupuestada de la cantidad real; en caso contrario, no se devuelve nada).

La fórmula de la celda F7 es SI(E7="Sí";F5*0,0825,0)
  • =SI(E7="Sí";F5*0,0825;0)

En este ejemplo, la fórmula en F7 dice lo siguiente: SI(E7 = "Sí", calcula la cantidad total con F5 * 8,25 %; en caso contrario, no hay ningún impuesto sobre las ventas, por lo que se devuelve 0)

Nota: Si va a usar texto en fórmulas, tendrá que escribir el texto entre comillas (por ejemplo, "Texto"). La única excepción es el uso de VERDADERO o FALSO, que Excel entiende de forma automática.

Problemas comunes

Problema

Qué ha fallado

0 (cero) en la celda

No había argumento para valor_si_verdadero ni para valor_si_falso. Para que se devuelva un valor correcto, agregue texto de argumento a los dos argumentos, o agregue VERDADERO o FALSO al argumento.

#¿NOMBRE? en la celda

Normalmente, esto significa que la fórmula se ha escrito mal.

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Vea también

Operadores de cálculo y prioridad en Excel

Usar funciones anidadas en una fórmula

Usar SI para comprobar si una celda está en blanco

Vídeo: Funciones SI avanzadas

Función SI.CONJUNTO (Office 365, Excel 2016 y posterior)

Funciones SI avanzadas: Trabajar con fórmulas anidadas para evitar errores.

Vídeos de aprendizaje: Funciones SI avanzadas

La función CONTAR.SI contará los valores según un solo criterio

La función CONTAR.SI.CONJUNTO contará los valores según varios criterios

La función SUMAR.SI sumará los valores según un solo criterio

La función SUMAR.SI.CONJUNTO sumará los valores según varios criterios

Función Y

Función O

Función BUSCARV

Información general sobre fórmulas en Excel

Cómo evitar la ruptura de las fórmulas

Detectar errores en las fórmulas con la comprobación de errores

Funciones lógicas

Funciones de Excel (por orden alfabético)

Funciones de Excel (por categoría)

Pruebas lógicas IF (vista previa gratuita)

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×